18:00:28 <alagalah_> #startmeeting TWS
18:00:28 <odl_meetbot> Meeting started Mon Mar  2 18:00:28 2015 UTC.  The chair is alagalah_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:28 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:28 <odl_meetbot> The meeting name has been set to 'tws'
18:00:34 <alagalah_> #link https://cisco.webex.com/join/krb
18:01:23 <alagalah_> Folks, we have the Webex snafu again so please join above link.
18:01:43 <alagalah_> colindixon: For those on the TWS old WEBEX and not on IRC, can you post this link into the OLD webex chat?
18:01:44 <alagalah_> https://cisco.webex.com/join/krb
18:03:59 <colindixon> Everyone, please join here so we can record the WebEx:  https://cisco.webex.com/join/krb
18:04:50 <vishnoianil> is there any meeting number for this?
18:04:52 <alagalah_> colindixon: When can I kick this off ?
18:05:03 <colindixon> alagalah_: I only have 3 people over here, so whenever
18:05:09 <colindixon> alagalah_, do you have a meeting #?
18:05:17 * colindixon points to vishnoianil
18:05:22 <alagalah_> colindixon: 304 278 733
18:05:28 <colindixon> Thanks!
18:05:28 <alagalah_> vishnoianil:  ^^^^^
18:05:29 <vishnoianil> okay
18:05:31 <vishnoianil> thanks
18:05:36 <alagalah_> colindixon: please let me know when I can start
18:05:55 <colindixon> alagalah_: go, I’m coming across and I’ll stay watching the old one without audio
18:08:00 <colindixon> Periodic statement that the webex for today is here: https://cisco.webex.com/join/krb
18:08:02 <colindixon> instead of normal
18:08:15 <colindixon> alagalah_: chair me?
18:09:42 <colindixon> #info LuisGomez shows how to get to the integration group main page
18:09:47 <colindixon> #undo
18:09:55 * colindixon can’t undo, not chair
18:10:50 <colindixon> #info LuisGomez starts with the Lithium test strategy
18:11:02 <colindixon> #link https://wiki.opendaylight.org/view/OVSDB_Integration:Main integration group main page
18:11:10 <colindixon> #undo
18:11:14 <colindixon> wrong link
18:11:26 <colindixon> #info ABOVE IS THE WRONG LINK
18:11:57 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group the integration group main page
18:12:08 <alagalah_> #chair colindixon
18:12:08 <odl_meetbot> Current chairs: alagalah_ colindixon
18:12:13 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Lithium_Test_Strategy Lithium test strategy
18:12:17 <colindixon> #undo
18:12:17 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1baba50>
18:12:18 <colindixon> #undo
18:12:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1bab3d0>
18:12:20 <colindixon> #undo
18:12:20 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1bab290>
18:12:21 <colindixon> #undo
18:12:21 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1bab510>
18:12:24 <alagalah_> colindixon: sorry for delay
18:12:32 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group the integration group main page
18:12:36 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Lithium_Test_Strategy Lithium test strategy
18:12:48 <colindixon> #topic Lithium Test Strategy
18:14:23 <alagalah_> ALL: I muted ALL ... you should be able to toggle it yourself, but please ping on here if you can't un-mute and I will fix it
18:16:30 <colindixon> #info Luis points out that we are trying to do both more testing (testing projects when their upstream dependencies change) and less testing (running fewer integration tests when “leaf” projects change)
18:17:17 <colindixon> #info the hope is that we will get a lot better coverage and find issues faster while still not having queue buildup in integration jenkins jobs
18:17:59 <colindixon> #topic Distributions
18:18:30 <colindixon> #info in Helium we had a single karaf distribution we built in integration for both testing and release
18:19:53 <alagalah_> colindixon: apologies, someone asked me to unmute but it bounced everyones mute. sigh.
18:20:44 <colindixon> #info in Lithium, we will have a test distribution and release distribution so that customers/users don’t have to see and aren’t tempted to use test-only features like compatible-with-all, etc.
18:21:33 <colindixon> #info colindixon asks if there’s a worry that we’re now testing the test distribution, but not necessarily the release distribution
18:21:54 <colindixon> #info LuisGomez says they should be exactly the same except for just those few test integration features
18:23:33 <colindixon> #info colindixon asks if they are actually the same even if they build at slightly different times, couldn’t one pull in new artifacts?
18:24:10 <colindixon> #info edwarnicke says this shouldn’t happen because the whole jenkins job (which builds both distributions) gets one m2 repo and they should pull down the same artifcats.
18:24:31 <colindixon> alagalah_: no worries, I should be able to figure out how to unmute myself
18:25:13 <vishnoianil> assuming each distribution build takes 30 minutes, and if any artifact is updated, ideally next build should pull the latest, isn't it ?
18:27:04 <colindixon> vishnoianil: good question, the usually reason to not do that is that it makes it hard to tell what caused a failure, but you should ask
18:31:20 <colindixon> #link https://wiki.opendaylight.org/view/File:Lithium_Test_Strategy.pptx the strategy slides are here
18:32:44 <colindixon> #topic build test vs. system test
18:33:15 <colindixon> #info build tests are run for your local project to test things with PAX exam, JUnit, etc. (usually run on verify, merge, and integration jogs)
18:33:50 <colindixon> #info system tests are targeted at testing things in as close as the real environment as possible with tests coming from outside the code itself (here showing as robot tests)
18:34:35 <colindixon> #topic test triggers
18:34:56 <colindixon> #info currently con code submit, we do a verify build, LuisGomez proposes also a feature-only system test
18:35:04 <colindixon> #undo
18:35:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1babd90>
18:35:09 <colindixon> #info currently on code submit, we do a verify build, LuisGomez proposes also a feature-only system test
18:36:33 <colindixon> #info currently code merge causes a merge build, LuisGomez proposes that it will also do: (i) integration builds for downstream projects, (ii) distribution builds for potentially affected feature-only tests [this and downstream projects] as well as feature-all tests
18:36:52 <colindixon> #info (this is slide 8 in the strategy slide deck)
18:39:19 <colindixon> #info edwarnicke asks if there are ways we can hand the distribution builds to tests directly (as opposed to via Nexus) to avoid race conditions
18:40:54 <colindixon> #info LuisGomez says this is a potential problem, we should look into how to fix it if we can figure out something better
18:42:58 <colindixon> #info edwarnicke suggests maybe attaching the distribution artifact itself to the distribution build and then pass enough information so that the downstream jobs can actually build a URL to get *that* artifact
18:44:01 <colindixon> #info colindixon asks if we can table that problem here and try to make it system test info for projects since we have lots of people on the call
18:44:41 <colindixon> #topic Integration Requirements for Lithium
18:44:52 <alagalah_> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Lithium_Project_Integration_Requirements LuisGomez is referring to this page
18:45:15 <colindixon> #info for M3 all release features must be defined (see the Karaf step-by-step guide) and part of that is to get your features into the integration repository
18:45:41 <alagalah_> #link https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#Prepare_your_feature_for_addition_to_the_integration_project how to prepare your project for integration
18:45:47 <colindixon> alagalah_: thanks!
18:46:10 <alagalah_> #info ^^^^^^^ title for link is actually "Prepare your feature for addition to the integration project"
18:46:25 <alagalah_> #undo
18:46:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x18b7310>
18:46:44 <alagalah_> #link https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#Prepare_your_feature_for_addition_to_the_integration_project "Prepare your feature for addition to the integration project"
18:47:40 <alagalah_> I have a Q
18:49:56 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template for features that are essential, this template should be filled out to describe how they’re doing integration/test
18:50:15 <colindixon> #info that is linked from the Lithium release plan for M3 as well
18:50:23 <alagalah_> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Schedule Lithium Release Plan schedule: This does have links back to the https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Lithium_Project_Integration_Requirements#Timeline_for_Deliverables
18:51:32 <colindixon> #info there are examples of how to fill this out at the bottom of the template
18:52:06 <colindixon> #info always reach out to the integration group via mail, IRC, etc. if you have help
18:52:16 <colindixon> #topic system test definition step-by-step
18:52:27 <alagalah_> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:System_Test:Step_by_Step_Guide
18:53:15 <colindixon> #info that is linked from the main integration job page (should also be linked into the Lithium release plan later)
18:53:41 <colindixon> #action LuisGomez to link to the system test step-by-step in the Lithium release plan schedule
18:53:46 <alagalah_> #info LuisGomez points out not to be daunted by the length of the wiki ... note.. this is usually a good thing as its very "paint by numbers".. rather than assuming knowledge
18:53:56 <colindixon> alagalah_: thanks for help
18:55:19 <colindixon> #info the distribution job is easy to fill out, really it should be just providing your project name for most projects
18:55:42 <alagalah_> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:System_Test:Step_by_Step_Guide#Check_new_jobs_in_Releng_Jenkins Check new jobs in Releng Jenkins
18:56:15 <alagalah_> #info please note that there are two places on the wiki with the same name. The above is the first one and LuisGomez points out its importance to check this step
18:59:35 <colindixon> #info LuisGomez says that they want to get as much system testing as possible, including using whatever framework you want, but they will be able to offer more support and have more experience with using the robot framework
18:59:51 <colindixon> #info LuisGomez thus suggests that we use the robot framework
19:00:26 <zxiiro> edwarnicke: "distribution" job types already have a tab today https://jenkins.opendaylight.org/releng/view/Distribution-Jobs/
19:00:35 <zxiiro> edwarnicke: we'd just make another tab for csit jobs
19:00:45 <edwarnicke> zxiiro: :)
19:01:13 <alagalah_> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:System_Test:Step_by_Step_Guide#System_Test_Job Robot testing information
19:02:48 <colindixon> #info there are jenkins job with templates from the integration group to make things easier
19:03:01 <colindixon> #info there will continue to be more things like this over time to make it as easy as possible
19:03:19 <alagalah_> #info Currently can do IMDS and CDS (single node) testing
19:03:37 <alagalah_> #info IMDS - in memory data store , CDS - clustered data store
19:06:20 <colindixon> thanks!
19:07:16 <alagalah_> #info edwarnicke suggests it may be a good idea for Integration project to join Wed AM (Pacific) cross-project IRC meeting.
19:07:35 <alagalah_> #action colindixon to get Phil to add to Wed agenda Integration section
19:07:40 <colindixon> alagalah_: thanks!
19:07:47 <alagalah_> colindixon: i can't type and go off mute
19:08:00 <alagalah_> colindixon: but I did find a Push to Talk App for Mac... may have to install
19:08:09 <colindixon> #action edwarnicke, colindixon, LuisGomez, rovarga, and others to explore how to better do triggering and avoid race conditions
19:24:04 <hideyuki> Is the TWS not ended yet?
19:25:22 <hideyuki> If the TWS call is ended, would a chair of the meeting end the meeting. I would like to get the URL of the minutes of the meeting.
19:28:56 <colindixon> #endmeeting