18:10:41 <colindixon> #startmeeting tws
18:10:41 <odl_meetbot> Meeting started Mon Nov  2 18:10:41 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:10:41 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:10:41 <odl_meetbot> The meeting name has been set to 'tws'
18:10:58 <colindixon> #topic casey presents new wiki design
18:12:26 <colindixon> #link https://wikistg.opendaylight.org/view/Main_Page the "staging" wiki which people can go check out
18:12:41 <colindixon> #info the username is daylight and password is ODLStageSiteAccess!
18:13:42 <colindixon> #link https://wiki.opendaylight.org/view/Main_Page that is linked to from the normal main wiki page here
18:17:49 <colindixon> #info the general plan dneary suggests, is to go through things here, then the TSC call briefly this week, then discuss any critical things at the hackfest
18:20:39 <colindixon> #info edwarnicke says he has concerns about the particular links and where they point, e.g., to AsciiDoc on github or to the "marketecture" slides
18:24:24 <colindixon> #info colindixon notes that this is not trying to hide the deep, developer cotent, but rather try to surface more user-oriented content to better serve a large number of people who wind up confued on the wiki
18:31:04 <colindixon> #info edwarnicke is particularly concerned that the release plans as linked from the new page is not the release plan he's used to
18:32:54 <colindixon> #info abhijitkumbhare and edwarnicke suggest maybe two release plan links one for users and one for developers
18:33:06 <dbainbri> we need to survey the target audience in terms of what content is needed and watch how they might go find it.
18:34:23 <colindixon> #info dbainbri notes that we likely need to survey the target audience (and define it?)  to better figure out what they're looking for and are we meeting their needs
18:34:36 <dbainbri> i would agree that the separation by audience is good, "user", "developer", etc and within each of those categories segment by experience "newbie", "toddler", "teen" etc.
18:35:23 <dbainbri> also, a difference between "odl developer" and "developer who builds something on top of ODL"
18:35:24 <colindixon> #info dneary asks, given what we have, what's missing?
18:36:29 <colindixon> #info edwarnicke says three things that are missing: getting started for developers, how to pull the code, and security would be things in the category
18:37:44 <colindixon> #info dbainbri asks is the the issue with the list of jumplinks or the jumplink topics, edwarnicke says he feels like it's a bit of both
18:38:05 <colindixon> #Info casey asks, what *should* be in the list for developer stuff
18:38:16 <dbainbri> shouldn't we ask the target audience what links they would like to see and then use our experience to sharpen that?
18:38:33 <colindixon> dbainbri: yes
18:41:16 <dbainbri> i would think this top level should be "task" based. answer the question "what do you want to do"
18:41:42 <dbainbri> behind that, could be much more detail about how do set up env, pull code (if you are a developer of ODL), etc.
18:41:53 <colindixon> #info dbainbri once again says that it seems like targeting the right audience
18:42:04 <dbainbri> almost "agile story based". "as a X, I want to do Y"
18:46:07 <edwarnicke> dbainbri: +1
18:47:12 <dbainbri> and how do we keep this all up to date … may be just as important and content
18:47:27 <colindixon> #info edwarnicke says that he feels this is going dramatically in the right direction overall, there are places where we may be missing and there are some places where it points the wrong way
18:48:32 <colindixon> #info edwarnicke points out some content is replicated in a few places, which is great
18:48:34 <edwarnicke> dneary: +1
18:48:52 <colindixon> #info abhijitkumbhare and dneary both suggest having a wiki page that fronts the mailing list page because it's so long as to be disorienting
18:50:23 <colindixon> #info dbainbri asks how we're going to keep this up to date
18:50:39 <colindixon> #info dneary asks if we can provide clear instructions how people can contribute to each of these places
18:51:48 <dneary> colindixon, The point being, improving the website/wiki is a great way to engage with the community, but I'm not sure if we enable that very well
18:53:59 <dneary> #info Example of a wiki mailing list page explaining lists, and linking to top ones: http://www.ovirt.org/Mailing_lists
18:54:21 <dbainbri> everyone has design preferences, won't make everyone happy.
18:54:30 <dneary> ^^^ Note that this page also uses the "wide margins, narrow text" approach
18:54:50 * dneary will not be introducing edwarnicke to Garrett, the designer that created the theme :-)
18:55:18 <colindixon> #info dneary's comment is that providing people ways to improve, contribute, or provide feedback on the webpage is a great way to engage the community
18:55:26 <edwarnicke> dneary: There is *completely* valid disagreement on choice of how much whitespace one wants
18:55:45 <colindixon> #info edwarnicke notes that there are very wide margins, and that he doesn't care for that
18:55:50 <edwarnicke> dneary: But when I was last involved in web design... the whole world was *running* towards fluid and away from pixel based ;)
18:55:51 * dbainbri thinks discussing wiki themes is like discussing what is the best color in the world
18:56:05 <colindixon> #info dbainbri notess (correctly) that themes are taste and we won't make everyone happy
18:56:07 <edwarnicke> dbainbri: Clearly, its #fffffff ;)
18:56:09 <dbainbri> its green by the way
18:56:10 <colindixon> dbainbri: literally bike shedding
18:56:21 <edwarnicke> colindixon: % of whitespace is taste
18:56:26 <edwarnicke> colindixon: pixel pasting is different
18:56:31 <colindixon> edwarnicke: I agree
18:57:10 <colindixon> edwarnicke: barring a way to reliably specify a rough number of words, inches, pixels are sadly the tech we have
18:57:24 <colindixon> the real issue is number of degrees a person's eyes have to move from end of one line to start of next
18:57:27 <edwarnicke> colindixon: We've had 'em' and % since the late 90s ;)
18:57:33 <colindixon> but that's sadly not a CSS-setable parameter
18:57:36 <dbainbri> i would think the priority is the content over format, is that fair?
18:57:43 <colindixon> dbainbri: +100
18:57:49 <edwarnicke> dbainbri: Agreed :)
19:00:35 <colindixon> #info colindixon says that at this point, the new three-column design is good enough compared to what we have, that the bigger risk is not moving than moving (assuming we fix the critical things like missing links to security issues)
19:02:17 <dbainbri> can we run in parallel until the new page meets some minimum and then switch it to the default, but have a link to the old wiki
19:02:25 <dbainbri> (click here to see new wiki)
19:02:37 <dbainbri> and then eventually (click here to see old wiki)
19:02:42 <colindixon> dbainbri: my take would be that we should err on the side of just doing it now
19:02:44 <colindixon> but that's me
19:03:18 <dbainbri> @colindixon: fine by me as long as we have a link to the old page for a while
19:03:29 <colindixon> +1
19:03:55 <dbainbri> @ccain: things will be missed, we are all human, can't be helped
19:05:28 <edwarnicke> dbainbri: +1 for link to old page
19:05:39 <edwarnicke> dbainbri: Makes all of this much less risky, and thus much more likely to succeed :)
19:06:28 <dbainbri> edwarnicke: no matter what we do, someone will consider it pure evil and a harbinger to the end of the world.
19:06:34 <colindixon> #info edwarnicke and dbainbri suggest that we could keep a link to the old page to make sure that we don't lose anything as we migration
19:07:25 <dneary> colindixon, I concur
19:08:07 <dbainbri> using google as an example, they allow "preview" views of maps for a while and then switch, with a link to the old way. if we don't want to provide a preview window, that is fine.
19:10:12 <colindixon> it's a wiki
19:10:16 <colindixon> rolling back if it's a mistake is trivial
19:10:23 <dbainbri> we have to points of view. they question is how do we resolve and make s decision ?
19:10:35 <dbainbri> s/they/the/
19:11:06 <dbainbri> (i miss the edit previous ability that #slack has and IRC doesn't)
19:13:43 <dneary> Dropped - I really need to join my next meeting
19:15:01 <dneary> My ¢0.02: Change ASAP, socialise this week on the TSC meeting to get a broader audience (but time-box to 10 mins)
19:15:14 <dneary> And make all the spelling anglicised
19:15:18 <dneary> :-)
19:18:00 <dbainbri> dneary, would that be your £0.02 then ?
19:18:04 <colindixon> #action colindixon to add socializing some of this wiki redesign to the TSC agenda for this week
19:20:26 <colindixon> #action edwarnicke to provide casey the link to the content he was thinking about, e.g., the getting started for new developers, and pulling the code
19:21:06 <dneary> dbainbri, No, definitely not worth 2p
19:21:15 <dneary> 0.02 cents sounds about right
19:21:33 <colindixon> #action colindixon to help get a thread started on the new wiki content to try to get more feedback
19:21:44 * colindixon needs to drop too
19:21:58 <colindixon> #endmeeting