14:30:39 <colindixon> #startmeeting weekly lithium IRC sync
14:30:39 <odl_meetbot> Meeting started Wed Mar 11 14:30:39 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:39 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:39 <odl_meetbot> The meeting name has been set to 'weekly_lithium_irc_sync'
14:30:45 <colindixon> #topic roll call and agenda bashing
14:30:56 <colindixon> #chair tbachman gzhao phrobb dfarrell07
14:30:56 <odl_meetbot> Current chairs: colindixon dfarrell07 gzhao phrobb tbachman
14:31:09 <tbachman> #info tbachman for groupbasedpolicy
14:31:09 <phrobb> #info Project Leads and TSC members please #info in
14:31:17 <colindixon> #info colindixon for docs, ttp, and the tsc
14:31:19 <gzhao> #info gzhao release
14:31:23 <LuisGomez> #info LuisGomez for Integration
14:31:37 <sdean778> #info Steve Dean for DIDM and SNMP Plugin
14:32:24 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Cross_Project_Meetings the loose agenda
14:32:46 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/weekly_lithium_irc_sync/opendaylight-meeting-weekly_lithium_irc_sync.2015-02-25-15.31.html there were no action items from the previous meeting
14:33:02 <colindixon> are there any topics anyone wants to add to the agenda?
14:33:42 <phrobb> #info Everyone please note that next Thursday (3/19) is M3 for Offset-2 project AND M4 == API Freeze for Offest-0 projects
14:33:52 <tbachman> :o
14:34:10 <phrobb> @tbachman Exactly
14:34:11 <gzhao> #info single feature test
14:34:33 * dfarrell07 is here and can answer ODL+OpenStack CI questions if anyone has any
14:34:44 <gzhao> Robert already did most of the changes
14:35:46 <gzhao> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1598222722 < Single Feature spreadsheet
14:36:05 <colindixon> #und
14:36:06 <colindixon> #undo
14:36:06 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1c3d490>
14:36:08 <colindixon> #undo
14:36:08 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a30650>
14:36:15 <colindixon> #topic single feature test
14:36:23 <colindixon> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1598222722 < Single Feature spreadsheet
14:36:44 <phrobb> gzhao:  it looks like we have many projects that have not yet verified the patches
14:37:22 <LuisGomez> dfarrell07: i will check your github before asking you questions  :)
14:37:25 <colindixon> do we have representatives from aaa, capwap, controller, dlux, discovery, integration, l2switch, lacp, packetcable, plugin2oc, reservation, sdninterfaceapp, snbi, snmp4sdn, sxp, or tsdr on the call?
14:37:47 <dfarrell07> LuisGomez: lol, no worries either way :)
14:38:02 <sdean778> DIDM is not in the spreadsheet, but is using single feature test
14:38:04 <phrobb> colindixon:  yes I was just noticing that we do not have many representatives on the channel this morning
14:38:18 <colindixon> #info as per the spreadsheet, it appears that aaa, capwap, controller, dlux, discovery, integration, l2switch, lacp, packetcable, plugin2oc, reservation, sdninterfaceapp, snbi, snmp4sdn, sxp, and tsdr have yet to fix their single feature test
14:38:31 <colindixon> sdean778: the list is populated with people that had the wrong single feature test to begin with
14:38:37 <colindixon> sdean778: so that’s expected :-)
14:39:14 <colindixon> phrobb: yeah
14:39:33 <LuisGomez> #info I remind al projects the single feature test is a condition to push your features to integration repo
14:39:57 <colindixon> #action aaa, capwap, controller, dlux, discovery, integration, l2switch, lacp, packetcable, plugin2oc, reservation, sdninterfaceapp, snbi, snmp4sdn, sxp, and tsdr projects to move to the new single feature test
14:40:35 <gzhao> I will send out an email requires project not reporting status or has action item to have a representative present
14:40:40 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-February/001488.html this mail gives guidelines as to how exactly to fix it, but for most projects there is already a patch waiting to be merged
14:40:53 <colindixon> #topic topics of general concern
14:41:22 <colindixon> other than the previously mentioned impending offset 2 M3, offset 0 M4, and the single feature test, anyone have anything
14:41:38 * colindixon notes that as phrobb pointed out we have light attendance, so we should just move through things quickly
14:41:42 <colindixon> going once
14:42:08 <gzhao> #info we have seen more and more projects in yellow status, so far, I didn't notice significant impact on depended projects
14:42:12 <phrobb> Question for dfarrell07
14:42:20 <colindixon> really, at this point anyone who’s actually here and paying attention should really just tell me if there’s anything they want to cover
14:42:55 <LuisGomez> #info Reminder of Robot FW tutorial next TWS call
14:43:08 <colindixon> that would be dfarrell07, phrobb, gzhao LuisGomez, sdean778, and tbachman as far as I can tell
14:43:16 <gzhao> colindixon: I would suggest projects in unreported status should at least be present in this meeting
14:43:20 <tbachman> colindixon: nothing at this point — other than more time ;)
14:43:46 <phrobb> On OVSDB I note a deliverable of "deprecate AD-SAL" and "Add MD-SAL interface".  With Functionality freeze occuring next Thursday, is the team expecting to have that completed in that timeframe?… i.e. "Is OVSDB status greeen"?
14:44:16 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1196332566 the current project status
14:44:44 <colindixon> phrobb: from my understanding the deprecating the AD-SAL is going pretty well, but the other stuff is less clear
14:45:24 <phrobb> colindixon:  Thanks… I'm just wanting to make sure that if the project isn't currently green, that we are representing it correctly
14:46:01 <phrobb> #info FYI on Maple, I have a meeting with the Lawyers (OpenDaylight's and Yale's) this afternoon
14:46:02 <colindixon> #info phrobb asks about the status of OVSDB hitting the “deprecate AD-SAL” and “add MD-SAL interface” and how that interacts with the M3 functionality freeze
14:46:43 <phrobb> Any other Questions or Announcements from anyone?
14:47:00 <colindixon> #action flaviof and/or dfarrell07 to figure that out since if we miss those targets it will have siginificant impact on other projects
14:47:15 * dfarrell07 is reading backlog
14:47:24 <colindixon> dfarrell07, phrobb, gzhao LuisGomez, sdean778, and tbachman, any questions?
14:47:31 * colindixon shamelessly uses mentions
14:47:39 <sdean778> no questions from me
14:47:47 <LuisGomez> no question
14:47:49 <tbachman> no questions from me either
14:47:59 <gzhao> no question
14:48:05 <dfarrell07> That #action should likely point at shague and flaviof, but my part can be bothering Sam :)
14:48:21 <phrobb> sounds good dfarrell07, thanks
14:48:30 <dfarrell07> phrobb: np :)
14:48:33 <LuisGomez> dfarrel07, i may be able to help you with jjb next week, i am just finishing integration jjb migration this week
14:48:34 * phrobb has no questions other than "where are the cookies?
14:48:36 <colindixon> dfarrell07: that’s why I put flaviof there
14:48:42 <colindixon> cookings going once
14:48:45 <colindixon> cookies
14:48:49 <colindixon> cookies going twice
14:48:50 <dfarrell07> cookies!
14:48:55 <dfarrell07> LuisGomez: kk, awesome
14:49:07 <colindixon> #topic cookies
14:49:09 <colindixon> #endmeeting