#opendaylight-meeting: weekly Lithium IRC sync

Meeting started by colindixon at 14:32:14 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 14:32:27)
    1. regXboi NN (regXboi, 14:32:38)
    2. Prem VPNService (Prem, 14:32:43)
    3. colindixon for TTP, docs, and TSC (colindixon, 14:32:56)
    4. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Cross_Project_Meetings agenda in it’s usual place (colindixon, 14:33:09)
    5. abhijitkumbhare OpenFlow plugin (can stay only some time) (abhijitkumbhare, 14:33:10)
    6. gzhao release (gzhao, 14:33:12)
    7. fabiel for Persistence Store Service (fabiel, 14:33:52)
    8. LuisGomez for integration (LuisGomez, 14:34:19)

  2. upcoming deadlines (colindixon, 14:35:25)
    1. M3 for offset 2, M4 for offset 0 due tomorrow (gzhao, 14:36:10)
    2. that’s API freeze for offset 0 (colindixon, 14:36:23)
    3. and functionality freeze for offset 2 (colindixon, 14:36:35)
    4. Helium 3 test and bug verification should be complete today (gzhao, 14:37:01)
    5. https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Information_From_Past_Meetings the March 16 TWS meeting has info on how to get your system tests started (required for M3) (colindixon, 14:37:22)
    6. https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Lithium_Project_Documentation_Requirements#Step-by-step_Guide this page has information on how to submit your documentation outliens (required for M3) (colindixon, 14:37:54)

  3. questtions, comments, concerns, announcements, etc. (colindixon, 14:38:29)
    1. alagalah_ for GBP (I undid it earlier because it was before the topic, this is redoing it) (colindixon, 14:39:18)
    2. alagalah GBP (alagalah_, 14:39:18)
    3. ttkacik1 asks if removing APIs that were deprecated in a previous release needs to happen before API freeze (colindixon, 14:42:04)
    4. colindixon and regXboi say they think that probably makes sense (colindixon, 14:42:16)
    5. ACTION: colindixon to review the patch to TTP to migrate away from composite nodes (colindixon, 14:46:49)
    6. alagalah_ asks if there is going to be a TSC review or just an e-mail for M3 (colindixon, 14:50:24)
    7. colindixon says that there will just be an e-mail the only time there’s a review with slots is for the release review between M5 and release (where TSC attendence is optional) (colindixon, 14:50:57)
    8. Prem asks how far out a deadline can be pushed with an ETA and have it be “reasonable" (colindixon, 14:55:15)
    9. gzhao and colindixon say to report where the honest progress is and how far away things are froming being done and the TSC and release staff will try to figure out if there’s a problem (colindixon, 14:55:44)
    10. regXboi|tsc_hat asks if Prem can explain what he means by making the VPNservice solution truly end-to-end (tbachman, 15:03:51)
    11. Prem says VPNService can be configured with needed parameters through an API. By end-to-end — he was expecting those parameters to flow in from OpenStack (tbachman, 15:04:27)
    12. regXboi|tsc_hat asks how they are getting those parameters via openstack (tbachman, 15:04:49)
    13. Prem says they only have L2 parameters coming from OpenStack (tbachman, 15:05:14)
    14. regXboi|tsc_hat asks how they come in from OpenStack (tbachman, 15:05:25)
    15. alagalah_ says that he and Prem are sitting down tomorrow to work out if OS GBP and ODL GBP together can get him over the line. (tbachman, 15:07:57)
    16. regXboi says in the spirit of full disclosure we have to point out to our customers that if VPN doesn't use NN, they will have to use a different part of OpenStack... (tbachman, 15:08:10)
    17. gzhao asks Prem if VPN services gets from openstack through NaN (tbachman, 15:09:21)
    18. Prem says yes, that’s how they started (tbachman, 15:09:27)
    19. colindixon says we want to track what’s happenign with VPN service, just to make sure they can have the best chance of getting the most out of the release (tbachman, 15:09:48)
    20. gzhao says the dependency diagrams need to change for VPN service (tbachman, 15:10:05)

  4. muffins (too early for cookies) (regXboi, 15:11:57)


Meeting ended at 15:12:22 UTC (full logs).

Action items

  1. colindixon to review the patch to TTP to migrate away from composite nodes


Action items, by person

  1. colindixon
    1. colindixon to review the patch to TTP to migrate away from composite nodes


People present (lines said)

  1. colindixon (58)
  2. tbachman (21)
  3. alagalah_ (16)
  4. Prem (12)
  5. regXboi (12)
  6. ttkacik1 (12)
  7. gzhao (10)
  8. regXboi|tsc_hat (8)
  9. odl_meetbot (7)
  10. LuisGomez (2)
  11. fabiel (1)
  12. abhijitkumbhare (1)
  13. phrobb- (0)


Generated by MeetBot 0.1.4.