14:32:14 <colindixon> #startmeeting weekly Lithium IRC sync
14:32:14 <odl_meetbot> Meeting started Wed Mar 18 14:32:14 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:32:14 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:32:14 <odl_meetbot> The meeting name has been set to 'weekly_lithium_irc_sync'
14:32:16 * alagalah_ looks around...
14:32:21 <alagalah_> #info alagalah GBP
14:32:26 <colindixon> #undo
14:32:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1bac4d0>
14:32:27 <colindixon> #topic agenda bashing and roll call
14:32:28 * regXboi notes oh there *IS* a meeting :)
14:32:38 <regXboi> #info regXboi NN
14:32:43 <Prem> #info Prem VPNService
14:32:45 <colindixon> #chair regXboi alagalah_ phrobb-
14:32:45 <odl_meetbot> Current chairs: alagalah_ colindixon phrobb- regXboi
14:32:56 <colindixon> #info colindixon for TTP, docs, and TSC
14:33:09 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Cross_Project_Meetings agenda in it’s usual place
14:33:10 <abhijitkumbhare> #info abhijitkumbhare OpenFlow plugin (can stay only some time)
14:33:12 * regXboi notes we should have named it neutron and northbound just so he could info in as NaN :)
14:33:12 <gzhao> #info gzhao release
14:33:52 <fabiel> #info fabiel for Persistence Store Service
14:34:07 <LuisGomez> #infi LusiGomez for integration
14:34:19 <LuisGomez> #info LuisGomez for integration
14:34:44 <colindixon> anyone have topics they want to raise?
14:35:25 <colindixon> #topic upcoming deadlines
14:36:10 <gzhao> #info M3 for offset 2, M4 for offset 0 due tomorrow
14:36:23 <colindixon> #info that’s API freeze for offset 0
14:36:35 <colindixon> #info and functionality freeze for offset 2
14:37:01 <gzhao> #info Helium 3 test and bug verification should be complete today
14:37:22 <colindixon> #link https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Information_From_Past_Meetings the March 16 TWS meeting has info on how to get your system tests started (required for M3)
14:37:54 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Lithium_Project_Documentation_Requirements#Step-by-step_Guide this page has information on how to submit your documentation outliens (required for M3)
14:38:11 <colindixon> #chair gzhao
14:38:11 <odl_meetbot> Current chairs: alagalah_ colindixon gzhao phrobb- regXboi
14:38:29 <colindixon> #topic questtions, comments, concerns, announcements, etc.
14:38:34 * tbachman wonders if colindixon undid alagalah_ ’s #info above
14:38:38 * colindixon opens up the floor
14:38:45 <tbachman> (for info-ing in)
14:38:53 <regXboi> yes - on purpose
14:39:09 <tbachman> alagalah_: you should re-info
14:39:12 <tbachman> regXboi: ack
14:39:18 <colindixon> #info alagalah_ for GBP (I undid it earlier because it was before the topic, this is redoing it)
14:39:18 <alagalah_> #info alagalah GBP
14:39:21 <colindixon> sorry
14:39:26 <colindixon> just leave it, not that much dirt
14:39:28 <tbachman> colindixon: no worries!
14:39:43 <alagalah_> My apologies, apparently my kid thought it would be acceptable to go to school without brushing her teeth (should have let her)
14:39:46 <colindixon> so, does anyone have any questions, concerns, annaouncements or anything?
14:39:53 <ttkacik1> sorry
14:39:58 <ttkacik1> timezone change
14:39:58 * regXboi listens for chirp chirp chirp
14:40:06 * tbachman smells stinky breath
14:40:07 <ttkacik1> colindixon: quick question
14:40:08 <alagalah_> colindixon: Q
14:40:11 <alagalah_> ttkacik1: you first
14:40:46 <ttkacik1> colindixon: does removal of deprecated APIs (from previous release) need to happen before API freeze? or do we need API Freeze Waiver?
14:40:54 <gzhao> I have a question about superpom, do we reach a decision with rovarga
14:41:29 <regXboi> ttkacik1: I would think it should happen before API freeze, but I can be argued around to the other position
14:41:40 <colindixon> ttkacik1: I think I would tend to agree with regXboi
14:42:00 <gzhao> ttkacik1: any other projects depend on those API?
14:42:04 <colindixon> #info ttkacik1 asks if removing APIs that were deprecated in a previous release needs to happen before API freeze
14:42:16 <colindixon> #info colindixon and regXboi say they think that probably makes sense
14:42:22 <ttkacik1> still TTP left out for composite nodes
14:42:44 <colindixon> ttkacik1: I thought you were going to submit a patch?
14:42:52 <ttkacik1> you have it there
14:43:11 <ttkacik1> was bit tricky to figure it out
14:43:14 <alagalah_> colindixon: I have my question after ttkacik1 .. want me to queue it up for addressing when you are done? Also looks like gzhao is in the Question Q (QQ) :)
14:43:55 <ttkacik1> problem is that some of other projects still sports uses other deprecated APIs
14:44:14 <ttkacik1> but I am fine with API Freeze Waiwer for removal
14:44:49 <ttkacik1> (just want to get Hydrogen code out from Lithium - since that backwards compatibility is entry barrier for people going to yangtools or controller)
14:46:49 <colindixon> #action colindixon to review the patch to TTP to migrate away from composite nodes
14:46:54 <colindixon> alagalah_: take your topic away
14:47:02 <alagalah_> colindixon: Ach
14:47:22 <alagalah_> colindixon: So are we doing a IRC meeting "scratch and sniff" on offset 2 M3 or is it just email ?
14:47:43 <colindixon> ttkacik1: is there a mail to the projects still using the APIs you’d like to remove?
14:48:17 * Prem wondering if the QQ is full or he can get his Qn in
14:48:20 * alagalah_ recalls the IRC review from He but can't recall what gate it was
14:48:28 <colindixon> alagalah_: I’m not sure I follow
14:48:48 <colindixon> Prem: please add questions to the queue
14:49:03 <colindixon> alagalah_: I think it’s just an e-mail
14:49:06 <alagalah_> colindixon: In He, projects had a Mx gate review with the TSC over IRC. We had timeslots etc assigned.. I can't recall if that was for a later gate or if we are doing away with it
14:49:20 <colindixon> alagalah_: that was for M5/RC0 I think
14:49:42 <alagalah_> colindixon: Ack... then our email is just about queued up ready to go... I ceded the floo
14:49:43 <ttkacik1> the composite node ones - they have already migrated / there are patches
14:49:43 <alagalah_> florr
14:49:49 <alagalah_> floor sigh... long day already
14:50:04 <ttkacik1> for other deprecated APIs (odl data store APIs) still need to figure out if there are such projects
14:50:24 <colindixon> #info alagalah_ asks if there is going to be a TSC review or just an e-mail for M3
14:50:57 <colindixon> #info colindixon says that there will just be an e-mail the only time there’s a review with slots is for the release review between M5 and release (where TSC attendence is optional)
14:51:01 <colindixon> Prem: did you have a question
14:51:25 <Prem> colindixon:  Yes, there are certain items that are in work in progress
14:51:47 <Prem> How far the ETA can be :)
14:52:26 <colindixon> gzhao: ?
14:52:45 <regXboi> Prem: I can say we went +1 week on M3 for NN as an offset 1 and nobody complained
14:52:46 <colindixon> Prem: for now, I think the idea is report the honest truth about where you are and what you could do to get back on schedule
14:52:53 <gzhao> well ETA to 3/31 is a little to long
14:53:05 <gzhao> but ETA is ETA to complete
14:53:32 <colindixon> Prem: from there the TSC and release staff will figure out what risk there is and decide how to try to help or not
14:53:38 <regXboi> Prem: of course, we did flag ourselves as yellow when we did it
14:53:57 <colindixon> Prem: does VPN service hae any one depending on it?
14:54:23 <Prem> colindixon:  Nope.  As of now we don't have any depedency on us
14:55:15 <colindixon> #info Prem asks how far out a deadline can be pushed with an ETA and have it be “reasonable"
14:55:44 <colindixon> #info gzhao and colindixon say to report where the honest progress is and how far away things are froming being done and the TSC and release staff will try to figure out if there’s a problem
14:56:25 <Prem> colindixon:  To make the VPNservice solution truly end to end, working with Openstack and GBP and hence wanted to some help
14:57:21 <colindixon> Prem: the short version (in my opinion) is this: if your project isn’t blocking others and will actually deliver something you feel is useful in the release in a reasonable time-frame, it’s probably fine
14:57:58 <colindixon> if you start to block others either directly (the depend on you) or indirectly (because you’ve broken the release build), then things get a lot harder
14:58:04 <Prem> colindixon:  Thanks and that helps!
14:58:07 <colindixon> but it doesn’t sound like that’s the case
14:58:28 <colindixon> Prem: also, we’d really like to see an understanding of how you will get across the finish line
14:59:30 <colindixon> Prem: so, will you deliver less than you expected? or are you getting extra help? or what?
14:59:34 <colindixon> if that makes sense
14:59:50 <colindixon> not to cut Prem off, but anything else people wanted to bring up?
14:59:52 <Prem> colindixon: We are good to go as a standalone module with needed APIs defined than can be used to define
15:00:16 * regXboi takes off NN hat and puts on TSC hat
15:00:54 <colindixon> ttkacik1: I would say that if you send a notice that you will seek an API freeze waiver about removing deprecated APIs and list the affected projects, that would be the right thing
15:00:58 <regXboi|tsc_hat> Prem: can you explain your "end to end" statement above?
15:01:47 <colindixon> #chair tbachman
15:01:47 <odl_meetbot> Current chairs: alagalah_ colindixon gzhao phrobb- regXboi tbachman
15:01:59 * tbachman pops in
15:02:12 <Prem> Sure.  VPNService can be configured with needed parameters through API.  What I meant end to end was - expecting these parameters to flow in from Openstack
15:02:16 * tbachman reads scrollbak
15:03:06 <regXboi|tsc_hat> Prem: I'm going to push you a bit harder on that statement - how are you getting those parameters via openstack?
15:03:25 <regXboi|tsc_hat> colidixon: I'm heading for a particular place here
15:03:39 <regXboi|tsc_hat> colindixon: so bear with me for a few more minutes
15:03:51 <tbachman> #info regXboi|tsc_hat asks if Prem can explain what he means by making the VPNservice solution truly end-to-end
15:04:07 <Prem> As of today, we don't have parameters other than L2 coming in from Openstack
15:04:27 <tbachman> #info Prem says VPNService can be configured with needed parameters through an API. By end-to-end — he was expecting those parameters to flow in from OpenStack
15:04:37 <regXboi|tsc_hat> Prem: that's the what - I'm asking the how
15:04:49 <tbachman> #info regXboi|tsc_hat asks how they are getting those parameters via openstack
15:05:14 <tbachman> #info Prem says they only have L2 parameters coming from OpenStack
15:05:25 <tbachman> #info regXboi|tsc_hat asks how they come in from OpenStack
15:05:36 <alagalah_> regXboi|tsc_hat: Prem I don't want to speak for Prem, but he and I are sitting down tomorrow to work out if OS GBP and ODL GBP together can get him over the line.
15:05:51 <regXboi|tsc_hat> alagalah_: that's what I'm trying to call out
15:06:02 <alagalah_> regXboi|tsc_hat: Prem Or some combination there of etc etc etc ... fullness of time, all things considered...
15:06:38 <regXboi|tsc_hat> because in the spirit of full disclosure we have to point out to our customers that if VPN doesn't use NN, they will have to use a different part of OpenStack...
15:06:52 * regXboi|tsc_hat takes off tsc_hat now
15:07:31 * gzhao curious does vpn services get from openstack through NaN?
15:07:57 <tbachman> #info alagalah_ says that he and Prem are sitting down tomorrow to work out if OS GBP and ODL GBP together can get him over the line.
15:07:58 <Prem> gzhao: Yes, that is how we started
15:08:10 <gzhao> Prem: thanks
15:08:10 <tbachman> #info regXboi says in the spirit of full disclosure we have to point out to our customers that if VPN doesn't use NN, they will have to use a different part of OpenStack...
15:08:46 <regXboi> all: tbachman's info is where I was trying to go - I'm done
15:08:59 <colindixon> so, I think it’s pretty clear that we want to track what’s happenign with VPN service, just to make sure they can have the best chance of getting the most out of the release
15:09:03 * tbachman notes that regXboi’s hat suffix is off
15:09:21 <tbachman> #info gzhao asks Prem if VPN services gets from openstack through NaN
15:09:21 <colindixon> thanks for letitng us know Prem and it sounds like you’re doing the right things
15:09:27 <tbachman> #info Prem says yes, that’s how they started
15:09:31 <colindixon> ok
15:09:35 <colindixon> so, any more topics?
15:09:43 <gzhao> Prem: I can see the dependency diagram changes for vpn service.
15:09:48 <tbachman> #info colindixon says we want to track what’s happenign with VPN service, just to make sure they can have the best chance of getting the most out of the release
15:10:05 <tbachman> #info gzhao says the dependency diagrams need to change for VPN service
15:10:21 <Prem> gzhao:  Yes
15:11:01 <colindixon> ok
15:11:07 <colindixon> last call for topics
15:11:09 <colindixon> going once
15:11:27 <regXboi> colindixon: you know I have one :)
15:11:35 <colindixon> going twice
15:11:57 <regXboi> #topic muffins (too early for cookies)
15:12:09 * tbachman grabs muffin, before meeting ends
15:12:19 <colindixon> gone
15:12:22 <colindixon> #endmeeting