14:31:02 <colindixon> #startmeeting weekly lithium irc sync
14:31:02 <odl_meetbot> Meeting started Wed Apr  8 14:31:02 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:31:02 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:02 <odl_meetbot> The meeting name has been set to 'weekly_lithium_irc_sync'
14:31:09 <colindixon> #topic agenda bashing and roll call
14:31:16 <colindixon> #info colindixon for TSC, docs, and ttps
14:31:27 <gzhao> #info gzhao for release
14:31:29 <regXboi> #info regXboi neutron northbound
14:31:30 <hideyuki> #info Hideyuki for VTN
14:31:38 <colindixon> #chair gzhao phrobb regXboi tbachman dfarrell07
14:31:38 <odl_meetbot> Current chairs: colindixon dfarrell07 gzhao phrobb regXboi tbachman
14:31:39 <Shreyas> #info shreyas for Persistence Store Service
14:31:49 <Prem> #info Prem for VPNService
14:32:00 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Cross_Project_Meetings agenda in it’s usual place
14:32:28 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/weekly_lithium_irc_sync/opendaylight-meeting-weekly_lithium_irc_sync.2015-04-01-14.30.html last week’s minutes with action times
14:32:33 <regXboi> edwarnicke: are you here?
14:32:56 <colindixon> it looks like edwarnicke and Reinaldo talked about clustering a lot
14:33:05 <colindixon> the OFP bugs did make it on the weather page
14:33:09 <edwarnicke> regXboi: I am
14:33:16 <colindixon> everyone, please add topics here if we need them
14:33:21 <edwarnicke> colindixon: I think I fixed both of the OFP bugs
14:33:33 <colindixon> #link https://wiki.opendaylight.org/view/Weather the weather page to track current and future issues
14:33:47 <colindixon> I didn’t see anything about this “alagalah to work with edwarnicke and Colin Dixon on changing the format of the Weather Page"
14:34:02 <abhijitkumbhare> #info abhijitkumbhare OpenFlow plugin
14:34:07 <colindixon> but I’ll assume alagalah and edwarnicke will find me if they need to or just fix it :-)
14:34:09 <edwarnicke> #info edwarnicke for fun
14:34:19 <edwarnicke> colindixon: LOL
14:35:08 <colindixon> ok, so rather than try to bin topics, I think I’m just going to put out an open call for any topics people have or things they want to cover
14:35:18 * regXboi raises hand
14:35:43 <colindixon> regXboi: go for it
14:35:46 * colindixon notes that Karaf 3.0.3 might be worth covering
14:35:57 <regXboi> #topci karaf feature order issue between restconf and neutron northbound
14:36:08 <regXboi> #topic karaf feature order issue between restconf and neutron northbound
14:36:13 <colindixon> thanks
14:36:15 <edwarnicke> colindixon: Ask and I will answer to the best of my ability :)
14:36:28 <abhijitkumbhare> #info OpenFlow plugin bugs 2895, 2896 & 2913 which were blocking other projects have been fixed
14:36:31 <regXboi> #info edwarnicke has determined that there is a feature ordering issue between neutron northbound and restconf
14:36:32 <abhijitkumbhare> Thx edwarnicke
14:36:46 <edwarnicke> regXboi: Its actually more 'moxy insists it is the very very very first JAXB thing loaded in the entire universe'
14:36:46 <regXboi> #info neutron northbound needs to be loaded before restconf
14:36:58 <edwarnicke> #undo
14:36:58 <regXboi> #chair edwarnicke
14:36:58 <odl_meetbot> Current chairs: colindixon dfarrell07 edwarnicke gzhao phrobb regXboi tbachman
14:37:11 <edwarnicke> #info neutron northbound needs to be loaded before any other JAXB thing
14:37:20 <abhijitkumbhare> Oops - sorry update given under wrong topic
14:37:30 <edwarnicke> Basically... this is the old moxy issue
14:37:35 <regXboi> abhijitkumbhare: no worries
14:37:35 <colindixon> it’s all good
14:37:40 <colindixon> OK
14:37:47 <edwarnicke> moxy is very ill behaved
14:37:51 <colindixon> does this affect other projects and is there a patch?
14:38:04 <edwarnicke> colindixon: no other project uses moxy
14:38:06 <colindixon> #info edwarnicke says it’s an old moxy issue and that moxy is ill-behaved
14:38:07 <regXboi> I made a pass at trying to remove moxy, but the patch falls down on handling namespaces
14:38:25 <regXboi> i.e. the patch broke downstream projects
14:38:30 <colindixon> OK
14:38:39 <colindixon> so, the change is made and we don’t expect it will affect other projects?
14:38:43 <regXboi> no
14:38:49 <colindixon> in terms of load ordering
14:38:53 <colindixon> not removing moxy
14:39:01 <edwarnicke> So... the moxy bug is also very very ugly because it manifests in random looking ClassNotFound exceptions
14:39:20 <edwarnicke> colindixon: The problem is this: we can't control the order a user loads things
14:39:37 <edwarnicke> colindixon: So even fixing the projects, it remains a risk
14:39:52 <colindixon> edwarnicke: ah
14:39:58 <regXboi> colindixon: I'd like to remove moxy, but to do so without changing APIs at this point is going to be ... difficult
14:39:59 <colindixon> I see now
14:40:06 <edwarnicke> colindixon: I would suggest there needs to be a concerted effort to see if we can solve the namespace issue with Jackson, so as to move away from moxy
14:40:13 <regXboi> edwarnicke: ++
14:40:22 <colindixon> ok
14:40:24 <colindixon> this is good to know about
14:40:30 <colindixon> does it make sense to put this on the weather page?
14:40:36 * edwarnicke notes this has been known since before Helium...
14:40:36 <regXboi> that's why we raised the profile
14:40:49 <colindixon> others: any topics while we close this one
14:40:59 <regXboi> I think it should be on the weather page
14:41:10 <regXboi> because it is the source of many random errors
14:41:16 <regXboi> or seemingly random errors
14:41:19 <edwarnicke> colindixon: So... please don't read the following as opposing putting the moxy thing on the weather page... but its sort of more like climate
14:41:38 * regXboi wonders if edwarnicke just proposed climate change :)
14:41:46 * edwarnicke definitely proposed climate change
14:41:54 <colindixon> #action regXboi or edwarnicke to post something about moxy and the interaction between restconf and neutron northbound to the weather page
14:41:55 <colindixon> ok
14:41:58 <colindixon> cool
14:42:08 <colindixon> we’ll track that, but it soudns like that’s all there is to report on it for now
14:42:16 <abhijitkumbhare> the climate is getting warmer - the weather here its raining :)
14:42:19 <edwarnicke> colindixon: Could we get a call out for someone to work on the moxy thing?
14:42:20 * regXboi thinks the weather page should include "climate"
14:42:27 <edwarnicke> colindixon: There is a lot of talk about how neutron is the most important thing
14:42:37 <edwarnicke> colindixon: But incredibly few folks actually showing up to *work* on neutron
14:42:56 <colindixon> edwarnicke: sure, where would you send that?
14:43:11 <edwarnicke> colindixon: I don't know... you've been wrangling folks on neutron, correct?
14:43:20 <colindixon> #action colindixon and/or phrobb to see if they can wrangle somebody to help with moxy issues
14:43:41 <edwarnicke> colindixon: We had over a dozen folks express a desire to be committers on neutron... but very few have shown up :(
14:43:47 <regXboi> actually, we can extend that past moxy
14:43:54 <edwarnicke> regXboi: True dat
14:43:58 <colindixon> understood
14:44:12 <edwarnicke> regXboi: We have a giant pile of things that need doing, and very few folks showing up to work on them
14:44:24 <colindixon> #topic Karaf 3.0.3 migration
14:44:33 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Karaf_3.0.3_Upgrade
14:44:49 <colindixon> #action EVERYONE please download and test your project with Karaf 3.0.3 to avoid pain later
14:44:54 <colindixon> edwarnicke: is there anythign else you wanted to cover here?
14:45:01 <colindixon> EVERYONE: are there any questions?
14:45:09 <edwarnicke> I don't think so, but am more than happy to answer questions
14:45:30 <edwarnicke> colindixon: I put a lot of work into making the update *not* be impacting... so we basically just need folks to test to catch the fringe issues
14:45:37 * tbachman wanders back into the room
14:45:40 <edwarnicke> colindixon: So far, the folks who have tested have reported no issues
14:45:43 * colindixon notes that *only three* projects (TTP, VTN, and LISP) have posted that they’ve tested
14:46:07 <tbachman> edwarnicke: was there a rebuild, post fixes to the ofplugin?
14:46:10 <colindixon> ok…
14:46:36 <colindixon> tbachman: good question
14:46:44 <edwarnicke> tbachman: Those fixes should be in nexus
14:46:46 * colindixon notes that he’s going to bring up docs next
14:46:59 <tbachman> edwarnicke: is karaf 3.0.3 in in nexus?
14:47:01 * edwarnicke scurries away to hide
14:47:04 <tbachman> lol
14:47:05 <colindixon> edwarnicke: I think he wants to know if there’s a courtesty integration build with Karaf 3.0.3 *and* the OF fixes
14:47:05 <edwarnicke> tbachman: No
14:47:06 <tbachman> k
14:47:17 <edwarnicke> colindixon: Ahh... thank you for clarifying :)
14:47:29 <edwarnicke> tbachman: No, but give me a few minutes to respin
14:47:33 <colindixon> #info tbachman asks if there’s a courtesty build of integration with the newer OFP patches that unbroke things, edwarnicke says no not yet
14:47:37 <tbachman> edwarnicke: awesome — thx!
14:47:52 <colindixon> #action edwarnicke to produce a build with Karaf 3.0.3 *and* the OFP fixes and post it to the weather page (largely because he’s awesome)
14:47:55 <colindixon> ok
14:47:56 <colindixon> next topic
14:47:58 <colindixon> going once
14:48:02 <colindixon> going twice…
14:48:06 <regXboi> cookies!
14:48:09 <colindixon> no, no
14:48:10 <colindixon> #topic docs
14:48:16 <regXboi> darn :(
14:48:16 <colindixon> #link https://lists.opendaylight.org/pipermail/documentation/2015-April/000414.html
14:48:25 <colindixon> #undo
14:48:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1a27b50>
14:48:28 * tbachman looks sheepishly away
14:48:36 <colindixon> #link https://lists.opendaylight.org/pipermail/documentation/2015-April/000414.html the status of docs patches as of yesterday afternoon
14:49:16 * edwarnicke whistles to himself
14:49:20 <regXboi> colindixon: other than filling in the yang half of the developers guide, NN's documentation is done
14:49:37 <colindixon> #info as of yesterday afternoon, 17 projects had made no effort I could find to provide asciidoc docs for Lithium and 2 projects had the patch in the wrong repo (not docs)
14:49:46 <tbachman> regXboi: teacher’s pet
14:50:00 <tbachman> lol
14:50:04 <regXboi> tbachman: you should read the comments on the patch before you say that
14:50:06 <colindixon> #info and four projects have just pointed to their Helium docs, which at least need to be moved to a new location
14:50:15 * regXboi called out colindixon in them :)
14:50:29 <edwarnicke> <joking>Would like to point out that docs are not type safe, and thus are very very scary</>
14:50:36 <regXboi> but it was all good
14:50:48 * regXboi groans
14:50:57 <colindixon> #action These projects need t post docs: AAA Service, Controller, Controller Core Functionality Tutorials, Defense4All, Device Identification and Driver Management (DIDM), Discovery, L2 Switch, Maple Programming Model, ODL-SDNi Application, Opflex, PacketCable PCMM Project, SB plugin to OpenContrail, SNMP Plugin, SNMP4SDN, Secure Network Bootstrapping Infrastructure (SNBI) project, Source Group Tag eXchange Protocol (SXP), d
14:50:58 <colindixon> - openDayLight User eXperience
14:51:07 <regXboi> um
14:51:17 <colindixon> #action These projects need move the docs to the docs repo: Application-Layer Traffic Optimization (ALTO), YANG Tools
14:51:17 <regXboi> hth is that supposed to be read?
14:51:48 <edwarnicke> colindixon: I thought we were going to work on having the docs project pull in docs from the projects in Lithium?
14:51:49 <regXboi> colindixon: back up with undos
14:51:51 <colindixon> #action These projects need to at least move the Helium docs to the right place: Group Policy Plugin Project, LISP Flow Mapping Service, OpenFlow Plugin, Virtual Tenant Network (VTN)
14:51:56 <edwarnicke> colindixon: Its much easier to keep up docs local to the project
14:52:03 <colindixon> edwarnicke: we were, but the work didn’t get done to make that easy
14:52:05 <edwarnicke> (not seeking to absolve projects)
14:52:06 <regXboi> the first one might be a mess in the minutes
14:52:13 <edwarnicke> colindixon: I feel ya
14:52:30 <colindixon> regXboi: noted
14:52:49 <colindixon> #info if those #actions are incomplete, check the link above for the e-mail version that is easier to parse
14:52:59 <colindixon> other topics before we call this one?
14:53:04 <colindixon> #topic upcoming deadlines
14:53:05 <regXboi> colindixon: ++ on the clarification
14:53:21 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Schedule the lithium schedule
14:53:42 <colindixon> #info M4 for offset 2 projects is a week from tomorrow
14:53:47 <colindixon> #undo
14:53:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x194a3d0>
14:53:55 <colindixon> #info M4 (API freeze) for offset 2 projects is a week from tomorrow
14:54:04 * edwarnicke eep!
14:54:07 <colindixon> #info M5 (code freeze) for offset 0 projects is a week from tommorrow
14:54:22 <colindixon> ok
14:54:26 <colindixon> I think that covers the key points
14:54:36 <colindixon> anyone want to cover something else other thank cookies?
14:55:03 <colindixon> going once
14:55:05 * edwarnicke waits anxiously for cookies
14:55:06 * colindixon counts to 10
14:55:15 <colindixon> going twice
14:55:19 * colindixon counts to 10
14:55:21 <regXboi> cookies!
14:55:41 * regXboi is amazed at how that has become a tradition :)
14:55:43 <edwarnicke> <chanting>cookies cookies cookies </>
14:55:43 <colindixon> done
14:55:45 <colindixon> #topic cookes
14:55:47 <colindixon> #undo
14:55:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1a8c110>
14:55:48 <colindixon> #topic cookies
14:55:49 <colindixon> #endmeeting