14:30:55 <colindixon> #startmeeting weekly lithium IRC sync
14:30:55 <odl_meetbot> Meeting started Wed Apr 22 14:30:55 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:55 <odl_meetbot> The meeting name has been set to 'weekly_lithium_irc_sync'
14:31:05 <colindixon> #topic roll call and agenda bashing
14:31:34 <colindixon> #info colindixon for docs, ttp and tsc
14:31:49 * colindixon waits for others to roll in
14:32:01 <gzhao> #info gzhao for release
14:32:09 <colindixon> #chair phrobb edwarnicke dfarrell07
14:32:09 <odl_meetbot> Current chairs: colindixon dfarrell07 edwarnicke phrobb
14:32:20 <edwarnicke> #info edwarnicke
14:32:34 <hideyuki_> #info hideyuki for vtn
14:33:29 <LuisGomez> #info LuisGomez integration
14:33:32 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/weekly_lithium_irc_sync/opendaylight-meeting-weekly_lithium_irc_sync.2015-04-08-14.31.html meetings from the last sync (two weeks ago)
14:35:46 <abhijitkumbhare> #info abhijitkumbhare OF Plugin
14:35:54 <colindixon> ok
14:36:00 <colindixon> that’s *very* light attendance
14:36:01 <Shreyas_> #info shreyas for Persistence Store Service
14:36:23 <colindixon> #link https://wiki.opendaylight.org/view/Weather the weather page for tracking cross-project issues
14:36:34 <LuisGomez> I have question: has karaf upgrade been successfully acomplished everywhere? or still issues?
14:36:51 <colindixon> everyone feel free to bring up topics
14:36:52 <gzhao> Shreyas_: does persistence elect new PTL?
14:37:05 <lori> #info lori for lispflowmapping
14:37:11 <abhijitkumbhare> I will be missing next week as I am on a vacation - but will conduct the OF plugin meeting & send the M5 status
14:37:26 <colindixon> #topic Karaf 3.0.3 migration
14:37:39 <colindixon> #info the Karaf 3.0.3 migration was harder than expected, but I *think* we’re through it
14:37:52 <colindixon> edwarnicke: see LuisGomez’s question above
14:37:54 <colindixon> any comments?
14:39:08 <colindixon> anyone else have any topics they want to queue up?
14:39:55 <edwarnicke> LuisGomez: well... I have no outstanding issue reports
14:39:56 <gzhao> colindixon: several projects under changes, would like to have updated PTL and project contact
14:40:28 <colindixon> #info LuisGomez asks if the Karaf 3.0.3 migration is complete, edwarnicke says that he’s not aware of any issues
14:40:42 <colindixon> #topic project leadership changes
14:40:50 <LuisGomez> #info we are investigating issue in Robot FW after karaf upgarde
14:41:00 <colindixon> #undo
14:41:00 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1932d90>
14:41:03 <colindixon> #undo
14:41:03 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1b97790>
14:41:12 <edwarnicke> gzhao: would you be willing to get a readout of Karaf 3.0.3 issues from projects?
14:41:22 <colindixon> #info LuisGomez says they’re investigating an issue in the robot framework after the Karaf issues
14:41:45 <LuisGomez> #info SSH execute remote command in Karaf console does not work anymore…
14:42:14 <colindixon> #action gzhao to add a line item to the next milestone report out for projects to report if they have experienced any issues since the upgrade to Karaf 3.0.3
14:42:18 <LuisGomez> #info will update when we find root cause
14:42:29 <colindixon> #undo
14:42:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ab77d0>
14:42:47 <gzhao> colindixon: will do
14:42:49 <colindixon> #info LuisGomez will provide more information about the ssh execute remote issue when they find the root cause
14:43:01 <colindixon> #action gzhao could also try to gather information earlier at his discretion
14:43:09 <colindixon> #topic projects under leadership change
14:43:26 <colindixon> gzhao: did you want to call out the projects that need to update things here
14:43:57 <gzhao> edwarnicke: for offset 0 M5 was right with Karaf 3.0.3 changes, will collect issues from offset 1 and offset 2
14:44:21 <colindixon> gzhao, edwarnicke: that sounds good
14:44:25 <gzhao> I know discovery is merged with didm
14:44:40 <hideyuki_> Do we plan to upgrade to Karaf 3.0.4 in Lithium?
14:44:44 <gzhao> Steven Dean is no longer working ODL from HP
14:44:47 <colindixon> hideyuki: I think not
14:44:53 <hideyuki_> colindixon: Thanks.
14:45:16 <colindixon> #info gzhao would like updated project leads and primary contacts from projects which have had recent changes
14:45:35 <colindixon> #info gzhao says that he believes that affects DIDM, discovery, and others
14:45:47 <colindixon> gzhao: can I #action you to make a list and reach out to those projects?
14:45:50 <gzhao> was l2switch PTL changed
14:45:59 <colindixon> gzhao: phil and I can help
14:46:06 <gzhao> colindixon: sure
14:46:31 <colindixon> #action gzhao, phrobb and colindixon to identify projects which may have had changes in primary contact and/or project lead and attempt to contact them
14:46:35 <gzhao> snmp plugin and sxp are two others
14:47:08 <colindixon> #action ANY PROJECT WITH A PTL OR PRIMARY CONTACT CHANGE please update the lithium release plan and your project facts block on your main page with the new information
14:47:18 <colindixon> more topics?
14:47:35 <colindixon> I note that the moxy issue never ended up on the weather page :-(
14:48:04 <colindixon> #action regXboi or edwarnicke to post something about moxy and the interaction between restconf and neutron northbound to the weather page
14:48:25 <colindixon> #action colindixon and/or phrobb to see if they can wrangle somebody to help with moxy issues
14:48:34 <colindixon> more topics
14:48:35 <colindixon> going once
14:48:37 <colindixon> anyone
14:48:45 <colindixon> #topic Karaf 3.0.4
14:48:55 <colindixon> #info hideyuki_ asks if we will move to 3.0.4 during Lithium
14:49:08 <colindixon> #info colindixon says he thinks not for Lithium given our stage in the cycle
14:49:20 <colindixon> LuisGomez: did you want to comment on system test status of projects
14:50:04 <LuisGomez> well, so far only a few have added system test in integration…
14:50:21 <LuisGomez> let me check quickly
14:50:24 <colindixon> LuisGomez: and have projects done any system tests
14:50:30 <colindixon> I know you sent out an e-mail summary
14:51:12 <LuisGomez> that one was for M3
14:51:21 <colindixon> yeah
14:51:22 <LuisGomez> did not count system test
14:51:35 <colindixon> ok
14:51:45 <gzhao> LuisGomez: you may give me the list and I can start to verify in the M5
14:52:08 <colindixon> #topic per-project documentation and integration readouts
14:52:17 <abhijitkumbhare> LuisGomez colindixon - when we release Lithium, do we want to clearly specify in the release notes or somewhere that projects with system tests are A, B, C, etc. ?
14:52:20 <LuisGomez> i will create a new check list for M4 yes
14:52:33 <lori> rovarga said awhile back that supporting Java 8 in Lithium is desirable, and the move to Karaf 3.0.3 was (in part?) because of that... another remaining issue is the use of Enunciate, which is not compatible with Java 8.  Anyone looking into alternatives? Is Java 8 support for Li still a goal?
14:52:46 <LuisGomez> abhijitkumbhare:, i guess so
14:52:55 <colindixon> #action LuisGomez to provide a list of project statuses for system test in Lithium
14:53:07 <lori> colindixon: topic proposal^^^
14:53:10 <rovarga> lori: it is for me :)
14:53:51 <colindixon> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit?pli=1#gid=613128231 documentation status is listed here, note *many* projects are red :-(
14:53:55 <colindixon> #topic Java 8
14:54:13 <colindixon> #info lori and rovarga ask about moving to being Java 8 compatible in Lithium
14:54:22 <lori> rovarga: we (lispflowmapping) are one of the project using enunciate for the OLD NB, which we deprecate in this release, but cannot remove yet
14:54:49 <colindixon> #info lori notes that moving to Karaf 3.0.3 was part of that effort, but removing enunciate was another part
14:54:50 <hideyuki_> #info VTN project is working on migrating Helium documents into Lithium documents.
14:55:03 <colindixon> hideyuki_: thanks!
14:55:36 <colindixon> #info lori notes that lispflowmapping is one of the projects using enunciate and while they will deprecate their usage in Lihtium, they can’t remove it in Lithium
14:55:44 <colindixon> edwarnicke: is Neutron still using enunciate as well?
14:59:01 <colindixon> #info in that case, it may be that we target Java 8 compatibility in Beryllium
14:59:03 <colindixon> ok
14:59:06 <colindixon> any more topics
14:59:15 <colindixon> otherwise, I’m going to call the meeting
14:59:29 <gzhao> cookies
14:59:42 <colindixon> #action colindixon and gzhao to reach out to rovarga, lori and others to figure out if we can get Java 8 in Lithium and plan for how to get there otherwise
14:59:45 <colindixon> #topic cookies
14:59:51 <colindixon> #endmeeting