14:30:37 <colindixon> #startmeeting weekly lithium irc sync
14:30:37 <odl_meetbot> Meeting started Wed Jun 17 14:30:37 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:37 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:37 <odl_meetbot> The meeting name has been set to 'weekly_lithium_irc_sync'
14:30:44 <gzhao> colindixon: thanks
14:30:45 <colindixon> #topic roll call and agenda bashing
14:30:59 <LACP-Rajesh> Rajesh from LACP team
14:31:00 <lori> #info lori for lispflowmapping
14:31:03 <colindixon> #info colindixon for docs, ttp and TSC
14:31:10 <Prem> #info for VPNService
14:31:11 <alagalah> #info alagalah gbp
14:31:12 <gzhao> #info release review for LACP and Neutron
14:31:18 <gzhao> #info gzhao
14:31:31 <colindixon> #chair gzhao
14:31:31 <odl_meetbot> Current chairs: colindixon gzhao
14:31:33 <Prem> #info Prem for VPNService
14:31:48 <hideyuki> #info Hideyuki for VTN
14:31:53 <colindixon> gzhao: so, we’re doing release reviews now or the weekly sync?
14:31:56 <edwarnicke> #info edwarnicke for neutron, TSC, and mischief
14:31:59 <odl-casey> Morning.
14:32:15 <abhijitkumbhare> #info abhijitkumbhare OpenFlow plugin
14:32:17 <edwarnicke> colindixon: I thought we were doing reviews...
14:32:28 <gzhao> colindixon: add release review to agenda
14:32:34 <colindixon> edwarnicke, gzhao: sounds good
14:32:36 <edwarnicke> gzhao: :)
14:33:16 <gzhao> #topic release review
14:33:38 <gzhao> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=743945554 <-- schedule
14:34:00 <colindixon> gzhao: sounds good
14:34:12 <colindixon> do we have LACP on the wire?
14:34:20 <gzhao> LACP-Rajesh:
14:34:24 <LACP-Rajesh> yes
14:34:46 <colindixon> #topic LACP release review
14:34:50 <gzhao> #link https://wiki.opendaylight.org/view/LACP:Lithium:Release_Review <-- LACP release review
14:35:12 <gzhao> #link https://wiki.opendaylight.org/view/LACP:Lithium:Release_Notes <-- LACP release note
14:35:31 * colindixon reads
14:35:46 <LACP-Rajesh> updated the contents for release review and release notes - please let us know of comments
14:35:51 <edwarnicke> LACP-Rajesh: I noticed you have two open bugs that are vexing you: https://wiki.opendaylight.org/view/LACP:Lithium:Release_Review#Bugzilla_.28summary_of_bug_situation.29
14:35:55 <edwarnicke> LACP-Rajesh: Are they blocker bugs?
14:36:27 <LACP-Rajesh> they are not blocker
14:36:40 <LACP-Rajesh> workaround is available for these bugs
14:36:49 <colindixon> #info LACP-Rajesh notes that while they have two open bugs, neither is a blocker as both have workarounds
14:37:20 <edwarnicke> LACP-Rajesh: Cool
14:37:22 <gzhao> LACP-Rajesh: ascii doc for release note is ready?
14:37:26 <LACP-Rajesh> Workaround for the defect - Start OpenDaylight controller with LACP module and then have the network connect to the controller.
14:37:54 <phrobb> LACP-Rajesh: will you be documenting the bugs and their work around in your release notes or somewhere else?
14:38:08 <colindixon> #link https://github.com/opendaylight/docs/blob/stable/lithium/manuals/user-guide/src/main/asciidoc/lacp/lacp-user.adoc user documentation
14:38:09 <edwarnicke> LACP-Rajesh: Do you have a notion of why LACP has to start before the network connects?
14:38:11 <LACP-Rajesh> it is updated in release notes
14:38:20 <colindixon> #link https://github.com/opendaylight/docs/blob/stable/lithium/manuals/developer-guide/src/main/asciidoc/lacp/lacp-dev.adoc developer documentation
14:38:50 <LACP-Rajesh> we need Ed's help to resolve ClassNotFound exception while LACP bringup
14:38:59 <colindixon> LACP-Rajesh: is that a blocking bug?
14:39:06 <edwarnicke> LACP-Rajesh: Let me grab your code :)
14:39:18 <LACP-Rajesh> when nodes are available in MD-SAL and then LACP is started
14:40:09 <colindixon> LACP-Rajesh: ah, this is not a blocking bug
14:40:48 <LACP-Rajesh> Ed - we can have a seperate meeting with you at your convenient time
14:41:25 <colindixon> +1
14:41:35 <phrobb> colindixon:  I believe Rajesh already noted neither of their two bugs listed and the work arounds are documented in their release notes
14:41:49 <colindixon> so, LACP-Rajesh I don’t actually see the workaround process in the release notes
14:41:51 <colindixon> I see the bugs
14:42:02 * regXboi pads in
14:42:09 <colindixon> but not the workarounds
14:42:32 <LACP-Rajesh> coline - in known issues and limitations
14:42:34 <alagalah> colindixon: I see the workaround
14:42:41 <alagalah> colindixon: Its a sub bullet
14:42:45 <alagalah> colindixon: Should it be a heading ?
14:42:53 <LACP-Rajesh> colin - please refer known issues and limitations
14:43:03 <colindixon> oh nevermind
14:43:05 <colindixon> I’m crazy
14:43:22 <colindixon> it’s listed in the notes, but not the release review and I missed it
14:43:23 <colindixon> ok
14:43:28 <colindixon> any other questions for LACP?
14:43:29 <alagalah> colindixon: not at all, if it wasn't obvious to you, then it may not be obvious to a use, so do you think these should have a heading in adoc ?
14:44:15 <colindixon> alagalah: it’s a good question that I think is going to come up a lot as we try to get our release notes together, so let’s handle it offline, sadly
14:44:19 <gzhao> shall we go to next one Neutron?
14:44:25 <colindixon> gzhao: I think so
14:44:37 <LACP-Rajesh> thank you all
14:44:42 <colindixon> #info alagalah notes that we might want to have a “workrounds” header to make things easier to find
14:44:45 <colindixon> LACP-Rajesh: thank you!
14:44:47 <gzhao> LACP-Rajesh: thank you
14:45:05 <gzhao> #topic Neutron release review
14:45:06 <regXboi> #info regXboi +1's alagalah's suggestion
14:45:18 <regXboi> #info regXboi wakes up
14:45:42 <gzhao> LACP-Rajesh: do you think you can do that workaround header suggest by alagalah
14:45:53 <regXboi> gzhao: do you have the release links?
14:46:03 <gzhao> #link https://wiki.opendaylight.org/view/NeutronNorthbound:LithiumReleaseReview <-- release review
14:46:31 <gzhao> #link https://wiki.opendaylight.org/view/NeutronNorthbound:LithiumReleaseNotes <-- Neutron release note
14:46:55 <colindixon> #link https://github.com/opendaylight/docs/blob/stable/lithium/manuals/developer-guide/src/main/asciidoc/neutron/neutron.adoc developer docuemntation
14:47:17 <regXboi> colindixon: let me add that to the release review on the fly
14:47:21 <gzhao> regXboi: release note misses some sections from sample release note
14:47:39 <regXboi> gzhao: I suspect they are all N/A
14:47:51 <gzhao> https://wiki.opendaylight.org/view/Sample_Release_Notes <-- sample release note
14:48:40 <gzhao> regXboi: oh, ok
14:49:09 <regXboi> I interpreted the later sections as not applying to the project, since this is neutron's first pass through the chute
14:49:14 <LACP-Rajesh> alagalah,gzhao - can i put the defect and workaround in a table?
14:49:15 <colindixon> regXboi: so, are the two bugs blocking?
14:49:25 <gzhao> regXboi: yes, you are right
14:49:27 <LACP-Rajesh> bug-id, bug-desc,workaround
14:49:35 <regXboi> they are blocking in the sense that full functionality is not possible
14:49:36 <LACP-Rajesh> as columns
14:49:49 <regXboi> however, they are also *not* bugs in NN itself
14:50:00 <edwarnicke> regXboi: Which bugs specifically?
14:50:05 <colindixon> regXboi: ah
14:50:08 <colindixon> 3304 and 3368
14:50:12 <gzhao> LACP-Rajesh: sure, sounds good to me
14:50:16 * edwarnicke is multitasking fixing LACP at the same time as attending the meeting
14:50:22 <LACP-Rajesh> thanks
14:50:40 <edwarnicke> LACP-Rajesh: On 3304
14:50:42 <regXboi> edwarnicke: this is the SG information bug and the missing tenant ID in neutronport bug
14:50:50 <colindixon> #info colindixon asks if bugs 3304 and 3368 are blocking, regXboi says they prevent full functionality, but are also bugs in external software
14:50:53 <edwarnicke> LACP-Rajesh: 128 switches is at the outer edge of what mininet itself can scale to
14:51:05 <edwarnicke> LACP-Rajesh: Have you tried with two hosts at 64 switches each?
14:51:19 <regXboi> #info neutron northbound has created an external component for tracking just these types of issues
14:51:33 <regXboi> #undo
14:51:36 <edwarnicke> regXboi: I think 3304 is resolved
14:51:43 <regXboi> somebody undo that last info please
14:51:50 <edwarnicke> regXboi: I also think that 3368 is resolved
14:51:52 <colindixon> #undo
14:51:52 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ba9150>
14:51:55 <colindixon> #chair regXboi
14:51:55 <odl_meetbot> Current chairs: colindixon gzhao regXboi
14:51:58 <edwarnicke> regXboi: But someone needs to verify the fixes
14:52:03 <regXboi> #info neutron northbound has created an external component in bugzilla for tracking these types of issues
14:52:20 <regXboi> #info edwarnicke reports that he believes both bugs are resolved but still need verification
14:52:27 <colindixon> ok
14:52:30 <colindixon> cool
14:52:36 <edwarnicke> regXboi: Which is to say, the known fixes for them are merged
14:52:37 <gzhao> regXboi: can we have links to the external tracking issues
14:52:49 <colindixon> they’re on the release notes
14:52:54 <regXboi> gzhao: they are the bugs themselves and are in the release notes
14:52:56 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=3304
14:52:57 <LuisGomez1> maybe silly question but is there any doc explaining current neutron capabilities? L2, L3, LB...
14:53:00 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=3368
14:53:19 <colindixon> LuisGomez: I think that is left to the neutron providers
14:53:19 <edwarnicke> LuisGomez1: That varies by provider
14:53:24 <LACP-Rajesh> Ed - we have tried 128 switches with 1 host
14:53:34 <regXboi> LuisGomez1: that's not a silly question, but colindixon and edwarnicke are correct
14:53:36 <ChrisPriceAB> ?? edwarnicke
14:53:43 <edwarnicke> LACP-Rajesh: I would suggest trying it spread across 2 or 4 hosts to see if mininet is the bottleneck
14:53:43 <gzhao> regXboi: got it
14:54:02 <regXboi> ChrisPriceAB: welcome - ed's multiplexing (again)
14:54:17 <regXboi> other questions?
14:54:23 <colindixon> #info LuisGomez asks if there are any documents explaining the L2, L3, LB, etc. capabilite, regXboi and edwarnicke say that’s currently left to the people who provide implementations of neutron, not the neutron project iself
14:54:37 <ChrisPriceAB> Hehe, yeah I noticed.  Are we talking about neutron providers in ODL?
14:54:40 <LuisGomez1> so all capabilities are available in neutron and then is up to provider to implement
14:54:47 <LuisGomez1> thanks
14:54:58 <edwarnicke> ChrisPriceAB: The time has come, the walrus said, to talk of many things, of ships and shoes and ceiling wax, of cabbages and kings...
14:55:01 <regXboi> #info ChrisPriceAB askes are we talking about neutron providers in ODL and regXboi say yes
14:55:04 <colindixon> ok, more questions for regXboi?
14:55:05 <edwarnicke> LuisGomez1: Good point :)
14:55:10 <edwarnicke> LuisGomez1: I see what you are getting at now :)
14:55:24 <regXboi> #info LusiGomez1 correctly points out that all capabilities are available in neutron and then is up to providers to implement
14:55:27 <edwarnicke> LuisGomez1: What does Northbound accept (whether it does anything is dependent on the provider)
14:55:44 * regXboi wonders if making the person representing the project a chair is a good idea :)
14:56:00 * edwarnicke wonders if being made chair is ever a good idea ;)
14:56:20 <regXboi> my only other note is that I'm still fighting with sonarqube on coverage reporting
14:56:28 <LACP-Rajesh> Ed - do you mean running mininet in 2 VM's  - each mininet having 64 switches and both mininet connecting to same controller?
14:56:35 <regXboi> sonarqube is not capturing IT code coverage correctly (yet)
14:56:50 <colindixon> ok
14:57:09 <colindixon> any more questions for regXboi?
14:57:26 <ChrisPriceAB> do we have descriptions of the capabilities of any of the neutron providers?
14:57:31 <edwarnicke> LACP-Rajesh: roughly yes... mininet is not highly scalable, and has been known to hit issues at 128 switches and above
14:57:48 <regXboi> ChrisPriceAB: isn't that out of scope for neutron northbound?
14:57:48 <edwarnicke> (no knock on mininet... it was never intended to be highly scalable... its good at what its good at ;) )
14:58:13 <ChrisPriceAB> colindixon didn't say they needed to be relvant questions!
14:58:16 <edwarnicke> ChrisPriceAB: I'd expect that description to be part of the providers review... but definitely a good thing to ask them to have ready there :)
14:58:20 <regXboi> ChrisPriceAB: I mean, it's a good question, but my answer is to give you my best "buster keaton"
14:58:31 <colindixon> ChrisPriceAB: I think that’s left during the release reviews for provider projects, e.g., GBP, VTN, OVSDB, …
14:59:06 <ChrisPriceAB> ok thanks guys.  I'll go back to my hole now
14:59:20 <colindixon> #info ChrisPriceAB asks if we have descriptions of what neutron features various providers give you. colindixon, edwarnicke, and regXboi say that will likely have to come during the release reviews for those projects.
14:59:21 * ChrisPriceAB sniffs quietly while skulking away
14:59:36 <colindixon> #topic broader lithium release issues
14:59:45 * edwarnicke hands ChrisPriceAB a handkerchief
14:59:45 <colindixon> ok, I think we’re done with release rviews
14:59:46 * regXboi calls ChrisPriceAB back
15:00:05 <colindixon> other ones are scheduled for monday and all of next week
15:00:16 <regXboi> colindixon: there was an RC bug on NN - the CORS bug
15:00:36 <regXboi> it was marked as a duplicate of one we already had in NN, which got fixed this morning in stable/lithium
15:00:41 <ChrisPriceAB> :D
15:00:47 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 blocking bugs
15:00:50 <regXboi> so the next RC1 (tomorrow) should not show that issue
15:01:09 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1757763090 RC test reports
15:01:21 <gzhao> I think there are blocking bug from SFC and TSDR, but I don't see them on the spreadsheet
15:01:22 <colindixon> #undo
15:01:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1b883d0>
15:01:28 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1757763090 RC1 test reports
15:01:34 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1072617634 RC0 test reports
15:02:02 <regXboi> hmm
15:02:10 <regXboi> how did 3368 make it on the blocking list?
15:02:24 <regXboi> oh wait - n/m
15:02:25 <colindixon> #action ALL PROJECTS NEED TO TRY THEIR CODE IN RC1 AND REPORT WHETHER THEY THIINK THEY HAVE ANY BLOCKING BUGS IN IT BY THE TSC CALL TOMORROW
15:02:27 * regXboi can't read :)
15:02:28 <gzhao> ok, TSDR listed a few non-blocking bugs in RC1 test reports.
15:02:52 * regXboi covers IRC ears from colindixon's IRC yelling
15:02:56 * ChrisPriceAB wishes colin would stop shouting...
15:03:06 <LACP-Rajesh> When will be the next RC1 build triggered?
15:03:07 <colindixon> right now we have 26 projects which haven’t done that
15:03:20 <regXboi> colindixon: and how many of them are here?
15:03:29 <colindixon> zxiiro or gzhao, do you know that for LACP-Rajesh
15:03:31 <edwarnicke> LACP-Rajesh: https://git.opendaylight.org/gerrit/22804  should fix 3767
15:03:41 <colindixon> regXboi: I’m not sure I’d have to go look up
15:03:52 <gzhao> #info all projects should update RC1 test reports spreadsheet before TSC call tomorrow. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1757763090
15:03:54 <edwarnicke> LACP-Rajesh: I got as far as verifying that when a switch connects before LACP initializes, we at least don't get the Exception thrown you are reporting
15:04:12 <gzhao> LACP-Rajesh:
15:04:24 <gzhao> colindixon: next will be UTC 11:59 today
15:04:32 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-June/002815.html here is the latest RC1 to test
15:04:50 <regXboi> colindixon: NN gives that one a thumbs up (tested it first thing this morning)
15:05:25 <regXboi> colindixon:gzhao: does it make sense to have in the RC testing page a column to say *which* RC1 candidate has been tested?
15:05:36 <gzhao> #info we still need the rest 26 projects to test RC1
15:05:41 <colindixon> cool
15:05:43 <colindixon> gzhao: yes
15:05:44 <edwarnicke> gzhao: What happened to the 'Needs verify' section of the blocking bug spreadsheet... it looks like its gone
15:05:53 <gzhao> regXboi: yes
15:05:57 <regXboi> because a green could be a green for the 6/14 version or the 6/15 version or ...
15:06:11 <LACP-Rajesh> Thanks Ed - Supersonic
15:06:12 <colindixon> #action gzhao to add a column in the RC1 readout that says which version of RC1 was tested
15:06:27 <LACP-Rajesh> we will test and let you know the results
15:06:41 <regXboi> #undo
15:06:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x19aadd0>
15:06:46 <regXboi> colindixon: I'm doing that right now
15:06:55 <colindixon> ok
15:07:08 <colindixon> any other critical isseus people need to bring forward
15:07:44 <regXboi> and added - somebody take a look and confirm
15:07:57 <edwarnicke> colindixon: We should shortly have a fix for offline mode, region, and slow startup
15:08:10 <edwarnicke> colindixon: The last piece just needs to be merged into integration
15:08:27 <colindixon> #info edwarnicke says we should have a fix soon to allow for offline running to work again
15:08:32 <colindixon> ok
15:08:37 <LuisGomez1> i will work on that today
15:08:44 <regXboi> alagalah: ping - did you really mark the RC as red?
15:08:47 <edwarnicke> Oh... and it makes the resulting zip file smaller to :)
15:08:55 <regXboi> smaller to what?
15:09:03 <colindixon> smaller too
15:09:06 <regXboi> :)
15:09:18 <edwarnicke> LOL
15:09:41 <colindixon> ok
15:09:44 <regXboi> as of right now - I see 9 green and 1 red in the RC page
15:10:09 <colindixon> #info regXboi notes that GBP is red in the RC1 at the moment
15:10:38 <regXboi> #info regXboi notes that there are 9 projects reporting green for RC1 as well
15:11:17 <colindixon> it looks like everything fro GBP is fixed but 2657
15:11:20 <colindixon> alagalah?
15:11:31 <alagalah> colindixon: Currently in GBP weekly status too
15:11:43 <tbachman> colindixon: I added a blocker bug to the spreadsheet today
15:11:44 <colindixon> #info bug 2657 is the remaining blocking issue that GBP is reporting
15:11:48 <tbachman> not against  NN tho
15:11:51 <alagalah> colindixon: That is correct, I have to show where we can reproduce it
15:12:22 <colindixon> ok
15:12:24 <alagalah> colindixon: when we reported it it was easily reproducible, now it only seems to occur at scale in our lab env (scale = 12 VMs ... not that many)
15:12:27 <colindixon> we’ll track that
15:12:40 <regXboi> tbachman: no worries about NN or not NN - we are off to more general items
15:12:52 <colindixon> anything else people wanted to cover?
15:12:55 <alagalah> colindixon: Its on my list to do today, this was reported quite some time ago, and we made as many changes as we could that helped but it appears not resolved it
15:13:14 <gzhao> zxiiro: do you know why the last build some tests in grey
15:13:17 <colindixon> otherwise, people please test your code in RC1, report any issues and help us track down and kill blocking bugs if we can
15:13:25 <regXboi> colindixon: other than if somebody else has made IT reporting work with sonarqube, they'll save me a bunch of time
15:13:54 <colindixon> regXboi: I *think* that madhu, brent and folks in OVSDB had that working sometime, but I don’t actually know
15:14:08 <regXboi> colindixon: I tried their solution and it didn't work for me
15:14:24 * regXboi is threrefore a bit ... dubious
15:14:36 <colindixon> #info there is a discussoin of 2657. in essence it was easily reproduced, but now is somewhat harder to get at, despite still being there with regularity.
15:14:38 <colindixon> regXboi: noted
15:14:41 <colindixon> I have nothing better
15:14:42 <colindixon> ok
15:14:44 <colindixon> going once
15:14:49 * regXboi will continue looking
15:14:49 <colindixon> last call for topics
15:14:53 <colindixon> going twice...
15:14:54 <regXboi> #topic cookies :)
15:14:58 <colindixon> gone
15:15:01 <colindixon> #endmeeting