16:00:08 <anipbu> #startmeeting beryllium release review
16:00:08 <odl_meetbot> Meeting started Fri Feb  5 16:00:08 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:08 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:08 <odl_meetbot> The meeting name has been set to 'beryllium_release_review'
16:00:14 <anipbu> #topic roll call
16:00:27 <anipbu> #info anipbu
16:00:53 <anipbu> TLee (Thomas Lee S), could you #info yourself in
16:01:00 <anipbu> #info PTL and TSC members please #info in
16:01:07 <colindixon> #info colindixon
16:01:20 <TLee> #info Thomas Lee
16:01:20 <anipbu> #chair phrobb colindixon
16:01:20 <odl_meetbot> Current chairs: anipbu colindixon phrobb
16:01:36 <colindixon> anipbu: phrobb might be phrobb- as well :p
16:01:40 <colindixon> #chair phrobb-
16:01:40 <odl_meetbot> Current chairs: anipbu colindixon phrobb phrobb-
16:02:08 <TLee> #info Thomas Lee for Controller Shield
16:02:51 <colindixon> anipbu: I'm ready whenever
16:02:55 <anipbu> So today we only have one project presenting: Controller shield.
16:02:58 <anipbu> Let's get started
16:03:03 <anipbu> #topic USECPLUGIN (Controller Shield)
16:03:08 <anipbu> #link https://wiki.opendaylight.org/view/Controller_Shield:_Beryllium_Release_Review  <-- Release Review
16:03:12 <anipbu> #link https://wiki.opendaylight.org/view/Controller_Shield:_Beryllium_Release_Notes  <-- Release Notes
16:03:18 <anipbu> #info Thomas Lee S is representing USECPLUGIN Team
16:03:26 <anipbu> TLee, anything you would like to add?
16:03:44 <gzhao> #info gzhao
16:03:44 <TLee> Nothing from our end An
16:04:01 <colindixon> TLee: in addition to the wiki dos, do you have AsciiDoc patches waiting for review to the docs project?
16:04:37 <colindixon> TLee: https://wiki.opendaylight.org/view/Controller_Shield:_Beryllium_User_Guide generally, the user guide shouldn't talk about cloning the code, the assumption is that they've downloaded the karaf distriubtion from the downloads page
16:04:48 <TLee> Colin we are waiting for merge
16:04:48 <colindixon> so it should start with a feature:install instead of git clone or anything like that
16:04:58 <colindixon> TLee: noted that's my fault, just making sure
16:05:01 <TLee> Will change that
16:05:19 <colindixon> TLee: does that make sense? (the feature:install vs. git clone in the user guide?)
16:05:31 <TLee> Sure I understood the mistake
16:05:45 <colindixon> cool
16:05:49 <anipbu> TLee, what are the patches waiting to merge?
16:05:54 <TLee> We will change the userguide accordingly
16:05:59 <colindixon> anipbu: for docs
16:06:22 <colindixon> #action TLee to update the user guide to not mention git clone and instead start with feature:install assuming somebody has already downloaded and run the karaf distrubtion
16:06:37 <colindixon> TLee: there's no other content...
16:06:42 <TLee> Sure Colin
16:06:44 <colindixon> TLee: do you have any open bugs?
16:06:56 <TLee> We dont have any bugs open
16:07:04 <colindixon> TLee: it's a security focused project, so it seems odd that there's no security considerations
16:07:12 <colindixon> #info TLee says there are no open bugs
16:07:39 <TLee> We have been securing the controller from PacketIn attacks
16:07:53 <TLee> We will add more information about that in the userguide
16:08:03 <colindixon> TLee: and the schedule went well, there weren't any major changes or shifts over the release?
16:08:21 <colindixon> TLee: I meant in the release review, you have N/A for all sections after Non-Code Aspects
16:08:26 <TLee> No Colin we have been on time.
16:08:27 <anipbu> #info TLee says there are patches waiting to be merge for docs
16:08:50 <anipbu> #action TLee will add information about security considerations
16:09:10 <colindixon> some of those make sense, e.g., end-of-lifing, others make less sense
16:09:15 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/29427/ the docs patch
16:09:38 <colindixon> TLee: did you do any testing either automated or otherwise?
16:10:04 <anipbu> TLee: Since usecplugin is first release in beryllium, it does not need a section on "Changes Since Previous Releases".  This can be removed.
16:10:16 <TLee> We did the basic testing
16:10:21 <colindixon> anipbu: N/A is fine there, I agree, it's just the security section that makes sense
16:10:47 <colindixon> TLee: the only last question I'd have would be do you think this is an "experimental" feature or a more "stable" feature in Boron? I'm not trying to coerce you either way, just lettying you label it experiemntal if you think that's more fitting.
16:11:01 <TLee> Automated Robot testing has been done
16:11:02 <colindixon> TLee: so, if you could summarize in a paragraph or two what you tested and what you think would work, that would be great
16:11:05 <colindixon> TLee: cool
16:11:16 <colindixon> TLee: providing a link to those test results would be awesome
16:11:26 <anipbu> TLee, you automatic testing does not have nay functional coverage
16:11:27 <anipbu> https://jenkins.opendaylight.org/releng/view/usecplugin/job/usecplugin-csit-1node-basic-all-beryllium/105/robot/report/log.html
16:11:27 <TLee> Experimental is better suited
16:11:49 <anipbu> TLee, it only tests "010 Restconf OK"
16:11:57 <colindixon> #action TLee to add a link to the automated robot tests they wrote in the QA and test coverage section (if you like your sonar code coverage results you can link to that too)
16:12:10 <colindixon> #info TLee notes that he thinks this is an experimental feature in Boron
16:12:33 <TLee> Sure we will add the links to the robot tests
16:13:12 <TLee> We will also add teh link to the SONAR
16:13:22 <colindixon> TLee: it would be good to just say what exactly about the feature you tested as well
16:13:31 <anipbu> TLee, you know the unit test coverage percentage?
16:13:52 <TLee> Sure colin we mention about the feature tested
16:14:13 <TLee> An we will check the test coverage and inform you over mail.
16:15:47 <colindixon> cool
16:15:55 <colindixon> I think that's all the questions I had
16:15:59 <anipbu> I don't have anything else, colindixon, anything else you'd like to ask?
16:16:08 <colindixon> anipbu: I think I'm good
16:16:17 <colindixon> anipbu: I assume you're tracking features that are experiemntal and you'll enter that
16:16:49 <anipbu> I've been tracking it in column J at this link https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=879332351
16:17:01 <TLee> Sure An we will do that. Thanks Colin and An. Thank you for all the support we had.
16:17:03 <anipbu> But agreed that I should put it on a wiki instead
16:17:14 <colindixon> anipbu: eventually that will go in the getting started guide
16:17:27 <colindixon> I just want to make sure we have an authoritative source and you update it for this project
16:17:39 <jamoluhrsen> did you guys note that CSIT is not there?
16:18:06 <colindixon> jamoluhrsen: thanks for pointing that out, I think anipbu noted it was just a REST call and nothing else
16:18:11 * jamoluhrsen just logged in
16:18:22 <anipbu> #action anipbu to track experimental features on wiki instead of the google spreadsheet as an authoritative source.  eventually it will go into the getting started guide
16:18:25 <colindixon> #info jamoluhrsen points out that no CSIT was done for this project
16:18:39 <jamoluhrsen> colindixon, ok.  the rest call has nothing to do with this project either.  it's a skeleton test to help projects over the hurdle of getting robot upstream
16:19:49 <anipbu> Okay, any other concerns jamoluhrsen for usecplugin?
16:19:54 <colindixon> jamoluhrsen: noted
16:20:20 <jamoluhrsen> nothing from me.
16:20:49 <anipbu> Okay, thanks TLee.  That completes the release review for USECPLUGIN.
16:21:07 <TLee> Thanks An.
16:21:15 <anipbu> That's all the projects for today.
16:21:35 <anipbu> Next release review is Monday at 8AM
16:21:56 <anipbu> Thanks colindixon, jamoluhrsen, TLee
16:22:15 <colindixon> thanks!
16:22:19 <colindixon> anipbu: that's all for today, right?
16:22:27 <TLee> Bye Colin, An and Janluhrsen
16:22:30 <anipbu> colindixon: yes, we are done
16:22:35 <anipbu> for today
16:22:53 <anipbu> #topic cookies
16:23:13 <anipbu> #endmeeting