16:00:05 <anipbu> #startmeeting beryllium release review
16:00:05 <odl_meetbot> Meeting started Mon Feb  8 16:00:05 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:05 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:05 <odl_meetbot> The meeting name has been set to 'beryllium_release_review'
16:00:11 <anipbu> #topic roll call
16:00:31 <anipbu> #info anipbu for USC, NEMO, CAPWAP
16:00:40 <anipbu> #info PTL and TSC members please #info in
16:03:27 <anipbu> #chair phrobb- colindixon
16:03:27 <odl_meetbot> Current chairs: anipbu colindixon phrobb-
16:03:48 <anipbu> So today we have three projects presenting: USC, NEMO, and CAPWAP.
16:03:57 <aricg> wc
16:05:35 <anipbu> welcome aricg
16:06:16 <LuisGomez> #info LuisGomez integration
16:06:33 <anipbu> good morning LuisGomez
16:06:47 <colindixon> #info colindixon
16:07:01 <anipbu> good morning colindixon
16:07:06 <anipbu> Let's get started
16:07:14 <LuisGomez> good mornind anipbu
16:07:14 <anipbu> #topic USC (Unified Secure Channel)
16:07:22 <anipbu> #link https://wiki.opendaylight.org/view/USC:Beryllium:Release_Review <-- Release Review
16:07:27 <anipbu> #link https://wiki.opendaylight.org/view/USC:Beryllium:Release_Notes <-- Release Notes
16:07:39 <anipbu> #info USC are working to add additional CSIT jobs for automated system testing of USC functionality, pending the merge of this patch
16:07:44 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/31730/
16:07:51 <anipbu> This is a maintenance release for USC.  We are focused on fixing bugs and implementing an automated testing environment for USC, including creating a java usc agent and echo server for the purpose of testing.
16:08:58 <anipbu> #chair LuisGomez
16:08:58 <odl_meetbot> Current chairs: LuisGomez anipbu colindixon phrobb-
16:08:58 * colindixon looks over things
16:10:01 <anipbu> USC also has clustering bug pending 3402: USC features has configuration issues with 3-node cluster environment.
16:10:10 <colindixon> this looks good to me
16:10:59 <anipbu> LuisGomez, any comments from integration regarding USC?
16:11:11 <LuisGomez> no, it looks good to me too
16:11:23 <anipbu> Okay let's move on to NEMO
16:11:36 <anipbu> #topic NEMO (NEtwork MOdeling)
16:11:42 <anipbu> #link https://wiki.opendaylight.org/view/NEMO:Beryllium:Release_Review <-- Release Review
16:11:47 <anipbu> #link https://wiki.opendaylight.org/view/NEMO:Beryllium:Release_Notes <-- Release Notes
16:11:52 * colindixon looks over the documents
16:11:54 <anipbu> #info NEMO has documentation in asciidocs pending the merge of this patch
16:11:58 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/32991/
16:12:25 <jamoluhrsen> LuisGomez, anipbu colindixon : I'm here now if needed.
16:12:40 <anipbu> good morning jamoluhrsen
16:12:55 <LuisGomez> hi jamo
16:13:25 <colindixon> anipbu: I'm assuming neither NEMO nor USC would be considered experiemental?
16:14:00 <anipbu> Yes
16:14:08 <anipbu> actually NEMO has testing in actual huawei device
16:14:14 <colindixon> anipbu: thanks
16:14:15 <colindixon> that's fine
16:14:32 <anipbu> NE40E
16:14:40 <LuisGomez> both projects were in Lithium right?
16:14:41 <colindixon> anipbu: are there release notes for either proejct?
16:15:00 <colindixon> there are release notes for NEMO
16:15:09 <colindixon> it seems like there are no release notes fro USC
16:15:40 <anipbu> #link https://wiki.opendaylight.org/view/USC:Beryllium:Release_Notes <-- Release Notes for USC
16:15:47 <colindixon> anipbu: thanks
16:15:57 <anipbu> #link https://wiki.opendaylight.org/view/NEMO:Beryllium:Release_Notes <-- Release Notes for NEMO
16:16:07 <colindixon> #action anipbu to link in release notes for the USC project into the release review
16:16:58 <colindixon> otherwise, this looks good to me
16:17:08 <colindixon> jamoluhrsen: NEMO is reporting system test?
16:17:57 <LuisGomez> afair they have a small system test
16:18:13 <anipbu> #link https://jenkins.opendaylight.org/releng/view/nemo/job/nemo-csit-1node-engine-all-beryllium/  <-- NEMO automated CSIT jobs
16:18:26 <colindixon> LuisGomez: cool
16:18:27 <colindixon> anipbu: thanks!
16:18:46 <anipbu> LuisGomez, NEMO has small functional coverage for CSIT jobs, hoping to expand in Boron.
16:18:51 <jamoluhrsen> colindixon, yes nemo has system test and currently working for more.
16:19:09 <colindixon> #info anipbu and jamoluhrsen note that NEMO has automated CSIT with more on the way
16:19:11 <colindixon> cool
16:19:13 <colindixon> I'm happy
16:19:34 <anipbu> LuisGomez, This is NEMO's first release, the focus was on functionality.  Will focus more on building larger scope for testing in Boron
16:19:54 <LuisGomez> sure anipbu, i am good with the current system test
16:21:36 <LuisGomez> so both NEMO and USC are fine for release, imo.
16:22:07 <anipbu> colindixon, any other comments for NEMO?
16:22:11 <colindixon> anipbu: I'm good
16:22:14 <colindixon> this looks good to me
16:22:25 <anipbu> Okay Let's move on to CAPWAP
16:23:09 <anipbu> #topic CAPWAP (Control And Provisioning of Wireless Access Points)
16:23:13 <anipbu> #link https://wiki.opendaylight.org/view/CAPWAP:Beryllium:Release_Review <-- Release Review
16:23:23 <anipbu> #link https://wiki.opendaylight.org/view/CAPWAP:Beryllium:Release_Notes <-- Release Notes
16:23:49 <anipbu> I was asked by PTL Navin from Brocade to present on his behalf.
16:24:10 <colindixon> anipbu: thanks
16:24:12 * colindixon looks
16:24:58 <anipbu> CAPWAP did not deliver on functional improvements spelled out in the release plan due to resource constraint. But they will work on Beryllium release deliverables and bug fixes in Boron.
16:25:32 <anipbu> CAPWAP for Beryllium will be a maintenance release, with no functionality changes, no api changes.
16:25:39 <jamoluhrsen> system test is there, but minimal
16:25:57 <colindixon> #Info jamoluhrsen notes that system test is there, but minimal
16:26:05 <colindixon> anipbu: was capwap experimentatl in Lithium?
16:26:50 <anipbu> It is experimental, having testing only an opensource simulator of CAPWAP AC
16:27:08 <anipbu> No actual testing on physical AC
16:27:10 <colindixon> anipbu: it was not labeled as experimental in Lihium, but if it should be labeled as such
16:27:20 <colindixon> then, we should do that in berryllium
16:27:42 <anipbu> This is the testing platform used by CAPWAP team: http://sourceforge.net/projects/capwap/
16:27:57 <colindixon> #action anipbu to follow up with navin about whether capwap should be lableled as experimental in Beryllium and note it on the spreadsheet if appropriate
16:29:02 <LuisGomez> also i am missing the test plan for capwap, do you know anupbu if they have one?
16:29:53 <anipbu> No, capwap team has not provided a system test plan.
16:29:59 <colindixon> jamoluhrsen: said they had basic sysem test
16:30:26 <colindixon> #link https://jenkins.opendaylight.org/releng/view/capwap/job/capwap-csit-1node-ac-all-beryllium/ it looks like they have CSIT, but that it is faiing
16:30:43 <colindixon> #undo
16:30:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x21bb1d0>
16:30:45 <jamoluhrsen> LuisGomez is referring to this, I think: https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report
16:30:55 <jamoluhrsen> most projects did not do this, I think.
16:31:02 <colindixon> #link https://jenkins.opendaylight.org/releng/view/capwap/job/capwap-csit-1node-ac-all-beryllium/ it looks like they have CSIT, but that is only very recently passing
16:31:07 <LuisGomez> right jamoluhrsen
16:31:46 <LuisGomez> i am good with this project as experimental
16:32:09 <jamoluhrsen> their -only- job for csit has been passing for a while.  I have not looked at this projects failures in -all- before.
16:33:06 <LuisGomez> they will need to look at the -all- test failure
16:33:15 <colindixon> #link https://jenkins.opendaylight.org/releng/view/capwap/job/capwap-csit-1node-ac-only-beryllium/ this CSIT seems to be passing
16:33:38 <anipbu> https://jenkins.opendaylight.org/releng/job/capwap-csit-1node-ac-all-beryllium/613/  <-- on latest RC2, capwap all testing passed.
16:33:49 <colindixon> this looks fine to me
16:34:07 <LuisGomez> ok anipbu
16:35:20 <anipbu> Okay, then we are done with all three projects for today.
16:35:40 <anipbu> Thanks colindixon, LuisGomez, jamoluhrsen
16:35:46 <colindixon> thanks
16:35:47 <colindixon> !
16:35:52 <LuisGomez> thanks
16:36:00 <colindixon> anipbu: do we have any idea on how many people are actually showing up tomorrow?
16:36:06 <jamoluhrsen> ok guys.  have a good monday.
16:36:39 <anipbu> colindixon, could I get back to you on that by email?
16:36:48 <colindixon> anipbu: yeah
16:36:54 <colindixon> end the meeting
16:36:56 <colindixon> I was just asking
16:36:57 <colindixon> :-)
16:37:01 <colindixon> thanks anipbu for making this all work
16:37:07 <anipbu> #topic cookies
16:37:17 <anipbu> #endmeeting