#opendaylight-meeting: beryllium release review

Meeting started by anipbu at 15:28:49 UTC (full logs).

Meeting summary

  1. roll call (anipbu, 15:28:55)
    1. anipbu (anipbu, 15:29:01)
    2. PTL and TSC members please #info in (anipbu, 15:29:08)
    3. rgoulding (rgoulding, 15:30:01)
    4. colindixon for TTP, docs, and TSC (colindixon, 15:30:08)
    5. rovarga for odlparent, yangtools (rovarga, 15:31:39)
    6. rgoulding for aaa (rgoulding, 15:31:58)

  2. ODLPARENT (OpenDaylight Root Parent) (anipbu, 15:32:32)
    1. https://wiki.opendaylight.org/view/ODL_Root_Parent:Beryllium:Release_Notes <-- Release Notes (anipbu, 15:32:36)
    2. https://wiki.opendaylight.org/view/ODL_Root_Parent:Beryllium:Release_Review <--Release Review (anipbu, 15:32:41)
    3. the only thing to maybe add to the release notes would be the various version upgrades we did in odlparent with skitt driving them (colindixon, 15:33:43)
    4. adetalhouet NIC (adetalhouet, 15:34:40)
    5. colindixon notes that while there is very little documentation and system test for ODL parent it gets tested and used all the time by all projects, so that's probably fine (colindixon, 15:37:39)
    6. it might be nice to have a user/developer guide showing what's available and how to use it in the future though (colindixon, 15:38:01)
    7. no blocking bugs in odlparent (anipbu, 15:38:09)
    8. anipbu asks if there are any oustanding blocking bugs, there aren't and the 5 bugs are described in reasonable detail on the release review document (colindixon, 15:38:30)
    9. one question around this is ... a lot of this is covered in coretutorials (rovarga, 15:38:45)

  3. YANGTOOLS (anipbu, 15:41:37)
    1. https://wiki.opendaylight.org/view/YANG_Tools:Beryllium:Release_Notes <-- Release Notes (anipbu, 15:41:45)
    2. https://wiki.opendaylight.org/view/YANG_Tools:Beryllium:Release_Review <--Release Review (anipbu, 15:41:54)
    3. Robert Varga is representing yangtools (anipbu, 15:42:30)
    4. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&bug_severity=enhancement&columnlist=product%2Ccomponent%2Cassigned_to%2Cbug_severity%2Ccf_issue_type%2Cshort_desc%2Cbug_status%2Cpriority%2Cdeadline%2Ccf_target_milestone&component=General&f1=cf_t (anipbu, 15:45:23)
    5. colindixon notes that YANG tools has significant unit test coverage and does a good job explaining (in an unbiased way) the problems encountered during the release (colindixon, 15:47:50)
    6. colindixon notes that there are lithium docs for YANG tools, but that he is unaware of any updates in Beryllium (colindixon, 15:48:17)
    7. rovarga notes there are not blocking bugs in yangtools (anipbu, 15:49:01)
    8. ACTION: rovarga will update the documentation link in the release review (anipbu, 15:49:59)

  4. AAA (anipbu, 15:52:12)
    1. https://wiki.opendaylight.org/view/AAA:Beryllium_Release_Notes <-- Release Notes (anipbu, 15:52:17)
    2. https://wiki.opendaylight.org/view/AAA:Beryllium_Release_Status <--Release Review (anipbu, 15:52:22)
    3. Ryan Goulding is representing AAA (anipbu, 15:52:27)
    4. Regarding Failing AAA Test suites: there are two AAA system test suites, one is passing 100%, the other 0%. I took a deeper look @ the latter and those haven�t passed even 30 builds back in stable/lithium. I do not have confidence they ever worked, and I am not sure who originally contributed them. I have tested the functionality manually and it works correctly, so this is definitely an error in the test (rgoulding, 15:52:46)
    5. rgoulding notes that one test suite is passing 100%, the other never passed 30 builds back in lithium, may be deprecated tests. (anipbu, 15:54:55)
    6. rgoulding tested the functionality manually and it works correctly, so this is definitely an error in the test (anipbu, 15:55:10)
    7. colindixon notes that AAA is used by nearly every other project and thus core system test is provide by merely continuing to exit and worked (colindixon, 15:55:44)
    8. Python2.7+ not required for normal operation, just AAA IdM data manipulation (anipbu, 15:56:19)
    9. ACTION: rgoulding will update the requirements section: should be generic Java, not just x86 (anipbu, 15:57:09)
    10. rgoulding says AAA has tested on RC2. No blocking bugs. (anipbu, 15:57:35)
    11. https://git.opendaylight.org/gerrit/#/c/34264/ (rgoulding, 15:58:05)
    12. rgoulding says documentation patch is pending (anipbu, 15:58:48)
    13. AAA clustering and authz are experimental (anipbu, 15:59:06)
    14. authz through shiro works (rgoulding, 15:59:16)
    15. authz broker facade is experimental, it has been since lithium and no one has stepped up to make changes (rgoulding, 15:59:39)

  5. CONTROLLER (anipbu, 16:02:33)
    1. Tony Tkacik is representing CONTROLLER (anipbu, 16:03:00)
    2. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Beryllium:Release_Review (ttkacik, 16:05:13)
    3. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Beryllium:Release_Review <-- Release Review (anipbu, 16:06:06)
    4. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Beryllium:Release_Notes <-- Release Notes (anipbu, 16:06:09)
    5. ttkacik says "not sure if it is clear from release notes - but we failed to deliver any new API features planned for Be due to time spent on MD-SAL migration / breakages bugfixes" (colindixon, 16:07:56)
    6. colindixon notes and ttkacik agrees that the config subsystem parts (config files) when moving from Lithium to Beryllium have changed and will need to be looked at (colindixon, 16:08:40)
    7. ACTION: ttkacik to add at least the migration concern about config files/config subsystem for clustering to the release notes (colindixon, 16:09:06)
    8. ttkacik says he is only aware of one RC2 failure and it was a test problem not a real problem (colindixon, 16:11:07)
    9. colindixon asks if there are further plans to spilt apart the controller, the short answer from rovarga is not really, there's three things left: clustering, config subsytem, and base karaf; base karaf might move to odlparent but the other too will stay for the near term at least (colindixon, 16:13:04)
    10. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&f1=cf_target_milestone&o1=notsubstring&order=Importance&product=controller&query_format=advanced&resolution=---&v1=Boron (colindixon, 16:15:01)
    11. 5019: fixed in beryllium - still opened because is pending cherrypick to Li (anipbu, 16:15:25)
    12. 5247 - waiting for review (anipbu, 16:15:32)
    13. 4866 - is waiting for review (anipbu, 16:16:18)
    14. 5135 requires more investigation (anipbu, 16:18:07)
    15. colindixon notes that he's not sure if there is additional updated docuemntation since Lithium (colindixon, 16:18:10)
    16. ACTION: ttkacik to follow up on the blocking bugs as mentioned above (anipbu, 16:18:11)
    17. https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/540/robot/report/log.html (jamoluhrsen, 16:20:41)
    18. ACTION: anipbu schedule follow up for controller release review (anipbu, 16:21:53)
    19. follow-up to include (1) blocking bugs (2) docuemntation and (3) system test failures (anipbu, 16:22:17)

  6. MDSAL (anipbu, 16:23:00)
    1. ttkacik is representing MDSAL (anipbu, 16:23:28)
    2. https://wiki.opendaylight.org/view/MD-SAL:Beryllium:Release_Review (phrobb, 16:24:37)
    3. https://wiki.opendaylight.org/view/MD-SAL:Beryllium:Release_Review (ttkacik, 16:24:45)
    4. https://wiki.opendaylight.org/view/MD-SAL:Beryllium:Release_Notes <-- Release Notes (anipbu, 16:25:25)
    5. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&f1=cf_target_milestone&o1=notsubstring&product=mdsal&query_format=advanced&resolution=---&v1=Boron blokcing/cirtical bugs (colindixon, 16:26:41)
    6. 1435: Is missing support for feature, not release blocking, could be delivered in SR1 (anipbu, 16:27:15)
    7. ttkacik mentions has tested using RC2 artifacts, no additional bugs found (anipbu, 16:27:39)
    8. ttkacik notes that the only thing othe than bugfixes was the migration of code from various other projects to mdsal and introduction of new experimental APIs that aren't usable for prodcution (colindixon, 16:29:25)
    9. ACTION: colindixon to follow up with docs w.r.t. controller and mdsal (colindixon, 16:30:22)
    10. ACTION: ttkacik will follow up with the blocking bugs in the link above (anipbu, 16:30:23)

  7. NETCONF (anipbu, 16:31:36)
    1. https://wiki.opendaylight.org/view/OpenDaylight_NETCONF:Beryllium_Release_Notes <-- Release Notes (anipbu, 16:31:40)
    2. https://wiki.opendaylight.org/view/OpenDaylight_NETCONF:Beryllium_Release_Review <-- Release Review (anipbu, 16:31:44)
    3. Tomas Cere is representing NETCONF (anipbu, 16:32:01)
    4. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&f1=cf_target_milestone&o1=notsubstring&product=netconf&query_format=advanced&resolution=---&v1=Boron one blocking bug (colindixon, 16:33:16)
    5. tcere notes that RC2 has blocking bug (5089), but that was fixed and merged today. (anipbu, 16:34:35)
    6. 3866 is wip. (anipbu, 16:34:57)
    7. 3866 not blocking, we can release without it imo (anipbu, 16:36:43)
    8. ACTION: tcere to note something about compatiblity and mgiration, if only to say that it'snot supported (colindixon, 16:37:59)
    9. tcere notes there shouldn't be any migration or compatiblity issues since the interface via the config subystema nd config files hasn't changed (colindixon, 16:40:08)
    10. ACTION: tcere to update netconf docs to beryllium (colindixon, 16:42:27)

  8. BGPCEP (BGP LS PCEP) (anipbu, 16:43:11)
    1. https://wiki.opendaylight.org/view/BGP_LS_PCEP:Beryllium_Release_Notes <-- Release Notes (anipbu, 16:43:15)
    2. https://wiki.opendaylight.org/view/BGP_LS_PCEP:Beryllium_Release_Notes <-- Release Review (anipbu, 16:43:26)
    3. Milos Fabian is representing BGPCEP (anipbu, 16:43:39)
    4. https://git.opendaylight.org/gerrit/34286 (Milos_, 16:44:58)
    5. https://git.opendaylight.org/gerrit/#/c/34287/ (Milos_, 16:45:04)
    6. https://git.opendaylight.org/gerrit/#/c/34288/ (Milos_, 16:45:09)
    7. bgpcep docs pushed yesterday: pending on the following: (anipbu, 16:45:41)
    8. https://wiki.opendaylight.org/view/BGP_LS_PCEP:Beryllium_Release_Review <--- actual release review (colindixon, 16:47:47)
    9. jamoluhrsen notes bgpcep has a ton of CSIT (awesome) but all but one Be job has failures. Do they have bugs to explain them, or is someone actively tracking them down? Milos_ says it's lack of equipment causing the failures (colindixon, 16:49:05)
    10. Milos_ says other failrues are cused by problems in testsuites/test tools - was fixed today (anipbu, 16:50:54)
    11. Milos_ says no blockers, there were some issues with tests themslef - fixed today by testers (anipbu, 16:51:53)
    12. Milos_ says No experimental (anipbu, 16:52:03)

  9. L2SWITCH (anipbu, 16:53:02)
    1. https://wiki.opendaylight.org/view/L2_Switch:Beryllium:Release_Notes <-- Release Notes (anipbu, 16:53:07)
    2. https://wiki.opendaylight.org/view/L2_Switch:Beryllium:Release_Review <-- Release Review (anipbu, 16:53:11)
    3. Evan Zeller is representing l2switch (anipbu, 16:53:26)
    4. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&f1=cf_target_milestone&list_id=47925&o1=notsubstring&order=Importance&product=l2switch&query_format=advanced&resolution=---&v1=Boron (anipbu, 16:54:45)
    5. evanz says he has tested on RC2 artifacts and found no blockers (anipbu, 16:56:30)
    6. for what it's worth l2switch appears to have been on life-support in this release and the key known issues remain (colindixon, 16:57:35)
    7. ACTION: evanz to follow up with 4485 (anipbu, 17:00:12)
    8. none of l2switch is experiemntal, but none of it is really prodcution ready either (anipbu, 17:00:53)
    9. colindixon assumes the docs haven't been updated for Beryllium, but that they should stay largely the same (colindixon, 17:01:26)
    10. ACTION: colindixon to follow up with l2switch docs (colindixon, 17:01:39)

  10. OPENFLOWJAVA (anipbu, 17:04:16)
    1. https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Beryllium_Release_Notes <-- Release Notes (anipbu, 17:04:24)
    2. https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Beryllium_Release_Review <-- Release Review (anipbu, 17:04:26)
    3. Michal Polkorab is representing OPENFLOWJAVA (anipbu, 17:04:43)
    4. oflibMichal has tested using RC2 artifacts with no blockers (anipbu, 17:05:57)
    5. colindixon asks if this is just a bugfixing release, oflibMichal says yes (colindixon, 17:05:58)
    6. colindixon notes that in that case the docs should require minimal updates if any (colindixon, 17:06:16)
    7. there's a syste test waiver, so the testing is good by jamoluhrsen (colindixon, 17:06:30)
    8. oflibMichal says it has nothing experimental (anipbu, 17:07:34)
    9. ACTION: oflibMichal to note if we're actually supproging 1.3.x where x is in {2,3,4,5} or if it's really 1.3.2 (colindixon, 17:08:16)
    10. ACTION: oflibMichal it would probably be good to add in a security consideration saying you should use SSL connections to switches if doing so in production (colindixon, 17:08:58)
    11. ACTION: oflibMichal it would be good to note that migration should be a no-op (colindixon, 17:10:52)

  11. cookies (anipbu, 17:12:56)


Meeting ended at 17:13:00 UTC (full logs).

Action items

  1. rovarga will update the documentation link in the release review
  2. rgoulding will update the requirements section: should be generic Java, not just x86
  3. ttkacik to add at least the migration concern about config files/config subsystem for clustering to the release notes
  4. ttkacik to follow up on the blocking bugs as mentioned above
  5. anipbu schedule follow up for controller release review
  6. colindixon to follow up with docs w.r.t. controller and mdsal
  7. ttkacik will follow up with the blocking bugs in the link above
  8. tcere to note something about compatiblity and mgiration, if only to say that it'snot supported
  9. tcere to update netconf docs to beryllium
  10. evanz to follow up with 4485
  11. colindixon to follow up with l2switch docs
  12. oflibMichal to note if we're actually supproging 1.3.x where x is in {2,3,4,5} or if it's really 1.3.2
  13. oflibMichal it would probably be good to add in a security consideration saying you should use SSL connections to switches if doing so in production
  14. oflibMichal it would be good to note that migration should be a no-op


Action items, by person

  1. anipbu
    1. anipbu schedule follow up for controller release review
  2. colindixon
    1. colindixon to follow up with docs w.r.t. controller and mdsal
    2. colindixon to follow up with l2switch docs
  3. evanz
    1. evanz to follow up with 4485
  4. oflibMichal
    1. oflibMichal to note if we're actually supproging 1.3.x where x is in {2,3,4,5} or if it's really 1.3.2
    2. oflibMichal it would probably be good to add in a security consideration saying you should use SSL connections to switches if doing so in production
    3. oflibMichal it would be good to note that migration should be a no-op
  5. rgoulding
    1. rgoulding will update the requirements section: should be generic Java, not just x86
  6. rovarga
    1. rovarga will update the documentation link in the release review
  7. tcere
    1. tcere to note something about compatiblity and mgiration, if only to say that it'snot supported
    2. tcere to update netconf docs to beryllium
  8. ttkacik
    1. ttkacik to add at least the migration concern about config files/config subsystem for clustering to the release notes
    2. ttkacik to follow up on the blocking bugs as mentioned above
    3. ttkacik will follow up with the blocking bugs in the link above


People present (lines said)

  1. anipbu (163)
  2. colindixon (118)
  3. LuisGomez (28)
  4. jamoluhrsen (28)
  5. rovarga (21)
  6. ttkacik (20)
  7. rgoulding (19)
  8. phrobb (16)
  9. tcere (13)
  10. oflibMichal (12)
  11. Milos_ (12)
  12. evanz (8)
  13. odl_meetbot (6)
  14. skitt (3)
  15. Sai (1)
  16. adetalhouet (1)
  17. phrobb- (0)


Generated by MeetBot 0.1.4.