15:28:49 <anipbu> #startmeeting beryllium release review
15:28:49 <odl_meetbot> Meeting started Tue Feb  9 15:28:49 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:28:49 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:28:49 <odl_meetbot> The meeting name has been set to 'beryllium_release_review'
15:28:55 <anipbu> #topic roll call
15:29:01 <anipbu> #info anipbu
15:29:08 <anipbu> #info PTL and TSC members please #info in
15:29:43 <anipbu> #chair phrobb- colindixon jamoluhrsen
15:29:43 <odl_meetbot> Current chairs: anipbu colindixon jamoluhrsen phrobb-
15:30:01 <rgoulding> #info rgoulding
15:30:08 <colindixon> #info colindixon for TTP, docs, and TSC
15:31:13 <anipbu> So today we have nine projects presenting: odlparent, yang tools, aaa, controller, mdsal, netconf, bgpcep, l2switch, openflowjava
15:31:24 <anipbu> PTL, please info in
15:31:39 <rovarga> #info rovarga for odlparent, yangtools
15:31:58 <rgoulding> #info rgoulding for aaa
15:32:13 <colindixon> anipbu: whenever you're ready, I think we can go
15:32:28 <anipbu> Let's get started
15:32:32 <anipbu> #topic ODLPARENT (OpenDaylight Root Parent)
15:32:36 <anipbu> #link https://wiki.opendaylight.org/view/ODL_Root_Parent:Beryllium:Release_Notes <-- Release Notes
15:32:40 <colindixon> anipbu: between you, jamoluhrsen and I we provide good coverage for most things
15:32:41 <anipbu> #link https://wiki.opendaylight.org/view/ODL_Root_Parent:Beryllium:Release_Review <--Release Review
15:32:44 * colindixon starts looking
15:32:48 <anipbu> #Robert Varga is representing odlparent
15:32:52 <anipbu> rovarga, anything you would like to add?
15:33:14 <rovarga> not much, those links pretty much contain a reasonable braindump
15:33:43 <colindixon> #info the only thing to maybe add to the release notes would be the various version upgrades we did in odlparent with skitt driving them
15:34:09 <rovarga> fair enough, I didn't have enough time to hunt all of them down :-/
15:34:16 <skitt> I'll take care of that
15:34:27 <rovarga> thanks Stephen
15:34:40 <adetalhouet> #info adetalhouet NIC
15:35:01 <skitt> np
15:35:09 <colindixon> skitt, rovarga: I don't think we need *all* of them, but the major ones would be nice mostly to list as a trophy :-)
15:35:23 <skitt> colindixon, indeed
15:36:17 <colindixon> the release review document looks good
15:36:34 <colindixon> there's no system testing per-se, but I think that's fine, and I'm guessing jamoluhrsen and LuisGomez would agree
15:37:06 <anipbu> rovarga: any blocking bugs found in these : https://bugs.opendaylight.org/buglist.cgi?component=General&list_id=47903&product=odlparent&resolution=---
15:37:24 <rovarga> anipbu: none
15:37:31 <rovarga> anipbu: these are improvements
15:37:39 <colindixon> #info colindixon notes that while there is very little documentation and system test for ODL parent it gets tested and used all the time by all projects, so that's probably fine
15:38:01 <colindixon> #info it might be nice to have a user/developer guide showing what's available and how to use it in the future though
15:38:08 <rovarga> anipbu: 2084 is somewhat fuzzy, as it means SingleFeatureTest does not completely match what user sees at feature:install, but we will follow up on that
15:38:09 <anipbu> #info no blocking bugs in odlparent
15:38:30 <colindixon> #info anipbu asks if there are any oustanding blocking bugs, there aren't and the 5 bugs are described in reasonable detail on the release review document
15:38:37 <colindixon> I think I'm good
15:38:44 <LuisGomez> odlparent may have a waiver for system test
15:38:45 <rovarga> #info one question around this is ... a lot of this is covered in coretutorials
15:39:02 <colindixon> rovarga: noted, maybe just point to that?
15:39:24 <anipbu> odlparent looks good to me.  Thanks rovarga
15:39:35 <colindixon> as I say, it's not an issue for now, but just something it would be good to have for people to easily find in the future
15:39:45 <anipbu> #chair LuisGomez
15:39:45 <odl_meetbot> Current chairs: LuisGomez anipbu colindixon jamoluhrsen phrobb-
15:40:14 <anipbu> LuisGomez, any comments you'd like to make for odlparent?
15:40:32 <rovarga> colindixon: agreed, we will work on it as we formalize the content of odlparent a bit more in the next release
15:40:39 <colindixon> I don't think we have LuisGomez or jamoluhrsen unless somebody else has seen them comment while I wasn't looking
15:40:40 <LuisGomez> no, i think it is good
15:40:42 <colindixon> dfarrell07: are you around?
15:40:48 * colindixon looks for his integration/test peeps
15:41:15 <anipbu> I think we do have LuisGomez :)
15:41:29 <anipbu> Okay let's move on
15:41:33 <LuisGomez> i am here, just joined
15:41:37 <anipbu> #topic YANGTOOLS
15:41:45 <anipbu> #link https://wiki.opendaylight.org/view/YANG_Tools:Beryllium:Release_Notes <-- Release Notes
15:41:54 <anipbu> #link https://wiki.opendaylight.org/view/YANG_Tools:Beryllium:Release_Review <--Release Review
15:41:59 <anipbu> #Robert Varga is representing yangtools
15:42:30 <anipbu> #info Robert Varga is representing yangtools
15:42:34 <anipbu> rovarga, anything you would like to add?
15:43:35 <rovarga> I am not sure what else to add :-)
15:43:39 * colindixon reads
15:44:58 <LuisGomez> developer guide link does not work, is this ongoing work?
15:45:23 <anipbu> rovarga: any blocking bugs in these
15:45:23 <anipbu> https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&bug_severity=enhancement&columnlist=product%2Ccomponent%2Cassigned_to%2Cbug_severity%2Ccf_issue_type%2Cshort_desc%2Cbug_status%2Cpriority%2Cdeadline%2Ccf_target_milestone&component=General&f1=cf_t
15:45:23 <anipbu> arget_milestone&known_name=Lithium%3A%20Yangtools&list_id=47910&o1=substring&product=yangtools&query_based_on=Beryllium%3A%20Yangtools&query_format=advanced&resolution=---&v1=Beryllium
15:45:35 <Sai> Hi L2switch devs, can you please pass on me the link for current meeting
15:46:06 <colindixon> Sai: the release review will happen here
15:46:12 <rovarga> LuisGomez: yes, I need to hunt down the proper page -- it is a bit wrecked by split-off
15:46:33 <colindixon> rovarga, LuisGomez: there is a yangtools developer guide in the docs project from Lithium, but I don't think it's been updated yet
15:46:36 <colindixon> I don't see a patch
15:46:56 <LuisGomez> ok
15:47:21 <rovarga> anipbu: I don't think so
15:47:50 <colindixon> #info colindixon notes that YANG tools has significant unit test coverage and does a good job explaining (in an unbiased way) the problems encountered during the release
15:48:17 <colindixon> #info colindixon notes that there are lithium docs for YANG tools, but that he is unaware of any updates in Beryllium
15:48:26 <phrobb> rovarga: From the release-review wiki, it looks like the pre-Be parser is marked as deprecated in this release.  Are there still projects using those deprecated APIs in Be, or has everyone moved to the new parser?
15:49:01 <anipbu> #info rovarga notes there are not blocking bugs in yangtools
15:49:04 <rovarga> phrobb: the only remaining users are some tests in BGPCEP as far as we can tell, we will migrate them over before removing it
15:49:55 <phrobb> rovarga:  Cool, I expected we had pretty full conversion in Be... just wanted to know if the transition was something we wanted to track closely in Boron.
15:49:59 <anipbu> #action rovarga will update the documentation link in the release review
15:50:37 <anipbu> yangtools looks good to me.  Thanks rovarga
15:50:50 <anipbu> #chair phrobb
15:50:50 <odl_meetbot> Current chairs: LuisGomez anipbu colindixon jamoluhrsen phrobb phrobb-
15:51:18 <phrobb> Yep, thanks rovarga
15:51:26 <anipbu> LuisGomez, phrobb, any additional comments you have for yangtools?
15:51:33 <LuisGomez> i guess yangtools, same as odlparent are tested through other projects so no need for system test
15:51:41 <LuisGomez> i am good with yangtools too
15:51:42 <phrobb> Nope, I'm ready to move on.
15:51:50 <rovarga> thanks ;-)
15:51:56 <anipbu> Okay, Let's move on.
15:52:08 <anipbu> congrats yangtools
15:52:12 <anipbu> #topic AAA
15:52:17 <anipbu> #link https://wiki.opendaylight.org/view/AAA:Beryllium_Release_Notes <-- Release Notes
15:52:19 <colindixon> cool, thanks rovarga
15:52:22 <anipbu> #link https://wiki.opendaylight.org/view/AAA:Beryllium_Release_Status <--Release Review
15:52:27 <anipbu> #info Ryan Goulding is representing AAA
15:52:37 <anipbu> ryangoulding, anything you would like to add?
15:52:45 <rgoulding> one thing
15:52:46 <rgoulding> #info Regarding Failing AAA Test suites:  there are two AAA system test suites, one is passing 100%, the other 0%.  I took a deeper look @ the latter and those haven�t passed even 30 builds back in stable/lithium.  I do not have confidence they ever worked, and I am not sure who originally contributed them.  I have tested the functionality manually and it works correctly, so this is definitely an error in the test
15:52:47 <rgoulding> logic and not AAA itself.  Working to fix the failing tests, but they should NOT hinder the release.
15:53:22 <colindixon> rovarga: why does it require Python2.7+?
15:53:28 <colindixon> sorry
15:53:32 <colindixon> rgoulding:
15:53:34 <colindixon> not rovarga
15:53:52 <rgoulding> colindixon: to run the idmtool script
15:53:58 <colindixon> rgoulding: OK
15:54:08 <rgoulding> colindixon: not required for normal operation, just AAA IdM data manipulation
15:54:08 <rovarga> rgoulding: will any x86 work, or is x64 required?
15:54:24 <anipbu> #rgoulding notes that one test suite is passing 100%, the other never passed 30 builds back in lithium, may be deprecated tests.
15:54:32 <rgoulding> rovarga: any x86 to my knowledge
15:54:55 <anipbu> #info rgoulding notes that one test suite is passing 100%, the other never passed 30 builds back in lithium, may be deprecated tests.
15:54:58 <rovarga> rgoulding: also, does that mean we are not portable to other arches (and do we have a handle on why) ?
15:55:10 <anipbu> #info rgoulding  tested the functionality manually and it works correctly, so this is definitely an error in the test
15:55:32 <rgoulding> rovarga:  I have not tested on other platforms as I do not own any.  There should be no issues since AAA uses pure java components
15:55:38 <anipbu> rgoulding: have you tested AAA using RC2 artifacts?  Were there any blocking bugs?
15:55:44 <colindixon> #Info colindixon notes that AAA is used by nearly every other project and thus core system test is provide by merely continuing to exit and worked
15:55:53 <colindixon> I'm pretty much happy with things
15:55:57 <rgoulding> anipbu: I have tested, no blocking bugs
15:56:05 <colindixon> we should make sure to label appropriate features as experimental
15:56:10 <rovarga> rgoulding: thanks, then perhaps target should be generic Java, not just x86?
15:56:19 <anipbu> #info Python2.7+ not required for normal operation, just AAA IdM data manipulation
15:56:24 <rgoulding> rovarga: good point... I am fine with making that claim instead
15:57:09 <anipbu> #action rgoulding will update the requirements section: should be generic Java, not just x86
15:57:12 <phrobb> rgoulding, is there anything in the new  "Tutorials and Examples" section of the wiki that should go into the dev or user guides?... We're trying to limit the number of places our uses have to know about to find reasonable docs.
15:57:35 <anipbu> #info rgoulding says AAA has tested on RC2.  No blocking bugs.
15:58:03 <rgoulding> phrobb:  patch is pending
15:58:05 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/34264/
15:58:13 <phrobb> cool, thanks rgoulding
15:58:29 <LuisGomez> is aaa an experimental feature in this release or am i reading wrong?
15:58:34 <colindixon> no
15:58:35 <colindixon> just some parts
15:58:46 <LuisGomez> ah ok
15:58:48 <anipbu> #info rgoulding says documentation patch is pending
15:58:54 <colindixon> LuisGomez: clustering and authz are experimental
15:59:06 <anipbu> #info AAA clustering and authz are experimental
15:59:16 <rgoulding> #info authz through shiro works
15:59:18 <LuisGomez> ok
15:59:39 <rgoulding> #info authz broker facade is experimental, it has been since lithium and no one has stepped up to make changes
15:59:59 <jamoluhrsen> LuisGomez, colindixon anipbu: good morning.
16:00:03 <rgoulding> improvements to the broker facade are talking points for boron
16:00:21 <LuisGomez> hi jamoluhrsen
16:00:41 <anipbu> good morning jamoluhrsen, i already made you chair :)
16:00:45 <jamoluhrsen> working on AAA?  anything for me to check?
16:00:59 <anipbu> aaa looks good to me.  Thanks rgoulding
16:01:19 <phrobb> Yep, it looks good to me as well.  Nice job rgoulding
16:01:34 <anipbu> LuisGomez any additional comments you'd like to make?
16:01:47 <colindixon> I'm happy, thanks rgoulding
16:01:56 * colindixon waves to jamoluhrsen
16:01:57 <LuisGomez> aaa has basic authn system test written by jamoluhrsen afair, i am good with this project too
16:02:11 <anipbu> Okay let's move on
16:02:17 <anipbu> congrats AAA
16:02:33 <anipbu> #topic CONTROLLER
16:03:00 <anipbu> #info Tony Tkacik is representing CONTROLLER
16:03:25 <anipbu> ttkacik, are you online?
16:03:49 <ttkacik> ttkacik here
16:03:58 <anipbu> do you have the release notes and release review template?
16:03:59 <jamoluhrsen> LuisGomez, do we have open bugs for the cluster test failures?
16:04:30 <LuisGomez> i think there were a few
16:05:13 <ttkacik> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Beryllium:Release_Review
16:06:06 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Beryllium:Release_Review <-- Release Review
16:06:09 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Beryllium:Release_Notes <-- Release Notes
16:06:19 * colindixon reads
16:06:30 <anipbu> ttkacik, anything you would like to add?
16:07:18 <colindixon> ttkacik: do you know if the clustering APIs have changed at all, e.g., the config YANG for it?
16:07:20 <colindixon> I thought they had
16:07:30 <ttkacik> not sure if it is clear from release notes - but we failed to deliver any new API features planned for Be due to time spent on MD-SAL migration / breakages bugfixes
16:07:52 <ttkacik> colindixon: I believe so, they change each and every release
16:07:56 <colindixon> #info ttkacik says "not sure if it is clear from release notes - but we failed to deliver any new API features planned for Be due to time spent on MD-SAL migration / breakages bugfixes"
16:08:40 <colindixon> #Info colindixon notes and ttkacik agrees that the config subsystem parts (config files) when moving from Lithium to Beryllium have changed and will need to be looked at
16:08:49 <anipbu> ttkacik, have you tested controller using RC2 artifacts and were there any blocking bugs?
16:09:06 <colindixon> #action ttkacik to add at least the migration concern about config files/config subsystem for clustering to the release notes
16:09:36 <colindixon> ttkacik: are there any plans to further break out things from the controller or is this likely to be the size and shape of it in Boron?
16:10:32 <LuisGomez> i see there are blocker bugs, are these under control?
16:10:36 <ttkacik> anipbu: oinly known failure for RC2 was controller-csit-3node-clustering-all but that was timeout on side of test
16:11:07 <colindixon> #info ttkacik says he is only aware of one RC2 failure and it was a test problem not a real problem
16:11:07 <jamoluhrsen> ttkacik, is there a bug(s) to account for the failures in the -only- clustering job?
16:11:13 <anipbu> since it was timeout issue, would you say that it is not a blocker?
16:11:30 <rovarga> colindixon: not right now, the only remaining bits are CDS and CONFIG ... the future of those remains to be discussed
16:11:33 * jamoluhrsen searching bz now
16:11:58 <colindixon> anipbu: that's my interpretation from what ttkacik said, but I tihnk the other blocker bugs might be a concern if they rremain
16:12:00 <colindixon> rovarga: thanks
16:12:05 <rovarga> colindixon: oh, forgot about base karaf, there is a discussion among odlparent committers to take ownership of that
16:13:04 <colindixon> #info colindixon asks if there are further plans to spilt apart the controller, the short answer from rovarga is not really, there's three things left: clustering, config subsytem, and base karaf; base karaf might move to odlparent but the other too will stay for the near term at least
16:13:38 <colindixon> anipbu, ttkacik, and LuisGomez: what's the status for known blockers/major bugs in controller?
16:14:35 <ttkacik> blocker are under control
16:14:55 <ttkacik> 5019: fixed in beryllium - still opened because is pending cherrypick to Li
16:15:01 <colindixon> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&f1=cf_target_milestone&o1=notsubstring&order=Importance&product=controller&query_format=advanced&resolution=---&v1=Boron
16:15:17 <ttkacik> 5247 - waiting for review
16:15:19 <colindixon> I see 5019 and 5247 are waiting for merge
16:15:25 <anipbu> #info 5019: fixed in beryllium - still opened because is pending cherrypick to Li
16:15:27 <colindixon> I see 4866 which is open and confirmed
16:15:32 <anipbu> #info 5247 - waiting for review
16:16:05 <colindixon> somebody needs to figure out what's going on with 4866
16:16:06 <ttkacik> 4866 - is waiting for review
16:16:14 <colindixon> ok
16:16:18 <anipbu> #info 4866 - is waiting for review
16:16:23 <rgoulding> yeah i just asked about that... will change state now
16:16:37 <colindixon> 5135 is maybe related to 4866, but is (for now) non-blocking
16:16:43 <colindixon> is that right?
16:17:26 <colindixon> assuming we have this under control, I'm happy
16:17:47 <ttkacik> 5135 may or may not be related
16:17:51 <ttkacik> requires more investigation
16:18:07 <anipbu> #info 5135 requires more investigation
16:18:08 <jamoluhrsen> there is a system test failure that seems basic, but I can't find any bug for it.
16:18:10 <colindixon> #info colindixon notes that he's not sure if there is additional updated docuemntation since Lithium
16:18:11 <anipbu> #action ttkacik to follow up on the blocking bugs as mentioned above
16:18:42 <anipbu> assuming blocking bugs are address, controller looks good to me. thanks ttkacik
16:18:54 <LuisGomez> jamoluhrsen, where is that?
16:19:02 <jamoluhrsen> controller-csit-3node-clustering-only-beryllium
16:19:20 <jamoluhrsen> leader not found after failing a node and bringing it back.  basic HA scenario
16:19:40 <anipbu> LuisGomez, phrobb, jamoluhrsen any other comments you'd like to make?
16:19:51 <colindixon> jamoluhrsen: I think ttkacik said that it was a timeout issue and not a real issue, but it would be good to make sure
16:19:58 <phrobb> Nothing from me anipbu.
16:20:04 <jamoluhrsen> that is the -all- test, colindixon  (I think)
16:20:35 <ttkacik> jamoluhrsen: could you point to exact run which failed with leader not found?
16:20:41 <jamoluhrsen> https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/540/robot/report/log.html
16:21:07 <anipbu> So we're ten minutes behind, do we need to schedule a longer review for controller?
16:21:10 <jamoluhrsen> ttkacik, "Shard member-1-shard-car-config currently has no leader. Try again later"
16:21:33 <jamoluhrsen> anipbu, I'm the only one causing a delay here.  so move on, and I'll take it offline
16:21:36 <colindixon> anipbu: probably we need to follow-up
16:21:52 <colindixon> anipbu: we have three topics (1) blocking bugs (2) docuemntation and (3) system test failures
16:21:53 <anipbu> #action anipbu schedule follow up for controller release review
16:22:17 <anipbu> #info follow-up to include (1) blocking bugs (2) docuemntation and (3) system test failures
16:22:20 <anipbu> Okay Let's move on.
16:23:00 <anipbu> #topic MDSAL
16:23:19 <anipbu> #ttkacik is representing MDSAL
16:23:28 <anipbu> #info ttkacik is representing MDSAL
16:24:06 <anipbu> ttkacik, do you have the release review and release notes for mdsal?
16:24:37 <phrobb> #link https://wiki.opendaylight.org/view/MD-SAL:Beryllium:Release_Review
16:24:45 <ttkacik> https://wiki.opendaylight.org/view/MD-SAL:Beryllium:Release_Review
16:25:21 * colindixon starts to read
16:25:25 <anipbu> #link https://wiki.opendaylight.org/view/MD-SAL:Beryllium:Release_Notes <-- Release Notes
16:25:41 <anipbu> ttkacik, anything you would like to add?
16:25:54 <ttkacik> anipbu: nothing more
16:26:10 <anipbu> ttkacik, status of the blocking bugs? https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&f1=cf_target_milestone&list_id=47925&o1=notsubstring&order=Importance&product=mdsal&query_format=advanced&resolution=---&v1=Boron
16:26:29 <anipbu> 2912 and 1435
16:26:41 <colindixon> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&f1=cf_target_milestone&o1=notsubstring&product=mdsal&query_format=advanced&resolution=---&v1=Boron blokcing/cirtical bugs
16:27:01 <anipbu> ttkacik, have we tested mdsal in RC2 artifacts, and did you find any additional blocking bugs?
16:27:01 <ttkacik> 1435: Is missing support for feature, not release blocking, could be delivered in SR1
16:27:12 <ttkacik> no additional bugs
16:27:15 <anipbu> #info 1435: Is missing support for feature, not release blocking, could be delivered in SR1
16:27:39 <anipbu> #info ttkacik mentions has tested using RC2 artifacts, no additional bugs found
16:27:53 <colindixon> so, the major thing that changed was moving from controller to mdsal
16:28:07 <colindixon> everything else seems to have been bugfixing
16:28:08 <colindixon> is that right?
16:28:21 <ttkacik> colindixon: right
16:28:35 <colindixon> has the documentation been updated for Beryllium?
16:28:38 <anipbu> I think 2912 was just a javadoc issue.  maybe the severity can be donwgraded if it's just javadocs
16:28:43 <ttkacik> colindixon: introduction of new APIS, but still not usable for production
16:29:25 <colindixon> #info ttkacik notes that the only thing othe than bugfixes was the migration of code from various other projects to mdsal and introduction of new experimental APIs that aren't usable for prodcution
16:29:29 <colindixon> anipbu: that sounds right
16:29:30 <ttkacik> colindixon: yes, there were not any significant change except migration which is in release plan
16:29:35 <ttkacik> in release notes
16:30:11 <colindixon> assuming nobody els has any comments, I'm good, I need to look over the docs changes
16:30:22 <colindixon> #action colindixon to follow up with docs w.r.t. controller and mdsal
16:30:23 <anipbu> #action ttkacik will follow up with the blocking bugs in the link above
16:30:33 <anipbu> mdsal looks good to me.  thanks ttkacik
16:30:44 <LuisGomez> it is good for me too
16:30:44 <phrobb> No questions from me.
16:31:00 <anipbu> jamoluhrsen, any comments you'd like to make?
16:31:05 * jamoluhrsen is good
16:31:35 <anipbu> Okay let's move on
16:31:36 <anipbu> #topic NETCONF
16:31:40 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_NETCONF:Beryllium_Release_Notes <-- Release Notes
16:31:44 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_NETCONF:Beryllium_Release_Review <-- Release Review
16:32:01 <anipbu> #info Tomas Cere is representing NETCONF
16:32:12 <anipbu> tcere, anything you'd like to add?
16:32:29 <tcere> just that rc2 had 5089 present, but the fix for that was merged today so it should be fine
16:32:54 * colindixon reads
16:33:16 <colindixon> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&f1=cf_target_milestone&o1=notsubstring&product=netconf&query_format=advanced&resolution=---&v1=Boron one blocking bug
16:33:22 <anipbu> #tcere notes that RC2 has blocking bug (5089), but that was fixed and merged today.
16:33:30 <tcere> oh and the patch for restconf PATCH is still not merged, but it should be ready for BE aswell
16:33:54 <anipbu> tcere, What's the status on 3866
16:34:22 <tcere> still wip, ttkacik should know more
16:34:22 <rgoulding> tcere:  is 3866 targeted at Beryllium or Beryllium-SR1?
16:34:35 <anipbu> #info tcere notes that RC2 has blocking bug (5089), but that was fixed and merged today.
16:34:57 <anipbu> #info 3866 is wip.
16:35:00 <colindixon> tcere: we probably need to note something about compatiblity and mgiration, if only to say that it'snot supported
16:35:10 <jamoluhrsen> tcere: do we have anyone looking in to the CSIT failures?  or are there already bugs to explain them?
16:35:20 <anipbu> tcere, is 3866 blocking, can we release beryllium with that known blocking bug?
16:35:43 <tcere> 5283 is tracking the scale test failure with -all feature
16:35:48 <tcere> im looking into the other failures
16:36:23 <tcere> 3866 not blocking, we can release without it imo
16:36:43 <anipbu> #info 3866 not blocking, we can release without it imo
16:37:31 <LuisGomez> tcere, i see system test for Be went green recently but stable/lithium went bad at the same time (https://jenkins.opendaylight.org/releng/view/netconf/job/netconf-csit-1node-userfeatures-only-stable-lithium), is the current test code only working for one branch or is there a real regression in stable/lithium?
16:37:59 <colindixon> #action tcere to note something about compatiblity and mgiration, if only to say that it'snot supported
16:38:14 <rgoulding> Bug 5269-  There was a fix to the config subsystem mount procedure for allowing "full override of netconf device capabilities".  However, it is noted in the bug that it still has not been done for topology configuration mount method.  Is this something that will happened in Beryllium or Beryllium-SR1?  We should at least note the divergent behavior.
16:38:26 <tcere> i think that was an issue with using BE testtool with lithium, but i will have to follow up with testers for that
16:38:58 <tcere> compatibility should be non issue, configuration through cfg subsystem has not changed
16:39:16 <tcere> rgoulding: that's SR-1
16:39:54 <anipbu> netconf looks good to me.  thanks tcere
16:39:56 <tcere> only compatibility issue i can think of is https://bugs.opendaylight.org/show_bug.cgi?id=5079
16:40:08 <colindixon> #info tcere notes there shouldn't be any migration or compatiblity issues since the interface via the config subystema nd config files hasn't changed
16:40:14 <colindixon> tcere: still add that
16:40:20 <colindixon> if it all just works, great
16:40:24 <colindixon> that makes you look good
16:40:25 <tcere> ok
16:40:28 <colindixon> tcere: what about docs?
16:40:44 <colindixon> anipbu: if we get an answer or action about docs I'm good and we can move on to the next project
16:40:56 <tcere> we still need to update the docs from lithium for the new topology configuration model
16:41:15 <tcere> and netconf clustering docs need to be updated
16:41:16 <anipbu> We're out of time for netconf, do we need a follow up for netconf, or are folks okay with netconf project?
16:41:53 <jamoluhrsen> I'm fine
16:41:59 <LuisGomez> i am ok as there seems to be no blockers
16:42:09 <anipbu> phrobb, any comments you'd like to make?
16:42:10 <phrobb> No questions from me
16:42:27 <colindixon> #action tcere to update netconf docs to beryllium
16:42:56 <colindixon> anipbu: next project
16:43:00 <anipbu> Okay Let's move on
16:43:07 <anipbu> congrats netconf
16:43:11 <anipbu> #topic BGPCEP (BGP LS PCEP)
16:43:15 <anipbu> #link https://wiki.opendaylight.org/view/BGP_LS_PCEP:Beryllium_Release_Notes <-- Release Notes
16:43:26 <anipbu> #link https://wiki.opendaylight.org/view/BGP_LS_PCEP:Beryllium_Release_Notes <-- Release Review
16:43:39 <anipbu> #info Milos Fabian is representing BGPCEP
16:43:54 <anipbu> Milos_ anything you would like to add?
16:44:23 <Milos_> Docs update was pushed yesterday.
16:44:37 <anipbu> do you have the gerrit patch linke?
16:44:58 <Milos_> https://git.opendaylight.org/gerrit/34286
16:45:04 <Milos_> https://git.opendaylight.org/gerrit/#/c/34287/
16:45:09 <Milos_> https://git.opendaylight.org/gerrit/#/c/34288/
16:45:14 <anipbu> Milos_ have you tested with RC2 artifacts, and are there any blocker bugs for BGPCEP?
16:45:41 <anipbu> #info bgpcep docs pushed yesterday: pending on the following:
16:45:53 <Milos_> No blockers, there were some issues with tests themslef - fixed today by testers
16:46:22 <anipbu> what's the bug ID for that bug?
16:46:53 <anipbu> Milos_, any features you would like to mark as experimental?
16:46:54 <Milos_> It was not bug in BGPCEP project
16:47:31 <colindixon> anipbu: those are both notes, can we get the release review?
16:47:32 <phrobb> Milos, fo rthe BGP-LS MPLS TE LSP, and PCEP testing that was not done with any real equipment, was the reason for this a lack of equipment or lack of time?... Ie would it help if  we found you equpment with which to test?
16:47:32 <Milos_> No experimental
16:47:47 <colindixon> #link https://wiki.opendaylight.org/view/BGP_LS_PCEP:Beryllium_Release_Review <--- actual release review
16:47:57 <jamoluhrsen> Milos_: bgpcep has a ton of CSIT (awesome) but all but one Be job has failures.  Do they have bugs to explain them, or is someone actively tracking them down?
16:48:00 <Milos_> Yes, lack of equiment.
16:49:05 <Milos_> Be system tests - there are two performance issues in BGP
16:49:05 <colindixon> #info jamoluhrsen notes bgpcep has a ton of CSIT (awesome) but all but one Be job has failures.  Do they have bugs to explain them, or is someone actively tracking them down? Milos_ says it's lack of equipment causing the failures
16:49:08 <colindixon> Milos_: is that right?
16:50:00 <LuisGomez> i think lack of equipment is for Phil’s question
16:50:16 <Milos_> Other failrues are cused by problems in testsuites/test tools - was fixed today
16:50:54 <anipbu> #info Milos_ says other failrues are cused by problems in testsuites/test tools - was fixed today
16:51:09 <jamoluhrsen> thanks Milos_
16:51:25 <jamoluhrsen> Milos_, do those perf issues have bugzillas?
16:51:29 <colindixon> assuming LuisGomez and jamoluhrsen are happy, I'm happy
16:51:37 <Milos_> yes - https://bugs.opendaylight.org/show_bug.cgi?id=4488 and https://bugs.opendaylight.org/show_bug.cgi?id=5185
16:51:43 <jamoluhrsen> sweet.  I'm good.
16:51:50 <LuisGomez> i am good too
16:51:53 <anipbu> #info Milos_ says no blockers, there were some issues with tests themslef - fixed today by testers
16:52:03 <anipbu> #info Milos_ says No experimental
16:52:19 <anipbu> bgpcep looks good to me.  thanks Milos_
16:52:30 <Milos_> thanks too
16:52:37 <anipbu> phrobb any comments on your side?
16:52:52 <phrobb> Nope, nothing else from me anipbu
16:52:52 <anipbu> Okay Let's move on
16:52:58 <anipbu> congrats bgpcep
16:53:02 <anipbu> #topic L2SWITCH
16:53:07 <anipbu> #link https://wiki.opendaylight.org/view/L2_Switch:Beryllium:Release_Notes <-- Release Notes
16:53:11 <anipbu> #link https://wiki.opendaylight.org/view/L2_Switch:Beryllium:Release_Review <-- Release Review
16:53:26 <anipbu> #info Evan Zeller is representing l2switch
16:53:31 <evanz> hi
16:53:41 <anipbu> evanz, anything you would like to add?
16:54:06 <evanz> nothing comes to mind
16:54:22 <anipbu> evanz, have you tested using RC2 artifacts, and are there any blockers for l2switch?
16:54:45 <anipbu> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&f1=cf_target_milestone&list_id=47925&o1=notsubstring&order=Importance&product=l2switch&query_format=advanced&resolution=---&v1=Boron
16:55:15 <jamoluhrsen> LuisGomez, evanz: do you guys recall the bug for hosts not being cleared after the network is taken away?  this is an issue in l2switch CSIT
16:55:38 <evanz> there are some issues, you can see in integration and in the backlog, no blockers as far as I'm aware
16:55:41 <LuisGomez> it is a missing feature according to devs
16:55:59 <LuisGomez> so i removed the test recently
16:56:17 <evanz> jamoluhrsen: there was a fix to address that problem back in lithium. I believe it reduced how often it occurs but sometimes it can still occur
16:56:30 <anipbu> #info evanz says he has tested on RC2 artifacts and found no blockers
16:56:31 <jamoluhrsen> LuisGomez, no, not that issue.
16:56:36 <LuisGomez> ah ok
16:56:49 <jamoluhrsen> LuisGomez, this one: https://jenkins.opendaylight.org/releng/view/l2switch/job/l2switch-csit-1node-periodic-host-scalability-daily-only-beryllium/268/robot/report/log.html
16:57:12 <anipbu> evanz, what's the status of 4485?  it's marked as a BLOCKER
16:57:35 <colindixon> #info for what it's worth l2switch appears to have been on life-support in this release and the key known issues remain
16:57:49 <LuisGomez> ok jamoluhrsen
16:57:54 <colindixon> LuisGomez, jamoluhrsen: do we know if it still does the basic tracking hosts and forwarding traffic on a clean coming up?
16:58:02 <anipbu> evanz, any features to mark as experimental?
16:58:07 <jamoluhrsen> colindixon, yes it seems clean on coming up.
16:58:39 <evanz> anipbu: I don't believe 4485 has been confirmed by any devs, in fact there is a patch https://git.opendaylight.org/gerrit/#/c/28472/ that should have addressed it
16:58:40 <jamoluhrsen> colindixon, it's a shame it's on life support.  feels like l2switch is always one of the first projects newcomers play with.
16:59:13 <colindixon> jamoluhrsen: there may be moves to fix that :-)
16:59:18 <anipbu> evanz, could we resolve that bug as "worksforme"
16:59:38 <evanz> sure
16:59:39 <LuisGomez> jamoluhrsen, is there bug for host scalability? it looks like we can do only 200 at the best…
16:59:56 <jamoluhrsen> LuisGomez, I don't know about any bug.  evanz ?
17:00:12 <anipbu> #action evanz to follow up with 4485
17:00:12 <jamoluhrsen> there is one other CSIT failure to note, plus this scale issue, otherwise I'm good from sys-test point of view.
17:00:26 <colindixon> anipbu, evanz: I think in general, none of l2switch is experiemntal, but none of it is really prodcution ready either
17:00:41 <evanz> ^
17:00:53 <anipbu> #info none of l2switch is experiemntal, but none of it is really prodcution ready either
17:00:58 <colindixon> anipbu, evanz: in every release, including this one, it's been more of a demo feature than an app
17:01:18 <anipbu> l2switch looks good to me.  thanks evanz
17:01:26 <colindixon> #info colindixon assumes the docs haven't been updated for Beryllium, but that they should stay largely the same
17:01:39 <colindixon> #action colindixon to follow up with l2switch docs
17:01:41 <colindixon> I'm good
17:01:42 <evanz> I will say that jamoluhrsen is right, newcomers to ODL on the mailing lists express interest in l2switch, host-paths and other features
17:01:53 <rovarga> are there any plans to bring l2switch out life support?
17:01:54 <LuisGomez> +1, l2switch quality is demo feature
17:02:13 <colindixon> rovarga: there might be
17:02:26 <jamoluhrsen> if we are going to say "demo" quality then I have no issues with any CSIT failures.
17:02:49 <rovarga> okay, I'll be watching, as there is a lot of cleanup that needs to happen there...
17:02:52 <colindixon> rovarga: currently nobody is working on l2swtich full time
17:02:55 <colindixon> rovarga: noted
17:02:56 <colindixon> so very noted
17:03:17 <phrobb> no further comments from me
17:03:18 <colindixon> anipbu: next project?
17:03:29 <anipbu> Do we need a follow up for l2switch?
17:03:38 <anipbu> or can we move on?
17:03:57 <anipbu> LuisGomez, any comments?
17:04:00 <colindixon> anipbu: I think we're OK, we can label it as experimental if that's the right nomenclature, but I think we're OK and understand the issues
17:04:02 <LuisGomez> not for me
17:04:10 <anipbu> okay let's move on
17:04:13 <anipbu> congrats l2switch
17:04:16 <anipbu> #topic OPENFLOWJAVA
17:04:24 <anipbu> #link https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Beryllium_Release_Notes <-- Release Notes
17:04:26 <anipbu> #link https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Beryllium_Release_Review <-- Release Review
17:04:43 <anipbu> #info Michal Polkorab is representing OPENFLOWJAVA
17:04:45 <oflibMichal> hello
17:04:56 <jamoluhrsen> openflowava has system test waiver, so no barking from me :)
17:04:57 <anipbu> oflibMichal, anything you'd like to add?
17:05:07 <oflibMichal> nothing to add
17:05:21 <anipbu> oflibMichal, have you tested RC2 artifacts, and are there any blockers for openflowjava?
17:05:22 <colindixon> it looks like this was just a bugfixing release
17:05:25 <colindixon> is that right?
17:05:29 <oflibMichal> yes, no blockers
17:05:35 <oflibMichal> colindixon: right
17:05:57 <anipbu> #info oflibMichal has tested using RC2 artifacts with no blockers
17:05:58 <colindixon> #info colindixon asks if this is just a bugfixing release, oflibMichal says yes
17:06:16 <colindixon> #info colindixon notes that in that case the docs should require minimal updates if any
17:06:30 <colindixon> #info there's a syste test waiver, so the testing is good by jamoluhrsen
17:07:01 <anipbu> and nothing experimental
17:07:09 <oflibMichal> true
17:07:21 <colindixon> oflibMichal: it says 1.3.2
17:07:28 <colindixon> but 1.3.{3,4,5} are out
17:07:33 <colindixon> do we know if we're compliant?
17:07:34 <anipbu> #info oflibMichal says it has nothing experimental
17:07:48 <oflibMichal> colindixon: I can check if we also follow those
17:08:00 <oflibMichal> colindixon: we should
17:08:16 <colindixon> #action oflibMichal to note if we're actually supproging 1.3.x where x is in {2,3,4,5} or if it's really 1.3.2
17:08:58 <colindixon> #action oflibMichal it would probably be good to add in a security consideration saying you should use SSL connections to switches if doing so in production
17:09:02 <anipbu> openflowjava looks good to me.  Thanks oflibMichal
17:09:15 <oflibMichal> thanks
17:09:41 <LuisGomez> it is good for me too
17:09:51 <anipbu> no migration issues from previous release, right?
17:09:58 <oflibMichal> right
17:10:10 <anipbu> should mention that release notes
17:10:19 <oflibMichal> it should, let me find
17:10:38 <oflibMichal> Compatibility with Previous Releasesthis release is backward compatible
17:10:39 <colindixon> anipbu: I think it says it's backward compatible and migration should be easy
17:10:43 <phrobb> looks good to me
17:10:52 <colindixon> #action oflibMichal it would be good to note that migration should be a no-op
17:11:15 <oflibMichal> will do
17:11:46 <anipbu> colindixon do you have any other comments, or should we do a follow up with openflowjava?
17:11:49 <colindixon> anipbu: I think we're ready for the next, last project?
17:11:52 <colindixon> anipbu: I think we're good
17:11:57 <anipbu> great
17:11:58 <colindixon> assuming the actions get done
17:12:05 <anipbu> congrats openflowjava
17:12:08 <anipbu> okay we're done
17:12:11 <anipbu> thanks everybody
17:12:24 <anipbu> thanks everybody for staying the extra 12 minutes
17:12:32 <phrobb> thanks anipbu
17:12:46 <colindixon> thansk anipbu
17:12:56 <anipbu> #topic cookies
17:13:00 <anipbu> #endmeeting