#opendaylight-meeting: beryllium release review

Meeting started by anipbu at 15:27:35 UTC (full logs).

Meeting summary

  1. roll call (anipbu, 15:27:42)
    1. anipbu (anipbu, 15:27:56)
    2. ebrjohn Brady Johnson, SFC PTL (ebrjohn, 15:28:50)
    3. colindixon for TTP, docs, and TSC (colindixon, 15:29:05)
    4. PTL and TSC members please #info in (anipbu, 15:29:08)
    5. alagalah for GBP (alagalah, 15:29:12)
    6. adetalhouet Reservation (adetalhouet, 15:29:32)

  2. RESERVATION (anipbu, 15:31:10)
  3. SFC (Service Function Chaining) (anipbu, 15:32:56)
    1. https://wiki.opendaylight.org/view/Service_Function_Chaining:Beryllium_Release_Notes <-- Release Notes (anipbu, 15:33:10)
    2. https://wiki.opendaylight.org/view/Service_Function_Chaining:Beryllium_Release_Review <-- Release Review (anipbu, 15:33:30)
    3. ACTION: adetalhouet to fill out release notes and release review and find another time to do a releaes review for reservation: https://wiki.opendaylight.org/view/Sample_Release_Review https://wiki.opendaylight.org/view/Sample_Release_Notes (colindixon, 15:33:34)
    4. Brady Johnson will be representing SFC (anipbu, 15:33:38)
    5. KLuehrs (UNI Manager project) (KLuehrs, 15:34:08)
    6. colindixon thanks ebrjohn for the extensive compatibility and migration sections (colindixon, 15:35:23)
    7. https://jenkins.opendaylight.org/releng/view/sfc/ (ebrjohn, 15:36:37)
    8. sfc tested RC artifacts. THere are no blockers (anipbu, 15:38:14)
    9. sfc has no experimental features (anipbu, 15:38:35)
    10. ACTION: ebrjohn to add links to the auotmated system test to the release notes (colindixon, 15:38:45)
    11. SFC User facing features: odl-sfc-model, odl-sfc-provider, odl-sfc-provider-rest (anipbu, 15:38:47)
    12. shague OVSDB NetVirt (shague_, 15:39:29)
    13. ebrjohn notes that there is automated system testing for SFC (colindixon, 15:40:06)
    14. ACTION: alagalah ebrjohn anipbu and colindixon to discuss offline what the right user-facing features for SFC are and descriptions that will be useful for users to understand (colindixon, 15:41:12)

  4. RESERVATION (anipbu, 15:43:03)
    1. https://wiki.opendaylight.org/view/Reservation:Beryllium_Release_Review <-- Release Review (anipbu, 15:43:16)
    2. https://wiki.opendaylight.org/view/Reservation:Beryllium_Release_Notes <-- Release Notes (anipbu, 15:43:27)
    3. adetalhouet is representing RESERVATION (anipbu, 15:43:47)
    4. ACTION: adetalhouet to add link to release notes from the release review (anipbu, 15:45:50)
    5. ACTION: zxiiro, LuisGomez, and/or jamoluhrsen to remove reservation from the Beryllium release in the RC3 respin (colindixon, 15:47:12)
    6. adetalhouet says For now the project only contain the driver/library but doesn't contain the bundle to use it (colindixon, 15:47:45)
    7. adetalhouet says it makes sense to remove reservation from Beryllium because there is no added value (anipbu, 15:48:43)
    8. even if reservation isn't removed from Beryllium in code, we shouldn't advertise it as being part of the Beryllium release (colindixon, 15:48:45)
    9. colindixon notes that reservations should probably wait for Boron, maybe a Beryllium SR, or maybe also just release out-of-band on top of Beryllium if there's time/resources (colindixon, 15:49:54)

  5. TTP (Table Type Patterns) (anipbu, 15:50:07)
    1. https://wiki.opendaylight.org/view/Table_Type_Patterns/Beryllium/Release_Notes <-- Release Notes (anipbu, 15:50:13)
    2. https://wiki.opendaylight.org/view/Table_Type_Patterns/Beryllium/Release_Review <-- Release Review (anipbu, 15:50:18)
    3. Curt Beckmann will be representing TTP (anipbu, 15:50:22)
    4. ChristineH represents SNMP4SDN (ChristineH, 15:51:19)
    5. TTP tested RC3. No blockers (anipbu, 15:53:00)
    6. curtbeckmann notes that while TTP didn't get automated system tests done in Beryllium, it's been manually tested and reported same as having external system test (colindixon, 15:53:17)
    7. TTP has no user facing features (anipbu, 15:53:37)
    8. curtbeckmann notes that the only user-facing feature is a CLI tool packaged as a jar outside the karaf distribution (colindixon, 15:54:00)
    9. TTP has no experimental features (colindixon, 15:54:08)
    10. the TTP project's system test waiver was rejected, but they have been doing external system tests https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/Waiver/System_Test#TTP (colindixon, 15:55:22)
    11. ACTION: curtbeckmann to link to release notes from the release review template (anipbu, 15:56:32)
    12. ACTION: curtbeckmann to report our external system test to the RC2 and RC3 status tabs here https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=149567092 (colindixon, 15:58:59)

  6. OVSDB (Open vSwitch Database Management Protocol and Network Virtualization) (anipbu, 15:59:54)
    1. https://wiki.opendaylight.org/view/OpenDaylight_OVSDB:Beryllium_Release_Notes <-- Release Notes (anipbu, 16:00:00)
    2. https://wiki.opendaylight.org/view/OpenDaylight_OVSDB:Beryllium_Release_Review <-- Release Review (anipbu, 16:00:04)
    3. Sam Hague is representing OVSDB (anipbu, 16:00:08)
    4. RC testing in progress. no blockers so far (pending completion of RC testing) (anipbu, 16:02:45)
    5. experimental features: odl-ovsdb-openstack-clusteraware odl-ovsdb-ui (anipbu, 16:03:21)
    6. user facing: odl-ovsdb-openstack, odl-ovsdb-southbound, odl-ovsdb-hwvtepsouthbound (anipbu, 16:03:37)
    7. colindixon notes that there are docs patches waiting for review, OVSDB has good system test coverage (colindixon, 16:06:19)
    8. ACTION: shague_ to make the migration section of the release notes more clear (colindixon, 16:06:47)

  7. SNMP4SDN (anipbu, 16:09:30)
    1. https://wiki.opendaylight.org/view/SNMP4SDN:Beryllium_Release_Note <-- Release Notes (anipbu, 16:09:34)
    2. https://wiki.opendaylight.org/view/SNMP4SDN:Beryllium_Release_Review <-- Release Review (anipbu, 16:09:42)
    3. Christine Hsieh is representing snmp4sdn (anipbu, 16:09:56)
    4. tested on RC3. No blockers. (anipbu, 16:12:41)
    5. no experimental features (anipbu, 16:12:48)
    6. user facing features: odl-snmp4sdn-all (anipbu, 16:12:57)
    7. https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/Waiver/System_Test#SNMP4SDN system test waiver (colindixon, 16:14:05)
    8. ACTION: ChristineH_ will follow up with bug 4720 (anipbu, 16:15:41)
    9. ACTION: ChristineH_ to provide system test plan for manual tests (anipbu, 16:16:54)
    10. ACTION: ChristineH_ to link to the unmerged asciidoc patches from the release review (colindixon, 16:17:20)
    11. ACTION: ChristineH_ to report results of manual tests here as well https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=149567092 (anipbu, 16:18:42)

  8. TOPOPROCESSING (anipbu, 16:21:57)
    1. https://wiki.opendaylight.org/view/Topology_Processing_Framework:BERYLLIUM_Release_Notes <-- Release Notes (anipbu, 16:22:01)
    2. https://wiki.opendaylight.org/view/Topology_Processing_Framework:BERYLLIUM_Release_Review <-- Release Review (anipbu, 16:22:07)
    3. Andrej Záň is representing topoprocessing (anipbu, 16:22:15)
    4. ACTION: Andrej_Zan to say "not supported" instead of "none" for migration (colindixon, 16:24:18)
    5. no experimental features (anipbu, 16:25:48)
    6. no user facing features (anipbu, 16:25:57)
    7. ACTION: Andrej_Zan to change "I2RS support" to "support for I2RS topology model" (colindixon, 16:26:13)
    8. ACTION: Andrej_Zan to look into CSIT failures (colindixon, 16:30:24)

  9. UNIMGR (User Network Interface Manager) (anipbu, 16:30:42)
    1. https://wiki.opendaylight.org/view/Unimgr:BerylliumReleaseReview <-- Release Review (anipbu, 16:30:46)
    2. https://wiki.opendaylight.org/view/Unimgr:BerylliumReleaseNotes <-- Release Notes (anipbu, 16:30:50)
    3. Kevin Luehrs is representing UNIMGR (anipbu, 16:30:54)
    4. UNI Mgr tested against RC3 and there were no blockers. The project overall is experimental as noted in the UNIMgr:Main page. User-facing: odl-unimgr-ui (KLuehrs, 16:32:14)
    5. UNI Mgr developer guide is awaiting review (KLuehrs, 16:32:40)
    6. UNI Mgr tested against RC3 and there were no blockers. (anipbu, 16:33:20)
    7. unimgr has no CSIT, but they have the jobs in place. something alarming there. controller not ever coming up (jamoluhrsen, 16:33:22)
    8. all unimgr features are experimental (anipbu, 16:33:37)
    9. User-facing: odl-unimgr-ui (anipbu, 16:33:55)
    10. ACTION: unimgr will investigate csit failure and follow up with jamoluhrsen https://jenkins.opendaylight.org/releng/view/unimgr/job/unimgr-csit-1node-basic-only-beryllium/363/consoleFull (anipbu, 16:36:10)
    11. ACTION: KLuehrs to update the release review with links to the docs guides once it's merged (anipbu, 16:37:41)
    12. https://git.opendaylight.org/gerrit/#/c/34682/ <-- mising docs patch (anipbu, 16:38:39)
    13. ACTION: KLuehrs will separate the user and developer documentation (colindixon, 16:41:00)
    14. ACTION: anipbu will start a follow up for unimgr (anipbu, 16:44:36)
    15. follow up to discuss 1) testing for unimgr (anipbu, 16:45:02)

  10. CENTINEL (anipbu, 16:45:10)
    1. https://wiki.opendaylight.org/view/Centinel:Beryllium:Release_Notes <-- Release Notes (anipbu, 16:45:14)
    2. https://wiki.opendaylight.org/view/Centinel:Beryllium:Release_Review <-- Release Review (anipbu, 16:45:18)
    3. Sumit Kapoor is representing CENTINEL (anipbu, 16:45:21)
    4. tesed against RC3. no blockers (anipbu, 16:47:50)
    5. centinel has no CSIT. (jamoluhrsen, 16:47:52)
    6. no experimental features (anipbu, 16:48:00)
    7. user facing feature : odl-centinel-all (anipbu, 16:48:08)
    8. https://git.opendaylight.org/gerrit/#/c/29441/ <-- centinel pending docs patch (anipbu, 16:49:34)
    9. ACTION: centinel to add with CSIT job with functional coverage (anipbu, 16:50:34)
    10. ACTION: sumit_kapoor to follow up with anipbu and colindixon about security concerns (colindixon, 16:52:23)
    11. ACTION: centinel to identify the test cases in system test plan (anipbu, 16:53:17)
    12. sumit_kapoor says that they've done manual testing (colindixon, 16:53:25)
    13. ACTION: anipbu to follow up email with centinel regarding 1) security concerns 2) testing coverage 3) marking centinel as experimental (anipbu, 16:56:55)

  11. TSDR (anipbu, 16:57:11)
    1. https://wiki.opendaylight.org/view/TSDR:Beryllium:Release_Review <-- Release Review (anipbu, 16:57:23)
    2. https://wiki.opendaylight.org/view/TSDR:Beryllium:Release_Notes <-- Release Notes (anipbu, 16:57:34)
    3. YuLing Chen is representing TSDR (anipbu, 16:57:46)
    4. tested against RC3. no blockers (anipbu, 17:00:12)
    5. no experimental features (anipbu, 17:00:20)
    6. some existing tsdr system test is there and passing. (jamoluhrsen, 17:00:21)
    7. user facing features: odl-tsdr-hsqldb-all odl-tsdr-hbase odl-tsdr-cassandra odl-tsdr-openflow-statistics-collector odl-tsdr-netflow-statistics-collector odl-tsdr-snmp-data-collector odl-tsdr-syslog-collector odl-tsdr-controller-metrics-collector (anipbu, 17:01:34)
    8. yuling notes that 3 are data stores and the rest are collectors (colindixon, 17:01:50)
    9. ACTION: yuling to make notes about the data stores and the security of sending information to them, i.e., is it encrypted in flight and how credentials for the stores are stored (colindixon, 17:02:40)

  12. SNMP (anipbu, 17:03:41)
    1. https://wiki.opendaylight.org/view/SNMP_PLugin:Beryllium <-- Release Review (anipbu, 17:03:47)
    2. https://wiki.opendaylight.org/view/SNMP_Plugin:SNMP_Plugin:Beryllium_Release_Notes <-- Release Notes (anipbu, 17:03:52)
    3. Vaishali Mithbaokar is representing SNMP (anipbu, 17:03:56)
    4. has one upstream CSIT test case. (jamoluhrsen, 17:05:03)
    5. https://wiki.opendaylight.org/view/SNMP_PLugin:Beryllium (anipbu, 17:05:47)
    6. Vaishali points out that Beryllium added no new features for SNMP (colindixon, 17:07:36)
    7. ACTION: Vaishali to update the security section in SNMP (anipbu, 17:09:28)
    8. ACTION: Vaishali to provide system test plan (anipbu, 17:09:37)
    9. ACTION: Vaishali will open bug for failing CSIT job (anipbu, 17:10:39)
    10. tested RC3. No blockers (anipbu, 17:10:46)
    11. user facing feature is odl-snmp-plugin (anipbu, 17:11:09)
    12. no experimental features (anipbu, 17:11:51)

  13. SNMP (anipbu, 17:12:19)
  14. GROUPBASEDPOLICY (anipbu, 17:12:27)
    1. https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Releases/Beryllium:Beryllium_Release_Notes <-- Release Notes (anipbu, 17:12:34)
    2. https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Releases/Beryllium/Release_Review <-- Release Review (anipbu, 17:12:38)
    3. Keith Burns is representing GROUPBASEDPOLICY (anipbu, 17:12:42)
    4. https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/CSIT CSIT in gdoc (alagalah, 17:13:12)
    5. experimental features: iovisor (anipbu, 17:15:00)
    6. iovisor is considered "experimental" as it involves an external agent in another repository (alagalah, 17:15:23)
    7. until we work out a way to sync releases then its fair to say "experimental" (alagalah, 17:15:40)
    8. ACTION: alagalah to say that migration hasn't been tested instead of "n/a" (colindixon, 17:16:14)
    9. iovisor is considered "experimental" as it involves an external agent in another (anipbu, 17:16:16)
    10. CSIT is there, other good system test info (too much to read now). (jamoluhrsen, 17:16:44)
    11. github.com/iovisor (anipbu, 17:16:52)
    12. https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report (jamoluhrsen, 17:17:08)
    13. jamoluhrsen says the GBP system tests is good stuff (which is high praise) (colindixon, 17:17:09)

  15. cookies (anipbu, 17:19:05)


Meeting ended at 17:19:15 UTC (full logs).

Action items

  1. adetalhouet to fill out release notes and release review and find another time to do a releaes review for reservation: https://wiki.opendaylight.org/view/Sample_Release_Review https://wiki.opendaylight.org/view/Sample_Release_Notes
  2. ebrjohn to add links to the auotmated system test to the release notes
  3. alagalah ebrjohn anipbu and colindixon to discuss offline what the right user-facing features for SFC are and descriptions that will be useful for users to understand
  4. adetalhouet to add link to release notes from the release review
  5. zxiiro, LuisGomez, and/or jamoluhrsen to remove reservation from the Beryllium release in the RC3 respin
  6. curtbeckmann to link to release notes from the release review template
  7. curtbeckmann to report our external system test to the RC2 and RC3 status tabs here https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=149567092
  8. shague_ to make the migration section of the release notes more clear
  9. ChristineH_ will follow up with bug 4720
  10. ChristineH_ to provide system test plan for manual tests
  11. ChristineH_ to link to the unmerged asciidoc patches from the release review
  12. ChristineH_ to report results of manual tests here as well https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=149567092
  13. Andrej_Zan to say "not supported" instead of "none" for migration
  14. Andrej_Zan to change "I2RS support" to "support for I2RS topology model"
  15. Andrej_Zan to look into CSIT failures
  16. unimgr will investigate csit failure and follow up with jamoluhrsen https://jenkins.opendaylight.org/releng/view/unimgr/job/unimgr-csit-1node-basic-only-beryllium/363/consoleFull
  17. KLuehrs to update the release review with links to the docs guides once it's merged
  18. KLuehrs will separate the user and developer documentation
  19. anipbu will start a follow up for unimgr
  20. centinel to add with CSIT job with functional coverage
  21. sumit_kapoor to follow up with anipbu and colindixon about security concerns
  22. centinel to identify the test cases in system test plan
  23. anipbu to follow up email with centinel regarding 1) security concerns 2) testing coverage 3) marking centinel as experimental
  24. yuling to make notes about the data stores and the security of sending information to them, i.e., is it encrypted in flight and how credentials for the stores are stored
  25. Vaishali to update the security section in SNMP
  26. Vaishali to provide system test plan
  27. Vaishali will open bug for failing CSIT job
  28. alagalah to say that migration hasn't been tested instead of "n/a"


Action items, by person

  1. adetalhouet
    1. adetalhouet to fill out release notes and release review and find another time to do a releaes review for reservation: https://wiki.opendaylight.org/view/Sample_Release_Review https://wiki.opendaylight.org/view/Sample_Release_Notes
    2. adetalhouet to add link to release notes from the release review
  2. alagalah
    1. alagalah ebrjohn anipbu and colindixon to discuss offline what the right user-facing features for SFC are and descriptions that will be useful for users to understand
    2. alagalah to say that migration hasn't been tested instead of "n/a"
  3. Andrej_Zan
    1. Andrej_Zan to say "not supported" instead of "none" for migration
    2. Andrej_Zan to change "I2RS support" to "support for I2RS topology model"
    3. Andrej_Zan to look into CSIT failures
  4. anipbu
    1. alagalah ebrjohn anipbu and colindixon to discuss offline what the right user-facing features for SFC are and descriptions that will be useful for users to understand
    2. anipbu will start a follow up for unimgr
    3. sumit_kapoor to follow up with anipbu and colindixon about security concerns
    4. anipbu to follow up email with centinel regarding 1) security concerns 2) testing coverage 3) marking centinel as experimental
  5. ChristineH_
    1. ChristineH_ will follow up with bug 4720
    2. ChristineH_ to provide system test plan for manual tests
    3. ChristineH_ to link to the unmerged asciidoc patches from the release review
    4. ChristineH_ to report results of manual tests here as well https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=149567092
  6. colindixon
    1. alagalah ebrjohn anipbu and colindixon to discuss offline what the right user-facing features for SFC are and descriptions that will be useful for users to understand
    2. sumit_kapoor to follow up with anipbu and colindixon about security concerns
  7. curtbeckmann
    1. curtbeckmann to link to release notes from the release review template
    2. curtbeckmann to report our external system test to the RC2 and RC3 status tabs here https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=149567092
  8. ebrjohn
    1. ebrjohn to add links to the auotmated system test to the release notes
    2. alagalah ebrjohn anipbu and colindixon to discuss offline what the right user-facing features for SFC are and descriptions that will be useful for users to understand
  9. jamoluhrsen
    1. zxiiro, LuisGomez, and/or jamoluhrsen to remove reservation from the Beryllium release in the RC3 respin
    2. unimgr will investigate csit failure and follow up with jamoluhrsen https://jenkins.opendaylight.org/releng/view/unimgr/job/unimgr-csit-1node-basic-only-beryllium/363/consoleFull
  10. KLuehrs
    1. KLuehrs to update the release review with links to the docs guides once it's merged
    2. KLuehrs will separate the user and developer documentation
  11. LuisGomez
    1. zxiiro, LuisGomez, and/or jamoluhrsen to remove reservation from the Beryllium release in the RC3 respin
  12. shague_
    1. shague_ to make the migration section of the release notes more clear
  13. sumit_kapoor
    1. sumit_kapoor to follow up with anipbu and colindixon about security concerns
  14. Vaishali
    1. Vaishali to update the security section in SNMP
    2. Vaishali to provide system test plan
    3. Vaishali will open bug for failing CSIT job
  15. yuling
    1. yuling to make notes about the data stores and the security of sending information to them, i.e., is it encrypted in flight and how credentials for the stores are stored
  16. UNASSIGNED
    1. centinel to add with CSIT job with functional coverage
    2. centinel to identify the test cases in system test plan


People present (lines said)

  1. anipbu (202)
  2. colindixon (138)
  3. jamoluhrsen (30)
  4. alagalah (28)
  5. adetalhouet (23)
  6. ebrjohn (19)
  7. yuling (19)
  8. sumit_kapoor (15)
  9. ChristineH_ (14)
  10. curtbeckmann (13)
  11. Vaishali (12)
  12. KLuehrs (11)
  13. odl_meetbot (8)
  14. Andrej_Zan (8)
  15. shague_ (8)
  16. ChristineH (1)
  17. anipbu2 (0)
  18. phrobb (0)
  19. LuisGomez (0)


Generated by MeetBot 0.1.4.