15:27:35 <anipbu> #startmeeting beryllium release review
15:27:35 <odl_meetbot> Meeting started Mon Feb 15 15:27:35 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:27:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:27:35 <odl_meetbot> The meeting name has been set to 'beryllium_release_review'
15:27:42 <anipbu> #topic roll call
15:27:56 <anipbu> #info anipbu
15:28:50 <ebrjohn> #info ebrjohn Brady Johnson, SFC PTL
15:29:05 <colindixon> #info colindixon for TTP, docs, and TSC
15:29:08 <anipbu> #info PTL and TSC members please #info in
15:29:12 <alagalah> #info alagalah for GBP
15:29:32 <adetalhouet> #info adetalhouet Reservation
15:30:18 <anipbu> #chair colindixon LuisGomez phrobb
15:30:18 <odl_meetbot> Current chairs: LuisGomez anipbu colindixon phrobb
15:30:32 <anipbu> Good Morning everybody
15:30:35 <anipbu> Okay Let's get started
15:30:45 <ebrjohn> FYI I have to leave at the top of the hour, I hope I can do my review before then
15:30:57 <ebrjohn> BTW: Good Morning
15:31:10 <anipbu> #topic RESERVATION
15:31:46 <anipbu> adetalhouet: mlemay: do you have release notes and review templates filled out?
15:32:12 <adetalhouet> anipbu, I'm representing Reservation
15:32:19 <adetalhouet> anipbu: I don't think we do have those
15:32:37 <anipbu> Okay, please fill them out
15:32:38 <colindixon> ebrjohn: want this slot
15:32:46 <ebrjohn> I can take the next slot, thanks
15:32:53 <anipbu> okay
15:32:56 <adetalhouet> no, we actually weren't able to come up with them filled out for now
15:32:56 <anipbu> #topic SFC (Service Function Chaining)
15:33:10 <anipbu> #link https://wiki.opendaylight.org/view/Service_Function_Chaining:Beryllium_Release_Notes <-- Release Notes
15:33:30 <anipbu> #link https://wiki.opendaylight.org/view/Service_Function_Chaining:Beryllium_Release_Review <-- Release Review
15:33:34 <colindixon> #action adetalhouet to fill out release notes and release review and find another time to do a releaes review for reservation: https://wiki.opendaylight.org/view/Sample_Release_Review https://wiki.opendaylight.org/view/Sample_Release_Notes
15:33:34 <ebrjohn> hello
15:33:38 <anipbu> #info Brady Johnson will be representing SFC
15:33:44 <ebrjohn> yes
15:33:48 <anipbu> ebrjohn: anything you would like to add?
15:33:57 * colindixon starts reading
15:33:59 <ebrjohn> Yes, I just wanted to point out a few details about SFC Beryllium.
15:34:00 <anipbu> ebrjohn: 1) Have you tested against RC3 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
15:34:08 <KLuehrs> #info KLuehrs (UNI Manager project)
15:34:10 <ebrjohn> Berylium was an important release for SFC because we integrated ODL SFC into OPNFV SFC.
15:34:19 <ebrjohn> In doing so, we also implemented Application Coexistence together with GBP and OVSDB NetVirt.
15:34:32 <ebrjohn> 1) We have tested with all the RC releases except RC3, and we have found no blocking issues.
15:34:39 <ebrjohn> 2) No experimental features
15:34:49 <ebrjohn> 3) User facing features: odl-sfc-model, odl-sfc-provider, odl-sfc-provider-rest
15:35:10 <colindixon> ebrjohn: thanks for the extensive compatibility and migration sections
15:35:23 <colindixon> #info colindixon thanks ebrjohn  for the extensive compatibility and migration sections
15:35:25 <ebrjohn> colindixon: hope its helpfull
15:36:03 <colindixon> ebrjohn: system tests? are they manual? automated? non-existent?
15:36:22 <ebrjohn> automated system tests
15:36:37 <ebrjohn> #link https://jenkins.opendaylight.org/releng/view/sfc/
15:36:41 <colindixon> ebrjohn: are odl-sfc-model and odl-sfc-provider really user-facing?
15:36:57 <ebrjohn> I guess it depends on the exact definition of user-facing
15:36:57 <colindixon> would somebody actually install those instead of installing the odl-sfc-provider-rest?
15:37:19 <colindixon> ebrjohn: https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Features
15:37:33 <alagalah> colindixon: May I help answer ?
15:37:41 <colindixon> alagalah: by all means
15:37:49 <anipbu> alagalah: feel free to chime in
15:38:14 <anipbu> #info sfc tested RC artifacts.  THere are no blockers
15:38:15 <colindixon> I'm not trying to tell you you're wrong, just trying to get the information which will go in the getting started guide in a way that's most useful for our users
15:38:35 <anipbu> #info sfc has no experimental features
15:38:39 <alagalah> colindixon: Historically SFC has enabled all features at runtime. Whether this is good, bad or indifferent, the key point is that during this release the features were refactored to be far cleaner layered. ... I believe it is a few of the committers desire in Boron that we follow the pattern of most other project
15:38:45 <colindixon> #action ebrjohn to add links to the auotmated system test to the release notes
15:38:47 <anipbu> #info SFC User facing features: odl-sfc-model, odl-sfc-provider, odl-sfc-provider-rest
15:39:20 <alagalah> colindixon: anipbu In essence the top layered features are
15:39:29 <shague_> #info shague OVSDB NetVirt
15:39:43 <colindixon> #info ebrjohn notest aht there is automated system testing for SFC
15:39:53 <colindixon> #undo
15:39:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ecd4d0>
15:40:06 <colindixon> #info ebrjohn notes that there is automated system testing for SFC
15:40:19 <alagalah> odl-sfc-vnfm-tacker odl-sfc-ui odl-sfc-sb-rest odl-sfclisp odl-sfcofl2 odl-sfc-scf-openflow
15:40:39 <alagalah> odl-sfc-netconf
15:40:51 <alagalah> Things like -model and -provider are consumed by the above list
15:41:08 <alagalah> There are things like -test and -bootstrap that I don't believe are meant for human consumption :-P
15:41:12 <colindixon> #action alagalah ebrjohn anipbu and colindixon to discuss offline what the right user-facing features for SFC are and descriptions that will be useful for users to understand
15:41:15 <alagalah> ebrjohn: Fair summary mate ?
15:41:30 <ebrjohn> alagalah: yes, thanks Keith
15:41:36 <colindixon> alagalah: thank you, I think that makes sense, does my action make sense?
15:42:02 <ebrjohn> colindixon: makes sense to me, sorry for not having that together
15:42:10 <colindixon> it should be fast, just a short sentence for each feature that we think a user needs to understand so that they know when they'd want to install it
15:42:10 <anipbu> SFC has system tests described here: https://jenkins.opendaylight.org/releng/view/sfc/job/sfc-csit-3node-clustering-all-beryllium/
15:42:13 <colindixon> ebrjohn: not your fault
15:42:15 <alagalah> ebrjohn: Historically a difficult one to answer :)
15:42:35 <colindixon> anipbu: I'm good, I think we covered what LuisGomez and jamoluhrsen would have covered
15:42:38 <colindixon> so I think we we can move on
15:42:44 <anipbu> sfc looks good to me
15:42:46 <anipbu> Let's move on
15:42:49 <anipbu> congrats sfc
15:43:03 <anipbu> #topic RESERVATION
15:43:09 <ebrjohn> Thanks!!
15:43:16 <anipbu> #link https://wiki.opendaylight.org/view/Reservation:Beryllium_Release_Review <-- Release Review
15:43:27 <anipbu> #link https://wiki.opendaylight.org/view/Reservation:Beryllium_Release_Notes <-- Release Notes
15:43:47 <anipbu> #info adetalhouet is representing RESERVATION
15:44:02 <anipbu> adetalhouet: anything you would like to add
15:44:19 * colindixon reads
15:44:21 <anipbu> 1) Have you tested against RC3 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
15:44:44 <adetalhouet> Not much, we weren't able to provide all the functionality we wanted at the beginning of the release due to lack of resources
15:44:48 <colindixon> adetalhouet: sorry for being abrupt earlier, just trying to keep things moving
15:44:58 <anipbu> from talking to mlemay all reservation features are experimental, correct?
15:45:02 <anipbu> can you confirm?
15:45:12 <colindixon> adetalhouet: "Provides TL1 Southbound Protocol." isn't a knonw issue or limitation, is it?
15:45:23 <adetalhouet> There is actually no real feature to install now, so it wasn't tested against RC3
15:45:26 <colindixon> adetalhouet: was this in the Lithium release?
15:45:46 <colindixon> adetalhouet: should this project be removed from Beryllium?
15:45:50 <anipbu> #action adetalhouet to add link to release notes from the release review
15:45:50 <adetalhouet> colindixon: Provides TL1 Southbound Protocol. is what Reservation offers
15:46:14 <adetalhouet> colindixon: make sense to me, because it doesn't actually add value
15:46:17 <colindixon> adetalhouet: we have to do a respin of RC3 anyway, we could just remove it if that makes more sense, but if you want it to stay in I can understand
15:46:22 <colindixon> mlemay: are you there?
15:46:29 <adetalhouet> mlemay: isn't around
15:46:32 <colindixon> adetalhouet: OK
15:46:36 <colindixon> do you know if he'd be OK with that
15:46:43 <adetalhouet> colindixon: yes he is
15:46:43 <colindixon> I don't want to put you or him on the spot
15:46:46 <colindixon> ok
15:47:11 <adetalhouet> colindixon: the thing is, Reservation provides the TL1 stuff, but we still need to build bundles around to make it usable
15:47:12 <colindixon> #action zxiiro, LuisGomez, and/or jamoluhrsen to remove reservation from the Beryllium release in the RC3 respin
15:47:27 <adetalhouet> For now the project only contain the driver/library but doesn't contain the bundle to use it
15:47:32 <adetalhouet> This is where we stand
15:47:45 <colindixon> #info adetalhouet says For now the project only contain the driver/library but doesn't contain the bundle to use it
15:47:48 <adetalhouet> So make sense to remove it from Beryllium because there is no added value
15:48:00 <adetalhouet> yet...
15:48:06 <colindixon> adetalhouet: it sounds like that means it should be delivered in Boron and maybe in a Beryllium SR
15:48:20 <colindixon> adetalhouet: or maybe as an out-of-band release
15:48:40 <adetalhouet> colindixon: so far we lack of resource to take care of it
15:48:43 <anipbu> #info adetalhouet says it makes sense to remove reservation from Beryllium because there is no added value
15:48:45 <colindixon> #Info even if reservation isn't removed from Beryllium in code, we shouldn't advertise it as being part of the Beryllium release
15:48:50 <adetalhouet> so I can't plan accordingly
15:49:06 <colindixon> adetalhouet: understood and thanks for explaining things
15:49:14 <adetalhouet> colindixon: anipbu: sure
15:49:26 <anipbu> okay, in that case, i'm ready to move on
15:49:36 <adetalhouet> anipbu: colindixon: thank you
15:49:45 <anipbu> colindixon: any other comments?
15:49:54 <colindixon> #info colindixon notes that reservations should probably wait for Boron, maybe a Beryllium SR, or maybe also just release out-of-band on top of Beryllium if there's time/resources
15:50:00 <colindixon> anipbu: I'm done, thanks adetalhouet
15:50:07 <anipbu> #topic TTP (Table Type Patterns)
15:50:13 <anipbu> #link https://wiki.opendaylight.org/view/Table_Type_Patterns/Beryllium/Release_Notes <-- Release Notes
15:50:18 <anipbu> #link https://wiki.opendaylight.org/view/Table_Type_Patterns/Beryllium/Release_Review <-- Release Review
15:50:22 <anipbu> #info Curt Beckmann will be representing TTP
15:50:34 <anipbu> curtbeckmann: anything you would like to add?
15:50:34 <curtbeckmann> I'm here
15:50:44 <curtbeckmann> Nothing to add
15:50:47 <anipbu> curtbeckmann: 1) Have you tested against RC3 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
15:51:05 <curtbeckmann> We did test RC3. No blockers
15:51:14 <curtbeckmann> No experimental features.
15:51:19 <ChristineH> #info ChristineH represents SNMP4SDN
15:51:26 <colindixon> since I'm a committer, I'll step back
15:51:32 <curtbeckmann> We have no system level user facing features
15:51:39 <curtbeckmann> Sorry, we have no user facing features
15:51:52 <curtbeckmann> we have separate (non-system level) developer facing features
15:52:12 <colindixon> anipbu: we had planned to have automated system test, but didn't get it done and so have been reporting external, manual system test
15:52:36 <colindixon> anipbu: we have a CLI tool packaged as jar outside the karaf distribution which is user-facing
15:52:43 <curtbeckmann> yes, that's true, manually tested.
15:53:00 <anipbu> #info TTP tested RC3.  No blockers
15:53:12 <anipbu> info TTP has no experimental features
15:53:17 <colindixon> #info curtbeckmann notes that while TTP didn't get automated system tests done in Beryllium, it's been manually tested and reported same as having external system test
15:53:36 <curtbeckmann> (one info missing #?)
15:53:37 <anipbu> #info TTP has no user facing features
15:54:00 <colindixon> #info curtbeckmann notes that the only user-facing feature is a CLI tool packaged as a jar outside the karaf distribution
15:54:08 <colindixon> #info TTP has no experimental features
15:54:16 <anipbu> #info TTP has system test waiver approved by integration test team https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/Waiver/System_Test#TTP
15:54:17 <colindixon> curtbeckmann, anipbu: yes, but I got it
15:54:31 <colindixon> #undo
15:54:31 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x203c250>
15:54:36 <colindixon> anipbu: it was rejected actually
15:55:14 <anipbu> colindixon: thanks for the correction
15:55:22 <colindixon> #info the TTP project's system test waiver was rejected, but they have been doing external system tests https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/Waiver/System_Test#TTP
15:56:32 <anipbu> #action curtbeckmann to link to release notes from the release review template
15:56:34 <colindixon> any other questions for curtbeckmann or me?
15:57:02 <anipbu> ttp test plan https://wiki.opendaylight.org/view/Table_Type_Patterns/Beryllium/System_Test_Report
15:57:58 <colindixon> anipbu, curtbeckmann: release notes are now linked to from the release review
15:58:04 <anipbu> Do you report the status of your manual tests anywhere?
15:58:15 <curtbeckmann> colindixon: thanks for doing that
15:58:31 <anipbu> do you have any pending docs patch?
15:58:51 <curtbeckmann> no pending docs patch. sounds like we need one?
15:58:59 <colindixon> #action curtbeckmann to report our external system test to the RC2 and RC3 status tabs here https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=149567092
15:59:11 <curtbeckmann> colindixon: will do.
15:59:17 <colindixon> anipbu: as there were no new features in Beryllium, we didn't update our docs
15:59:22 <anipbu> okay
15:59:27 <anipbu> ttp looks good to me
15:59:31 <colindixon> thanks anipbu
15:59:38 <curtbeckmann> thanks as well
15:59:39 <anipbu> Let's mone on
15:59:44 <anipbu> congrats ttp
15:59:54 <anipbu> #topic OVSDB (Open vSwitch Database Management Protocol and Network Virtualization)
16:00:00 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_OVSDB:Beryllium_Release_Notes <-- Release Notes
16:00:04 <anipbu> #link https://wiki.opendaylight.org/view/OpenDaylight_OVSDB:Beryllium_Release_Review <-- Release Review
16:00:08 <anipbu> #info Sam Hague is representing OVSDB
16:00:20 <anipbu> shague_: any comments you would like to make?
16:00:27 * colindixon reads
16:01:23 <shague_> No, I think the wikis cover everything
16:01:39 <anipbu> shague_: 1) Have you tested against RC3 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:01:59 <shague_> RC3 testing is underway. Most testing looks good so far. Looking into issue with security group updates not happening from networking-odl.
16:02:05 <colindixon> anipbu: experimental features are in the release review
16:02:08 <shague_> user facing: odl-ovsdb-openstack, odl-ovsdb-southbound, odl-ovsdb-hwvtepsouthbound
16:02:17 <shague_> experimental: odl-ovsdb-openstack-clusteraware: used openflowplugin-li. odl-ovsdb-ui for DLUX
16:02:36 <colindixon> thanks
16:02:45 <anipbu> #info RC testing in progress.  no blockers so far (pending completion of RC testing)
16:03:21 <colindixon> shague_: when you say "none" in migration, I assume you mean it's not supported, is that right?
16:03:21 <anipbu> #info experimental features: odl-ovsdb-openstack-clusteraware odl-ovsdb-ui
16:03:37 <anipbu> #info user facing: odl-ovsdb-openstack, odl-ovsdb-southbound, odl-ovsdb-hwvtepsouthbound
16:04:49 <shague_> colindixon: yeah, I guess. We didn't do anythign specific for migration
16:05:15 <colindixon> shague_: I mean, if you think it will work, you should say so, I was just curious what you meant
16:05:49 <colindixon> I'm good
16:06:19 <colindixon> #info colindixon notes that there are docs patches waiting for review, OVSDB has good system test coverage
16:06:47 <colindixon> #action shague_ to make the migration section of the release notes more clear
16:06:57 <colindixon> anipbu, shague_: I'm happy with that
16:07:03 <shague_> colindixon: I will update the section
16:07:17 <anipbu> no slippage in schedule?
16:07:29 <colindixon> shague_: sure, let me know if you want help reviewing it, I'm not trying to single you out, just trying to make sure somebody could understand it if they read it
16:08:01 <shague_> no, slippage, things were tight at the end
16:08:15 <anipbu> thanks
16:08:35 <anipbu> ovsdb looks good to me
16:09:03 <anipbu> colindixon: any other comments?
16:09:12 <colindixon> anipbu: I'm good
16:09:26 <anipbu> Okay let's move on
16:09:29 <anipbu> congrats ovsdb
16:09:30 <anipbu> #topic SNMP4SDN
16:09:34 <anipbu> #link https://wiki.opendaylight.org/view/SNMP4SDN:Beryllium_Release_Note <-- Release Notes
16:09:42 <anipbu> #link https://wiki.opendaylight.org/view/SNMP4SDN:Beryllium_Release_Review <-- Release Review
16:09:56 <anipbu> #info Christine Hsieh is representing snmp4sdn
16:10:08 <ChristineH_> hi
16:10:22 * colindixon reads
16:10:31 <anipbu> ChristineH_: Have you closed the loop on this bug?
16:10:49 <anipbu> ChristineH_: 1) Have you tested against RC3 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:11:32 <ChristineH_> anipbu: 1) RC3 is good, no blockers 2) no, no experimental features 3) userfacing feature: odl-snmp4sdn-all
16:11:34 <colindixon> ChristineH_: it's OpenDaylight not OpenDayLight in a few places
16:12:01 <ChristineH_> colindixon: I see, ok I'll correct as OpenDaylight
16:12:22 <anipbu> "SNMP4SDN Plugin is still using AD-SAL" <-- Does this have any compatibility implications for end users?
16:12:41 <anipbu> #info tested on RC3.  No blockers.
16:12:48 <anipbu> #info no experimental features
16:12:57 <anipbu> #info user facing features: odl-snmp4sdn-all
16:13:11 <colindixon> ChristineH_: do you have any automated system tests running in integration?
16:13:21 <anipbu> ChristineH_: Have you closed the loop on this bug: https://bugs.opendaylight.org/show_bug.cgi?id=4720
16:13:38 <ChristineH_> colindixon: no automated system tests, system test waiver
16:14:05 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/Waiver/System_Test#SNMP4SDN system test waiver
16:14:30 <colindixon> ChristineH_: if it still uses the AD-SAL... how does it work?
16:14:32 <ChristineH_> anipbu: bug 4720 is not resolved yet
16:14:48 <anipbu> ChristineH_: does ChristineH_ have a system test plan?
16:15:10 <ChristineH_> colindixon, anipdu: snmp4sdn uses just a certain ad-sal artifact
16:15:41 <anipbu> #action ChristineH_ will follow up with bug 4720
16:15:42 <colindixon> ChristineH_: OK and do you publish it now or is it published as part of autorelease?
16:15:54 <colindixon> I'm guessing that it's been fixed since it's working in autorelease
16:16:24 <ChristineH_> anipbu: currently no system test plan
16:16:54 <anipbu> #action ChristineH_ to provide system test plan for manual tests
16:17:01 <ChristineH_> colindixon: excuse me, publish what?
16:17:12 <ChristineH_> anipbu: provide system test plan for manual tests -> ok, sure
16:17:20 <colindixon> #action ChristineH_ to link to the unmerged asciidoc patches from the release review
16:17:29 <colindixon> ChristineH_: the sal 0.7 artifact
16:17:34 <colindixon> I think it's fine
16:17:39 <anipbu> ChristineH_: where do you report the results of the manual tests?
16:17:43 <ChristineH_> thanks, colindixon
16:18:42 <anipbu> #action ChristineH_ to report results of manual tests here as well https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=149567092
16:18:49 <ChristineH_> anipbu: current no manual test report, shall I write one?
16:19:02 <ChristineH_> anipbu: ok, thanks
16:19:18 <anipbu> we ask that projects with manual tests should have some write up on the results of their manual tests
16:19:40 <ChristineH_> colindixon: link to the unmerged asciidoc patches from the release review -> ok, thanks
16:19:55 <colindixon> anipbu: whenever you're comfortable, I am
16:20:00 <anipbu> ChristineH_: but at the minimum, they should report the RC3 manual testing on this spreadsheet https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=149567092
16:21:33 <anipbu> snmp4sdn looks good to me (assuming the action items are addressed)
16:21:42 <anipbu> Okay Let's move on
16:21:48 <anipbu> congrats snmp4sdn
16:21:52 <ChristineH_> anipbu: ok, i'll update snmp4sdn status on the spreadsheet.
16:21:57 <anipbu> #topic TOPOPROCESSING
16:22:01 <anipbu> #link https://wiki.opendaylight.org/view/Topology_Processing_Framework:BERYLLIUM_Release_Notes <-- Release Notes
16:22:07 <anipbu> #link https://wiki.opendaylight.org/view/Topology_Processing_Framework:BERYLLIUM_Release_Review <-- Release Review
16:22:15 <anipbu> #info Andrej Záň is representing topoprocessing
16:22:26 <anipbu> Andrej_Zan: anything you would like to add?
16:22:37 <Andrej_Zan> no
16:22:43 <anipbu> Andrej_Zan: 1) Have you tested against RC3 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:23:37 <colindixon> Andrej_Zan: I assume by "I2RS support" you mean for the yang model, not the protocol
16:23:42 <colindixon> is that right??
16:24:00 <jamoluhrsen> colindixon, anipbu LuisGomez: here finally.
16:24:18 <colindixon> #action Andrej_Zan to say "not supported" instead of "none" for migration
16:24:54 <Andrej_Zan> 1) No, only integration system tests are running on current master 2) No 3) We doesn't have user facing features
16:25:00 <anipbu> #chair jamoluhrsen anipbu2
16:25:00 <odl_meetbot> Current chairs: LuisGomez anipbu anipbu2 colindixon jamoluhrsen phrobb
16:25:09 <Andrej_Zan> Yes I mean yang model
16:25:23 <jamoluhrsen> CSIT has lots of failures.  are those understood?
16:25:24 <anipbu> *waves to jamoluhrsen*
16:25:48 <anipbu> #info no experimental features
16:25:54 <colindixon> #action Andrej_Zan to change "I2RS support" to support for
16:25:57 <colindixon> #undo
16:25:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x20d3890>
16:25:57 <anipbu> #info no user facing features
16:26:13 <colindixon> #action Andrej_Zan to change "I2RS support" to "support for I2RS topology model"
16:26:26 <Andrej_Zan> Lot of failures are caused by bug 5157
16:27:06 <Andrej_Zan> Most of them are understood and related bugs are created
16:27:36 <jamoluhrsen> thanks Andrej_Zan .  obviously the bugs aren't blockers.
16:27:54 <Andrej_Zan> No they aren't blockers
16:28:37 <anipbu> topoprocessing looks good to me
16:29:16 <colindixon> I'm good then
16:29:25 <Andrej_Zan> thanks
16:29:36 <jamoluhrsen> I'm fine.
16:29:43 <anipbu> Okay let's move on
16:29:49 <anipbu> congrats topoprocessing
16:29:51 <jamoluhrsen> Andrej_Zan, go check your CSIT karaf.log artifact.  lots of stuff there to look in to.
16:30:14 <Andrej_Zan> Ok, thanks
16:30:24 <colindixon> #action Andrej_Zan to look into CSIT failures
16:30:42 <anipbu> #topic UNIMGR (User Network Interface Manager)
16:30:46 <anipbu> #link https://wiki.opendaylight.org/view/Unimgr:BerylliumReleaseReview <-- Release Review
16:30:50 <anipbu> #link https://wiki.opendaylight.org/view/Unimgr:BerylliumReleaseNotes <-- Release Notes
16:30:54 <anipbu> #info Kevin Luehrs is representing UNIMGR
16:31:05 * colindixon reads
16:31:18 <anipbu> KLuehrs: anything you would like to add?
16:31:22 <KLuehrs> No
16:31:33 <anipbu> KLuehrs: 1) Have you tested against RC3 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:32:14 <KLuehrs> #info UNI Mgr tested against RC3 and there were no blockers. The project overall is experimental as noted in the UNIMgr:Main page. User-facing: odl-unimgr-ui
16:32:40 <KLuehrs> #info UNI Mgr developer guide is awaiting review
16:33:17 <colindixon> jamoluhrsen, KLuehrs: it looks like the system test was not merged: https://git.opendaylight.org/gerrit/#/c/34362/
16:33:20 <anipbu> #info UNI Mgr tested against RC3 and there were no blockers.
16:33:22 <jamoluhrsen> #info unimgr has no CSIT, but they have the jobs in place.  something alarming there.  controller not ever coming up
16:33:37 <anipbu> #info all unimgr features are experimental
16:33:51 <jamoluhrsen> colindixon, correct.  CSIT patch came recently and we are going through review now.
16:33:55 <anipbu> #info User-facing: odl-unimgr-ui
16:34:19 <jamoluhrsen> KLuehrs, can you confirm what's broken here?  https://jenkins.opendaylight.org/releng/view/unimgr/job/unimgr-csit-1node-basic-only-beryllium/363/consoleFull
16:34:27 <jamoluhrsen> KLuehrs, I mean is there a bug?
16:34:43 <KLuehrs> I don't know offhand. We will investigate that ASAP.
16:35:38 <KLuehrs> I'
16:35:41 <jamoluhrsen> so from a user perspective (using the csit job) unimgr does not work.
16:36:10 <anipbu> #action unimgr will investigate csit failure and follow up with jamoluhrsen https://jenkins.opendaylight.org/releng/view/unimgr/job/unimgr-csit-1node-basic-only-beryllium/363/consoleFull
16:36:54 <colindixon> anipbu: based on the fact that UNIMgr is experimental and it's first release, things look fine on my end
16:37:04 <anipbu> unimgr is new to Beryllium, this being the first release.  you could probably remove the section "Changes Since Previous Releases"
16:37:14 <KLuehrs> OK
16:37:41 <anipbu> #action KLuehrs to update the release review with links to the docs guides once it's merged
16:37:57 <KLuehrs> OK
16:38:39 <anipbu> #info https://git.opendaylight.org/gerrit/#/c/34682/ <-- mising docs patch
16:38:49 <jamoluhrsen> I would say that until we know unimgr works (e.g. we can install it and use restconf) I can't say it's ok from system test side
16:38:49 <anipbu> KLuehrs: any other docs patches youre missing?
16:39:09 <KLuehrs> No that's the only document
16:39:31 <colindixon> KLuehrs: is there supposed to be user documentation or not in this release?
16:40:06 <adetalhouet> jamoluhrsen: the patch currently in review for UniMgr CSIT will fix those issues
16:40:25 <KLuehrs> We combined User and Developer documentation. If TSC would like to see separate User Document we will create that.
16:41:00 <colindixon> #action KLuehrs will separate the user and developer documentation
16:41:29 <anipbu> jamoluhrsen KLuehrs are manual tests for unimgr reported anywhere (since CSIT are not yet merged)?
16:41:33 <jamoluhrsen> adetalhouet, are you sure?  What I see is that restconf never comes up, so any robot patch wont run anyway.
16:41:45 <adetalhouet> yes because the test suite was wrongly named
16:42:50 <adetalhouet> functionality is unimgr-basic, test suite is unimgr so that doesn't work in the eye of our infra, test suite must be named <project>-<functionality>
16:43:00 <adetalhouet> the patch currently in review fix that
16:43:00 <KLuehrs> UNI Manager manual test is conducted by installing with northbound API implementations and UI. We have run this as a demo.
16:43:11 <anipbu> okay
16:43:17 <anipbu> unimgr looks good to me
16:43:24 <colindixon> anipbu: I'm also good
16:43:30 <anipbu> jamoluhrsen: do you feel we need a follow up with unimgr?
16:44:21 <jamoluhrsen> anipbu, yes.  I would not give OK yet from system test if that matters.
16:44:36 <anipbu> #action anipbu will start a follow up for unimgr
16:45:02 <anipbu> #info follow up to discuss 1) testing for unimgr
16:45:06 <anipbu> Okay let's move on
16:45:10 <anipbu> #topic CENTINEL
16:45:14 <anipbu> #link https://wiki.opendaylight.org/view/Centinel:Beryllium:Release_Notes <-- Release Notes
16:45:18 <anipbu> #link https://wiki.opendaylight.org/view/Centinel:Beryllium:Release_Review <-- Release Review
16:45:21 <anipbu> #info Sumit Kapoor is representing CENTINEL
16:45:26 <anipbu> sumit_kapoor: anything you would like to add?
16:45:30 <anipbu> sumit_kapoor: 1) Have you tested against RC3 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:45:48 <sumit_kapoor> we have done RC3 completion with no blockers
16:45:58 <sumit_kapoor> no experimental features
16:46:11 <sumit_kapoor> user facing feature : odl-centinel-all
16:47:22 <colindixon> sumit_kapoor: are there any security considerations in attaching centinel to outside components?
16:47:42 <colindixon> sumit_kapoor: do you use TLS/SSL or something to encrypt data? are there credentials, how are they stored?
16:47:50 <anipbu> #info tesed against RC3.  no blockers
16:47:52 <jamoluhrsen> #info centinel has no CSIT.
16:48:00 <anipbu> #info no experimental features
16:48:08 <anipbu> #info user facing feature : odl-centinel-all
16:48:13 <sumit_kapoor> no there is no security issues. We are not supporting AAA for now .
16:48:48 <colindixon> sumit_kapoor: so that means that you haven't thought about security yet, not that there aren't issues
16:49:11 <anipbu> so the logs are being sent insecurely form device to the log aggregator?
16:49:31 <colindixon> sumit_kapoor: or am I wrong, basically, if somebody goes to deploy this, it sounds like there's no guarantee that they won't be sending log information in the clear
16:49:34 <anipbu> #info https://git.opendaylight.org/gerrit/#/c/29441/ <-- centinel pending docs patch
16:49:56 <sumit_kapoor> we are using REST API ..
16:50:34 <anipbu> #action centinel to add with CSIT job with functional coverage
16:50:45 <colindixon> sumit_kapoor: so, is data moved from logging to flume?
16:50:54 <colindixon> is it encrypted?
16:51:29 <sumit_kapoor> we have created syslog collector ..
16:51:53 <sumit_kapoor> syslog data from sources like odl and sflow goes to collector
16:51:56 <anipbu> sumit_kapoor: if there are no CSIT job, how was your features tested?  Has it been tested thoroughly enough for use in production?  Would it warrant marking centinel as experimental?
16:52:07 <sumit_kapoor> than we using flume client to persist it
16:52:23 <colindixon> #action sumit_kapoor to follow up with anipbu and colindixon about security concerns
16:52:25 <sumit_kapoor> not encrypted yet
16:52:39 <colindixon> sumit_kapoor: so, that would be something to list in security concerns
16:52:47 <sumit_kapoor> we have done unit testing and manual testing
16:53:00 <anipbu> jamoluhrsen: sumit_kapoor: the system test plan has ZERO test cases: https://wiki.opendaylight.org/view/Centinel:Beryllium_Feature_Integration_System_Test
16:53:02 <colindixon> sumit_kapoor: presumably Flume also requires that you provide credentials, right? how are they stored in centinel?
16:53:05 <sumit_kapoor> we have tested all REST APIs and web interface
16:53:17 <anipbu> #action centinel to identify the test cases in system test plan
16:53:24 <sumit_kapoor> it is configurable ..
16:53:25 <colindixon> #Info sumit_kapoor says that they've done manual testing
16:53:32 <anipbu> sumit_kapoor: where do you report the manual testing?
16:53:44 <sumit_kapoor> configuration apis are supported using REST as well using WEB interface
16:53:56 <colindixon> assuming the above things get fixed (security concerns and test reporting) I'm OK
16:54:17 <sumit_kapoor> we save all configurable data in md-sal
16:54:55 <sumit_kapoor> we were updating tracker till RC3 ..
16:55:03 <jamoluhrsen> I see nothing I can go by for system test, but if these are experimental features I am OK with it.
16:55:08 <anipbu> assuming the test issues are completed, centinel looks good to me
16:55:23 <anipbu> jamoluhrsen: centinel is NOT experimental
16:55:50 <anipbu> see comment above from sumit_kapoor
16:55:58 <anipbu> we are 5 minute past
16:56:05 <anipbu> do we need a follow up for centinel?
16:56:15 <colindixon> anipbu: at least over e-mail, I think so
16:56:52 <jamoluhrsen> ok another follow up.
16:56:55 <anipbu> #action anipbu to follow up email with centinel regarding 1) security concerns 2) testing coverage 3) marking centinel as experimental
16:57:06 <anipbu> Okay Let's move on
16:57:11 <anipbu> #topic TSDR
16:57:23 <anipbu> #link https://wiki.opendaylight.org/view/TSDR:Beryllium:Release_Review <-- Release Review
16:57:34 <anipbu> #link https://wiki.opendaylight.org/view/TSDR:Beryllium:Release_Notes <-- Release Notes
16:57:46 <anipbu> #info YuLing Chen is representing TSDR
16:57:55 <anipbu> yuling: anything you would like to add?
16:58:07 <yuling> Yes, we've done all the manual testing with results on https://wiki.opendaylight.org/view/TSDR_Beryllium_:TSDR_Integration_System_Test
16:58:23 <yuling> We've also automated all the test cases, half of them have been running on Jenkins
16:58:33 <colindixon> yuling: I have similar questions about how TSDR talks to external services, wether it's encrypted and how credentials are stored
16:58:34 <yuling> half of them running successfully on staging server
16:58:43 <jamoluhrsen> yuling, can you please add your system test as a link from here: https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report
16:58:46 <yuling> our test lead is working on moving all the automation test cases onto Jenkins
16:58:56 <yuling> ok, will do
16:59:10 <yuling> We've also done longevity testing and everything looked good
16:59:16 <anipbu> yuling: 1) Have you tested against RC3 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
16:59:48 <yuling> performance and scalability testing is still going on... according to our initial performance testing results, it's at least as good as lithium
16:59:58 <yuling> yes, we've tested RC3 and everything looks good
17:00:07 <yuling> no experimental features
17:00:12 <anipbu> #info tested against RC3.  no blockers
17:00:17 <yuling> user facing features are:
17:00:20 <anipbu> #info no experimental features
17:00:21 <jamoluhrsen> #info some existing tsdr system test is there and passing.
17:00:38 <yuling> odl-tsdr-hsqldb-all odl-tsdr-hbase odl-tsdr-cassandra  odl-tsdr-openflow-statistics-collector odl-tsdr-netflow-statistics-collector odl-tsdr-snmp-data-collector odl-tsdr-syslog-collector odl-tsdr-controller-metrics-collector
17:01:01 <yuling> three of them are tsdr data stores
17:01:03 <colindixon> yuling: that's a long list of user-facing features...
17:01:07 <yuling> others are tsdr data collectors
17:01:10 <anipbu> info https://git.opendaylight.org/gerrit/#/c/28542/ <-- Pending docs patches for TSDR
17:01:22 <yuling> yes, I know. However the administrator needs to know what data collectors to install
17:01:23 <colindixon> yuling: that makes sense
17:01:34 <anipbu> #info user facing features: odl-tsdr-hsqldb-all odl-tsdr-hbase odl-tsdr-cassandra  odl-tsdr-openflow-statistics-collector odl-tsdr-netflow-statistics-collector odl-tsdr-snmp-data-collector odl-tsdr-syslog-collector odl-tsdr-controller-metrics-collector
17:01:43 <anipbu> tsdr looks good to me
17:01:50 <colindixon> #info yuling notes that 3 are data stores and the rest are collectors
17:01:55 <colindixon> anipbu: I agree
17:01:59 <yuling> we don't want them to use bundled features to blindly install all the cllectors to increase the system resource cost
17:02:03 <yuling> thanks
17:02:04 <colindixon> well, actually
17:02:40 <colindixon> #action yuling to make notes about the data stores and the security of sending information to them, i.e., is it encrypted in flight and how credentials for the stores are stored
17:02:46 <colindixon> yuling: does that make sense?
17:03:05 <colindixon> assuming that's put in the release notes, I'm happy
17:03:07 <yuling> yes, sure. we do have credentials enabled for collectors, such as snmp
17:03:12 <anipbu> jamoluhrsen: any additional comments you would like to make?
17:03:14 <yuling> will send out information offline
17:03:27 <jamoluhrsen> I'm good with this one.
17:03:33 <anipbu> Okay let's move on
17:03:36 <anipbu> congrats tsdr
17:03:41 <anipbu> #topic SNMP
17:03:46 <yuling> thanks very much
17:03:47 <anipbu> #link https://wiki.opendaylight.org/view/SNMP_PLugin:Beryllium <-- Release Review
17:03:52 <anipbu> #link https://wiki.opendaylight.org/view/SNMP_Plugin:SNMP_Plugin:Beryllium_Release_Notes <-- Release Notes
17:03:56 <anipbu> #info Vaishali Mithbaokar is representing SNMP
17:04:14 <anipbu> Vaishali: anything you would like to add?
17:04:28 <Vaishali> As mentioned in release notes, we dont have any new feature added to Beryllium, except bug fixes
17:04:51 <colindixon> anipbu: that's not a release review
17:05:03 <jamoluhrsen> #info has one upstream CSIT test case.
17:05:19 <jamoluhrsen> but it's failing with 500 status.  Vaishali is there an open bug for this?
17:05:20 <colindixon> Vaishali: is there a release review document to go with the release notes?
17:05:44 <Vaishali> the release review is at https://wiki.opendaylight.org/view/SNMP_PLugin:Beryllium
17:05:47 <anipbu> https://wiki.opendaylight.org/view/SNMP_PLugin:Beryllium
17:05:51 <Vaishali> I can addlink to it from release notes
17:05:51 <anipbu> It's missing some sections though
17:05:58 <colindixon> ok
17:06:19 <Vaishali> Jamo, I will open a bug to track CSIT test case, to update it to use SNMP simulator
17:06:32 <Vaishali> which section is missing, can you let me know? I will update
17:06:33 <colindixon> Vaishali: sorry, the name of the page just confused me
17:06:38 <anipbu> security concerns
17:06:45 <Vaishali> oh ok, sorry, I willupdate it
17:06:45 <jamoluhrsen> Vaishali, thanks.   also, where is the stystem test template?
17:06:46 <anipbu> i believe snmp uses SSH?
17:07:03 <colindixon> anipbu: security concerns is there, but I have questions similar to above
17:07:18 <colindixon> is the connection encrypted? how are credentials stored?
17:07:36 <colindixon> #info Vaishali points out that Beryllium added no new features for SNMP
17:07:58 <Vaishali> I will have to ask about encryption to Adam, who is owner. Will get back in email thread
17:08:19 <Vaishali> yeah, no new features in Berryliuj, so whatever we had in Lithium holds good
17:09:05 <anipbu> Vaishali: 1) Have you tested against RC3 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
17:09:12 * jamoluhrsen still looking for the system test plan.  can't find it.
17:09:28 <anipbu> #action Vaishali to update the security section in SNMP
17:09:37 <anipbu> #action Vaishali to provide system test plan
17:09:43 <colindixon> anipbu: other than that, I'm OK
17:09:56 <colindixon> Vaishali: how has SNMP been tested?
17:10:09 <Vaishali> RC3 tested. No blocker. Need to update system test as Jamo mentioned, to use SNMP simulator, will open bug to track same. User facing feature is odl-snmp-plugin
17:10:11 <jamoluhrsen> with those actions (bug, provide system test plan) I'm OK.
17:10:35 <Vaishali> yes, I will update those
17:10:39 <anipbu> #action Vaishali will open bug for failing CSIT job
17:10:46 <anipbu> #info tested RC3.  No blockers
17:11:09 <anipbu> #info user facing feature is odl-snmp-plugin
17:11:24 <anipbu> Vaishali: any experimental?
17:11:45 <Vaishali> Not that I know off. But will ask Adam and get back to you on experimental
17:11:51 <anipbu> #info no experimental features
17:12:08 <anipbu> snmp looks good to (assuming actions are addressed)
17:12:11 <anipbu> Let's move on
17:12:13 <colindixon> anipbu: I agree
17:12:15 <anipbu> congrats snmp
17:12:19 <anipbu> #topic SNMP
17:12:20 <Vaishali> thx
17:12:27 <anipbu> #topic GROUPBASEDPOLICY
17:12:31 <alagalah> anipbu: hello
17:12:34 <anipbu> #link https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Releases/Beryllium:Beryllium_Release_Notes <-- Release Notes
17:12:38 <anipbu> #link https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Releases/Beryllium/Release_Review <-- Release Review
17:12:42 <anipbu> #info Keith Burns is representing GROUPBASEDPOLICY
17:12:52 <anipbu> alagalah: anything you would like to add?
17:12:58 <alagalah> Maybe this:
17:13:12 <alagalah> #link https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/CSIT CSIT in gdoc
17:13:16 <anipbu> alagalah: 1) Have you tested against RC3 and were there any blockers?  2) Do you have any features that should be considered experimental?  3)  What are the user-facing features in your project?
17:13:27 <alagalah> anipbu: 1. no
17:13:42 <alagalah> 2. hmmmmm maybe iovisor and I can explain in more detail
17:14:08 <colindixon> alagalah: does n/a mean migration isn't supported?
17:14:10 <alagalah> 3. Listed in the https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Releases/Beryllium/Release_Review#Features
17:14:35 <alagalah> colindixon: Is migration really supported anywhere? I can't see how its possible... we haven't tried it though to be honest
17:14:40 <alagalah> colindixon: Untested ?
17:14:54 <alagalah> colindixon: I thought n/a but untested would be better
17:15:00 <anipbu> #info experimental features: iovisor
17:15:08 <colindixon> alagalah: untested sounds good
17:15:23 <alagalah> #info iovisor is considered "experimental" as it involves an external agent in another repository
17:15:24 <colindixon> alagalah: it's just more clear what's meant if you come across it
17:15:40 <alagalah> #info until we work out a way to sync releases then its fair to say "experimental"
17:15:40 <colindixon> alagalah: there have been a few projects that actually tested migration, to my surprise
17:15:45 <alagalah> colindixon: Fair question
17:16:14 <colindixon> #action alagalah to say that migration hasn't been tested instead of "n/a"
17:16:16 <anipbu> #info iovisor is considered "experimental" as it involves an external agent in another
17:16:33 <alagalah> anipbu: correct, github.com/iovisor
17:16:42 <colindixon> anipbu, alagalah: I'm good, jamoluhrsen any comments?
17:16:44 <jamoluhrsen> #info CSIT is there, other good system test info (too much to read now).
17:16:49 <jamoluhrsen> good stuff alagalah
17:16:52 <anipbu> #link github.com/iovisor
17:16:54 <alagalah> jamoluhrsen: Gracias
17:17:03 <jamoluhrsen> oh, can you link your system test plan to our landing page?
17:17:06 <alagalah> jamoluhrsen: More to come :)
17:17:08 <jamoluhrsen> https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report
17:17:09 <colindixon> #info jamoluhrsen says the GBP system tests is good stuff (which is high praise)
17:17:12 <alagalah> Ack
17:17:17 <colindixon> anipbu: I'm good
17:17:33 <anipbu> gbp looks good to me
17:17:40 <anipbu> let's move on
17:17:46 <anipbu> congrats groupbasedpolicy
17:17:46 <colindixon> as an aside, do we want to have a TWS on Boron planning today? do we have more things to discuss are people around?
17:17:51 <alagalah> anipbu: thanks !
17:17:52 <anipbu> okay that's it for today
17:17:54 <colindixon> anipbu: I think we're done
17:17:57 <colindixon> thanks anipbu
17:18:05 <alagalah> colindixon: thanks!
17:18:10 <anipbu> we've covered all the projects for today
17:18:16 <jamoluhrsen> colindixon, I know half of people I know are not working today in US.  just fyi
17:18:21 <anipbu> thanks colindixon jamoluhrsen
17:18:27 <colindixon> jamoluhrsen: yeah, that's my take too
17:18:30 <jamoluhrsen> thanks to you as well anipbu
17:18:37 <anipbu> TWS is bad idea for today because of holiday
17:18:41 <colindixon> we'll cancel the TWS and ask people to comment on the mailing list
17:18:44 <colindixon> anipbu: +1
17:18:44 <colindixon> thanks
17:19:05 <anipbu> #topic cookies
17:19:15 <anipbu> #endmeeting