#opendaylight-meeting: docs

Meeting started by colindixon at 19:01:11 UTC (full logs).

Meeting summary

  1. agenda (colindixon, 19:01:37)
    1. when to do a TWS (colindixon, 19:02:12)
    2. state of project-specific docs patches (colindixon, 19:02:22)
    3. state of xinghao's patches (colindixon, 19:02:42)
    4. ACTION: colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (colindixon, 19:04:03)
    5. ACTION: colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version (colindixon, 19:04:07)
    6. ACTION: colindixon and/or zxiiro to fix the favicon (colindixon, 19:04:12)
    7. ACTION: colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior (colindixon, 19:04:19)
    8. ACTION: phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon, 19:04:31)

  2. when to do a TWS (colindixon, 19:05:01)
    1. the plan of record is that phrobb and dfarrell07 will do a TWS on TSC elections on Monday, 8/1 (colindixon, 19:05:41)
    2. and then we'll do a TWS on docs migration on Monday, 8/8 (colindixon, 19:05:49)
    3. we should present the plan insofar as we have on on one of the upcoming TSC meetings to get blessing for it (colindixon, 19:07:45)

  3. the state of project-specific docs patches (colindixon, 19:08:00)
    1. https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 we currently have 2 unreviewd docs patches (both came up today), we were briefly at 0 yesterday (colindixon, 19:08:26)
    2. there are 29 total open docs patches (colindixon, 19:08:37)
    3. the maybe scarier part is that we have 31 projects with no docs updates in Boron (colindixon, 19:08:53)
    4. ACTION: anipbu to go through the documentation matrix and mark patch status as N/A and put a link to the mail (in the patch ID column) saying they will have no new docs for appropriate proejcts (colindixon, 19:10:32)
    5. ACTION: colindixon to e-mail projects with no docs and no e-mail saying there won't be any after anipbu does his update (colindixon, 19:10:59)
    6. ACTION: zxiiro to review and merge colindixon's docs patches: https://git.opendaylight.org/gerrit/#/q/project:docs+author:colin%2540colindixon.com+status:open (colindixon, 19:11:57)
    7. https://lists.opendaylight.org/pipermail/release/2016-July/007456.html mail to release@ telling projects to look to see if their docs patches need attention (colindixon, 19:12:42)

  4. xinghao's autconverter and auto-splitter (colindixon, 19:13:06)
    1. https://git.opendaylight.org/gerrit/#/c/42104/ this patch is progressing nicelly, colindixon expects it will be merged today (colindixon, 19:13:28)
    2. ACTION: colindixon and xinghao to check for cross-project links in the guides, to make sure they still work (colindixon is pretty sure they won't, but there aren't very many) (colindixon, 19:15:16)
    3. colindixon asks what happens with content that is above the chapter level (colindixon, 19:15:37)
    4. ACTION: colindixon and xinghao to make sure content above chapters works (colindixon, 19:17:03)
    5. this should allow for automated migration of all the adoc to resST, which is really cool stuff (colindixon, 19:18:04)

  5. editing the getting started guide (colindixon, 19:19:06)
    1. https://git.opendaylight.org/gerrit/gitweb?p=docs.git;a=tree;f=docs/getting-started-guide; (anipbu, 19:19:13)
    2. beau asks if we're done migrating the getting started to sphinx and stuff (colindixon, 19:23:50)
    3. colindixon says yes, it's done migrating (colindixon, 19:23:58)
    4. colindixon walks Beau through the process of updating his docs repo to the latest so he can get work done (colindixon, 19:24:34)
    5. Beau says that he needs to gets back to doing some very basic stuff with OpenDaylight as a user, to be able to help get some content in the getting started guide (colindixon, 19:27:53)
    6. Beau in particular says that for NETCONF in particular, he'd like to borrow some of Gile's Herron's perl scripts (colindixon, 19:37:28)


Meeting ended at 19:40:02 UTC (full logs).

Action items

  1. colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches
  2. colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
  3. colindixon and/or zxiiro to fix the favicon
  4. colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
  5. phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money
  6. anipbu to go through the documentation matrix and mark patch status as N/A and put a link to the mail (in the patch ID column) saying they will have no new docs for appropriate proejcts
  7. colindixon to e-mail projects with no docs and no e-mail saying there won't be any after anipbu does his update
  8. zxiiro to review and merge colindixon's docs patches: https://git.opendaylight.org/gerrit/#/q/project:docs+author:colin%2540colindixon.com+status:open
  9. colindixon and xinghao to check for cross-project links in the guides, to make sure they still work (colindixon is pretty sure they won't, but there aren't very many)
  10. colindixon and xinghao to make sure content above chapters works


Action items, by person

  1. anipbu
    1. anipbu to go through the documentation matrix and mark patch status as N/A and put a link to the mail (in the patch ID column) saying they will have no new docs for appropriate proejcts
    2. colindixon to e-mail projects with no docs and no e-mail saying there won't be any after anipbu does his update
  2. colindixon
    1. colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches
    2. colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
    3. colindixon and/or zxiiro to fix the favicon
    4. colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
    5. colindixon to e-mail projects with no docs and no e-mail saying there won't be any after anipbu does his update
    6. zxiiro to review and merge colindixon's docs patches: https://git.opendaylight.org/gerrit/#/q/project:docs+author:colin%2540colindixon.com+status:open
    7. colindixon and xinghao to check for cross-project links in the guides, to make sure they still work (colindixon is pretty sure they won't, but there aren't very many)
    8. colindixon and xinghao to make sure content above chapters works


People present (lines said)

  1. colindixon (37)
  2. odl_meetbot (4)
  3. anipbu (3)


Generated by MeetBot 0.1.4.