19:01:11 <colindixon> #startmeeting docs
19:01:11 <odl_meetbot> Meeting started Tue Jul 26 19:01:11 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:01:11 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:11 <odl_meetbot> The meeting name has been set to 'docs'
19:01:37 <colindixon> #topic agenda
19:02:12 <colindixon> #info when to do a TWS
19:02:22 <colindixon> #info state of project-specific docs patches
19:02:42 <colindixon> #info state of xinghao's patches
19:04:03 <colindixon> #action colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches
19:04:07 <colindixon> #action colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
19:04:12 <colindixon> #action colindixon and/or zxiiro to fix the favicon
19:04:19 <colindixon> #action colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
19:04:31 <colindixon> #action phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money
19:05:01 <colindixon> #topic when to do a TWS
19:05:41 <colindixon> #info the plan of record is that phrobb and dfarrell07 will do a TWS on TSC elections on Monday, 8/1
19:05:49 <colindixon> #info and then we'll do a TWS on docs migration on Monday, 8/8
19:07:45 <colindixon> #info we should present the plan insofar as we have on on one of the upcoming TSC meetings to get blessing for it
19:08:00 <colindixon> #topic the state of project-specific docs patches
19:08:26 <colindixon> #link https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 we currently have 2 unreviewd docs patches (both came up today), we were briefly at 0 yesterday
19:08:37 <colindixon> #info there are 29 total open docs patches
19:08:52 <anipbu> anipbu says he's so excited to the progress we have made in Boron for the documentation patches.  many thanks to the amazing work from colindixon
19:08:53 <colindixon> #info the maybe scarier part is that we have 31 projects with no docs updates in Boron
19:09:51 <colindixon> #action anipbu to go through the documentation matrix and mark patch status as N/A and put a link to the mail saying they will have no new docs for appropriate proejcts
19:10:14 <anipbu> put into patch id column
19:10:21 <colindixon> #undo
19:10:21 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2584250>
19:10:32 <colindixon> #action anipbu to go through the documentation matrix and mark patch status as N/A and put a link to the mail (in the patch ID column) saying they will have no new docs for appropriate proejcts
19:10:59 <colindixon> #action colindixon to e-mail projects with no docs and no e-mail saying there won't be any after anipbu does his update
19:11:57 <colindixon> #action zxiiro to review and merge colindixon's docs patches: https://git.opendaylight.org/gerrit/#/q/project:docs+author:colin%2540colindixon.com+status:open
19:12:42 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-July/007456.html mail to release@ telling projects to look to see if their docs patches need attention
19:13:06 <colindixon> #topic xinghao's autconverter and auto-splitter
19:13:28 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/42104/ this patch is progressing nicelly, colindixon expects it will be merged today
19:15:16 <colindixon> #action colindixon and xinghao to check for cross-project links in the guides, to make sure they still work (colindixon is pretty sure they won't, but there aren't very many)
19:15:37 <colindixon> #info colindixon asks what happens with content that is above the chapter level
19:17:03 <colindixon> #action colindixon and xinghao to make sure content above chapters works
19:18:04 <colindixon> #info this should allow for automated migration of all the adoc to resST, which is really cool stuff
19:19:06 <colindixon> #topic editing the getting started guide
19:19:13 <anipbu> https://git.opendaylight.org/gerrit/gitweb?p=docs.git;a=tree;f=docs/getting-started-guide;
19:23:50 <colindixon> #info beau asks if we're done migrating the getting started to sphinx and stuff
19:23:58 <colindixon> #info colindixon says yes, it's done migrating
19:24:34 <colindixon> #info colindixon walks Beau through the process of updating his docs repo to the latest so he can get work done
19:27:53 <colindixon> #info Beau says that he needs to gets back to doing some very basic stuff with OpenDaylight as a user, to be able to help get some content in the getting started guide
19:37:28 <colindixon> #info Beau in particular says that for NETCONF in particular, he'd like to borrow some of Gile's Herron's perl scripts
19:40:02 <colindixon> #endmeeting