#opendaylight-meeting: kernel projects

Meeting started by colindixon at 16:03:09 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:03:14)
    1. https://wiki.opendaylight.org/view/Kernel_Projects_Call the call page (colindixon, 16:03:26)
    2. https://wiki.opendaylight.org/index.php?title=Kernel_Projects_Call&oldid=50863#Upcoming_Agenda_Topics today's agenda in it's usual place (with a permanent link) (colindixon, 16:05:29)
    3. https://git.opendaylight.org/gerrit/#/c/46531/1 this patch was merged to Lithium-SR4 (colindixon, 16:07:15)

  2. changes that have been waiting for a while (colindixon, 16:08:10)
    1. https://git.opendaylight.org/gerrit/#/c/44099/ (colindixon, 16:08:15)
    2. https://git.opendaylight.org/gerrit/#/c/46479/ (colindixon, 16:08:22)
    3. https://git.opendaylight.org/gerrit/#/c/46534/ (colindixon, 16:08:26)
    4. https://git.opendaylight.org/gerrit/#/c/46684/ (colindixon, 16:08:38)
    5. Michael Vorburger asks what's going on with the above patches and how to proceed from there (colindixon, 16:09:05)
    6. TomP says his biggest complaint was adding more xtend to the project, which we have been trying to push back on (colindixon, 16:11:02)
    7. Michael says that this is usable without any xtend, you can do assertEqualBeans() with two objects and you don't need to understand, read, or write xtend (colindixon, 16:18:43)
    8. https://docs.google.com/presentation/d/1bnwj8CrFGo5KekONYSeIHySdkoXZiewJxkHcZjXnzkQ/edit#slide=id.g17d8ae4d92_0_225 specifically, line 43 here (colindixon, 16:19:45)
    9. to be clear, michael says that he'd rather do this a test-driven development, but this is trying to help get test coverage higher without having to write your own test code (colindixon, 16:22:14)
    10. TomP asks that the commit message make it clear what this is trying to do, specifically, to get better assert output (colindixon, 16:25:40)
    11. the other question is: where should this go? mdsal? infrautils? (colindixon, 16:27:47)
    12. it looks like it has to introduce a dependency on yangtools because it has special code for DataObjects to work correctly (colindixon, 16:31:06)
    13. colindixon says that it probably belongs in mdsal, infrautils seems like the wrong place (colindixon, 16:31:20)
    14. ACTION: vorburger1 to send e-amil to figure out if 44099 would be taken to the MD-SAL, if so then he'll rework it (colindixon, 16:33:01)
    15. looking at the last 3 patches (46479, 46534, 46684) are all around trying to make more convient code for constructing inputs for transactions, e.g., IIDs and DataObjects (colindixon, 16:39:10)
    16. vorburger1 says that this is because it's really common pattern in OpenDaylight which basically creates a triple of an InstanceIdentifier, DataObject, and DataStoreType (operation vs. config) and then tries to define common patterns that would make code more idiomatic and easier to use (colindixon, 16:44:10)
    17. it seems like TomP's complaint is mostly the number of new overrides on put, merge in the WriteTransation in 46434 (colindixon, 16:45:40)
    18. ACTION: vorburger1 and skitt to work with TomP to figure out how to pick some subset of the put/merge variants and then work on getting it pushed, likely to mdsal (colindixon, 16:49:40)

  3. bouncycastle pkix library (colindixon, 16:49:58)
    1. https://git.opendaylight.org/gerrit/#/c/46577/ rgoulding coudl use skitt's input on this patch to get it merged (colindixon, 16:50:21)

  4. YANG 1.1 (colindixon, 16:50:31)
    1. https://lists.opendaylight.org/pipermail/yangtools-dev/2016-October/001611.html see this thread (colindixon, 16:50:34)
    2. ACTION: skitt to review https://git.opendaylight.org/gerrit/#/c/46577/ (skitt, 16:50:39)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-10-04-16.04.html notes from some meeting (colindixon, 16:51:02)
    4. rashmi says she'd like to be included in the YANG 1.1 discussions (colindixon, 16:51:28)
    5. mostly tracked through bugzilla and most of them have a YANG 1.1 prefix for it (colindixon, 16:51:46)
    6. martin ciglan says that the plan is to use bugzilla not a trello board (colindixon, 16:52:05)
    7. vorburger1 asks if there's a dependency or relationship between binding spec v2 and YANG 1.1 (colindixon, 16:54:55)
    8. colindixon and martin ciglan say mostly no, but it's important that the binding spec v2 work for almosta all (and ideally all) possible YANG 1.1 models (colindixon, 16:55:31)

  5. karaf features generation (colindixon, 16:55:50)
    1. https://git.opendaylight.org/gerrit/39539 this patch tries to avoid us having to define both pom.xml and features.xml instead having features.xml generated from the pom file (colindixon, 16:56:30)
    2. adetalhouet asks some questions, skitt and vorburger1 point out that this is optional and doesn't require any changes (colindixon, 16:57:05)
    3. the big win from this (from skitt) is to be able to import features in your pom files to focus on features instead of bundles (which are harder) (colindixon, 16:57:45)
    4. this lets us move more toward features, which sounds good overall (colindixon, 16:58:24)

  6. MD-SAL cleanup (colindixon, 16:58:41)
    1. https://git.opendaylight.org/gerrit/#/c/46503/ (colindixon, 16:58:45)
    2. https://git.opendaylight.org/gerrit/#/q/message:6859 there are more patches in this bug (colindixon, 16:59:13)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=6859 the relevant bug (colindixon, 16:59:34)


Meeting ended at 16:59:41 UTC (full logs).

Action items

  1. vorburger1 to send e-amil to figure out if 44099 would be taken to the MD-SAL, if so then he'll rework it
  2. vorburger1 and skitt to work with TomP to figure out how to pick some subset of the put/merge variants and then work on getting it pushed, likely to mdsal
  3. skitt to review https://git.opendaylight.org/gerrit/#/c/46577/


Action items, by person

  1. skitt
    1. vorburger1 and skitt to work with TomP to figure out how to pick some subset of the put/merge variants and then work on getting it pushed, likely to mdsal
    2. skitt to review https://git.opendaylight.org/gerrit/#/c/46577/


People present (lines said)

  1. colindixon (44)
  2. odl_meetbot (3)
  3. adetalhouet (2)
  4. skitt (1)


Generated by MeetBot 0.1.4.