16:13:10 <colindixon> #startmeeting kernel projects
16:13:10 <odl_meetbot> Meeting started Tue Nov  1 16:13:10 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:13:10 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:13:10 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:13:22 <colindixon> #topic agenda bashing
16:13:46 <colindixon> #info many of the people in Slovakia are out because of a national holiday
16:15:15 <colindixon> #action vorburger and rovarga to talk about how to manage oomph plugins and Eclipse builds over e-mail
16:15:45 <colindixon> #action Ryan Goulding to come up with a bugs query to do a bug scrub in the future
16:17:30 <colindixon> #link https://lists.opendaylight.org/pipermail/netconf-dev/2016-November/000760.html Ryan gave a list of jersey 2 upgrade bugs
16:17:37 <colindixon> #topic SR1
16:18:22 <colindixon> #info anipbu asks rovarga to check that yangtools bugs have been fixed in the latest build
16:21:44 <colindixon> #info anipbu asks colindixon to check in on l2switch for sai and adetalhouet to work on dlux (which is actually an l2switch issue)
16:21:54 <colindixon> #topic karaf 4 upgrade
16:22:11 <colindixon> #info we wil not get karaf 4 on boron
16:26:49 <colindixon> #topic reviewing patches
16:27:21 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/46914/ makes it easier to do findbugs with lots of checking
16:30:04 <colindixon> #info a bunch of controller patches are fixing findbugs and checkstyle issues are waiting for review
16:31:33 <colindixon> #info for now there's a bug in findbugs that gives issues on a pattern for serialization we use
16:31:59 <colindixon> #info we filed a bug with findbugs and suppressed the warning for now
16:36:45 <colindixon> #info rovarga and tpantelis are discussing whether or not we should enforce findbugs
16:48:08 <colindixon> #info rovarga comments that he wants to avoid adding time to runs, but tpantelis says that it's really hard to enforce things without a run on each time
16:48:16 <colindixon> #topic findbugs/sonar across projects
16:48:35 <colindixon> #info long, long discussion about why we do or don't have requirements about checkstyle/sonar/findbugs
16:49:12 <colindixon> #info colindixon points out that really the issue here is that we haven't had anyone find a comfortable middle ground there in terms of minimizing pain vs. improving code quality
16:49:23 <colindixon> #info and then drive it across things
16:57:55 <colindixon> #info we've removed a bunch of protobufs stuff
17:02:15 <colindixon> #endmeeting