16:58:44 <Sai__> #startmeeting kernel_projects
16:58:44 <odl_meetbot> Meeting started Tue Nov 29 16:58:44 2016 UTC.  The chair is Sai__. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:58:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:58:44 <odl_meetbot> The meeting name has been set to 'kernel_projects'
17:00:04 <Sai__> #Agenda - info - 1. Review Action Items
17:00:17 <Sai__> #undo
17:00:24 <Sai__> #topic - Agenda
17:00:31 <Sai__> #chair colindixon
17:00:32 <odl_meetbot> Current chairs: Sai__ colindixon
17:00:43 <Sai__> #Info - 1. Review Action Items
17:01:21 <Sai__> #info - 2. mdsal-trace debugging utility
17:01:47 <Sai__> #info - 3. Review the code change dashboards
17:02:05 <Sai__> #topic - Review Action Items
17:05:16 <Sai__> #info - [DONE] - colindixon will bring up the issue of maybe deprecating the config subsystem in carbon and/or saying we will do it in the future
17:06:16 <Sai__> #info - to be deprecated in carbon, debate is on to when to remove.
17:06:47 <Sai__> #Action - colindixon to add a topic for next week or maybe an e-mail about how to mechanically potentially allow us to special case true-leaf projects to avoid things
17:07:04 <Sai__> #info - [DONE] - Ryan / colindixon to reach out AG regarding Netconf SourceException Synopsis
17:07:13 <Sai__> #info - email sent and will be presented in the December AG meeting
17:07:33 <colindixon> #link https://lists.opendaylight.org/pipermail/controller-dev/2016-November/012859.html e-mail thread on deprecating the config subsystem
17:07:45 <Sai__> #info - [DONE] - vorburger will push the yangtools publicly usable checkstyle things into the upstream checkstyle rules so that it also works for IDEs
17:08:08 <Sai__> #info - Michael has re-engaged with the Checksystle community last week, and am currently waiting for https://github.com/sevntu-checkstyle/sevntu.checkstyle/issues/461
17:09:04 <Sai__> #Action - rgoulding to move the tool to change passwords to /bin insead of /etc Bug 7265
17:09:26 <Sai__> #Action - rgoulding to move the idmlight.db (actual DB) from a top-level place to a better location Bug 7090
17:09:48 <colindixon> https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/SR4/Release_Notes
17:11:16 <Sai__> #info - colin explain how we generates the releas enotes in to the docs.
17:11:56 <colindixon> https://github.com/opendaylight/docs/blob/master/docs/user-guide/authentication-and-authorization-services.rst
17:12:01 <colindixon> that's the file
17:12:18 <colindixon> http://docs.opendaylight.org/en/stable-boron/user-guide/authentication-and-authorization-services.html
17:12:24 <colindixon> it eventually shows up here
17:12:28 <colindixon> vorburger: ^^^^^^^
17:12:58 <Sai__> #topic - mdsal-trace debugging utility
17:13:11 <Sai__> #info - proper project location and controller dependencies (https://git.opendaylight.org/gerrit/#/c/46870/)
17:13:29 <colindixon> this is the patch that created that: https://git.opendaylight.org/gerrit/#/c/45186/
17:14:54 <Sai__> #info - It advertises services with BP with a higher priority
17:17:13 <Sai__> #info - Intended for data broker
17:19:03 <Sai__> #info - #info - Robert initially suggested to move it to MD-SAL
17:19:33 <Sai__> #info - Seems that was a general opinion and after talking to TomP seems controller is the right place
17:20:35 <rovarga> is there a pointer to that discussion?
17:20:43 <rovarga> we want to be moving things *out* of the controller ...
17:22:00 <Sai__> rovarga: currently the discussion is on going in MDSAL call
17:22:27 <colindixon> rovarga: I agree, but until we actually move the things out, we need allow contributions
17:22:44 <colindixon> we can't freeze large chunks of opendaylight because at some point in the future we plan to do something
17:22:56 <rovarga> colindixon: what is the reason to drop it into the controller?
17:23:06 <Sai__> #topic - Guava vs JDK8 Optionals
17:23:08 <colindixon> what's the alterantive?
17:23:30 <rovarga> mdsal, as info'd just 4 minutes ago
17:23:46 <colindixon> I think there are issues with that too, right?
17:24:02 <Sai__> #info - Guava doesn't allow functional style, move towards java Optionals
17:24:04 <colindixon> it's unfortunate josh isn't here
17:24:36 <Sai__> #info - Michael asks - Are we considering moving overall from Guava to Java Optional ?
17:25:07 <Sai__> #info - Stephen says we are awaiting Guava v21
17:26:29 <Sai__> #info - once it is available , stephen thinks we may have to figure out the API
17:27:18 <Sai__> #info - Robert says migration path is merged in Guava v21 , hence we may need to wait for v21
17:29:59 <Sai__> #info - Michael isn't convinced about new guava v21 would help us in solving the issue in future.
17:31:43 <rovarga> #link https://groups.google.com/forum/#!topic/guava-discuss/ZRmDJnAq9T0
17:31:49 <Sai__> #topic - Opinions about (optionally) using JDT ECJ instead of javac
17:32:12 <Sai__> #undo
17:32:12 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2badd90>
17:32:19 <Sai__> #link - https://groups.google.com/forum/#!topic/guava-discuss/ZRmDJnAq9T0
17:32:24 <Sai__> #topic - Opinions about (optionally) using JDT ECJ instead of javac
17:32:39 <Sai__> #link - https://git.opendaylight.org/gerrit/#/c/47370/
17:33:43 <Sai__> #info - Michael asks if it is completely crazy or something to explore ?
17:36:07 <Sai__> #info - gerrit introduces a maven profile, when active runs additional null safety checks
17:36:38 <Sai__> #info - Michael says we can decide on when to activate this (compiler/runtime/locally)
17:40:04 <Sai__> #info - Robert thinks the utility of current analysis is close to zero, using multiple compiler will explode the testing matrix
17:40:49 <Sai__> #topic - Review the code change dashboards
17:41:07 <Sai__> #link - https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:me
17:41:16 <rovarga> Unsafe interpretation of method return type as '@NonNull' based on substitution 'T=@NonNull AddServer'. is a typical problem
17:49:11 <Sai__> #info - Patches - https://git.opendaylight.org/gerrit/#/c/48441/ & https://git.opendaylight.org/gerrit/#/c/48440/ deal with Persist log entries asycnhronously and Adding  persistAsync method to DataPersistenceProvider
17:49:34 <Sai__> #info - performnace improvement is expected
17:51:19 <colindixon> https://datatracker.ietf.org/doc/draft-ietf-netconf-restconf/
17:51:43 <Sai__> #Info - state of data tracker - https://datatracker.ietf.org/doc/draft-ietf-netconf-restconf/
17:51:43 <rovarga> #link https://www.rfc-editor.org/current_queue.php current RFC Editor queue
17:52:05 <Sai__> #link - https://www.rfc-editor.org/current_queue.php current RFC Editor queue
17:53:33 <Sai__> #info - Modified Patches for last 7 days
17:53:36 <Sai__> #link - https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+a
17:57:37 <Sai__> #info - Robert requests TomP to rebase the patches for review
17:58:19 <Sai__> #info - Alexis asks Netconf committers to join to the call for questions and discussions
17:59:58 <Sai__> #topic - participants #info - Sai / Ryan / Alexis / Colin / Martin / Michael / Oren / Robert / Stephen / TomP
18:00:07 <Sai__> #undo
18:00:07 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x29245d0>
18:00:13 <Sai__> #topic - Participants
18:00:24 <Sai__> #info - Sai / Ryan / Alexis / Colin / Martin / Michael / Oren / Robert / Stephen / TomP
18:00:27 <Sai__> #endmeeting