16:51:52 <Sai_> #startmeeting kernel_projects
16:51:52 <odl_meetbot> Meeting started Tue Dec 20 16:51:52 2016 UTC.  The chair is Sai_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:51:52 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:51:52 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:52:47 <Sai_> #link - previous_meeting_minutes
16:52:49 <vorburger> Sai_: you're early!
16:53:00 <Sai_> yeah just getting ready
16:53:33 <Sai_> meeting technically won't start till 9, but just getting the agenda / action items on to the board.
16:54:13 <Sai_> #topic - previous_meeting_minutes
16:54:34 <Sai_> #link - https://meetings.opendaylight.org/opendaylight-meeting/2016/kernel_projects/opendaylight-meeting-kernel_projects.2016-12-13-16.57.html
16:54:41 <Sai_> #topic - Agenda
16:55:11 <Sai_> #info - 1. Call for any topics
16:55:24 <Sai_> #info - 2. Review action items
16:56:31 <Sai_> #info 3. Ttp project discussion
16:56:46 <Sai_> #info 4. odlparent SingleFeatureTest
16:56:58 <Sai_> #info 5. Review the code change dashboards
16:58:32 <Sai_> #chair colindixon
16:58:32 <odl_meetbot> Current chairs: Sai_ colindixon
16:58:42 <Sai_> #topic - Call for any topics
17:03:49 <Sai_> #info - Karaf 4
17:04:21 <Sai_> #topic - Review action items
17:05:45 <vorburger> FYi I'm struggling to join WebEx again (from Linux desktop)
17:06:06 <Sai_> #action - Michael to discuss with Stephen regarding karaf 4 distribution wrt gerrit https://git.opendaylight.org/gerrit/#/c/48901
17:07:34 <Sai_> #action - [DONE] Bala to add notes (or breakdown patches in to several patches) for patch change id - 49253
17:07:51 <Sai_> #undo
17:07:51 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2a9c990>
17:07:56 <Sai_> #info - [DONE] Bala to add notes (or breakdown patches in to several patches) for patch change id - 49253
17:09:49 <skitt> vorburger, we could hear you
17:10:38 <Sai_> #info - [DONE] - closing for now, will open action items as need for Bug 5902.  note mciglan: assigned, replicated & in progress - might need new solution - code re-done
17:11:33 <Sai_> #topic - Ttp project
17:11:44 <Sai_> #link - https://lists.opendaylight.org/pipermail/ttp-dev/2016-December/thread.html
17:12:07 <Sai_> #info - vorburger requesting guidance how to make ttp project move on ignored email ? If no reaction, what do I do? What's our process in such cases, where would I raise a motion to get ttp removed from autorelease? As of now it still is in.
17:12:34 <Sai_> #info - colindixon asks if there is any existing patch.
17:14:03 <Sai_> #info - Micheal to update patch in ttp project and add colin as reviewer
17:15:37 <rgoulding> #link https://lists.opendaylight.org/pipermail/ttp-dev/2016-December/000168.html
17:16:30 <Sai_> #topic - odlparent SingleFeatureTest
17:16:41 <Sai_> #info - https://git.opendaylight.org/gerrit/#/c/48901/ odlparent SingleFeatureTest ready, just waiting for 1 (?) project to fix up. Merge when, now, or first thing Jan 9th when vorburger is back from vacation? Or Jan 2nd when others pick up?
17:17:33 <Sai_> #info - Stephen asks if it makes karaf 4 update more harder ?
17:19:21 <Sai_> #info - Stephen says karaf 4 update requires more time, hence better to get in odlparent singlefeature Test either early or push it after karaf update
17:20:43 <Sai_> #link - https://git.opendaylight.org/gerrit/#/c/48901/
17:23:40 <Sai_> #link - https://git.opendaylight.org/gerrit/#/c/48901/25/features-test/src/main/java/org/opendaylight/odlparent/featuretest/SingleFeatureTest.java
17:25:18 <Sai_> #info - some features in BLACKLISTED_BROKEN_FEATURES are not working , need further attention.
17:27:14 <Sai_> #info - colin suggests using multi patch test job
17:28:04 <Sai_> #topic - Karaf 4 Update
17:30:28 <Sai_> #info - it runs singlefeaturetest , fixes all missing dependencies (example patch exists in yangtools).
17:31:31 <Sai_> #info - all the projects' missing bundles are to be figured out to make sure karaf 4 update is done.
17:33:01 <Sai_> #info - colin suggests waiting till january first week to push karaf 4 update.
17:35:02 <Sai_> #info - karaf 3 has known security issues, it requires java 7.
17:36:36 <Sai_> #info - when upgraded to karaf 4, some bundles needs updation.
17:37:50 <Sai_> #info - if karaf 3 & 4 are allowed parallel, there is a possibility that most projects may not move to karaf 4.
17:38:34 <Sai_> #info - RC0 deadline is  April 13.
17:40:58 <Sai_> #info - Stephen says it cannot be prepared in advance , since it requires all the dependent projects to be moved to karaf 4 , before updating the parent projects.
17:43:02 <Sai_> #info - Michael says it sounds scary, since the parent projects have to wait till all dependent projects are ready.
17:44:53 <Sai_> #info - Michael volunteers to help Stephen in preparing patches for karaf 4 upgrade
17:47:01 <Sai_> #info - odlparent / controller / yangtools / md-sal are the projects for which patches are ready as of now.
17:50:40 <Sai_> #info - Colin suggests to present karaf topic in TSC with patches and instructions (doc) on how to upgrade to karaf 4.
17:54:49 <colindixon> jamoluhrsen: do we have examples of the multi-patch test jobs?
17:55:07 <Sai_> #info - Vrakto suggests to create karaf 4 in parallel to karaf 3 by distribution projects / check jobs etc.,  and then test the patches.
17:55:15 <jamoluhrsen> colindixon, like a how-to?
17:55:23 <colindixon> jamoluhrsen: like anything?
17:55:33 <colindixon> docs, exmaples of it being run, etc.
17:55:35 <jamoluhrsen> colindixon: give me a sec
17:56:00 <colindixon> a pointer to the patch/file backing it
17:56:39 <jamoluhrsen> colindixon, here is a wiki     https://wiki.opendaylight.org/view/Integration/Test/Running_System_Tests#Running_System_Tests_Using_Custom_Distribution_Built_From_Multiple_Patches
17:56:49 <jamoluhrsen> colindixon, looking for a live example if we have one.
17:56:55 <colindixon> thank you
17:56:57 <colindixon> !
17:57:19 <colindixon> #link https://wiki.opendaylight.org/view/Integration/Test/Running_System_Tests#Running_System_Tests_Using_Custom_Distribution_Built_From_Multiple_Patches multiple-patch test job docs
17:57:30 <Sai_> #link - https://wiki.opendaylight.org/view/Integration/Test/Running_System_Tests#Running_System_Tests_Using_Custom_Distribution_Built_From_Multiple_Patches
17:57:36 <colindixon> #undo
17:57:36 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2bbd850>
17:57:42 <jamoluhrsen> colindixon, looks like there was a job run
17:57:48 <colindixon> Sai_: I just linked it
17:58:04 <Sai_> colindixon: sure thanks
17:58:16 <jamoluhrsen> https://jenkins.opendaylight.org/releng/view/integration/job/integration-multipatch-test-carbon/1
17:58:25 <jamoluhrsen> honeycomb + gbp used it.
17:58:59 <colindixon> #link https://jenkins.opendaylight.org/releng/view/integration/job/integration-multipatch-test-carbon/ multi-patch test job in jenkins, was used once by honeycompb + gbp recently for carbon
18:02:44 <colindixon> thanks jamoluhrsen you rock!
18:02:57 <jamoluhrsen> colindixon :)
18:04:00 <Sai_> #info - Michael says implementing odlparent SingleFeatureTest earlier than karaf 4 upgrade would be better.
18:05:06 <Sai_> #topic - participants
18:05:11 <colindixon> thanks Sai, rgoulding
18:05:51 <Sai_> #info - Sai / Ryan / Colin / Igor / Michael / Stephen / TomP / Tomas / Vratko
18:05:58 <Sai_> #endmeeting