17:01:16 <SaiMarapaReddy> #startmeeting MD-SAL Interest Call
17:01:16 <odl_meetbot> Meeting started Tue Jan 12 17:01:16 2016 UTC.  The chair is SaiMarapaReddy. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:16 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:16 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
17:02:15 <SaiMarapaReddy> #chair colindixon
17:02:15 <odl_meetbot> Current chairs: SaiMarapaReddy colindixon
17:02:37 * colindixon starts to get on webex
17:06:04 <colindixon> #topic agenda bashing
17:06:21 <colindixon> #link https://wiki.opendaylight.org/view/MD-SAL_Weekly_Call#Upcoming_Agenda_Topics ryan says he a few topics here
17:06:43 <colindixon> #topic netconf schema mount directory
17:07:03 <colindixon> #iink https://bugs.opendaylight.org/show_bug.cgi?id=4577 this is related to this bug
17:07:30 <colindixon> #it's merged into stable/lithium and it's now on master too, but there's more testing to do for the relevant patch before it goes
17:07:46 <colindixon> #info it's merged into stable/lithium and it's now on master too, but there's more testing to do for the relevant patch before it goes
17:08:07 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/30163/ relevant patch that's merged
17:08:17 <SaiReddy> #chair
17:08:37 <colindixon> #chair SaiReddy
17:08:37 <odl_meetbot> Current chairs: SaiMarapaReddy SaiReddy colindixon
17:09:23 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/32362/ the yet-to-be-merged patch for master
17:10:07 <colindixon> #info ryan says it's as easy to add a schema cache directory as a username or password with NETCONF
17:10:11 <colindixon> #topic RC0 isseus
17:10:24 <colindixon> #info ryan asks anipbu if there are any RC0 issues from the syncs
17:10:32 <SaiReddy> #info An H says - attendance is very low last week
17:10:44 <colindixon> SaiReddy: thanks
17:11:09 <SaiReddy> #info - ryan asks any issues that are oncgoing right now
17:12:22 <SaiReddy> #info ttkacik says implemented inyang tools and implemented in controller. implemented in yang tools and took time to merge in controller.
17:12:50 <SaiReddy> #info ryan says we can leverage tomorrows meeting to get about status updates
17:13:11 <SaiReddy> #info colindixon asks where abouts about netconf clustering
17:13:35 <SaiReddy> #info Ryan says we shoudl change functionality for service release
17:13:52 <SaiReddy> #info colindixon asks is there any description of netconf semantics
17:15:13 <SaiReddy> #info colindixon do we have where netconf is defined ? location of docs ?
17:15:30 <SaiReddy> #info Robert asks to shoot mail to dev list
17:16:29 <SaiReddy> #tomP asks mechanism to push the config system exists ?
17:16:50 <SaiReddy> #ttkacik says it exists still, it is separated from wiring configuration
17:17:57 <SaiReddy> #info tomP says what is recommended forward ? ttkacik says the guidelines are ultimately migrate the configuration topology
17:18:37 <colindixon> +1 to that
17:18:48 <SaiReddy> #topic clustering updates
17:19:13 <SaiReddy> #info ryan asks is there any upgrade story ?
17:19:25 <SaiReddy> #info robert says there is nothing as of now
17:20:10 <SaiReddy> #info ryan requests for a story config system related to yang - cds
17:20:39 <SaiReddy> #action - ryan opens a bug to deal with upgradability of netconf clustering
17:26:50 <colindixon> #info colindixon, ryan, and TomP all basically say it would be good to have a script or at least instructions on how to migrate netconf mounts from the old config-subsystem-based mounts to new clustered datastore based
17:27:09 <colindixon> #topic new YANG Tools versioning
17:27:38 <colindixon> #info rovarga says that they plan to move to semantic versionion staring with 1.0.0 in YANG Tools
17:28:05 <colindixon> #link https://lists.opendaylight.org/pipermail/yangtools-dev/2016-January/001176.html description here
17:29:40 <colindixon> #info rovarga says that in boron yang tools will be explicitly incompatible with beryllium and before, in particular people need to move to using the yangtools-artifacts way to get versions
17:32:46 <colindixon> #info ryan asks mechanically, what he'd need to do to get to be compliant
17:36:45 <colindixon> #Info rovarga says basically, switch to using the yantools-artifact way to pull in depeendency management information to get the other versions from yangtools
17:37:38 <colindixon> #Info ryan says he's willing to try to create an example for how to do this
17:37:41 <colindixon> #chair Sai
17:37:41 <odl_meetbot> Current chairs: Sai SaiMarapaReddy SaiReddy colindixon
17:39:07 <Sai> #info robert says - you should import yang tools artifacrts which imports. it doesn't use specific version, from boron we can import branch imports like 1.0.0. to 2.0.0. No specific mechanism as of now but trying to built a   #info - ryan asks what is the generic idea   #info robert says - current ly i don't see any   #info An H -  project cannot use version bumping stuff is that it ?  #info colindixon - it is more than that
17:40:07 <colindixon> #action anipbu to add reporting whether you have moved to the new YANG tools versioning as part of Boron readouts
17:41:06 <Sai> #info - ryan asks for patches to derive similar for other projects
17:41:23 <colindixon> #info ryan asks if he can find an example of how to migrate from normal versioing to artifacts way to do versioning
17:41:24 <Sai> #info robert says he has couple and could pass on
17:42:41 <Sai> #info colindixon asks difference in boron / beryllium. is it only deperecate stuff removed or any other  ?
17:42:53 <Sai> #info robert says - it is deprecated.
17:43:46 <Sai> #info ryan thanks robert for exaplanation.
17:44:59 <Sai> #endmeeting