17:00:25 <Sai> #startmeeting MD-SAL Interest Call
17:00:25 <odl_meetbot> Meeting started Tue Jan 19 17:00:25 2016 UTC.  The chair is Sai. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:25 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:25 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
17:01:31 <colindixon> #topic agenda bashing
17:01:37 <colindixon> oh, wait, Sai you have to do that
17:02:00 <Sai> #topic agenda bashing
17:02:18 <Sai> #info - last meeting actions items -
17:02:18 <colindixon> do we have topics for today?
17:02:39 <Sai> #info - Action items  - ryan opens a bug to deal with upgradability of netconf clustering anipbu to add reporting whether you have moved to the new YANG tools versioning as part of Boron readouts
17:03:21 <Sai> #link - last meeting notes https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-01-12-17.01.html
17:04:35 <Sai> #info - Todays likely agenda - - MD-SAL release interview with An Ho;  - Bug 4577 patch is ready for review/merge [1] ; netconf master branch test failures (not present in stable/beryllium) ; RC0 issues
17:05:45 <Sai> #chair colindixon
17:05:45 <odl_meetbot> Current chairs: Sai colindixon
17:06:51 <colindixon> #topic bug 4577 patches
17:07:11 <colindixon> #info this fixes the revisionless import issues by having a custom schemaPath for mounted NETCONF devices
17:07:28 <colindixon> #topic failing tests in NETCONF on master (not seen on stable/beryllium)
17:07:52 <colindixon> #info tomas cere says that the fix should have been merged by tony an things should be good now
17:07:57 <Sai> #Info - Ryan says regarding Netconf - revision-less import and spawn a separate schema - changes in stable lithium - going to beryllium - netconf master brnach has failing tests - to be reviewed - Tony just moved to branch - so should be fine now.
17:08:10 <colindixon> thanks Sai
17:09:12 <Sai> #Info - An Ho says capturing features which end users look for. Going to each individual project and asking for representative to deliver in beryllium.
17:09:32 <Sai> #An Ho - says it takes around 30 min/project. Looking for MD-SAl volunteers.
17:10:55 <Sai> #Action - AnHo & ttkacik will meet at 9:30 PST
17:11:20 <Sai> #topic - Bug 4577 patch is ready for review/merge [1]
17:12:00 <Sai> #Info - robert says - he needs the patch need to be reviewed by one more.
17:12:14 <colindixon> Sai, that's tony, not robert
17:12:21 <Sai> #topic - Bug 4925
17:12:49 <Sai> #info - Robert says - ready to be merged, but it is still level 1 type event.
17:12:57 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=4925
17:13:08 <Sai> #Action - robert will send out a mail regarding the patch and details of bug
17:13:42 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/26853/
17:13:55 <Sai> #Info - Robert says they were able to analyze the issue and proceed further.
17:15:04 <Sai> #info - Ryan asks for any concerns wrt bug 4925
17:15:31 <colindixon> #inf it's 4295, not 4925
17:15:36 <Sai> #Info - Colin asks for 2 min details
17:15:36 <colindixon> #info it's 4295, not 4925
17:16:02 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=4295 real bug (ignore previous link to a bug)
17:17:16 <Sai> #Info - Robert says  the bug has to deal with refactoring the lazy expansion, now it has better memory and overall characteristics, how it is being represented in data tree.
17:18:05 <Sai> #info - Robert says they have been working on it for past  2 months
17:18:29 <Sai> #info - Robert says they dont have any explicit performance numbers.
17:19:48 <colindixon> #info says his memory is that it's 20% more memory effiicient
17:19:57 <Sai> #info - Robert not able to run the bench mark tests, but did some analysis on xml files and skipping all the merge operations. In memory usage of 20% is observed, but it should not affect any performance report.
17:20:18 <Sai> #info - 20% more efficient
17:20:48 <Sai> #info - Ryan asks for is there any standard test tool for bench marking performace test wrt to netconf.
17:21:10 <Sai> #info - Robert says he has no idea where it resides.
17:21:54 <Sai> #topic - rc0 issues
17:22:09 <Sai> #Info - Ryan is not aare of any escalated issues
17:22:19 <Sai> #info - aware
17:22:57 <Sai> #info - RC0 is thursday - Please feel free to reach out for any issues.
17:23:16 <Sai> #Info - Ryan asks for any other issues/topics
17:23:45 <colindixon> #link https://bugs.opendaylight.org/buglist.cgi?list_id=45615&product=mdsal&product=yangtools&product=netconf&product=controller&resolution=--- bugs in controller, mdsal, yangtools, and netconf
17:25:04 <colindixon> #undo
17:25:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x21a5690>
17:25:27 <colindixon> #link https://bugs.opendaylight.org/buglist.cgi?columnlist=product%2Ccomponent%2Cbug_severity%2Cassigned_to%2Cbug_status%2Cresolution%2Cshort_desc%2Cchangeddate&list_id=45615&order=bug_severity%2Cchangeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=mdsal&product=yangtools&product=netconf&product=controller&query_based_on=&query_format=advanced&resolution=--- bugs in controller, mdsal, yangtools, and netconf
17:26:28 <Sai> #topic - Bug 4823 - Data store unrecoverable failure
17:27:03 <Sai> #Info - TomP says they discussed the same in other clustering call. They are doing stress testing.
17:27:16 <Sai> #info - Colin asks if it is going to be fixed in beryllium
17:28:04 <Sai> #info - TomP Says they are trying to push through. Colin says is it critical. TomP replies these are not critical.
17:28:35 <Sai> #Action - Colin asks Ryan  for downgrade of severity
17:28:49 <Sai> #Topic - Bug 4684
17:29:08 <Sai> #info - robert says it will be addressed in RC1
17:29:25 <Sai> #Topic - Bug 4664 - clustering bug
17:30:18 <Sai> #Info - ttkacik says it is openflow related bug.
17:31:13 <Sai> #info - Robert says it is using litium/helium plugin.  Colin asks there is a duplicate of the same bug
17:31:33 <Sai> #info - TomP please close this as duplicate.
17:32:08 <Sai> #info - The other bug is 4665
17:32:41 <Sai> #Colin asks TomP did they talk about this in clustering meeting ?
17:32:47 <Sai> #info - TomP says no
17:33:20 <Sai> #Info - Colin says they want to make sure if it is duplicate and prioritize accordingly.
17:34:52 <Sai> #info - Robert says - Has gone through the bugs overview - bugs has to deal with openflow - they leaves empty child in data store - fixed in beryllium .
17:35:33 <Sai> #info - Colin asks if they can be reproduced in beryllium
17:36:02 <Sai> #info - Robert says he has to check the emails from november.
17:36:35 <Sai> #link - https://bugs.opendaylight.org/show_bug.cgi?id=4665
17:36:43 <Sai> #link - https://bugs.opendaylight.org/show_bug.cgi?id=4664
17:37:11 <Sai> #Action - Colin to follow up with  Anil about these bugs
17:37:20 <Sai> #topic bug 2974
17:38:25 <Sai> #info - ttkacik says - targeted for RC1 , aims to fix the revisionless input mechanism.
17:38:54 <Sai> #info - Ryan says looks good for beryllium release
17:39:12 <Sai> #topic - bug 4574
17:39:52 <Sai> #Info - TomP - May be Moiz / Sanjiv have better idea
17:39:56 <Sai> #link -https://bugs.opendaylight.org/show_bug.cgi?id=4574
17:41:07 <Sai> #info - TomP says Sanjiv in India/ Moiz tried to follow up, this is from lithium SR2. this is 5 node clustering.
17:42:36 <Sai> #Action - Colin says they have to reach out to Ericsson/Fujitsu wrt 4664/4665/4108
17:42:47 <Sai> #Topic - Bug 4108
17:43:25 <colindixon> #info bugs 4664, 4574, 4572, 4484, 4164 are all seemingly related to Ericsson testing of OpenFlow clsutering, someody will reach out to see if they're still real
17:43:44 <Sai> #info - TomP - it is wrt to RPC stuff, he doesn't have more knowledge. need to reach Moiz
17:45:15 <Sai> #Action - adds Jamo to the list wrt bug 4108 to see if it is still relavent to beryllium
17:46:43 <Sai> #info - Colin says needs to go through all bugs and fix them if they are critical.
17:47:58 <Sai> #info - Ryan asks about any other issues / bugs critical for release
17:48:19 <Sai> #Info - log people
17:48:30 <Sai> info -  Ryan Robert An Ho Colin Sai Tomas Cere Xingjun chu Tom P Bala Gary Wu
17:48:40 <Sai> #endmeeting