#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai at 17:00:01 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 17:00:16)
    1. - last meeting notes/action items - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-02-09-17.13.html (Sai, 17:01:39)
    2. - possible topics (Sai, 17:03:04)
    3. 1. Beryllium Blockers Bug 5345 - Unable to use get-schema RPC due to unsafe class casting (Sai, 17:03:25)
    4. 2. Possibility of Deprecating Netconf mount through config subsystem (Sai, 17:03:36)

  2. - previous minute action items followup (Sai, 17:06:05)
    1. ACTION: - Ryan follows up on last meeting action item - TomP to create a new bug wrt Bug4866 (Ryan is closing out bug4866 as fixed) (Sai, 17:06:33)
    2. ACTION: - colindixon fixes Bug2912 (Sai, 17:07:55)
    3. ACTION: - colindixon opens an improvement bug wrt improving usability of DTCL (Sai, 17:09:05)
    4. -Deprecating netconf mount through config subsystem - We are missing a mechanism - to be followed up in Boron . (Sai, 17:10:54)
    5. - rgoulding asks for more info about deprecating netconf mount through config subsystem. Tony says currently not much info. (Sai, 17:11:48)
    6. - Tony says some deployment time logic would help here (Sai, 17:12:52)
    7. ACTION: - rgoulding opens an enhancement bug wrt possibility of deprecating netconf mount through config subsystem (Sai, 17:13:45)

  3. - Bug5345 - Unable to use get-schema RPC due to unsafe class casting (Sai, 17:14:23)
    1. - Api doc doesn't use restconf directly - it uses schema context (Sai, 17:15:46)
    2. - Tony says seems nobody argues that rest interfaces are used less internally. (Sai, 17:17:08)
    3. - colindixon & Tony agrees on the work around that we can use yang files to get RPCs (Sai, 17:18:46)
    4. - rgoulding changes target milestone to Be-1 with importance as critical (Sai, 17:21:07)

  4. - Bug3987 - Unable to add dlux feature to a new md-sal based application (Sai, 17:21:48)
    1. - rgoulding asks if this is a blocker (Sai, 17:23:00)
    2. - Alexis says it is not a blocker (Sai, 17:23:16)
    3. - colindixon says it cannot be a blocker since it is by definition it is not against this release. (Sai, 17:24:08)
    4. - Tony echoes with colindixon (Sai, 17:24:46)
    5. - Alexis says this feature doesn't exist in Beryllium. (Sai, 17:25:07)

  5. - bug5345 - (again ) (Sai, 17:27:26)
    1. - it sounds like there is a workaround where you do a get on restconf/modules and then parse it for RPCs (Sai, 17:27:46)

  6. - Boron Release (Sai, 17:29:13)
    1. ACTION: - Tony comes up with a plan for Boron release - wrt controller & MD-SAl projects. (Sai, 17:30:16)
    2. - Mechanism to make sure that controller is up & running - more complicated problem that anticipated. (Sai, 17:32:14)
    3. - rgoulding asks could we provide a hook for applications to implement themselves ? (Sai, 17:36:31)
    4. - binding config susbsystem to lifecycle state / Making sure that application is up/ Adding things to subtree and everything is expected to behave normally are some of the issues which needs attention. (Sai, 17:39:49)
    5. - TomP says blueprint advertises each module as a service , When each bundle comesup it process blueprint .xml and publishes it (Sai, 17:42:51)
    6. TomP says initialization doesn't mean it is ready (Sai, 17:43:31)
    7. - TomP thinks how about advertising to a service registry ? (Sai, 17:44:17)
    8. - colindixon thinks OSGI really needs a third life cycle state. (Sai, 17:44:46)
    9. - Tony & TomP thinkd that is the reason because it is application specific (Sai, 17:45:10)
    10. - colindixon says only semantics are application specifics but patterns are not. (Sai, 17:46:24)
    11. -TomP things how about puclishing an event to osgi event component? (Sai, 17:47:02)

  7. Cluster bugs (Sai, 17:48:15)
    1. - AnHo says failing jenkins is not a problem (Sai, 17:48:37)
    2. ACTION: - rgoulding requests TomP to followup on jenkins failure build of 3nodeclustering-only-beryllium-590 build - https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/590/ (Sai, 17:50:07)
    3. - https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/590/ (Sai, 17:50:10)
    4. - AnHo requests TomP to mark it as non-blocking if it so. (Sai, 17:50:47)
    5. ACTION: - rgoulding follows up with Luis & TomP on clsutering & netconf bugs - https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/590/ (Sai, 17:53:01)

  8. - How to determine controller is up ? (Again) (Sai, 17:57:12)
    1. - colindixon divides in to three phases. 1. Need to have a karaf feature / some mode (yang/css) which should determine the up condition. 2. On typing the feature we should be able to determine 'up' ness 3.Need to prioritize the importance of having this feature and be implemented in all applications. (Sai, 18:00:29)
    2. - colindixon thinks it face two problems - Implementation of feature itself & bundle implementation of the up service (Sai, 18:01:34)

  9. participants (Sai, 18:01:53)
    1. - Sai/Ryan/Abhijit/Alexis/An Ho/Colin/Gary/Lori/Tom P/ Tony (Sai, 18:02:01)


Meeting ended at 18:02:13 UTC (full logs).

Action items

  1. - Ryan follows up on last meeting action item - TomP to create a new bug wrt Bug4866 (Ryan is closing out bug4866 as fixed)
  2. - colindixon fixes Bug2912
  3. - colindixon opens an improvement bug wrt improving usability of DTCL
  4. - rgoulding opens an enhancement bug wrt possibility of deprecating netconf mount through config subsystem
  5. - Tony comes up with a plan for Boron release - wrt controller & MD-SAl projects.
  6. - rgoulding requests TomP to followup on jenkins failure build of 3nodeclustering-only-beryllium-590 build - https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/590/
  7. - rgoulding follows up with Luis & TomP on clsutering & netconf bugs - https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/590/


Action items, by person

  1. colindixon
    1. - colindixon fixes Bug2912
    2. - colindixon opens an improvement bug wrt improving usability of DTCL
  2. UNASSIGNED
    1. - Ryan follows up on last meeting action item - TomP to create a new bug wrt Bug4866 (Ryan is closing out bug4866 as fixed)
    2. - rgoulding opens an enhancement bug wrt possibility of deprecating netconf mount through config subsystem
    3. - Tony comes up with a plan for Boron release - wrt controller & MD-SAl projects.
    4. - rgoulding requests TomP to followup on jenkins failure build of 3nodeclustering-only-beryllium-590 build - https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/590/
    5. - rgoulding follows up with Luis & TomP on clsutering & netconf bugs - https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/590/


People present (lines said)

  1. Sai (52)
  2. odl_meetbot (5)
  3. colindixon (5)


Generated by MeetBot 0.1.4.