16:57:52 <Sai> #startmeeting MD-SAL Interest Call
16:57:52 <odl_meetbot> Meeting started Tue Feb 23 16:57:52 2016 UTC.  The chair is Sai. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:57:52 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:57:52 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:59:46 <Sai> #topic Agenda
17:00:17 <Sai> #info 1. Call for any topics to be added to the agenda that people didn't get around to adding.
17:00:45 <Sai> #info 2.Review the existing action items (PDF provided by email).
17:00:53 <Sai> #info 3.Introduce the Boron Planning Page.
17:01:02 <Sai> #info 4.Bug 5345 - Unable to use get-schema RPC due to unsafe class casting [1] Status change from "In Progress" to "Confirmed". What is the plan for this?
17:01:11 <Sai> #info 5.Bug 4688 - QNameModule.getRevision() should return a specialized object [2]
17:01:20 <Sai> #info 6.odlparent "Upgrade Bouncycastle 1.52 -> 1.53"; why not 1.54? CVE-2015-7575 was fixed in 1.54 [3]
17:01:31 <Sai> #info 7.odlparent "Upgrade jolokia 1.3.1 -> 1.3.2" why not 1.3.3? [4] required for AAA in Boron
17:01:50 <Sai> #info 8. Odlparent "bundle-parent should pull in junit" [5] Should all bundles inherit from bundle-parent instead of odlparent?
17:02:22 <Sai> #topic Last-Meeting-Notes-Items-link
17:02:28 <Sai> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-02-16-17.00.html
17:04:57 <Sai> #info - Bug2912 solved by colin
17:06:10 <Sai> #info - Ryan / TomP opened bug 5289 wrt followup of Bug4866
17:07:09 <Sai> #info - Ryan opened enhancement bug5407 wrt deprecating netconf
17:07:52 <Sai> #info - Tony sent an email regarding boron release plan for controller
17:08:34 <Sai> #info - colindixon suggests sharding & upgradability are the two topics which should be part of every project
17:11:11 <Sai> #topic - Boron planning
17:11:23 <Sai> #info - New page view/boron_planning is created
17:11:32 <Sai> #topic - Bug5345
17:11:50 <Sai> #Info - TOny & team would work on the bug
17:12:03 <Sai> #topic - bug 4688
17:13:10 <Sai> #info - Robert says it should affect any other project.
17:13:44 <abhijitkumbhare> Sai: did you mean Robert says it should not affect any other project?
17:14:02 <Sai> #undo
17:14:02 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2029c10>
17:14:12 <Sai> #info - Robert says it should NOT affect any other project.
17:14:23 <Sai> #info - Thanks abhijitkumbhare for correction
17:14:37 <Sai> #topic - Upgrade bouncycastle
17:15:19 <Sai> #info - Stephen opened a new bug to upgrade to 1.54
17:15:51 <Sai> #topic bundle-parent
17:16:24 <Sai> #info - Should all bundles inherit from bundle-parent instead of odlparent?
17:16:47 <Sai> #info - Robert says it depends
17:17:20 <Sai> #info - Robert says patch 35124 address this issue
17:17:59 <Sai> #info - Ryan says he will look further in to it
17:19:18 <Sai> #action - Ryan looks through patch 35125 and will send points.
17:20:06 <Sai> #topic - Boron Planning
17:20:19 <Sai> #
17:21:17 <Sai> #link - https://wiki.opendaylight.org/view/Boron_Planning
17:21:59 <Sai> #info - Topic Upgrade Compatibility
17:22:25 <Sai> #info - Advisory thinks this is the single most flaw in ODL
17:23:37 <Sai> #info - colin says we need to device a plan through we can have atleast some projects supporting upgradability
17:24:20 <Sai> #info - Losing data  while upgrading
17:24:56 <Sai> #info - MD-Sal data store & config sub system  are the two data
17:25:37 <Sai> #info - Losing data refers to MD-SAL, if schema changes users wont be able to migrate.
17:26:26 <Sai> #info - When yang data schema model changes users won't be able to follow persistence
17:27:26 <Sai> #info - TomP Says when code wiring changes / user configuration changes it becomes problem wrt upgradability
17:29:12 <Sai> #info - TomP says Third topic Karaf upgradability is the third topic
17:30:23 <Sai> #info - These corresponds to in place upgrade (stop/start) vs service upgrade (where controller keeps running)
17:35:04 <Sai> #info - Rolling upgrades are difficult since all the nodes may not contain same schema/version
17:36:20 <Sai> #info - TomP says theoretically there are no infrastructure limitations wrt clustering
17:38:17 <Sai> #info - Ashutosh agrees with TomP that we should not make insfrastructure as bottleneck.
17:40:09 <Sai> #info - infrastructure & application level testing are both equally necessary
17:42:43 <Sai> #info - Ashutosh says scoping the guidelines on how to do backward compatibility should be included
17:44:53 <Sai> #info - Ashutosh says scripts helps in translating data from previous to current. Is it possible to not use scripts and have a better plan ?
17:46:33 <Sai> #info - TomP is in favor of moving away from config subsystem. Prefers blue print.
17:50:16 <Sai> #info - Robert asks if blueprint is for boron ? boron uses only blueprint ?
17:50:55 <Sai> #info - TomP says boron could be both (blueprint / config subsystem)
17:54:14 <Sai> #info - TomP thinks both cannot co-exist together
17:59:40 <Sai> #info - An Ho requests that we should make sure that there should not be any incompatible issues for end users
18:06:15 <Sai> Topic - participants
18:07:31 <Sai> #info - Sai/Ryan/Abhijith/Ashutosh/An Ho/ Gary/ Martin / Robert / Stephen / TomP / Tony
18:07:40 <Sai> #end meeting
18:07:47 <Sai> #endmeeting