17:00:08 <Sai> #startmeeting MD-SAL Interest Call
17:00:08 <odl_meetbot> Meeting started Tue Mar  8 17:00:08 2016 UTC.  The chair is Sai. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:08 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:08 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
17:01:05 <Sai> #topic lastmeeting minutes
17:01:11 <Sai> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-02-23-16.57.html
17:01:19 <Sai> #topic Agenda Bashing
17:02:54 <Sai> #info - 1. followup Action items
17:02:58 <Sai> #info 2. Enhanced Wiki Format for Past Notes
17:03:07 <Sai> #info - 3.Boron M1 Offset 0 Status Due 3/10 [2]
17:03:21 <Sai> #info - 4.Bug 5345 Unable to use get-schema RPC due to unsafe class casting [3]
17:03:31 <Sai> #info - 5.DCL -> DTCL conversion example patch done by Tom Pantelis [4]
17:03:48 <Sai> #info - 6.Bump akka from 2.3.14 -> 2.4.1 Merged
17:04:03 <Sai> #info - 7.Bug 2825 Deficiencies in current yangtool generation of ietf types [5]
17:05:56 <Sai> #topic - Review the existing action items
17:06:22 <Sai> #info - Ryan looking through it  and send out an email this week
17:06:58 <Sai> #Action - Ryan to followup on patch 35124
17:07:28 <Sai> #topic - Enhanced Wiki Format for Past Notes
17:07:43 <Sai> #info - new look with all meeting notes & age4nda are updated here
17:07:50 <Sai> #topic - Boron M1 Offset 0 Status Due 3/10 [2]
17:08:13 <Sai> #info - Ryan says PTL has to take care of the plan
17:08:49 <Sai> #info - Projects likely to be ready for the offset 0 status
17:09:13 <Sai> #Action - Ryan sends an email informaingall the projects about Boron M1 Offset status
17:09:25 <Sai> #topic - Bug 5345
17:10:46 <Sai> #info - Martin suggests custom mini schema context is the mini solution
17:11:09 <Sai> #info - Martin is busy with beryllium, and expects the bug can wait till SR1
17:13:03 <Sai> #topic - DCL to DTCL
17:13:36 <Sai> #info - DCL to be deprecated in boron timeframe
17:14:05 <Sai> #info - TomP submitted a patch modifying the toaster example which is useful for DTCL
17:14:53 <Sai> #info - Toaster example doesn't have children
17:15:32 <Sai> #Action - Ryan tried to make a better example of toaster or similar which has changes in children (DTCL replication)
17:15:54 <Sai> #Action - Ryan will make a better example of toaster or similar which has changes in children (DTCL replication)
17:17:46 <Sai> #Info - Ericsson when trying to replicate with million flows observed performance problems with DCL, with DTCL we expect to increase the performance
17:19:28 <Sai> #info - it includes API changes
17:21:12 <Sai> #info - Abhijit suggests it may be a good candidate for deprecation , better leave the decision to project folks (project will select between DCL , DTCL based on performance )
17:22:01 <Sai> #Action - Ryan works with TomP on recommendation of DTCL over DCL especially wrt to performance point of view
17:22:24 <Sai> #topic  - Akka from 2.3.14 -> 2.4.1
17:22:58 <Sai> #info - version is bumped
17:23:08 <Sai> #topic - Bug 2825
17:23:33 <Sai> #info - several patches merged, to be followed up in next meeting
17:23:40 <Sai> #topic - Upgrades
17:24:44 <Sai> #info - TomP asks Abhijit about the path forward regarding upgrades
17:25:47 <Sai> #info - TomP says it includes community wide effort to make upgrades possible
17:26:15 <Sai> #info - TomP comes up with Blueprint which is going to take care of hierarchy issues.
17:26:40 <Sai> #info - TomP says Robert agrees too.
17:29:24 <Sai> #info - TomP says blueprint may be longer term solution but for Boron we may need another effort or a feasible solution
17:29:53 <Sai> #info - Abhijit supports the idea
17:35:19 <Sai> #info - Ryan says during transition there will be a big responsibility on application developers
17:36:46 <Sai> #info - Abhijit says OpenflowPlugin has no specific plan for upgrades, but they are busy in migrating to Li framework.
17:38:58 <Sai> #info - TomP has a wiki page which describes the upgrade issues.
17:39:19 <Sai> #info - AnHo asks do we have go to push the blueprint in boron ?
17:40:17 <Sai> #info - Abhijit/TomP says this is just about reaching out to contributors and make sure they are aware.
17:40:55 <Sai> #info - TomP is interested in getting the thoughts of more people
17:41:05 <abhijitkumbhare> Sai - can you add the link for config/upgrades via the # link command?
17:41:28 <Sai> #info - link for config/upgrades
17:41:30 <Sai> #link - https://wiki.opendaylight.org/view/Upgrades_And_Config_System
17:41:35 <abhijitkumbhare> Thanks
17:41:41 <Sai> Thanks Abhijit
17:43:34 <Sai> #info - AnHo says he can ask for how the projects are testing upgradability, requests TomP for step by step process on upgrade and testing.
17:45:39 <Sai> #info - AnHo agrees that upgrade & upgrade testing is of utmost importance, but looking for solution where projects can deal with upgrades all alone. Looking for guidelines / rules.
17:46:34 <Sai> #info - AnHo asks if blueprint may be a better solution for carbon ?
17:48:04 <Sai> #info - TomP says we can push blueprint enabled controller core initially and we can take it from there.
17:49:01 <Sai> #info - AnHo TWS session may be better place on the upgrades discussion.
17:49:14 <Sai> #undo
17:49:14 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2a08510>
17:49:21 <Sai> #info - AnHo says TWS session may be better place on the upgrades discussion.
17:50:12 <Sai> #Action - TomP to send out a mail wrt upgrades including the link for uprades and config system
17:52:05 <Sai> #info - Ryan brings idea of compatibility
17:52:43 <Sai> #info - AnHo says it is a good idea for end users will benefit from compatibility matrix
17:53:38 <Sai> #Action - Ryan followsup with Colin on how to deal with the compatibility matrix for upgrades.
17:55:50 <Sai> #info - AnHo suggests TomP to go release review and add it as a contraint in the excel
17:55:58 <Sai> #link - https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=45904332
17:57:34 <Sai> #Action - TomP to link the release review plan with upgrades & config subsystem.
18:04:15 <Sai> #topic - Attendance
18:04:41 <Sai> #info - Sai/Ryan/Abhijit/Alexis/AnHo/TomP/Martin
18:05:01 <Sai> #endmeeting