15:56:37 <Sai> #startmeeting MD-SAL Interest Call
15:56:37 <odl_meetbot> Meeting started Tue Mar 29 15:56:37 2016 UTC.  The chair is Sai. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:56:37 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:56:37 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
15:56:44 <Sai> #chair colindixon
15:56:44 <odl_meetbot> Current chairs: Sai colindixon
15:57:05 <colindixon> hey
15:57:08 <Sai> #topic Previous Meeting Minutes
15:57:42 <Sai> #link - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-03-22-16.02.html
15:57:49 <Sai> #Topic Agenda
15:58:52 <Sai> #info - 1. Call for any topics to be added to the agenda that people didn't get around to adding.
15:59:00 <Sai> #info 2. Review the existing action items
15:59:24 <Sai> #info 3. Bug 5504 - Controller crashes with OOM.
15:59:37 <Sai> #info 4. Karaf Upgrades
15:59:48 <Sai> #info 5. Blueprint Update
16:05:40 <Sai> #topic Review the existing action items
16:06:12 <Sai> #info - Ryan & Bala will link the Bug (behavioral constraints in Be 5484) to Bug 5396 - Done
16:06:24 <Sai> #info - Tony will sync up with Peter wrt Bug 5396 - Done
16:06:34 <Sai> #info - Dynamic Filter Injection Documentation - Done
16:06:45 <Sai> #link - https://wiki.opendaylight.org/view/AAA:DynamicFilterFramework
16:07:07 <Sai> #topic - Bug5504 Controller crashes with OOM.
16:07:17 <Sai> #link - https://bugs.opendaylight.org/show_bug.cgi?id=5504
16:07:28 <Sai> #info - itr was a blocker at one point for beryllium SR1
16:08:17 <Sai> #link - Ryan asks if it is fixed in master ?
16:08:22 <Sai> #info - Ryan asks if it is fixed in master ?
16:08:41 <Sai> #info - it is done
16:09:32 <Sai> #info - Robert says old/root is no more there.
16:09:41 <Sai> #info - changed to toString()
16:10:19 <Sai> #info - TomP has an idea the next steps wrt BluePrint
16:11:50 <Sai> #info - Followup patch exists in git
16:12:16 <Sai> #info - git patch Change id 36812
16:12:39 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/36812/1
16:13:11 <Sai> #info - TomP sees it happening if config yang file fails to push
16:15:05 <Sai> #Action - TomP opens a bug to track the potential bug ( config yang  change - fails to push - reproducible in local box )
16:15:17 <Sai> #topic - Karaf Upgrades
16:15:52 <Sai> #info - Stephen says he prefers Karaf 4.0, but it breaks a bunch of code
16:16:33 <Sai> #info - Stephen says he needs to figure out how to deal with karaf 3.0
16:16:54 <Sai> #info - Ryan has a patch for  KARAF-4457 in upstream karaf 3.X stream to update pax-web
16:17:06 <Sai> #link - https://issues.apache.org/jira/browse/KARAF-4457
16:17:30 <Sai> #info - Ryan is Working with Jamie Goodyear and team to get some movement here
16:17:49 <Sai> #info - probably not until .6 or .7 release
16:19:08 <Sai> #info - TomP refers to startup properties , requests Ryan to check with stephen
16:19:25 <Sai> #info - Stephen says we can do it without waiting for karaf release
16:20:30 <Sai> #info - TomP says empty one install all features, we are missing admin bundle (which BluePrint needs). ODL karaf installs everything but no the the empty one.
16:20:54 <Sai> #info - TomP asks is there any preference for ODL karaf over empty one  ?
16:21:57 <Sai> #info - TomP says changing karaf configurations is not a really good solution
16:23:18 <Sai> #info - We need not upgrade entire containers, since karaf team is good at having revision based upgrades
16:24:13 <Sai> #Action - Ryan to followup with TomP regarding upstream karaf 3.X stream to update pax-web
16:24:59 <Sai> #Info - Stephen says rebuilding the distribution is current issue with karaf 4.X
16:25:29 <Sai> #info - Stephen says it is time consuming since we need to figure out each build fail
16:25:59 <Sai> #info - Ryan volunteers to help Stephen
16:27:41 <Sai> #topic - Blueprint Update
16:29:59 <Sai> #info - TomP poiont to change id 35867 and wades through the blueprint implementation details
16:30:44 <Sai> #info - TomP explains the toaster example in context with BluePrint
16:35:17 <Sai> #info - TomP emphasis on proxy mechanism and why it is double edged sword
16:36:41 <Sai> #info - TomP - points to "restart dependant on updates" - it walks the service hierarchies - same as config system like atomic restarts
16:38:33 <Sai> #info - TomP says there is a default for all reference type, (default means user will land up in CDS)
16:42:33 <Sai> #info - TomP actually implemented config system & Blueprint side to side and got them working !!!!
16:43:08 <Sai> #TomP says toaster is also compatible with config system
16:43:55 <Sai> #undo
16:43:55 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x24cfa10>
16:44:00 <Sai> #info - TomP says toaster is also compatible with config system
16:47:15 <Sai> #info - AutoColsable in Remote RPC broker Module might be a good example for users to check out the different between both
16:47:41 <Sai> #info - TomP says it works with both Restconf & Netconf
16:50:23 <Sai> #info - Blueprint theoretically should be possible to do with same feature config in the order of the feature hierarchy
16:53:16 <Sai> #info - Implicit dependencies in blueprint are done via service or blueprint advertiser. it makes possible to add an extension which solves the dependencies problem. (think about  OVSDB dependent on OF)
16:54:22 <Sai> #Action - TomP will make sure to have a wiki on how Blueprint is implemented / how it works
16:55:31 <Sai> #info - TomP waiting on patch "Improve config system shutdown" to be reviewed by Robert / Tony
16:58:36 <Sai> #info - TomP says he is waiting on code reviews from other committers in the controller project
16:59:51 <Sai> #info -Robert says he would be very careful wrt to config admin (single point of failure) when blueprint is completely switches over to.
17:01:16 <Sai> #info - TomP says it is little harder to do right now, but have plans to implement
17:02:47 <Sai> #info - TomP wades through toaster-provider-impl in change id 36405 - showing the user facing config & actual code wiring.
17:05:08 <Sai> #info - TomP says in short we have to make user config system as an option to do user operation
17:06:35 <Sai> #info - colin says we have to more consolidate the user interfering way and how much we should allow user to make changes.
17:06:50 <colindixon> Sai: thanks for taking the notes
17:07:38 <Sai> #info - Robert says Netty configs using the datastore implementation should be considered
17:08:02 <Sai> #info - Robert says using sharding we can overcome some issues
17:08:26 <colindixon> #info rovarga says what worries him the most is the fragmentation of configuration state
17:08:32 <Sai> #info Robert says this is excellent progress but only he is worried about framentation of configuration state
17:09:37 <Sai> #info - Robert says devices don't have yang representation , and when we ask everyone to jump on to blueprint .. there may be a problem since we don't have ready made configs
17:10:11 <colindixon> #info is there a compelling reason to store configuration outside the data store
17:10:26 <Sai> #info - TomP says use config system side by side , bridge netconf to config admin are the possible options
17:10:39 <colindixon> #action rgoulding to add things about user config and making sure we have ideally one option to the next week's agenda
17:10:55 <Sai> #info thanks colindixon
17:11:08 <Sai> #endmeeting