16:00:11 <Sai> #startmeeting MD-SAL Interest Call
16:00:11 <odl_meetbot> Meeting started Tue Apr  5 16:00:11 2016 UTC.  The chair is Sai. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:11 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:11 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:00:19 <Sai> #chair colindixon
16:00:19 <odl_meetbot> Current chairs: Sai colindixon
16:00:56 <Sai> #topic last-meeting-minutes
16:00:59 <Sai> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-03-29-15.56.html
16:01:09 <Sai> #topic Agenda
16:02:02 <Sai> #info 1. Call for any topics to be added to the agenda that people didn't get around to adding.
16:02:10 <Sai> #info 2. Review the existing action items
16:02:18 <Sai> #info 3.Infrastructure Issues and Compilation Problems this Week
16:02:26 <Sai> #info 4. DCL Deprecation [3]
16:02:37 <Sai> #info 5. Documentation of necessary changes to support YANG 1.1 [4]
16:02:51 <Sai> #info 6. Update on Blueprint
16:05:10 <Sai> #topic Action items
16:05:39 <Sai> #info - Ryan to followup with TomP regarding upstream karaf 3.X stream to update pax-web - Active conversation going on
16:06:04 <Sai> #info - some progress but we can't cross it off
16:06:29 <Sai> #info - TomP opens a bug to track the potential bug ( config yang change - fails to push - reproducible in local box )  -- Merged to beryllium
16:07:06 <Sai> #info - TomP will make sure to have a wiki on how Blueprint is implemented / how it works - Work in progress
16:07:56 <Sai> #topic - Infrastructure Issues and Compilation Problems this Week
16:08:09 <Sai> #info - cert problem was solved to use correct cert
16:08:17 <Sai> #link - https://lists.opendaylight.org/pipermail/dev/2016-April/001874.html
16:08:31 <Sai> #info - javax.xml.bind.UnmarshalException (s)
16:08:39 <Sai> #link - https://lists.opendaylight.org/pipermail/controller-dev/2016-April/011830.html
16:09:10 <Sai> #info - Ryan is not alone who is facing issue with xmls, Stephen too.
16:10:05 <Sai> #info - colindixon asks to mail to release (Andy) , open a ticket using helpdesk.
16:11:42 <Sai> #info - Tony says it seems xml being downloaded from internet, issue may be dealing with the place where we store. (it expects xml but it downloads html)
16:12:20 <Sai> #info - Tony says target/features of individual repo will have more explanation on errors
16:12:47 <colindixon> #info we think they're really infrastructure failures, then we should report them to helpdesk or on #opendaylight-releng here
16:13:49 <Sai> #info - colindixon says migration of nexus / other stuff shouldn't be ideally affecting these builds
16:14:43 <Sai> #info colindixon says jenkins pulls from local mirror of nexus, if public nexus has any issues that explains it.
16:15:31 <Sai> #Action - Ryan sends out mail / open ticket using helpdesk wrt javax.xml.bind.UnmarshalException (s)
16:16:10 <Sai> #topic DCL Deprecation
16:16:23 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/36970/
16:16:42 <Sai> #info - Ryan says we need to deprecate the ACL deprecation as well
16:17:25 <Sai> #Action - Ryan to followup with DCL Deprecation [3]
16:18:57 <Sai> #info - Api's are used, Tony tries to deprecate all the old Api's so that it is easier for new changes / new Api
16:19:57 <Sai> #info - Tony says If they are deprecated in Boron , they could be deleted in Boron. But with previous release experience it takes 2-3 releases in general
16:20:22 <Sai> #info - Tony suggests to deal with deprecation after carbon
16:20:47 <Sai> #info - colindixon supports it too.
16:21:17 <Sai> #info - TomP suggests Nitrogen and Tony agrees.
16:22:04 <Sai> #topic - Documentation of necessary changes to support YANG 1.1
16:22:11 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/37081/
16:22:27 <Sai> #info - Ryan requests for time frame
16:23:11 <Sai> #info - The patch i just a small list, other part yang1.1 affects MD-SAl, given that we are close to M2, most likely in carbon.
16:23:44 <Sai> #info - Tony says it introduces lot features , so it will be carbon.
16:24:15 <Sai> #info - Ryan volunteers for any help here
16:24:52 <Sai> #topic - Update on Blueprint
16:26:12 <Sai> #info - TomP says - there are no new updates, bu there is progress in work wrt to apache karaf with help of Stephen
16:28:11 <Sai> #info - Improve config subsystem Change 36777 - is a precursor and it is ready to go.
16:28:37 <Sai> #info - TomP asks Tony/other commiters to review the patch
16:29:56 <Sai> #info - TomP has several other patches to be merged and requests for volunteers to review / merge
16:30:42 <Sai> #info - Stephen is interested, Tony requests to add Milos.
16:34:35 <Sai> #Action - TomP will start to work on a wiki page to state how to move from config system to BluePrint
16:35:32 <Sai> #info - Ryan offers help from AAA side.
16:36:04 <Sai> #info - TomP suspects Netconf will be more harder wrt user configuration.
16:37:33 <Sai> #info - Ryan asks if there are any people concerns , requests to raise sooner than later.
16:38:17 <Sai> #topic - new topics
16:39:21 <Sai> #info - question on patch 37009 wrt data tree consumers / data tree producers
16:40:12 <Sai> #info - colindixon says it would be very confusing to developers, say OFP could be both consumer/producer in case of writing a flow .
16:41:46 <Sai> #info - colindixon asks if there is any reason we can't do it in the context.
16:42:20 <Sai> #info - Robert says we are throwing away standalone one way transactions.
16:43:18 <Sai> #info - Robert says it is a consistency win as well as performace win.
16:44:27 <Sai> #info - colin summarizes that  data tree producer is a transacation factory and it is little bit more than that because it is a transaction chain
16:44:59 <Sai> #info - colindixon requests not to introduce new terminology which will confuse developers
16:46:04 <Sai> #info - Robert says since these are new concepts (not similar to data broker) we need to come up with new names.
16:46:44 <Sai> #info - Robert is open for contribution
16:48:05 <Sai> #info - Robert says with this patch we are moving readwritetransaction entirely
16:49:32 <Sai> #info - colindixon says there are somethings (like increment values) are no more possible with this approach.
16:50:01 <Sai> #info - Robert says we still have exclusive ability to write to a subtree
16:50:56 <Sai> #info - Robert says we can have an another producer to write to subtree
16:51:54 <Sai> #info - Muthu asks will the cardinality of 1:1 will be be enforced on a subtree
16:52:14 <Sai> #info - Robert says Yes, At any given time only one producer can write to subtree.
16:52:50 <Sai> #info - TOny says using locking mechanism it is possible.
16:53:28 <Sai> #info - colindixon summarizes if a data tree is claimed by a procuder , you will be unable to write using netconf/restconf
16:54:49 <Sai> #info - Robert says it is true, but it doesn't mean we can't negotiate mechanism, but it is out of the scope of these APIs
16:56:38 <Sai> #info - colindixon says there are currently applications which usess single data tree where two producers are writing at same time.
16:57:19 <Sai> #info - colindixon says in an application logical part & updation of status is an example
16:57:55 <Sai> #info - Robert says intrinsic race condition comes in to picture.
16:59:53 <Sai> #info - Robert says the main reason to do is pushing intent in to config and pushing status in to operational
17:00:26 <Sai> #info - colindixon refers to difference between networking and Software way of looking at it.
17:01:39 <Sai> #info - Robert says the system is never designed or architect-ed for these purposes
17:05:21 <Sai> #info - colindixon says when write transaction is done it will fail when if sub tree is gone away or moved.
17:05:48 <Sai> #info - Robert requests for use case / applications so that we can move ahead
17:07:23 <Sai> #info - Tony rephrases Robert and asks is there is any application in odl which does listening / writing to the same subtree  at same time.
17:08:12 <Sai> #Action - colindixon to work on checking out an application in odl where it listens / writes to the same subtree at same time.
17:08:22 <Sai> #topic - participants
17:09:54 <Sai> #info - Sai / Ryan / Ajay Lele / Alexis / Andrej / Aolin / Martin Ciglan / Muthu / Robert /Shuva Kar / Stephen / Tom P / Tomas Cere / Tony / Vaclav / Viera / Vratko
17:09:58 <Sai> #endmeeting