15:59:38 <Sai> #startmeeting MD-SAL Interest Call
15:59:38 <odl_meetbot> Meeting started Tue Apr 19 15:59:38 2016 UTC.  The chair is Sai. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:59:38 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:38 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:00:54 <Sai> #chair colindixon
16:00:54 <odl_meetbot> Current chairs: Sai colindixon
16:01:08 <Sai> #topic - last-meeting-minutes
16:01:12 <Sai> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-04-12-16.00.html
16:01:48 <Sai> #Agenda
16:02:00 <Sai> #info - 1.Call for any topics to be added to the agenda that people didn't get around to adding.
16:02:13 <Sai> #info 2. Review the existing action items
16:02:26 <Sai> #info 3. Modify config Module impls to co-exist with blueprint Patch
16:02:50 <Sai> #info 4. Binding v2 spec status binding-v2.adoc - Textual description by Tony; Patch for Bug 1411: Design Binding specification v2
16:03:00 <Sai> #info 5. Akka bump to 2.4.4 Patch
16:03:10 <Sai> #info 6. Bug 3866 RESTCONF PATCH Patch
16:04:22 <Sai> #topic - Review the existing action items
16:04:53 <Sai> #info - rgouldin to followup Bug 2515 if it is related to security fix and open bugs as needed. - Done
16:05:26 <Sai> #info - Ryan will followup with colin wrt checking out an application in odl where it listens / writes to the same subtree at same time
16:06:20 <Sai> #info - wrt Bug 2515 several bugs opened by Ryan - groupbasedpolicy Bug 5750 sfc Bug 5751 tsdr Bug 5752 alto Bug 5753 sdninterfaceapp Bug 5754 centinel Bug 5755 neutron Bug 5757 faas Bug 5758 usecplugin Bug 5759 aaa Bug 5760 snmp4sdn This patch removes the unused references to jersey/jaxrs
16:07:23 <Sai> #Action - Ryan will Will follow up RE: unsecured REST endpoints in a few projects today after patches are complete (need a fix before reporting) - Ryan will follow up with security folks.
16:07:52 <Sai> #topic - Modify config Module impls to co-exist with blueprint Patch
16:08:07 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/36714/25
16:08:51 <Sai> #info - TomP waiting for Tony for status/consensus on above mentioned patch
16:09:17 <Sai> #info - Tony couldn't find time last week, will go through it tomorrow.
16:16:17 <Sai> info - we need to figure out if some projects in odl are not configuring their instances not using config susbsystem
16:18:31 <Sai> #info - Tony suggests TomP to look in to OpenflowJava / Openflowconfig projects
16:20:04 <Sai> #info - TomP asks tony if the comment mentioned by Tony blocks the patch
16:20:41 <Sai> #info - Tony says it depends on the projects consuming it.
16:21:16 <Sai> #info Robert says he is pretty sure BGP (may be openflow ) uses global config
16:22:30 <Sai> #Action - Tom P to look through downstream consumers to ensure they aren't spinning up their own netty threadgroups
16:25:15 <Sai> #topic  - Binding v2 spec status
16:25:25 <Sai> #info - binding-v2.adoc - Textual description by Tony
16:25:35 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/37176/1/docs/analysis/binding-v2.adoc
16:26:05 <Sai> #info - Tony says that patch is still in draft, not final.
16:26:54 <Sai> #info - Patch for Bug 1411: Design Binding specification v2
16:27:03 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/37735/
16:27:23 <Sai> #info - Tony is working on it
16:27:46 <Sai> #topic - Akka bump to 2.4.4 Patch
16:28:08 <Sai> #info - Robert says it should not affect any downstream projects.
16:28:18 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/37742/
16:29:08 <Sai> #topic - Bug 3866
16:29:17 <Sai> #info - Bug 3866 RESTCONF PATCH
16:29:25 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/30554/
16:30:04 <Sai> #info - Martin says they are developing new restconf, so diffferent solution for boron expected when compared to beryllium
16:30:17 <Sai> #info -TomP asks if it works for mounted netconf devices
16:30:25 <Sai> #info - Tony says it should work
16:32:00 <Sai> #info - Robert says it allows to specify RPC request in multiple ways.
16:33:16 <Sai> #topic - Question on Yangtools
16:34:06 <Sai> #info - David karr asks when he seacrhes m2e in eclipse he finds old snapshots (2013), recent ones are there only in md-sal and looking forward to know the difference between two .
16:34:31 <Sai> #info - Tony says bundle is always a jar file
16:35:03 <Sai> #info - Tony says changing of type shouldn't change anything.
16:35:36 <Sai> #info - David Karr sends any additional questions on md-sal
16:36:26 <Sai> #topic - participants
16:37:29 <Sai> #info - Sai/Ryan/Alexis/Andrej/DavidKArr/Filip Gregor/ Martin / Robert/Shuva Kar/ Stephen Kitt/TomP/Tomas/Tony/Vaclav/Viera/Vratko
16:37:51 <Sai> #endmeeting