#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai at 15:59:46 UTC (full logs).

Meeting summary

  1. - previous meeting minutes (Sai, 16:00:43)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-04-19-15.59.html (Sai, 16:01:03)

  2. - Agenda (Sai, 16:01:08)
    1. - Review the existing action items (Sai, 16:01:50)
    2. - Beryllium-SR2 Test Failures (Sai, 16:01:57)
    3. - Boron M2 Status for Controller Project (Sai, 16:02:04)
    4. - Bug 5421 - Single cluster-wide project instances (Sai, 16:02:12)
    5. - Karaf Upgrade Status (Sai, 16:02:19)
    6. - moxy upgrade status (Sai, 16:02:25)
    7. - jersey upgrade status (Sai, 16:02:31)
    8. - Bug 5647 (Sai, 16:02:40)
    9. - Check augments for equality in LazyDataObject (Sai, 16:02:54)
    10. - Blueprint / CDS configuration strategies going forward (Sai, 16:03:03)

  3. - Review the existing action items (Sai, 16:04:47)
    1. - carry forward - colindixon to work on checking out an application in odl where it listens / writes to the same subtree at same time. - continue from last week's action item (Sai, 16:05:01)
    2. - Ryan will Will follow up RE: unsecured REST endpoints in a few projects today after patches are complete (need a fix before reporting) - Ryan will follow up with security folks. - DONE this was reported and some patches have already taken place (Sai, 16:05:28)
    3. ACTION: - Ryan will continue to follow up RE: unsecured REST endpoints in a few projects today after patches are complete (need a fix before reporting) (Sai, 16:05:49)
    4. - Tom P to look through downstream consumers to ensure they aren't spinning up their own netty threadgroups - DONE - they were not (Sai, 16:06:10)

  4. - Beryllium-SR2 Test Failures (Sai, 16:07:02)
    1. - Error is in clustering (Sai, 16:07:09)
    2. - TomP & Moiz are not in today's call (Sai, 16:07:19)
    3. ACTION: - Ryan will followup with regarding cluster failures wrt Beryllium-SR2 Test Failures (Sai, 16:08:11)

  5. - Boron M2 Status for Controller Project (Sai, 16:08:24)
    1. -Tony is PTL, not available in today's call (Sai, 16:08:37)

  6. - Bug 5421 - Single cluster-wide project instances (Sai, 16:08:50)
    1. - Moving to next week since low / no attendance (Sai, 16:09:05)

  7. - Karaf Upgrade Status (Sai, 16:09:29)
    1. -Stephen didn't have time to look in to it. (Sai, 16:09:40)
    2. - Please refer to comments to here - https://git.opendaylight.org/gerrit/#/c/26323 (Sai, 16:11:02)
    3. - odl-integration-all sits in integration distribution (Sai, 16:11:52)
    4. ACTION: - Ryan will pull odl-integration-all & update the progress on https://git.opendaylight.org/gerrit/#/c/26323 (Sai, 16:12:23)
    5. https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=185051143 (anipbu, 16:12:36)
    6. - Beryllium-SR2 Test Failures (Sai, 16:13:05)
    7. -An requests TomP to update the spreadsheet here - https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=185051143 (Sai, 16:13:31)
    8. - TomP is not familiar with tests, needs little help on what tests are exactly processing (Sai, 16:14:35)
    9. - An points to https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/756/robot/report/log.html (Sai, 16:14:56)
    10. ACTION: - TomP looks in to error related to https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/756/robot/report/log.html with help of Ryan (Sai, 16:17:45)

  8. - Boron M2 Status for Controller Project (Sai, 16:17:57)
    1. - Work in progress (Sai, 16:18:05)
    2. - Robert says he will have an update today (Sai, 16:18:18)
    3. - Robert finishes the release plan for controller project by today (Sai, 16:18:38)

  9. - Bug 5421 - Single cluster-wide project instances (Sai, 16:19:26)
    1. - https://git.opendaylight.org/gerrit/#/c/37957/ (Sai, 16:19:33)
    2. - TomP interested in knowing the idea behind the patch (Sai, 16:20:24)
    3. - Vaclav says making application singleton across cluster is the main idea. (Sai, 16:20:54)
    4. -Vaclav presents the presentation - life cycle behind plugin in osgi (Sai, 16:23:00)
    5. - Vaclav walks through the code with presentation (Sai, 16:26:43)

  10. - moxy upgrade status (Sai, 16:37:08)
    1. - Ryan needs to look deep in to tcp errors (Sai, 16:37:24)
    2. - failing test-distribution due to tcp-md5 error (Sai, 16:37:33)
    3. ACTION: - Ryan needs to look deep in to tcp-md5 error (Sai, 16:37:48)

  11. - jersey upgrade status (Sai, 16:37:56)
    1. - many patches submitted to align downstream projects with odlparent versions (Sai, 16:38:04)
    2. - we should at least be able to get a minor version bump this release (Sai, 16:38:11)
    3. - major version work has been revived, but I am still scoping what it will actually take. (Sai, 16:38:18)
    4. - there are lot of downstream consumers which aren't actually using them, going forward it may be a different scenario (Sai, 16:38:54)

  12. - Bug 5647 (Sai, 16:39:31)
    1. - Bug is related to Add schema-less version of XMLStreamNormalizedNodeStreamWriter (Sai, 16:39:43)
    2. - Robert says it is an improvement CDS task and it is useful (Sai, 16:40:52)
    3. - TomP says schema point is invalid at the point and it is going to fail too. (Sai, 16:42:14)
    4. - Robert says model needs to be persisted, current assumption is what eevr is done, we will be able to restore somehow, but it breaks on upgrades. (Sai, 16:43:01)

  13. - Check augments for equality in LazyDataObject (Sai, 16:44:49)
    1. - https://git.opendaylight.org/gerrit/#/c/37719/ (Sai, 16:45:04)
    2. - Maros is the owner, Robert summarizes the need of it (Sai, 16:46:02)
    3. - Ryan asks if they need a bug to track what the non-equal objects return ? (Sai, 16:46:29)
    4. ACTION: - Ryan opens a bug (wrt non-equal objects return) and will file corresponding patch (Sai, 16:47:31)

  14. - Blueprint / CDS configuration strategies going forward (Sai, 16:47:43)
    1. - TomP says Idea is to let applications use CDS for code / data / certain ways of tweaking like timeouts. (Sai, 16:49:02)
    2. - TomP says Robert has idea of rolling in to conceptual data tree structure. (Sai, 16:49:43)
    3. - TomP says not using config admin is a preferable way (Sai, 16:50:34)
    4. - RObert asks if we have a bugzilla entry (Sai, 16:50:45)
    5. ACTION: - TomP will create a bug on how to place / where to use config admin wrt Blueprint / CDS configuration strategies going forward (Sai, 16:52:17)

  15. - Participants (Sai, 16:53:07)
    1. - Sai / Ryan / Alexis / An Ho / Martin / Robert / Shuva Kar / Stephen / Tom P / Tomas Cere / Tony / Vaclav (Sai, 16:53:56)


Meeting ended at 16:54:06 UTC (full logs).

Action items

  1. - Ryan will continue to follow up RE: unsecured REST endpoints in a few projects today after patches are complete (need a fix before reporting)
  2. - Ryan will followup with regarding cluster failures wrt Beryllium-SR2 Test Failures
  3. - Ryan will pull odl-integration-all & update the progress on https://git.opendaylight.org/gerrit/#/c/26323
  4. - TomP looks in to error related to https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/756/robot/report/log.html with help of Ryan
  5. - Ryan needs to look deep in to tcp-md5 error
  6. - Ryan opens a bug (wrt non-equal objects return) and will file corresponding patch
  7. - TomP will create a bug on how to place / where to use config admin wrt Blueprint / CDS configuration strategies going forward


People present (lines said)

  1. Sai (80)
  2. odl_meetbot (4)
  3. anipbu (1)


Generated by MeetBot 0.1.4.