15:59:46 <Sai> #startmeeting MD-SAL Interest Call
15:59:46 <odl_meetbot> Meeting started Tue Apr 26 15:59:46 2016 UTC.  The chair is Sai. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:59:46 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:46 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:00:43 <Sai> #topic - previous meeting minutes
16:01:03 <Sai> #link - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-04-19-15.59.html
16:01:08 <Sai> #topic- Agenda
16:01:50 <Sai> #info - Review the existing action items
16:01:57 <Sai> #info - Beryllium-SR2 Test Failures
16:02:04 <Sai> #info - Boron M2 Status for Controller Project
16:02:12 <Sai> #info - Bug 5421 - Single cluster-wide project instances
16:02:19 <Sai> #info - Karaf Upgrade Status
16:02:25 <Sai> #info - moxy upgrade status
16:02:31 <Sai> #info - jersey upgrade status
16:02:40 <Sai> #info - Bug 5647
16:02:54 <Sai> #info - Check augments for equality in LazyDataObject
16:03:03 <Sai> #info - Blueprint / CDS configuration strategies going forward
16:04:47 <Sai> #topic  - Review the existing action items
16:05:01 <Sai> #info - carry forward - colindixon to work on checking out an application in odl where it listens / writes to the same subtree at same time. - continue from last week's action item
16:05:28 <Sai> #info - Ryan will Will follow up RE: unsecured REST endpoints in a few projects today after patches are complete (need a fix before reporting) - Ryan will follow up with security folks. - DONE this was reported and some patches have already taken place
16:05:49 <Sai> #Action - Ryan will continue to follow up RE: unsecured REST endpoints in a few projects today after patches are complete (need a fix before reporting)
16:06:10 <Sai> #info - Tom P to look through downstream consumers to ensure they aren't spinning up their own netty threadgroups - DONE - they were not
16:07:02 <Sai> #topic - Beryllium-SR2 Test Failures
16:07:09 <Sai> #info - Error is in clustering
16:07:19 <Sai> #info - TomP & Moiz are not in today's call
16:08:11 <Sai> #Action - Ryan will followup with regarding cluster failures wrt Beryllium-SR2 Test Failures
16:08:24 <Sai> #topic - Boron M2 Status for Controller Project
16:08:37 <Sai> #info -Tony is PTL, not available in today's call
16:08:50 <Sai> #topic - Bug 5421 - Single cluster-wide project instances
16:09:05 <Sai> #info - Moving to next week since low / no attendance
16:09:20 <Sai> link - https://git.opendaylight.org/gerrit/#/c/37957/
16:09:29 <Sai> #topic - Karaf Upgrade Status
16:09:40 <Sai> #info -Stephen didn't have time to look in to it.
16:11:02 <Sai> #info - Please refer to comments to here - https://git.opendaylight.org/gerrit/#/c/26323
16:11:52 <Sai> #info - odl-integration-all sits in integration distribution
16:12:23 <Sai> #Action - Ryan will pull odl-integration-all & update the progress on https://git.opendaylight.org/gerrit/#/c/26323
16:12:36 <anipbu> https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=185051143
16:13:05 <Sai> #info - Beryllium-SR2 Test Failures
16:13:31 <Sai> #info -An requests TomP to update the spreadsheet here - https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=185051143
16:14:35 <Sai> #info - TomP is not familiar with tests, needs little help on what tests are exactly processing
16:14:56 <Sai> #info - An points to https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/756/robot/report/log.html
16:17:45 <Sai> #Action - TomP looks in to error related to https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/756/robot/report/log.html  with help of Ryan
16:17:57 <Sai> #topic - Boron M2 Status for Controller Project
16:18:05 <Sai> #info - Work in progress
16:18:18 <Sai> #info - Robert says he will have an update today
16:18:38 <Sai> #info - Robert finishes the release plan for controller project by today
16:19:26 <Sai> #topic - Bug 5421 - Single cluster-wide project instances
16:19:33 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/37957/
16:20:24 <Sai> #info - TomP interested in knowing the idea behind the patch
16:20:54 <Sai> #info - Vaclav says making application singleton across cluster is the main idea.
16:22:30 <Sai> #info - Vaclav presents the presentation behind life cycle plugin in osgi
16:22:39 <Sai> #undo
16:22:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x29ce510>
16:23:00 <Sai> #info -Vaclav presents the presentation - life cycle behind plugin in osgi
16:26:43 <Sai> #info - Vaclav walks through the code with presentation
16:37:08 <Sai> #topic - moxy upgrade status
16:37:24 <Sai> #info - Ryan needs to look deep in to tcp errors
16:37:33 <Sai> #info - failing test-distribution due to tcp-md5 error
16:37:48 <Sai> #Action - Ryan needs to look deep in to tcp-md5 error
16:37:56 <Sai> #topic - jersey upgrade status
16:38:04 <Sai> #info - many patches submitted to align downstream projects with odlparent versions
16:38:11 <Sai> #info - we should at least be able to get a minor version bump this release
16:38:18 <Sai> #info - major version work has been revived, but I am still scoping what it will actually take.
16:38:54 <Sai> #info - there are lot of downstream consumers which aren't actually using them, going forward it may be a different scenario
16:39:31 <Sai> #topic - Bug 5647
16:39:43 <Sai> #info - Bug is related to Add schema-less version of XMLStreamNormalizedNodeStreamWriter
16:40:22 <Sai> link - https://git.opendaylight.org/gerrit/#/c/36975/
16:40:52 <Sai> #info - Robert says it is an improvement CDS task and it is useful
16:42:14 <Sai> #info - TomP says schema point is invalid at the point and it is going to fail too.
16:43:01 <Sai> #info - Robert says model needs to be persisted, current assumption is what eevr is done, we will be able to restore somehow, but it breaks on upgrades.
16:44:49 <Sai> #topic  - Check augments for equality in LazyDataObject
16:45:04 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/37719/
16:46:02 <Sai> #info - Maros is the owner, Robert summarizes the need of it
16:46:29 <Sai> #info - Ryan asks if they need a bug to track what the non-equal objects return ?
16:47:31 <Sai> #Action - Ryan opens a bug (wrt non-equal objects return) and will file corresponding patch
16:47:43 <Sai> #topic - Blueprint / CDS configuration strategies going forward
16:49:02 <Sai> #info - TomP says Idea is to let applications use CDS for code / data / certain ways of tweaking like timeouts.
16:49:43 <Sai> #info - TomP says Robert has idea of rolling in to conceptual data tree structure.
16:50:34 <Sai> #info - TomP says not using config admin is a preferable way
16:50:45 <Sai> #info - RObert asks if we have a bugzilla entry
16:52:17 <Sai> #Action - TomP will create a bug on how to place / where to use config admin wrt Blueprint / CDS configuration strategies going forward
16:53:07 <Sai> #topic - Participants
16:53:56 <Sai> #info - Sai / Ryan / Alexis / An Ho / Martin / Robert / Shuva Kar / Stephen / Tom P / Tomas Cere / Tony / Vaclav
16:54:01 <Sai> #nemeeting
16:54:06 <Sai> #endmeeting