16:00:33 <Sai> #startmeeting MD-SAL Interest Call
16:00:33 <odl_meetbot> Meeting started Tue May  3 16:00:33 2016 UTC.  The chair is Sai. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:33 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:33 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:00:57 <Sai> #topic - last meeting minutes
16:01:01 <Sai> #info - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-04-26-15.59.html
16:01:18 <Sai> #topic - Agenda
16:01:48 <Sai> #info - Call for any topics to be added to the agenda that people didn't get around to adding.
16:01:58 <Sai> #info 2. Review the existing action items
16:02:13 <Sai> #info 3. Bug 5830 - Mandatory leaf enforcement is not correct with presence container
16:02:21 <Sai> #info 4. Bug 5484: Fix of Yang statement lexer
16:02:39 <Sai> #info 5. Ubuntu 16.04 LTS - default jdk
16:02:49 <Sai> #info 6. Upgrade Jetty 8.1.14.v20131031 -> 8.1.19.v20160209
16:02:59 <Sai> #info 7. RESTCONF Draft upgrade.
16:03:11 <Sai> #info 8. Change opendaylight-karaf-distro-archetype to use karaf-parent
16:03:54 <Sai> #topic - Call for any topics to be added to the agenda that people didn't get around to adding.
16:05:33 <Sai> #info - no extra topics as of now
16:05:54 <Sai> #topic - Review the existing action items
16:06:20 <Sai> #Action - colindixon to work on checking out an application in odl where it listens / writes to the same subtree at same time. - continue from last week's action item - Ryan digging in to ovsdb stuff, will followup next week.
16:06:40 <Sai> #info - Robert to complete Controller M2 status
16:07:01 <Sai> #Action - Tony to send reports regarding controller M2 status
16:07:14 <Sai> #info - Ryan will continue to follow up RE: unsecured REST endpoints in a few projects today after patches are complete (need a fix before reporting) - Done
16:07:24 <Sai> #info - Ryan will followup with regarding cluster failures wrt Beryllium-SR2 Test Failures - Done
16:07:42 <Sai> #info - Done by Luis & Ryan
16:08:22 <Sai> #Action - Ryan will pull odl-integration-all & update the progress on https://git.opendaylight.org/gerrit/#/c/26323 - Re-evaluating based on later karaf release.
16:08:40 <Sai> #info - TomP looks in to error related to https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/756/robot/report/log.html with help of Ryan - DONE by Luis Gomez
16:08:58 <Sai> #info - Ryan opens a bug (wrt non-equal objects return) and will file corresponding patch - DONE Bug for transparency/visibility: Bug 5837.
16:09:08 <Sai> #info - The change was a blocker for OVSDB; will it affect the outside community who is building their own applications on top of Beryllium?
16:10:38 <Sai> #info - Tony says it depends on use case of application
16:11:00 <Sai> #info - Downstream customers may be affected.
16:11:20 <Sai> #info - colindixon suggests to put it in release notes
16:12:18 <Sai> #Action - Ryan to followup with release team wrt change regarding wrt non-equal objects return and corresponding patch
16:12:32 <Sai> #Action - TomP will create a bug on how to place / where to use config admin wrt Blueprint / CDS configuration strategies going forward
16:12:36 <Sai> #chair colindixon
16:12:36 <odl_meetbot> Current chairs: Sai colindixon
16:13:22 <Sai> #topic - Bug 5837
16:13:36 <Sai> #info - colin asks if it is a API change ?
16:14:02 <Sai> #info - Tony says it is a behaviour change but not API change
16:14:40 <Sai> ##info - colindixon pushes the idea of adding it in release notes. Again.
16:14:42 <Sai> #info - colindixon pushes the idea of adding it in release notes. Again.
16:14:57 <Sai> #topic - Bug 5830 - Mandatory leaf enforcement is not correct with presence container
16:15:28 <Sai> #link - https://bugs.opendaylight.org/show_bug.cgi?id=5830
16:16:38 <Sai> #info - if you don't have mandatory leaf node, if closest ancestor exists, then leaf node also should exists.
16:19:47 <Sai> #info - Tony agrees that it is a bug
16:22:51 <Sai> #info - Please refer to the comments here https://bugs.opendaylight.org/show_bug.cgi?id=5830
16:26:07 <Sai> #info - Robert says at run time we don't have a wait consistently, constraints span across modules.
16:28:07 <Sai> #info - If augmentation is used - when someone runs before you run it will blow up.
16:30:25 <Sai> #info - Robert says the mandatory leaf should be enforced, whether it is a list item , case, presence container.
16:32:03 <Sai> #info - TomP says Robert explanation is logical and proceed further
16:32:28 <Sai> #info - Robert thinks it is document in commit or release notes.
16:33:05 <Sai> #Action - Robert to document (release notes ? ) wrt to bug 5830
16:33:54 <Sai> #topic - Bug 5484: Fix of Yang statement lexer
16:34:03 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/38190/
16:34:27 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/28666/ the behavior of mandatory enforcement is described in this comment message as "The presence of mandatory leaves which do not have any ancestors other than structural containers are not enforced as mandatory. The reason for this is that the first transaction on such a DataTree would have to introduce all mandatory leaves, as their non-presence would make other transactions fail consistency chec
16:34:42 <Sai> #info - Fixing of Yang statement lexer
16:36:16 <Sai> #info - using regular expressions and quotes we relaxed the yang statement usages
16:36:25 <Sai> #topic - Ubuntu 16.04 LTS
16:37:03 <Sai> #Action - Ryan to reach intergation tesm (or concerned team) regarding Ubuntu 16.04 LTS package manager "default-jdk" installs 1.8.0_03-Ubuntu
16:37:59 <Sai> #info - TOny says if it is the case then we won't be able to compile.
16:38:44 <Sai> #info - Stephen says default package is just a meta package.
16:41:20 <Sai> #info - Stephen asks colin to publish or advertise the changing the dynamics of ubuntu / java wrt opendaylight
16:42:13 <Sai> #Action - colindixon to followup with concerned team on how to react / document  the dynamic changes of ubuntu / java wrt opendaylight
16:42:32 <Sai> #topic - Upgrade Jetty 8.1.14.v20131031 -> 8.1.19.v20160209
16:42:42 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/27529/
16:43:24 <Sai> #topic - RESTCONF Draft upgrade
16:43:47 <Sai> #info - Ryan asks if downstream consumers have to worry about this ?
16:44:34 <Sai> #info - TOny says there are lot of difference in uri, existing use cases should continue to work out even if the new draft is rolled out.
16:44:42 <Sai> #link - https://git.opendaylight.org/gerrit/#/q/project:netconf+%22Bug+5526%22
16:45:04 <Sai> #info - Tony says payload is similar, but may be the rendering of api may change.
16:46:00 <Sai> #topic  - Change opendaylight-karaf-distro-archetype to use karaf-parent
16:46:07 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/38092
16:46:44 <Sai> #info - Patch includes changes to karaf distro to use karaf parent
16:48:06 <colindixon> have we updated the project startup archetype?
16:48:09 <Sai> #info - TomP says we should not be having any issues when people uses karaf parent in future
16:49:17 <Sai> #info - colin suggests the directin may be something like other projects are expected to use karaf parent.
16:50:00 <Sai> #info - TomP says we cannot control it, but probably using archetypes maybe lot easier.
16:50:45 <colindixon> https://wiki.opendaylight.org/view/CrossProject:HouseKeeping_Best_Practices_Group:Project_layout
16:50:51 <Sai> #Action - Ryan to add documentation / release notes which suggests people should use karaf parent for downstream applications etc.,
16:51:23 <Sai> #link - may be here ? https://wiki.opendaylight.org/view/CrossProject:HouseKeeping_Best_Practices_Group:Project_layout
16:53:44 <Sai> #info - colindixon suggests everyone should feel free to change the wiki pages (except main pages (only with certain permissions)) so as to have the most updated info at wiki opendaylight.
16:56:02 <Sai> #info - weather page has more details regarding karaf parent upgraded to use karaf plugin
16:56:04 <Sai> #link - https://wiki.opendaylight.org/view/Weather#Karaf-parent_upgraded_to_use_karaf-plugin
16:57:18 <Sai> #info - colindixon asks reason behid why karaf parent shouldn't be a odl-parent ?
16:57:49 <Sai> #info - Stephen says he is not aware of it.
16:58:37 <Sai> #topic - Karaf 3.0.3 to Karaf 3.0.6
16:58:53 <Sai> #info - Stephen moving from 3.0.3 to 4, 5, 6.
16:59:52 <Sai> #info - Stephen says he is rebuilding controller, Luis is helpful in fixing distribution
17:00:13 <colindixon> I have to drop
17:00:19 <Sai> #info - Stephen says 3.0.6 is released in feb
17:00:21 <colindixon> thanks Sai, Ryan and everyone
17:00:28 <Sai> thanks colindixon
17:01:34 <Sai> #info - 3.0.6 is the latest release of karaf as of now.
17:02:13 <Sai> #info - Stephen tries to make the karaf upgrades for Boron as well.
17:02:23 <Sai> #topic  - participants
17:03:17 <Sai> #info - Sai /Ryan/Alexis/Colin/ jeff/ Martin / Shuva / Stephen / TomP / Tony / Vaclav Demcak
17:03:22 <Sai> #endmeeting