16:01:37 <Sai_> #startmeeting MD-SAL Interest Call
16:01:37 <odl_meetbot> Meeting started Tue May 10 16:01:37 2016 UTC.  The chair is Sai_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:37 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:37 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:02:10 <Sai_> #topic - previous-meeting-minutes
16:02:22 <Sai_> #link - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-05-03-16.00.html
16:02:46 <Sai_> #topic Agenda
16:03:12 <Sai_> #info - Call for any topics to be added to the agenda that people didn't get around to adding.
16:03:23 <Sai_> #info - Review the existing action items
16:04:09 <Sai_> #info - POM Structure - Local project parent vs odlparent
16:04:29 <Sai_> #info - deprecating the existing RESTCONF interfaces (draft 11)
16:04:38 <Sai_> #info - Karaf upgrade from 3.0.3 to 3.0.6
16:04:48 <Sai_> #info - Introduce a Semantic Version concept for yangtools
16:05:10 <Sai_> #info - Features generation with karaf-maven-plugin.
16:05:20 <Sai_> #topic - review action items
16:05:39 <Sai_> #Action - Tony to send reports regarding controller M2 status
16:06:02 <Sai_> #info - Ryan to followup with release team wrt change regarding wrt non-equal objects return and corresponding patch - In progress
16:06:28 <Sai_> #Action - Ryan to followup with release team wrt change regarding wrt non-equal objects return and corresponding patch - IN PROGRESS- Ryan working with An Ho on release note
16:07:41 <Sai_> #Action - TomP will create a bug on how to place / where to use config admin wrt Blueprint / CDS configuration strategies going forward  - In progress - TomP has a patch - Please will link through the patch / bug
16:08:25 <Sai_> #Action - Ryan will take/followup the task Robert to document (release notes ? ) wrt to bug 5830.
16:08:49 <Sai_> #Action - Ryan to reach intergation tesm (or concerned team) regarding Ubuntu 16.04 LTS package manager "default-jdk" installs 1.8.0_03-Ubuntu - IN PROGRESS- email thread started
16:09:46 <Sai_> #Action - colindixon to followup with concerned team on how to react / document the dynamic changes of ubuntu / java wrt opendaylight - IN PROGRESS - checked with Daniel and in progress. (Possible to rely on OPNFV)
16:10:15 <Sai_> #Action - Ryan to add documentation / release notes which suggests people should use karaf parent for downstream applications etc., - IN PROGRESS- working with An Ho on release note
16:10:39 <Sai_> #topic  - POM Structure
16:11:04 <Sai_> #info - Alexis doing lot of good work to centralize the things
16:11:13 <Sai_> #info - Local project parent vs odlparent
16:11:35 <Sai_> #link - Project Layout Guidelines - https://wiki.opendaylight.org/view/CrossProject:HouseKeeping_Best_Practices_Group:Project_layout
16:12:30 <Sai_> #info - Main intention - to provide common look'n'feel for all projects, split build system metadata to ease interactions with infrastructure services as well as with other projects, future-proof your project such that it can be evolved without major shake-ups
16:14:37 <colindixon> I want to bring up the deprecation of the old RESTCONF interface
16:14:51 <colindixon> oh
16:14:52 <colindixon> nm
16:14:53 <colindixon> it's there
16:15:18 <Sai_> #chair colindixon
16:15:18 <odl_meetbot> Current chairs: Sai_ colindixon
16:16:40 <Sai_> #info - Stephen supports adding local dependency
16:17:49 <Sai_> #info - Alexis's centralized version would be very helpful in longterm
16:18:22 <Sai_> #info - Robert says odlparent is not a dumping ground for all dependencies
16:19:51 <Sai_> #info - Robert says currently bunch of dependencies exist in odlparent which no body uses, in that case colindixon suggests a regular check on odlparent
16:21:07 <Sai_> #info - Robert says he worked both ways, he prefers the other way (not centralized) because downstream may be pull dependencies which are not there in odlparent
16:21:51 <Sai_> #info - Ambiguity continues about local parent or not
16:24:20 <Sai_> #Action - Alexis will add more information on Project Layout Guidelines so that users can decide which one to prefer (local or odlparent)
16:24:55 <Sai_> #topic - deprecating the existing RESTCONF interfaces (draft 11)
16:25:14 <Sai_> #info - Robert says main part of deprecation will be in CSIT / tests
16:25:28 <Sai_> #link - https://git.opendaylight.org/gerrit/#/q/project:netconf+status:merged+%22Bug+5526%22+OR+%22Bug+5676%22
16:26:14 <Sai_> #info - Ryan asks the plan - whether to deprecate completely or plan to keep it for a while or ever ?
16:26:44 <Sai_> #info - Robert says we ship one release which supports both - May be Boron
16:27:09 <Sai_> #info - colindixon suggests since there is already draft 13 .. will we go for it after a while ?
16:27:28 <Sai_> #info - Robert says since it is cosmetic we may not go for it
16:27:56 <Sai_> #info - colindixon is afraid of moving / migrating since draft 11 is not final
16:28:08 <Sai_> #info - Robert says that can take years
16:28:59 <Sai_> #info - colindixon suggests moving to draft11 (assuming a newer draft release sooner) is a bad software development
16:29:21 <Sai_> #info - RObert suggests that he will remove change log of draft12,14
16:29:26 <Sai_> #undo
16:29:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x29ccb90>
16:29:30 <Sai_> #info - RObert suggests that he will remove change log of draft12,13
16:29:43 <colindixon> #Info colindixon would really like to avoid making every one move from the current, working version to draft 11, only to make them move to another version if draft 14+ coomes out and makes changes that cause problems
16:30:28 <Sai_> #info - Robert says difference between 13 and 11 are clarifications / editorial changes
16:33:56 <Sai_> #info - colindixon asks Robert to create a weather item about restconf migration
16:35:18 <Sai_> #info - Robert suggests once we finalize the migration discussion informing testing team + release notes should also be part of it.
16:35:54 <Sai_> #Action - Robert to create a weather item about deprecating the existing RESTCONF interfaces for the new implementation (draft-11)
16:36:28 <Sai_> #info - Robert is not aware of how much the downstream projects going to get affected.
16:37:42 <Sai_> #info - colindixon suggests an email - about release plan regarding deprecating existing RESTCONF interfaces
16:39:22 <Sai_> #info - Robert is confident that migration restconf won't be a bigger impact and he has experience of doing lot of migration work.
16:40:11 <Sai_> #info - Robert says NO to keeping existing restconf version for ever.
16:41:14 <Sai_> #info - Robert says no matter how well we communicate someone will come and scream after deprecation .
16:45:01 <Sai_> #info - with migration -> mount point is same but URIs change, Alexis suggests better to make no impact enduser
16:45:19 <Sai_> #info - Robert clarifies there will be impact on end user and no way of skipping it.
16:46:05 <Sai_> #info - TomP asks compelling reason to migration
16:46:20 <Sai_> #info - Robert says interoperability
16:47:04 <Sai_> #info - Robert says a major SP is after it.
16:47:41 <Sai_> #info - TomP suggests giving an ample time for deprecating current rest api
16:48:00 <Sai_> #info - Robert suggests forking
16:49:08 <Sai_> #info - TomP says if it is a separate bundle it should be fine, Robert is not sure about it.
16:51:45 <Sai_> #topic - Karaf upgrade from 3.0.3 to 3.0.6
16:51:51 <Sai_> #link - https://git.opendaylight.org/gerrit/#/c/26323/
16:52:23 <Sai_> #info - Stephen asks for a suitable time to merge - Robert suggests early next week after SR2.
16:53:09 <Sai_> #topic - Features generation with karaf-maven-plugin.
16:54:23 <Sai_> #info - Stephen says karaf-maven-plugin generates feature.xml file , there are couple of bugs where feature doesn't work correctly.
16:54:43 <Sai_> #info - Roert suggests unit testing to make sure features work correctly
16:54:56 <skitt> https://git.opendaylight.org/gerrit/38638
16:55:26 <Sai_> #link - https://git.opendaylight.org/gerrit/#/c/38638/
16:55:31 <Sai_> thanks skitt
16:56:04 <Sai_> #info - Stephen has got a patch for yang tools - https://git.opendaylight.org/gerrit/#/c/38638/
16:56:29 <Sai_> #topic - Introduce a Semantic Version concept for yangtools
16:56:41 <Sai_> #link - https://git.opendaylight.org/gerrit/#/q/project:yangtools+NOT+age:7d+status:open
16:57:14 <Sai_> #info - Introducing of semantic version concept into SchemaContextFactory.
16:57:42 <Sai_> #info - Robert says he don't think this infrastructure will not used for the release.
16:58:02 <Sai_> #info - since this is v2 spec .. it won't have any impact on this release.
16:58:11 <Sai_> #topic - participants
16:59:21 <Sai_> #info - Sai / Ryan / Alexis / Colin Dixon / Deni Hakim / Martin Ciglan / Robert / Shuva Kar / Stephen Kitt / TomP / Tomas Cere / Tony / Vaclav Demcak
16:59:25 <Sai_> #endmeeting