15:59:33 <Sai> #startmeeting MD-SAL Interest Call
15:59:33 <odl_meetbot> Meeting started Tue May 17 15:59:33 2016 UTC.  The chair is Sai. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:59:33 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:33 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:00:19 <Sai> #topic - last-meeting-minutes
16:00:28 <Sai> #info - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-05-10-16.01.html
16:00:35 <Sai> #link - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-05-10-16.01.html
16:01:33 <Sai> #topic Agenda
16:01:46 <Sai> #info 1. Call for any topics to be added to the agenda
16:02:16 <Sai> #info 2. Review the existing action items
16:02:48 <Sai> #info 3. Upgrade Karaf 3.0.3 -> 3.0.6
16:03:00 <Sai> #info 4. Bug 5446: Yangtools UnionStringCodec is not consistent with BinaryStringCodec
16:03:08 <Sai> #info 5. Bug 5788: enum used as a key does not work
16:03:17 <Sai> #info 6. Upgrade commons-net 3.4 -> 3.5
16:03:26 <Sai> #info 7. Upgrade resteasy jaxrs-api 3.0.4 -> 3.0.12
16:03:34 <Sai> #info 8. Bug 4760: YANG leaf named 'class' breaks write with netconf connector
16:03:42 <Sai> #info 9. Bug 5899
16:04:12 <Sai> #topic - Call for any topics to be added to the agenda
16:04:39 <Sai> #info - No added topics
16:04:51 <Sai> #topic - Review the existing action items
16:05:40 <Sai> #Action - Tony to send reports regarding controller M2 status - [Tony has templates, he will send today] - [In progress]
16:06:09 <Sai> #info - Ryan to followup with release team wrt change regarding wrt non-equal objects return and corresponding patch. An extremely helpful - Done - https://git.opendaylight.org/gerrit/#/c/38845/
16:07:55 <Sai> #info - TomP will create a bug on how to place / where to use config admin wrt Blueprint / CDS configuration strategies going forward - In progress - TomP has a patch - Please will link through the patch / bug - TomP says not need for further bug since since it is merged.  - [DONE]
16:08:22 <Sai> #info - Ryan will take/followup the task Robert to document (release notes ? ) wrt to bug 5830. - [DONE] - Patch - https://git.opendaylight.org/gerrit/#/c/38845/
16:09:03 <Sai> #info - Ryan to add documentation / release notes which suggests people should use karaf parent for downstream applications etc.- [DONE] - patch - https://git.opendaylight.org/gerrit/#/c/38845/
16:09:31 <Sai> #Action - Ryan to reach intergation team (or concerned team) regarding Ubuntu 16.04 LTS package manager "default-jdk" installs 1.8.0_03-Ubuntu - [IN PROGRESS]- email thread started
16:14:47 <Sai> #info - TomP says there is no plan to deprecate the configsystem wrt BluePrint in this release. Tony/TomP agrees it would be a bigger deprecation than AD-SAL to MD-SAL move.
16:15:35 <Sai> #Action - Tony/An requests for a weather page wrt BluePrint release / deprecation process.
16:15:42 <Sai> #undo
16:15:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x269edd0>
16:15:48 <Sai> #info - Tony/An requests for a weather page wrt BluePrint release / deprecation process.
16:16:52 <anipbu> Tom, Tony, Alexis: let's sync up after the meeting and identify plans to track and community outreach for the blueprint migration.
16:16:54 <Sai> #Action - TomP/Tony/An  will meet to discuss on BluePrint deprecation / release / dependencies on projects.
16:17:21 <Sai> #undo
16:17:21 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x29d3b90>
16:17:28 <Sai> #Action - TomP/Tony/An/Alexis  will meet to discuss on BluePrint deprecation / release / dependencies on projects.
16:19:07 <Sai> #Action - Alexis will add more information on Project Layout Guidelines so that users can decide which one to prefer (local or odlparent) - [In PROGRESS] - didn't get time to work on it
16:19:56 <Sai> #info - Robert to create a weather item about deprecating the existing RESTCONF interfaces for the new implementation (draft-11) - [DONE] - only integration & test should be affected.
16:20:54 <Sai> #Action - An followsup with Robert by e-mail wrt deprecating the existing RESTCONF interfaces for the new implementation (draft-11). [ compatibility issues / end user issues ]
16:21:04 <Sai> #Action - colindixon to followup with concerned team on how to react / document the dynamic changes of ubuntu / java wrt opendaylight - IN PROGRESS - checked with Daniel and in progress. (Possible to rely on OPNFV)
16:21:23 <Sai> #topic - Upgrade Karaf 3.0.3 -> 3.0.6
16:21:30 <Sai> #info - ongoing work
16:21:39 <Sai> #topic - Bug 5446: Yangtools UnionStringCodec is not consistent with BinaryStringCodec
16:21:50 <Sai> #info - patch - https://git.opendaylight.org/gerrit/#/c/38853/
16:22:08 <Sai> #info - corresponding MD-SAL change: https://git.opendaylight.org/gerrit/#/c/38272/
16:22:21 <Sai> #topic - Bug 5788: enum used as a key does not work
16:22:33 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/38865/ - bug fix done
16:22:44 <Sai> #topic - Upgrade commons-net 3.4 -> 3.5
16:22:56 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/32362/
16:23:06 <Sai> #topic - Upgrade resteasy jaxrs-api 3.0.4 -> 3.0.12
16:23:13 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/32362/
16:24:03 <Sai> #info - raise any concerns on e-mail
16:24:11 <Sai> #topic - Bug 4760: YANG leaf named 'class' breaks write with netconf connector
16:24:37 <Sai> #link - https://git.opendaylight.org/gerrit/#/c/36134/
16:25:30 <Sai> #topic - Bug 5899
16:25:39 <Sai> #link - https://bugs.opendaylight.org/show_bug.cgi?id=5899
16:26:07 <Sai> #info - Cardinality check incorrectly limited to 1 for "must" substatements in "refine" statement
16:26:53 <Sai> #info - Robert has to take a look at it.
16:28:49 <Sai> #info - Robert / Tony agrees on the idea that cardinality should be [ 0-n ]
16:29:45 <Sai> #topic - merged patch of checkstyle in AAA
16:30:09 <Sai> #info - Robert requests Ryan to have a look at the patch.
16:30:39 <Sai> #topic - system test Waiver on release 3
16:30:55 <Sai> #info - An requests for system test waiver and ask if there are any objections
16:31:17 <Sai> #info - Robert / Tony has no objections
16:31:50 <Sai> #topic - participants
16:33:05 <Sai> #info - Sai / Ryan / Alexis / An Ho / Martin / Robert / Shuva / Stephen / TomP / Tomas / Tony / Vaclav
16:33:39 <Sai> #endmeeting