16:01:35 <Sai_> #startmeeting MD-SAL Interest Call
16:01:35 <odl_meetbot> Meeting started Tue Jun  7 16:01:35 2016 UTC.  The chair is Sai_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:35 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:04:40 <Sai_> #topic - last-meeting-minutes
16:04:49 <Sai_> #link - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-05-31-16.00.html
16:04:54 <anipbu> https://lists.opendaylight.org/pipermail/controller-dev/2016-June/012102.html
16:04:54 <Sai_> #topic - Agenda
16:05:15 <Sai_> #topic - review existing items
16:07:09 <anipbu> #link https://lists.opendaylight.org/pipermail/controller-dev/2016-June/012102.html   <--- Anil looking into Controller M2/M3/M4
16:07:48 <Sai_> #Action - An Ho requests Anil to respond email thread  wrt M3 status.
16:08:28 <Sai_> #Action - Anil / Tony to send reports regarding controller M2 status - [Tony has templates, he will send today] - [In progress] An Ho adds information that by thursday (06/02/2016) we need M2,M3,M4 status
16:08:41 <anipbu> https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1100527871
16:10:04 <Sai_> #Action - Ryan to followup with TomP/Tony/An/Alexis to meet and discuss on BluePrint deprecation / release / dependencies on projects. [IN PROGRESS] - AnHo sent an email for which colin responded. AnHo received a reply from OPFLex.
16:10:22 <anipbu> https://wiki.opendaylight.org/view/Weather#Blueprint_support  <--- Weather for blueprint
16:10:26 <Sai_> #link - https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1100527871
16:10:36 <Sai_> #link - https://wiki.opendaylight.org/view/Weather#Blueprint_support  <--- Weather for blueprint
16:12:28 <Sai_> #info - Alexis will add more information on Project Layout Guidelines so that users can decide which one to prefer (local or odlparent) - [In PROGRESS] - didn't get time to work on it DONE: Covered in a TWS; a recording is available link
16:12:37 <Sai_> #link - https://meetings.webex.com/collabs/#/meetings/detail?uuid=I6V3DC117BPBBQVM42KQ8CY05D-9VIB
16:12:54 <Sai_> #Action - Projects AAA,controller,MD-SAL,yangtools,odlparent to reply on M3 status update - [INPROGRESS]. only projects (AAA,odlparent) are done. DONE M3 for md-sal and yangtools now as well. M4 status still needed from AAA, MD-SAL, and possibly others
16:13:07 <Sai_> #Action - (Michael's suggestion) Stephen will send out e-mail and/or wiki page regarding karaf/features with all the gerrit patches along with brief description.
16:13:21 <Sai_> #info - Rashmi Pujar will work on create a new wiki page with all the details about added NETCONF CLI commands [DONE]
16:17:54 <Sai_> #topic - Deprecation of methods
16:17:55 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/39891/
16:19:02 <Sai_> #info - Alexis points out that TomP has deprecated methods using this patch - https://git.opendaylight.org/gerrit/#/c/39891/ . Requests TomP to publicize in future.
16:19:31 <Sai_> #topic - Bug 5830
16:19:34 <Sai_> #link - Bug 5830: Mandatory leaf enforcement is not correct with presence container
16:21:07 <Sai_> #link - https://git.opendaylight.org/gerrit/39313
16:21:19 <Sai_> #topic - Yantools Semver
16:21:26 <Sai_> #info - Bug 4662: Introduce a SemanticVersion concept - SchemaContextFactory Bug 4662: Introduce a SemanticVersion concept - import processing
16:21:34 <Sai_> #link - https://git.opendaylight.org/gerrit/37622
16:21:42 <Sai_> #link - https://git.opendaylight.org/gerrit/36877
16:21:53 <Sai_> #topic - Bug 5946:
16:21:59 <Sai_> #info -Unique statement is not exposed by the YANG parser
16:22:07 <Sai_> #link - https://git.opendaylight.org/gerrit/39481
16:22:16 <Sai_> #topic - Bug 5979
16:22:36 <Sai_> #info - enforce cursors are closed on transaction submit
16:22:43 <Sai_> #link - https://git.opendaylight.org/gerrit/39751
16:22:54 <Sai_> #topic - yang parser in controller
16:23:10 <Sai_> #info - This was done in master only, as it was deprecated in Beryllium
16:23:10 <Sai_> #info - Get rid of old Yang Parser in Controller
16:23:15 <Sai_> #topic - Formatting fixes to startup archetype
16:23:22 <Sai_> #link - https://git.opendaylight.org/gerrit/#/c/39175/2
16:23:30 <Sai_> #info - Format startup archetype much more nicely, and clean up stuff
16:23:40 <Sai_> #info - Merge job failed; I am attempting to remerge this.
16:23:44 <Sai_> #info -  Clean up pom.xml of archetypes projects (not archetypes content)
16:23:50 <Sai_> #link - https://git.opendaylight.org/gerrit/#/c/39482/
16:30:14 <Sai_> #topic  - Enforce Java 8 runtime (in controller karaf opendaylight-karaf-resources)
16:30:22 <Sai_> #ilnk - https://git.opendaylight.org/gerrit/#/c/39063/
16:30:29 <Sai_> #info - Is this a candidate for moving to odlparent?
16:30:39 <Sai_> #topic - Fix of build breakage caused by changes in Yangtools
16:30:45 <Sai_> #info - https://git.opendaylight.org/gerrit/39923
16:30:54 <Sai_> #info - This was also submitted to remove reference to dead yangtools code Replace old yang parser usages in netconf.
16:31:01 <Sai_> #link - https://git.opendaylight.org/gerrit/39609
16:31:13 <Sai_> #topic - BUG 4968
16:31:20 <Sai_> #info - Clear transaction after proxy tx is submitted.
16:31:27 <Sai_> #info - There is a patch pending for stable/beryllium, so the fix will likely be a part of beryllium-sr3 patch
16:31:34 <Sai_> #link - https://git.opendaylight.org/gerrit/#/c/32935/2
16:31:42 <Sai_> #topic - Checkstyle update
16:31:50 <Sai_> #info - rules moved to odlparent Move 3 Checkstyle from controller/checkstyle to odlparent
16:31:57 <Sai_> #link - https://git.opendaylight.org/gerrit/39797
16:32:09 <Sai_> #info - Move Checkstyle module MethodName up in XML.
16:32:16 <Sai_> #link - https://git.opendaylight.org/gerrit/#/c/39403/3
16:40:26 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/38646/3/openflowplugin-api/src/main/yang/openflow-provider-config.yang
16:41:26 <rgoulding> #action Alexis and Ryan to update blueprint guide for migration
16:45:56 <Sai_> ryan - meeting ended right ?
16:46:04 <rgoulding> yes
16:46:09 <Sai_> thanks
16:46:12 <rgoulding> how do i close this out
16:46:13 <Sai_> #endmeeting