15:55:47 <Sai> #startmeeting MD-SAL Interest Call
15:55:47 <odl_meetbot> Meeting started Tue Jul 12 15:55:47 2016 UTC.  The chair is Sai. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:55:47 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:55:47 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
15:56:26 <Sai> #topic - last meeting minutes
15:56:30 <Sai> #link - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-07-05-15.56.html
15:56:36 <Sai> #topic - Agenda
15:57:51 <Sai> #info - 1. Call for any topics
15:59:57 <Sai> #info - 2. Review the existing action items
16:00:24 <Sai> #info - 3.Blocking bugs review query - https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&list_id=46270&order=changeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_based_on=&query_format=advanced&resolution=---
16:01:05 <Sai> #info - 4. Review the new Dashboards -  Core Patches Merged In Last 7 Days &  Core Patches Modified In Last 7 Days
16:01:48 <Sai> #topic - Call for any topics
16:02:13 <Sai> #chair colindixon
16:02:13 <odl_meetbot> Current chairs: Sai colindixon
16:02:29 <colindixon> I'm coming in a second, clustering call is winding down
16:02:39 <Sai> sure
16:06:01 <Sai> #topic - Review the existing action items
16:06:24 <Sai> #info - [DONE] Ryan will followup with Tony regarding M3 status. Tony said it would be done by 06/14/2016
16:06:40 <Sai> #info - [DONE] Ryan to address AAA M5 status
16:07:08 <Sai> #Action - skitt (or somebody else if they have time in the next few weeks) to look at trying to purge some of these (which we thnk are erroneous at this point) - https://wiki.opendaylight.org/view/RelEng/Autorelease/Orbit https://bugs.opendaylight.org/show_bug.cgi?id=5973
16:07:16 <Sai> #info - skitt is on vacation
16:07:29 <Sai> #Action - Ryan to followup author regarding changes in bug 6149
16:07:53 <Sai> #Action - [IN PROGRESS] Ryan to followup wrt bug 6148 and report back if it has cyclic dependencies and solution.
16:08:09 <Sai> #Action - [DONE] Ryan to link corresponding gerrit patch on bug 6010
16:08:13 <Sai> #undo
16:08:13 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x259d3d0>
16:08:20 <Sai> #info - [DONE] Ryan to link corresponding gerrit patch on bug 6010
16:08:36 <Sai> #info - [DONE] Bug 5923 - Ryan to followup with author on how to proceed further.
16:09:28 <Sai> #topic - Blocking bugs review query
16:11:36 <Sai> #link - https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&list_id=46270&order=changeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_based_on=&query_format=advanced&resolution=---
16:11:49 <Sai> #Action - Ryan to send an email wrt remaining / in progress critical bugs wrt offset release
16:11:56 <Sai> #undo
16:11:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x24c9150>
16:12:04 <Sai> #Action - Ryan to send an email wrt remaining / in progress critical bugs of offset release
16:12:37 <Sai> #Action - Bug 5923 - Ryan to followup with author on the status
16:14:38 <Sai> #Action - Bug 6154 - Ryan to followup with author on the status
16:15:02 <Sai> #Action - Bug 6152 - Ryan to followup with author on the status
16:17:08 <Sai> #Action - Bug 6152 - Igor still need more info on circumstances. Igor to followup with Ambika.
16:18:52 <Sai> #Action - Bug 5807 - Ryan to followup with author on the status.
16:20:06 <Sai> #topic - Review the new Dashboards
16:20:18 <Sai> #info - Core Patches Merged In Last 7 Days
16:20:28 <Sai> #link - https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merged
16:23:46 <Sai> #info - no concerns on odl parent / yangtools patches
16:24:38 <Sai> #info - Bug 4784 - Opendaylight copyrights existsted during hydrogen release, but were removed due to concerns.
16:25:19 <Sai> #info - Robert suggests Ryan a different approach which uses xml.
16:31:54 <Sai> #info - An says yang rfc 6121 has been superseded by 6991, due to which ietf-inet-types-upgrade is necessary.
16:32:49 <Sai> #info - An sees some infrastructure issues & approvals but else it is on track.
16:33:34 <Sai> #Action - Ryan to reach out Anil wrt gerrit patch 40820
16:35:07 <Sai> #info - Robert says upgrading ietf model is to avoid consistent transitive dependencies (binding spec v2 should alleviate this problem in future)
16:36:19 <Sai> #info - Robert says the changes are documented in binding spec .
16:37:29 <Sai> #info - An requests to Robert to communicate the tentative plan to avoid going to each individual project for upgrade.
16:40:10 <Sai> #info - entire versioning in yang assume it always go through committee and strictly compatible, which means there is a change in namespace. It doesn't work good with software development. Here open version semantics help.
16:42:04 <Sai> #info - colin requests more transparency on changes
16:43:24 <Sai> #info - colin agrees on goals but more concerned about implications.
16:44:30 <colindixon> #Info it's not so much more transparency, as trying to make sure that we understand the implications of adding a layer of indirection between Java APIs and YANG models which may make it difficult for an ODL app to understand what YANG models it's using, which matters when interacting with the outside world
16:47:29 <Sai> #info - Robert thinks a prototype is necessary (on how different consumers uses code and impacts).
16:52:19 <Sai> #topic - participants
16:53:05 <Sai> #info - Sai / Ryan / An / Brinda / Colin / Igor / Robert / TomP / Vaclav / Venkatrangan / Vratko
16:53:22 <Sai> #endmeeting