16:06:55 <Sai__> #startmeeting MD-SAL Interest Call
16:06:55 <odl_meetbot> Meeting started Tue Jul 19 16:06:55 2016 UTC.  The chair is Sai__. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:06:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:06:55 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:07:04 <Sai__> #topic - last-meeting-minutes
16:07:22 <Sai__> #link - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-07-12-15.55.html
16:07:35 <Sai__> #topic - Action-Items
16:08:18 <Sai__> #Action - skitt (or somebody else if they have time in the next few weeks) to look at trying to purge some of these (which we think are erroneous at this point) - https://wiki.opendaylight.org/view/RelEng/Autorelease/Orbit https://bugs.opendaylight.org/show_bug.cgi?id=5973
16:08:51 <Sai__> #info - [DONE] - Ryan to followup author regarding changes in bug 6149 DONE: Followed up with author; no answer yet. The candidate patch was abandoned.
16:09:07 <Sai__> #info - [DONE] Ryan to send an email wrt remaining / in progress critical bugs of offset release DONE
16:09:19 <Sai__> #Action - [IN PROGRESS] Ryan to followup wrt bug 6148 and report back if it has cyclic dependencies and solution.
16:09:40 <Sai__> #Action - [IN PROGRESS] Bug 5923 - Ryan to followup with author on the status Will be solved with upgrade to karaf 3.0.7; an actual JCE problem in some environments
16:10:03 <Sai__> #info - [DONE] Bug 6154 - Ryan to followup with author on the status DONE: resolved fixed by Jakub Morvay
16:10:18 <Sai__> #Action - [IN PROGRESS] Bug 5923 - Ryan to followup with author on the status Will be solved with upgrade to karaf 3.0.7; an actual JCE problem in some environments
16:10:33 <Sai__> #Action - [IN PROGRESS] Bug 6152 - Ryan to followup with author on the status Added Tom P. as a watcher; he has taken the lead on CSS issues this release.
16:10:45 <Sai__> #Action - [IN PROGRESS] Bug 5099 - Igor still need more info on circumstances. Igor to followup with Ambika. Igor followed up, seems that more info is still needed to reproduce.
16:10:56 <Sai__> #info - [DONE] Bug 5807 - Ryan to followup with author on the status. DONE: No answer from author. I tried to reproduce this locally, and it worked for me. Resolved WorksForMe.
16:11:08 <Sai__> #info - [DONE] - Ryan to reach out Anil wrt gerrit patch 40820 DONE: it was merged.
16:12:33 <Sai__> #topic - Deviation changes in yangtools (Weather Item)
16:13:29 <Sai__> #info - API waiver may be necessary here, since API code freeze is done.
16:14:49 <Sai__> #info - only one project is affected through this
16:16:42 <Sai__> #info - Robert apologizes for breaking the API
16:17:21 <Sai__> #Action - Robert follows up with team wrt API change
16:17:27 <Sai__> #undo
16:17:27 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2464250>
16:18:07 <Sai__> #Action - Robert follows up with team wrt API change [ gerrit id 40592 ]
16:19:02 <Sai__> #topic - clustered-app-config and external default data XML file
16:20:54 <Sai__> #info - TomP asks where should we look for xml files
16:22:38 <Sai__> #info - TomP leans toward configuration/initial folder.
16:26:06 <Sai__> #info - Robert says configuration may not be best name since we use the files for operational too.
16:29:45 <Sai__> #info - Robert & TomP agrees on configuration doesn't mean it is configuration datastore
16:31:46 <rovarga> etc/opendaylight/datastore/initial
16:32:11 <Sai__> #info - consensus is /etc/opendaylight/datastore/initial/config
16:34:14 <rovarga> #info this will allow us to perform migrations between persistence by storing snapshots in etc/opendaylight/snapshot/ ;-)
16:34:22 <rovarga> #undo
16:34:26 <rovarga> #info this will allow us to perform migrations between persistence by storing snapshots in etc/opendaylight/datastore/snapshot/ ;-)
16:35:13 <Sai__> thanks rovarga
16:37:23 <Sai__> #info - same module name & same container name but no different namespaces yields in manually specifying where the files are coming from
16:40:27 <Sai__> #topic - colon is a bad idea but underscore would do, no need for revision.
16:40:40 <Sai__> #undo
16:40:40 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2448e50>
16:40:47 <Sai__> #info - colon is a bad idea but underscore would do, no need for revision.
16:41:04 <Sai__> #topic - Deviation Changes in Yangtools
16:41:21 <Sai__> #info - Robert fixes it live is during the call
16:41:37 <Sai__> #topic - different consistency models in distributed datastore
16:41:43 <Sai__> #info -example:Eventual Consistency or NWR
16:43:45 <Sai__> #info - e-mail thread in Opendaylight TSC project
16:44:25 <Sai__> #info - more pointers on how to read / understand would help
16:45:04 <Sai__> #info - Robert says we have javadocs in md-sal but none other
16:46:17 <Sai__> #topic - Blocking bugs
16:47:53 <Sai__> #info - Bug 6149
16:48:10 <Sai__> #info - Robert says we may not be able to fix it
16:49:53 <Sai__> #info - Bug 6152
16:50:27 <Sai__> #info - Downgraded from blocker to critical due to distributions
16:51:48 <Sai__> #info - Robert says it is coming from datatree, server provided leaf is definitely configurable
16:53:32 <Sai__> #info - Bug 6210
16:54:32 <Sai__> #undo
16:54:32 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2595e10>
16:54:36 <Sai__> #info - Bug 6209
16:55:04 <Sai__> #info - Ryan asks for logs
16:55:23 <Sai__> #info - Bug 5099
16:55:46 <Sai__> #info - Igor says this is not a bug in yangtools
16:56:37 <Sai__> #info - Igor considers to close it as invalid
16:57:06 <Sai__> #info - since the casting a leaf as an xml is not supported.
16:57:22 <Sai__> #info - Bug 5923
16:58:28 <Sai__> #info - Ryan follows up with author
16:59:21 <rovarga> #info https://git.opendaylight.org/gerrit/#/c/42066/ bumps the version to JDK8
16:59:40 <Sai__> #info - Bug 6148
17:00:05 <Sai__> #info - Ryan working with mohammed and it is in progress
17:00:32 <Sai__> #info - Bug 6113
17:01:20 <Sai__> #info - Martin suggests to decrease the importance to major
17:03:32 <Sai__> #topic - participants
17:04:49 <Sai__> #info - Sai / Ryan / An Ho / Brinda / Colin / Igor / Jakub / Lori / Martin / Robert / TomP / Vaclav / Viera
17:04:53 <Sai__> #endmeeting