15:58:07 <Sai_> #startmeeting MD-SAL Interest Call
15:58:07 <odl_meetbot> Meeting started Tue Jul 26 15:58:07 2016 UTC.  The chair is Sai_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:58:07 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:58:07 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
15:58:23 <Sai_> #topic - last-meeting-minutes
15:58:33 <Sai_> #link - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-07-19-16.06.html
15:58:38 <Sai_> #topic - Agenda
16:00:15 <Sai_> #info - 1. Call for any topics
16:00:23 <Sai_> #info - 2. Review Action Items
16:00:55 <Sai_> #info - 3. Review Blocking bugs
16:01:38 <Sai_> #info - 4. Review the new Dashboards - Core Patches Merged & Modified in last 7 days
16:04:38 <Sai_> #topic - Call for any topics
16:05:12 <Sai_> #info - 1. Restconf draft 15
16:05:37 <Sai_> #info - 2. Binding spec v2 review / opinions
16:06:12 <Sai_> #info - 3. netconf / restconf bugzilla is obselete in controller project.
16:07:13 <Sai_> #Action - TomP to followup with helpdesk to remove restconf/netconf bugs from bugzilla
16:07:56 <Sai_> #info - 4. Beryllium SR3 from An
16:08:09 <Sai_> #topic - Review Action items
16:09:17 <Sai_> #info - [DONE] skitt (or somebody else if they have time in the next few weeks) to look at trying to purge some of these (which we think are erroneous at this point) - https://wiki.opendaylight.org/view/RelEng/Autorelease/Orbit https://bugs.opendaylight.org/show_bug.cgi?id=5973
16:11:21 <Sai_> #Action - [IN PROGRESS] Ryan to followup wrt bug 6148 and report back if it has cyclic dependencies and solution.
16:11:31 <Sai_> #chair colindixon
16:11:31 <odl_meetbot> Current chairs: Sai_ colindixon
16:11:39 <Sai_> #info - DONE Bug 5923 - Ryan to followup with author on the status Will be solved with upgrade to karaf 3.0.7; an actual JCE problem in some environments
16:11:56 <Sai_> #Action - [IN PROGRESS] Bug 6152 - Ryan to followup with author on the status Added Tom P. as a watcher; he has taken the lead on CSS issues this release.
16:12:16 <Sai_> #info - [DONE] - Robert follows up with team wrt API change [ gerrit id 40592 ]
16:12:33 <Sai_> #Action - [IN PROGRESS] Bug 5099 - Igor still need more info on circumstances. Igor to followup with Ambika. Igor followed up, seems that more info is still needed to reproduce.
16:12:47 <Sai_> #Topic - Restconf Draft 15
16:12:51 <Sai_> #info - In progress
16:13:13 <colindixon> #info we're currently working on draft 11, but there are supposedly no (or only minor) technical changes between 11 and 15
16:13:33 <Sai_> #info -  plan to support for yang 1.1 (switches xml to any data)
16:13:34 <colindixon> #info Martin Ciglan points out that YANG 1.1 is required to support draft 11/15
16:13:50 <colindixon> #info the plan is to support YANG 1.1 as part of Carbon efforts
16:14:31 <Sai_> #info - colindixon presented this to advisory group and general consensus is to eventually migrate it.
16:17:52 <Sai_> #info - This includes difficult design decisions and there is a need to document the plan.
16:18:28 <Sai_> #topic - Binding Spec v2
16:18:44 <colindixon> #info the key point is that there are at least three layers: RESTCONF draft 11 or draft 15, YANG model 1.1 vs. 1.0, and NETCONF using YANG 1.0 or 1.1
16:19:11 <colindixon> #info as an aside, it's pretty ridiculous that the IETF has tied RESTCONF to a particular version of YANG vs. having it be a transport and not caring, but I guess it's done
16:19:15 <Sai_> #info - Martin sent e-mail to md-sal dev / controller-dev and awaiting feedback
16:19:51 <rgoulding> #link https://lists.opendaylight.org/pipermail/mdsal-dev/2016-July/000398.html
16:20:05 <Sai_> #link - https://lists.opendaylight.org/pipermail/mdsal-dev/2016-July/000398.html
16:20:56 <Sai_> #info - colindixon suggests to present binding v2 spec in TWS call
16:21:06 <colindixon> #action colindixon to work with martin ciglan to get a binding v2 spec TWS call
16:21:41 <Sai_> #topic - Beryllium SR3
16:22:28 <Sai_> #info - An says there are distribution test failures in AAA & Netconf for SR3.
16:23:00 <Sai_> #Action - Ryan / Tomas to look in to distribution test failures wrt Ber SR3
16:23:13 <Sai_> #topic - Weekly Sync IRC Meeting
16:24:19 <Sai_> #info - An says started from M5, 10 AM PST is likely
16:24:32 <Sai_> #info - colindixon suggests 7 AM PST
16:25:31 <Sai_> #Action - An to sent an e-mail regarding scheduled times of weekly sync IRC meeting
16:25:44 <Sai_> #topic - DCL Removal plans
16:26:54 <Sai_> #info - Toaster doesn't have many children and it relatively easy to switch from DCL to DTCL
16:27:15 <Sai_> #info - Stephen says they haven't finished in ovsdb
16:28:22 <Sai_> #info - change in granularity / rework events / react in a different way are hurdles in ovsdb as of now
16:28:42 <colindixon> #info skitt says that the change in granularity of events means that you either don't get any speed benefit or you have to react ina  substantively different way
16:28:59 <Sai_> #info - Since deprecated in Boron it can be removed in Carbon. But Ryan suggests NOT to remove in Carbon
16:31:23 <Sai_> #info - Consensus is NOT to remove in carbon cycle.
16:32:51 <Sai_> #topic - Blocking bugs
16:33:03 <Sai_> #link - https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&list_id=46270&order=changeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_based_on=&query_format=advanced&resolution=---
16:33:48 <Sai_> #info - Bug 6271
16:34:56 <Sai_> #info - Vrakto says there is possibility that it happens only in auto-release builds
16:35:35 <Sai_> #info - Bug 6209
16:36:22 <Sai_> #info - Martin added comments
16:38:07 <Sai_> #Action - Ryan to look in to enhancement bug wrt Bug 6209
16:38:30 <Sai_> #info - Bug 6152
16:41:11 <Sai_> #info - Move it to topoprocessing project
16:41:29 <Sai_> #info - TomP says it is not config system error
16:42:13 <Sai_> #info - Bug 5923
16:43:14 <Sai_> #info - Ryan built with auto release and see sporadic failures.
16:44:34 <Sai_> #info - Ryan plan to move karaf parent to odlparent
16:44:40 <Sai_> #undo
16:44:40 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x25a0fd0>
16:44:44 <Sai_> #info - Ryan plans to move karaf parent to odlparent
16:45:01 * colindixon has to run, but you're in good hands with Sai_
16:47:05 <Sai_> #info - In that case we don't need to bump karaf parent everytime
16:47:31 <Sai_> #info - Bug 6148
16:47:51 <Sai_> #Ryan to followup with Mohammed wrt Bug 6148
16:47:55 <Sai_> #undo
16:47:55 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x25a0510>
16:48:01 <Sai_> #Action - Ryan to followup with Mohammed wrt Bug 6148
16:48:23 <Sai_> #topic - Review the new Dashboards
16:48:35 <Sai_> #info - Core Patches Merged In Last 7 Days
16:48:44 <Sai_> #link - https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merge
16:49:00 <Sai_> #info - Good thing to have bug Id for every gerrit
16:50:32 <Sai_> #info - checkstayle rules / Google Truth / PMD CPD are some of the important merged patches in odlparent
16:52:34 <Sai_> #info - patches include deprecations in yangtools
16:53:05 <Sai_> #info - increasing code coverage in mdsal
16:56:46 <Sai_> #info - place to store the xml files / change in auto-down feature
16:58:36 <Sai_> #Action - Sai to add change in auto-down feature to release notes
17:00:32 <Sai_> #info - Bug fixes for Be / Boron in netconf
17:00:38 <Sai_> #info - document fixes in AA
17:00:42 <Sai_> #undo
17:00:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x257d810>
17:00:44 <Sai_> #info - document fixes in AAA
17:00:49 <Sai_> #topic - participants
17:02:01 <Sai_> #info - Sai / Ryan / An / Colin / Igor / Martin / Stephen / TomP / Tomas / Vaclav / Vratko
17:02:06 <Sai_> #endmeeting