#opendaylight-meeting: MD-SAL interest call

Meeting started by colindixon at 16:04:26 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:04:30)
    1. https://wiki.opendaylight.org/view/Kernel_Projects_Call this is the new wiki page (colindixon, 16:05:48)

  2. existing action items (colindixon, 16:08:45)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=5995 and https://bugs.opendaylight.org/show_bug.cgi?id=5996 were updated by Stephen (colindixon, 16:09:51)
    2. ACTION: colindixon to follow up with anipbu and TomP about how to deal with the fact that if you rapidly change the candidate list, you might end up with an owner that isn't a candidate (colindixon, 16:10:53)
    3. martin says that internal discussions about YANG 1.1 have started, but no upstream regular meeting has started (colindixon, 16:12:24)
    4. ryan says he'd like to help out if at all possible and points out that real end-users are asking for it on the bug ID now (colindixon, 16:13:47)
    5. rovarga shares his current take on what needs to happen between YANG 1.0 and YANG 1.1 (colindixon, 16:19:07)
    6. see the recording for the shared analysis major points that need to be done (colindixon, 16:20:15)
    7. https://tools.ietf.org/rfcdiff?url2=rfc7950&url1=rfc6020 RFCs differences between YANG 1.0 and YANG 1.1 (adetalhouet, 16:21:31)
    8. the overall analysis seems to be that OpenDaylight migth be better served by doing piece-by-piece pulling in what people need (colindixon, 16:23:30)
    9. rovarga notes that there are going to be YANG 1.1 models that can't be expressed in the binding spec v1 (colindixon, 16:26:12)
    10. rovarga says he's trying to make the meeting for YANG 1.1 public, but he says that he needs to talk to Vierra and will get back next week (colindixon, 16:26:45)
    11. rovarga notes that his curent list is really unlikely to be complete (colindixon, 16:27:47)

  3. Boron-SR1 (colindixon, 16:29:23)
    1. the cutoff is sunday 10/23 at 23:59 UTC, the release is planned for 10/27 (colindixon, 16:29:49)
    2. anipbu notes that there are a lot of open patches that still need attention on stable/boron (colindixon, 16:30:01)

  4. moving to mave 3.3.9+ for ODL (colindixon, 16:31:12)
    1. you now need it to build ODL, shoudln't matter much for people (colindixon, 16:31:24)

  5. bug 6771 problem with typdefs nested in augment (colindixon, 16:31:36)
    1. does this need to bey cherry-picked to stable/beryllium (colindixon, 16:31:49)
    2. answer is yes, but it has a merge conflic (colindixon, 16:31:57)
    3. ACTION: rgoulding or anyone else could cherry pick the patch back to stable/berylilum before SR4 (colindixon, 16:32:24)

  6. YANG 1.1 (colindixon, 16:33:26)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=2305 this is the bug (colindixon, 16:33:29)

  7. move sal-remote to sal-rest-connector (colindixon, 16:33:49)
    1. this is just cleanup from netconf splitout from the controller (colindixon, 16:33:58)

  8. restconf draft 15 vs. 16 (colindixon, 16:34:15)
    1. rgoulding asks if we need to support draft 15 because we shipped it in Boron? (colindixon, 16:36:03)
    2. colindixon says his take is that in this case common sense about replacing experimental things that weren't advertised with other experimental things that weren't advertised being legal (colindixon, 16:37:16)
    3. adetalhouet asks if there is a wiki about how to use the newer RESTCONF draft (colindixon, 16:37:53)
    4. https://lists.opendaylight.org/pipermail/netconf-dev/2016-October/000649.html (rgoulding, 16:38:31)
    5. martin ciglan says he's willing to help get that written up and also plans to send out an analysis of draft 11 => 15 => 16 => 17 (colindixon, 16:38:45)
    6. rgoulding asks if it makes sense to produce lots of documentation and make it seem official before we've stabiliized things (colindixon, 16:39:16)
    7. colindixon notes that the wiki isn't seachable, so there's relatively little risk to generating docs there, also it's a bad sign if we can't even generate docs for ourselves, maybe adetalhouet and martin ciglan could get together and at least get little things (colindixon, 16:42:07)

  9. bringing up specific patches on this call (colindixon, 16:45:10)
    1. michael vorburger asks when it's reasonable to bring up individual patches here, colindixon says his take is yes after a while, and a while is probably something like a week (colindixon, 16:45:13)

  10. controller PTL and future (colindixon, 16:45:20)
    1. tomP says that tony plans to step down as PTL of controller and he plans to nominate himself as PTL when that happens (colindixon, 16:45:27)
    2. TomP has already sent out the declaring intent to participate for the controller (colindixon, 16:45:34)
    3. https://lists.opendaylight.org/pipermail/release/2016-October/008404.html controller M0 status (thanks rgoulding) (colindixon, 16:45:49)
    4. TomP asks about what we need to do to deprecate and and clean up the controller so that it's not full of random abandoned code (colindixon, 16:46:36)
    5. adetalhouet mentions that he's trying to move the yangtools APIs out of mdsal (colindixon, 16:48:01)
    6. it sounds like (listening to rovarga and TomP) there's some more planning needed to try to get rid of the MD-SAL implementations and APis in controller (colindixon, 16:51:06)
    7. rovarga says that he'd rather not move those to the MD-SAL project intead of just slowly deprecating and eventually remove them from controller (colindixon, 16:52:15)
    8. adetalhouet, TomP, and rovarga talk about how that we would try to get rid of the stuff in controller as much as we can (colindixon, 16:54:55)
    9. rgoulding asks how the logistics might change depending on who was actually participating in carbon and when we'd get to know who was paticipating (colindixon, 16:57:17)
    10. colindixon says everyone should be in or out by 11/3, but in practice a week or two after that, so by thanksgiving, we should have a really good idea (colindixon, 16:57:51)


Meeting ended at 16:58:36 UTC (full logs).

Action items

  1. colindixon to follow up with anipbu and TomP about how to deal with the fact that if you rapidly change the candidate list, you might end up with an owner that isn't a candidate
  2. rgoulding or anyone else could cherry pick the patch back to stable/berylilum before SR4


Action items, by person

  1. colindixon
    1. colindixon to follow up with anipbu and TomP about how to deal with the fact that if you rapidly change the candidate list, you might end up with an owner that isn't a candidate
  2. rgoulding
    1. rgoulding or anyone else could cherry pick the patch back to stable/berylilum before SR4


People present (lines said)

  1. colindixon (62)
  2. odl_meetbot (9)
  3. rgoulding (3)
  4. adetalhouet (2)


Generated by MeetBot 0.1.4.