18:00:31 <colindixon> #startmeeting tsc
18:00:31 <odl_meetbot> Meeting started Thu Jan  7 18:00:31 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:31 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:31 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:37 <colindixon> #topic agenda bashing and roll call
18:00:46 <mohnish_> #info mohnish anumala
18:00:53 <colindixon> #chair phrobb phrobb_ anipbu gzhao
18:00:53 <odl_meetbot> Current chairs: anipbu colindixon gzhao phrobb phrobb_
18:00:56 <colindixon> tsc members please #info in
18:00:58 <colindixon> #info colindixon
18:01:11 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=40002 agenda for today
18:01:15 <edwarnicke> #info edwarnicke
18:01:16 <dfarrell07> #info Daniel Farrell
18:01:52 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-12-17-18.00.html last week's minutes for action items
18:02:20 <colindixon> #action phrobb to poll the PTLs about Hackfest attendance
18:03:12 <LuisGomez> #info LuisGomez
18:03:47 <ChrisPriceAB> #info Chris Price
18:03:50 <jmedved> #info jmedved
18:05:55 <colindixon> #action phrobb and/or gzhao to work with ChrisPriceAB to continue to figure out when/where/who would run a Europe boot camp
18:06:04 <ChrisPriceAB> ongoing
18:06:19 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
18:06:33 <colindixon> #action colindixon and tbachman to send a mail with some ideas about running tutorials with new known knows
18:07:08 <colindixon> #Info jmedved says to loop in some folks from Cisco in a Europe bootcamp who have been organizing other bootcamps as well as looping in some people in bratislava if it's in europe
18:07:29 <colindixon> #action rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
18:07:45 <colindixon> #action phrobb to make sure ONS is listed under ODL's events page
18:07:56 <colindixon> #action colindixon to try to bump boron planning back up the prioirty list
18:08:20 <colindixon> #topic updates
18:08:31 <colindixon> #undo
18:08:31 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x21bba10>
18:08:33 <colindixon> #topic events
18:08:42 <colindixon> #link https://www.opendaylight.org/global-events
18:08:48 <colindixon> #info ONS CFP closes on 1/15
18:08:50 * tbachman pops in, sees that he has an outstanding action item
18:08:57 <tbachman> should that email be sent to  discuss@lists.opendaylight.org?
18:08:58 <colindixon> #info OpenStack CFP closes on 2/1
18:09:48 <colindixon> #info community day and cisco bootcamp on in shenzhen on 1/18-1/22
18:10:32 <colindixon> #info ODL hackfest 2/29 to 3/1 registraction coming soon
18:11:12 <colindixon> #topic Beryllium
18:11:43 <colindixon> #undo
18:11:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x21bbf90>
18:11:58 <phrobb_> #link http://opennetsummit.org/program/  link to ONS CFP
18:12:06 <colindixon> #action alagalah to coordinate with phrobb_ and colindixon about i/ovisor stuff
18:12:22 <colindixon> phrobb_: let me know when you're done
18:12:24 <phrobb_> #link https://www.openstack.org/summit-login/login?BackURL=%2Fsummit%2Faustin-2016%2Fcall-for-speakers%2F link to OpenStack CFP
18:12:33 <phrobb_> done
18:12:55 <phrobb_> colindixon done
18:13:07 <colindixon> #topic Beryllium
18:13:44 <zxiiro> #link https://lists.opendaylight.org/pipermail/release/2016-January/005132.html Removing old SNAPSHOTS
18:13:58 <colindixon> #info still missing M5 status from SNMP4SDN, l2switch, and one other project, not clear if yangpush is offset 1 or 2
18:14:44 <colindixon> #info weather-wise, bug-4355 to enable mandatory:true support in YANG was merged today, but the merge job failed, so we may have to sort some aftermath of that out as we go through
18:15:15 <colindixon> #und
18:15:16 <colindixon> #undo
18:15:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1fe7890>
18:15:18 <colindixon> #undo
18:15:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1fe7590>
18:15:19 <colindixon> #undo
18:15:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1fe7690>
18:15:24 <colindixon> #info still missing M5 status from SNMP4SDN, l2switch, and one other project, not clear if yangpush is offset 1 or 2
18:15:27 <colindixon> #info weather-wise, bug-4355 to enable mandatory:true support in YANG was merged today, but the merge job failed, so we may have to sort some aftermath of that out as we go through
18:15:50 <zxiiro> #link https://lists.opendaylight.org/pipermail/release/2016-January/005118.html Building autorelease with JDK7 or JDK8
18:16:09 <alagalah> colindixon, you only asked for TSC members to chime in, but if I may as a non-TSC member, Id like us to cut the rope and do 8
18:16:36 <alagalah> colindixon, no apologies necessary....
18:16:52 <colindixon> #Info alagalah and rovarga says to jump to JDK8 if at all possible
18:17:54 <jamoluhrsen> colindixon, we have work in progress to run CSIT on both 8 and 7
18:19:23 <colindixon> #info colindixon asks if it would work to build with Java 8 and the test the RCs/release with both Java 7 and Java 8 so that we build with Java 8, but support Java 7 and Java 8 JREs in Beryllium
18:19:53 <colindixon> #info anipbu, jamoluhrsen, LuisGomez, and rovarga say that seems to make sense, jamoluhrsen says that work is happening already
18:21:20 <colindixon> #agreed we will build Beryllium artifacts with Java 8 and test at least the RCs on both Java 7 and Java 8 JREs
18:21:50 <colindixon> #info alagalah asks if we can move odlparent to using Java 8 outside of autorelease
18:22:48 <colindixon> #topic system integration and testing
18:23:06 <colindixon> #info over the first of the year, some libarary failed to import so all jobs were failing, that's now fixed
18:23:36 <colindixon> #info a patch was merge that changed status codes that has resulted in lots test failing, people should look at that and fix them
18:24:33 <colindixon> #topic infastructure
18:25:04 <colindixon> #Info rovarga says that we are having issues with gerrit being slow becuase too many jenkins jobs cloning from it
18:25:24 <colindixon> #info tykeal is trying to upgrade our RPCs interface, that hasn't happened yet, but it's coming
18:25:42 <colindixon> #Info tykeal says they're building out a new, larger VM for gerrit to alleiviate the slowdown
18:26:08 <colindixon> #info tykeal says zxiiro put in a priortization pluging that seems to have helped some
18:27:34 <colindixon> #info tykeal says they've also put the merges and verifies in the same place so that they are going faster, but that's putting strain on CSIT resources which they're in discussions with integration folks to try to fix that
18:27:49 <colindixon> #info tykeal says the larger VM for gerrit should be done by end of next week, rovarga says that would help a lot
18:28:53 <tykeal> managed your 5 minutes colindixon ;)
18:29:08 <mohnish_> colin: ok
18:29:34 <colindixon> thanks all
18:30:31 <colindixon> #topic TSC elections
18:30:53 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Election_Proposal wiki page descripting things
18:31:24 <colindixon> #info we seem to have an agreement on having company caps, by turning them instead into caps on reprepesented groups representation, not just companies
18:32:17 <colindixon> #info basically by modeling copanies as represented groups with no guanteed seats, but just a cap on how many seats they could have, but this could also be applied to all different RGs
18:33:05 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-January/004531.html please look into this thread which is now shoter to catch up and provide feedback
18:33:48 <colindixon> #info dfarrell07 asks anyone and everyone to please go look at the thread and wiki to help push this to a conclusion
18:34:23 <colindixon> #info dfarrell07 notes that while the wiki is long, it's mostly alterantives that can be skimmed, e.g., the last section
18:36:22 <colindixon> #topic integration/test graduation review
18:36:36 <colindixon> #link https://wiki.opendaylight.org/view/Integration/Test/Mature_Graduation_Review
18:36:46 <tykeal> apropos to test the process with integration/test ;)
18:36:56 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-December/000382.html request for review on December 5th, 2015
18:40:38 <colindixon> #info for reference, jamoluhrsen says that this project split out of the broader integration project, which has was created for Hydrogen, and has been very active ever since then
18:41:29 <colindixon> #link https://jenkins.opendaylight.org/releng/view/CSIT-Jobs/ list of CIST running jobs showing this project does build and run
18:41:57 <colindixon> #link https://meetings.webex.com/collabs/url/fI_jTMbTyPKuDAREuBLYn-9YKno2Gg83cay8Ub2u0vu00000 WebEx recording showing demos of robot framework and system test and how to use it/write them
18:42:25 <colindixon> #info dfarrell07 and edwarnicke add that this is a great example of a project that doesn't participate in the SR and how they can be relevant and mature
18:43:39 <colindixon> #info as far as history of mature releases, the data looks great for H, He, and Li, but it looks like they won't release in Be since they're not actually released
18:45:33 <colindixon> #info edwarnicke and colindixon note that even though integration/test won't be "released" it will clearly be participating in the release in the sense that without it we wouldn't have a simultaneous release
18:45:54 <colindixon> #action colindixon to try to add some way to capture support projects like this which aren't part of the SR, but clearly do have some analog of a history of mature releases
18:46:51 <colindixon> #startvote shall the TSC graduate the integration/test project from incubation to mature? -1, 0, +1
18:46:51 <odl_meetbot> Begin voting on: shall the TSC graduate the integration/test project from incubation to mature? Valid vote options are -1, 0, +1.
18:46:51 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:46:57 <dfarrell07> #vote +1
18:46:57 <edwarnicke> #vote +1
18:46:58 <LuisGomez> #vote +1
18:47:00 <jmedved> #vote +1
18:47:01 <colindixon> #vote +1
18:47:02 <Uri_> #vote +1
18:47:02 <mohnish_> #vote +1
18:47:15 <dfarrell07> w00t! first mature project
18:47:17 <colindixon> #endvote
18:47:17 <odl_meetbot> Voted on "shall the TSC graduate the integration/test project from incubation to mature?" Results are
18:47:17 <odl_meetbot> +1 (7): jmedved, LuisGomez, dfarrell07, edwarnicke, Uri_, colindixon, mohnish_
18:47:24 <tykeal> congrats, now go update your wiki ;)
18:48:04 <edwarnicke> #info integration test should fill in the various dates for actual approval on their proposal page :)
18:48:05 <tykeal> made with sunshine?
18:48:05 <colindixon> #agreed contgratuations to integration/test project for being the first mature project in OpenDaylight
18:48:07 <edwarnicke> Contrats :)
18:48:16 <edwarnicke> tykeal: rainbows, unicorns, and bacon ;)
18:48:20 <tykeal> hehe
18:48:27 <dfarrell07> #action jamoluhrsen to go update the wikis with relevant "now approved" pointers/info
18:48:28 <jamoluhrsen> tykeal, wiki updated
18:48:33 <Prem> Congrats Integration/Test !
18:48:45 <anipbu> Congrats Int/Test!
18:49:12 <colindixon> #topic boron planning
18:49:50 <colindixon> #info edwarnicke says that he's concerned about repeating our bad pattern of planning the release in the gap after the release
18:50:21 <colindixon> #info colindixon and dfarrell07 agree
18:50:52 <colindixon> #info edwarnicke says he's increasingly happy with the idea of "fast phased" releases, e.g., releasing faster with simpler SRs
18:51:09 <colindixon> #info rovarga says that anything less than 3 months will basically be all overhead in his analysis
18:52:49 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-October/003849.html this is the thread that petered out before
18:53:06 <abhijitkumbhare> at the last hackfest - we had discussed about previous release of kernel projects being consumed by current release of protocol projects ; and then same relationship for the apps & protocol projects
18:53:21 <colindixon> #info edwarnicke asks for rovarga to provide his analysis if he can so that they can try to address some issues
18:53:52 <abhijitkumbhare> it was mathieu, edwarnicke (I think), colindixon, dlenrow, phrobb, myself, etc.
18:54:07 <colindixon> #info rovarga says his core issue is unresponsive downstream projects, edwarnicke says that he doesn't quite get it
18:54:24 <colindixon> abhijitkumbhare: yes, I think this is a similar idea
18:55:32 <colindixon> #info abhijitkumbhare notes that at the last hackfest, there was a discussion about doing something like this with kernel releasing first, then services start development on that and release, and the apps start their development on top of that and release
18:55:44 <colindixon> #info more details are on the thread
18:59:29 <colindixon> #action colindixon and phrobb_ to schedule a TWS on possible alternatives for the schedule for Boron with rovarga and edwarnicke
19:00:09 <colindixon> #topic interns
19:00:37 <colindixon> #link https://lists.opendaylight.org/pipermail/discuss/2016-January/006083.html
19:00:40 <dfarrell07> #link https://wiki.opendaylight.org/view/Interns Intern proposal wiki
19:00:53 <colindixon> #info DUE TODAY
19:01:56 <colindixon> #topic cookies
19:02:03 <colindixon> #endmeeting