18:00:08 <colindixon> #startmeeting tsc
18:00:08 <odl_meetbot> Meeting started Thu Jan 14 18:00:08 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:08 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:08 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:13 <colindixon> #topic agenda bashing and roll call
18:00:22 <colindixon> #chair anipbu phrobb phrobb_
18:00:22 <odl_meetbot> Current chairs: anipbu colindixon phrobb phrobb_
18:00:26 <colindixon> #info colindixon
18:00:59 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=40151#Agenda today's agenda
18:01:03 <colindixon> TSC members please #info in
18:01:16 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-01-07-18.00.html last week's meeting minutes for action items
18:02:46 <dfarrell07> #info Daniel Farrell
18:02:54 <snackewm> #info Eric Multanen
18:02:58 <mohnish_> #info mohnish anumala
18:03:29 <jmedved> #info jmedved
18:03:47 <LuisGomez> #info LuisGomez
18:03:47 <edwarnicke> #info edwarnicke
18:04:08 <colindixon> #action colindixon to keep boron planning on our minds
18:04:24 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2016-January/004552.html Cross-project breakage thread
18:04:43 <shague> #info shague
18:05:01 <flaviof> #info flaviof
18:05:08 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2016-January/004554.html best practices for preventing/handling	cross-project breakages
18:05:49 <colindixon> #action colindixon to add the best practices for preventing/handling cross-project breakages to the next TWS meeting as at least a brief topic
18:05:57 <dfarrell07> flaviof, shague it's just TSC voters that need to #info in, FYI (unless you guys have a chair somehow I'm not aware of?)
18:06:27 <flaviof> dfarrell07 nope, I'm used to #info on meeting I participate... sorry
18:06:33 <colindixon> #chair dfarrell07
18:06:33 <odl_meetbot> Current chairs: anipbu colindixon dfarrell07 phrobb phrobb_
18:06:39 <dfarrell07> #undo
18:06:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1feced0>
18:06:40 <dfarrell07> #undo
18:06:40 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1fecc10>
18:06:50 <dfarrell07> #undo
18:06:50 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1fd0e90>
18:06:51 <dfarrell07> #undo
18:06:51 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1feca90>
18:06:57 <colindixon> #action jamoluhrsen to go update the wikis with relevant "now approved" pointers/info
18:07:06 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2016-January/004554.html best practices for preventing/handling	cross-project breakages
18:07:12 <dfarrell07> #action colindixon to add the best practices for preventing/handling cross-project breakages to the next TWS meeting as at least a brief topic
18:07:24 <colindixon> #action phrobb to make sure ONS is listed under ODL's events page
18:07:32 * dfarrell07 hopes that was right, idk
18:07:39 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
18:08:13 <dfarrell07> #info ONS CFP closes 1/15 tomorrow, but keep in mind that UTC can be tricky so maybe shoot for today
18:08:53 <colindixon> #action phrobb and/or gzhao to work with ChrisPriceAB to continue to figure out when/where/who would run a Europe boot camp
18:09:05 <colindixon> dfarrell07: I more meant as an event you might wnat to attend, but noted
18:09:55 <colindixon> #topic TSC elections
18:10:22 <colindixon> #info dfarrell07 says he was hoping to get a broader communit discussion during the last week, but it didn't happen
18:10:49 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-January/004545.html the end of that thread with some ideas of how to enage more people
18:12:18 <abhijitkumbhare> #info abhijitkumbhare for ChrisPriceAB
18:12:58 <abhijitkumbhare> ChrisPriceAB just sent me a message (hence did the info)
18:13:19 <colindixon> #action colindixon and dfarrell07 to make sure there is some time (likely TWS) to try to provide more understandability
18:13:59 <dfarrell07> #info suggestion for easier feedback - more examples
18:14:32 <colindixon> #info colindixon notes some people have privately communicated to him that they felt like they felt like they would be more likely to embarass themselves than provide valuable feedback, which probably needs some explicit attention
18:15:29 <colindixon> #info dfarrell07 has been working on an ODL election machine in python, but it might help to geneate examples
18:16:38 <colindixon> #info abhijitkumbhare says if we need tooling, things might be more complicated than is a good idea
18:18:54 <colindixon> #startvote will you be here for the TWS on Monday if we have it on MLK day? yes, no
18:18:54 <odl_meetbot> Begin voting on: will you be here for the TWS on Monday if we have it on MLK day? Valid vote options are yes, no.
18:18:54 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:19:04 <dfarrell07> #vote yes
18:19:06 <colindixon> #vote yes
18:19:13 <jamoluhrsen> #vote no
18:19:17 <abhijitkumbhare> #vote yes
18:19:18 <jmedved> #vote no
18:19:19 <phrobb_> #vote no
18:19:19 <snackewm> #vote no
18:19:30 <gzhao> #vote no
18:19:31 <colindixon> #vote yes
18:20:01 <mohnish_> #vote no
18:20:01 <colindixon> #endvote
18:20:01 <odl_meetbot> Voted on "will you be here for the TWS on Monday if we have it on MLK day?" Results are
18:20:01 <odl_meetbot> yes (3): colindixon, dfarrell07, abhijitkumbhare
18:20:01 <odl_meetbot> no (6): gzhao, jmedved, snackewm, jamoluhrsen, phrobb_, mohnish_
18:20:16 <colindixon> #Info it sounds like it's not worth doing, actually 7 nos and only 3 yeses
18:20:40 <colindixon> #topic events
18:20:44 <dfarrell07> #action colindixon phrobb_ to get TWS topics squared away
18:20:51 <colindixon> #link https://www.opendaylight.org/global-events
18:21:01 <colindixon> #info the CFP for ONS is closing TOMORROW
18:21:12 <colindixon> #info OpenStack's CFP is open until the end of the month
18:22:04 <colindixon> #Info phrobb_ is at a modeling workshop that the ETSi people put toegether with ~12 SDOs and a handfull of open source projects
18:22:52 <colindixon> #Info phrobb_ says that there is only one ONS application place, not a separate track for ODL
18:23:06 <colindixon> #topic pre-boron
18:23:27 <colindixon> #info branch cutting and version bumping will be done today after the meeting
18:24:00 <colindixon> #info this will involve removing all the pre-boron jobs and then creating boron jobs to cover master after branch cutting
18:24:14 <colindixon> #info autorelease-validate jobs will have to be disabled during branch cutting
18:24:20 <tykeal> lol
18:25:00 <colindixon> #info zxiiro says he's planning to keep the pre-boron branch around for a month to make sure he cherry-picks everything correctly, then he'll likely delete the branches
18:25:17 <phrobb_> @ jmedved  I muted you as you had background/hold music going :-)
18:25:53 <colindixon> #info zxiiro says his current plan is to just cherry-pick, but not merge patches
18:26:00 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/status:merged+branch:pre-boron list of all merged patches on pre-boron
18:26:57 <colindixon> #undo
18:26:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1f6cc10>
18:27:14 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/status:merged+branch:pre-boron+NOT+owner:%22Thanh+Ha+%253Cthanh.ha%2540linuxfoundation.org%253E%22,25 list of all patches merged to pre-boron that aren't from zxiiro (about 40)
18:27:33 <colindixon> #topic Beryllium
18:27:39 <colindixon> #info offset 2 M5 is due today
18:28:12 <colindixon> #info anipbu notes that we had an issue with LACP breaking autorelease, it's been reverted and fixed so things are again moving
18:28:28 <colindixon> #info the build for RC0 will start on 1/21 (about a week from now)
18:28:44 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the weather
18:29:18 <colindixon> #info there is a meeting at 9a on Monday to attend a meeting to figure out about conflicting OpenFlow plugin designs conflict (-li vs. normal)
18:29:39 <jamoluhrsen> +1 for projects to give opinion on two different ofp impls
18:29:59 <colindixon> #Info anipbu says we need to address it in Beryllium in some way
18:30:15 <LuisGomez> most of pre-boron patches have corresponding master cherry-pick, I wonder people understood the purpose of this branch…
18:31:31 <colindixon> #info rovarga asks if this will be a possible Beyllium slippage, anipbu and colindixon say the really hope and believe not
18:32:51 <colindixon> #info rovarga says he thinks this does pose some risks to the release
18:34:04 <colindixon> #info colindixon, abhijitkumbhare, LuisGomez, and others say the worst case is to carefully document things, we can still hope for a better way
18:36:14 * ebrjohn nice description Ed, "Explody boom" :)
18:37:07 <colindixon> #info colindixon says the bare minimum of what he'd want to see us do is provide a validator that will let you know if you've managed to install conflicting things
18:37:47 <colindixon> #inof the monday meeting about this is just the normal OF plugin meeting, so find details on their homepage
18:37:51 <colindixon> #info the monday meeting about this is just the normal OF plugin meeting, so find details on their homepage
18:38:28 <colindixon> #info every wednesday at 7:30a pacific time we have a Beyrllium sync on IRC in #opendaylight-meeting (this room), please attend
18:38:30 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/Weekly_Sync_Meeting
18:38:51 <colindixon> #topic system integration and test
18:39:12 <colindixon> #info last week we checked about REST responses changing, but that's been reverted so ignore that
18:39:42 <colindixon> #info earlier this week, had issues with verify jobs, but they're working now
18:39:48 <colindixon> #topic infrastructure
18:39:57 <colindixon> #Info yesterday jenkins was basically dead
18:40:22 <colindixon> #info zxiiro and tykeal made jenkins and gerrit bigger and brought them back up as an emergency, and things seem happy since then
18:40:39 <colindixon> #info rovarga says both seem happy as a clam now
18:41:01 <colindixon> #info went from 30 GB of RAM to 60 GB to do this, still have 24 GB free for now
18:41:17 <colindixon> #info tykeal says we are at a point where we have one more larger system and after that we're out-of-luck
18:41:47 <colindixon> #info tykeal says we desperately need zuul and nodepool to be able to scale
18:43:38 <colindixon> #info dfarrell07 says that the integration call this morning also remembered the idea about maybe moving to JIRA, just to remind people that this exists
18:45:52 <colindixon> #Info rovarga also chimes in around JIRA, colindixon suggests maling list threads, meetings and eventually documentation on how to move
18:45:57 <colindixon> #topic OVSDB Graduation review
18:46:07 <colindixon> #link https://wiki.opendaylight.org/view/OVSDB_Integration:OVSDB_NetVirt_Mature_Graduation_Proposal the proposal
18:46:46 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-December/000383.html requested a review with e-mail 12/15
18:47:35 * dfarrell07 can't see screen because webex hates linux :(
18:47:44 <colindixon> dfarrell07: it's just the page
18:47:58 <colindixon> #info ovsdb has been around since Hydrogen has meet all the milestones
18:48:24 <colindixon> #info it's been a pretty active project since the beginning, there is a very active community in part because of the interest in openstack netvirt
18:49:25 <colindixon> #Info developers and users from diverse community across companies
18:50:22 <colindixon> #info tutorials can be found on the graudation review including links to youtube and slides showing how to get it up and working
18:51:04 <colindixon> #info LuisGomez says he thinks it should pass, edwarnicke says the document looks very thorough, dfarrell07 says similar things
18:51:32 <colindixon> #info dfarrell07 brings up the issue of the plans to split the project in two in Boron
18:53:08 <colindixon> #info edwarnicke notes that both sides of the project have "walked the walk" in terms of maturity and thus it would split into two mature projects
18:53:55 <colindixon> #Info colindixon agrees and notes that this has come up repeatedly and we've always said history should count across splits if it's really the same code
18:53:57 <phrobb_> WebEx callin user 5 is causing an echo on the line.  You have been muted.  IRC me if you want to come off mute
18:54:11 <dfarrell07> phrobb_: thanks, that kept throwing me off lol
18:54:19 <colindixon> #startvote shall the TSC graduate the OVSDB project to being a mature project? -1, 0, +1
18:54:19 <odl_meetbot> Begin voting on: shall the TSC graduate the OVSDB project to being a mature project? Valid vote options are -1, 0, +1.
18:54:19 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:54:23 <abhijitkumbhare> #vote +1
18:54:24 <dfarrell07> #vote +1
18:54:26 <colindixon> #vote +1
18:54:26 <edwarnicke> #vote +1
18:54:27 <mohnish_> #vote +1
18:54:27 <jmedved> #vote +1
18:54:31 <snackewm> #vote +1
18:54:32 <LuisGomez> #vote +1
18:54:47 <colindixon> #endvote
18:54:47 <odl_meetbot> Voted on "shall the TSC graduate the OVSDB project to being a mature project?" Results are
18:54:47 <odl_meetbot> +1 (8): jmedved, LuisGomez, edwarnicke, dfarrell07, colindixon, mohnish_, snackewm, abhijitkumbhare
18:54:50 <edwarnicke> Congratulations to the ovsdb project! :)
18:54:54 <dfarrell07> Congrats OVSDB! :) :) :)
18:54:58 <colindixon> #agreed the OVSDB project is now the second mature project in OpenDaylight
18:54:59 <tykeal> congrats ovsdb. now go update your wiki ;)
18:54:59 <alagalah> colindixon, ok
18:55:03 <ebrjohn> Congrats OVSDB!
18:55:06 <phrobb_> Congrats OVSDB Integration Project!!
18:55:09 * edwarnicke misses you guys... need to come back to play soon :)
18:55:09 <mohnish_> Congrats to ovsdb project
18:55:10 <LuisGomez> yes congrats
18:55:17 <colindixon> #action shague to update the proposal page and your project facts page appropriately
18:55:25 <abhijitkumbhare> Congrats OVSDB/NetVirt
18:55:32 <alagalah> shague, flaviof Congrats !!!
18:56:14 <colindixon> #topic major topics
18:56:25 <shague> Thanks guys! Flavio spoke well when he said we have had a lot of help and appreciate it.
18:56:28 <flaviof> alagalah thanks! kudos are to y'all
18:56:34 <anipbu> Congrats OVSDB/NetVirt
18:56:36 <colindixon> #info we have three major topics of discussion
18:56:46 <colindixon> #info 1. Boron planning which was covered on this week's TWS at least partially
18:57:08 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tws/opendaylight-meeting-tws.2016-01-11-18.27.html something is here
18:57:20 <colindixon> #info 2. TSC elections, see above
18:57:43 <colindixon> #info 3. openflow plugin designs and how they'll play together in Beryllium, again see above
18:57:57 <colindixon> #topic cookies
18:58:01 <colindixon> #endmeeting