18:00:06 <colindixon> #startmeeting tsc
18:00:06 <odl_meetbot> Meeting started Thu Feb 18 18:00:06 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:06 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:06 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:11 <colindixon> #topic agenda bashing and roll call
18:00:30 <colindixon> TSC members please #info in
18:00:34 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=41862#Agenda today's agenda
18:00:44 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-02-11-18.02.html last week's meeting minutes
18:00:49 <colindixon> #info colindixon
18:00:55 <dfarrell07> #info Daniel Farrell
18:01:48 <abhijitkumbhare> #info abhijitkumbhare for ChrisPriceAB
18:01:52 <colindixon> #chair dfarrell07 anipbu phrobb
18:01:52 <odl_meetbot> Current chairs: anipbu colindixon dfarrell07 phrobb
18:01:58 <mohnish_> #info mohnish anumala
18:02:05 <jmedved> #info jmedved
18:03:15 <edwarnicke> #info edwarnicke
18:03:27 <colindixon> #action colindixon to keep boron planning on our minds
18:03:28 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
18:03:29 <colindixon> #action colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future
18:03:30 <colindixon> #action rovarga to follow up with a counter-proposal with the new workflow ;-)
18:03:31 <colindixon> #action colindixon and phrobb to draft up a Boron release plan that looks like Beryllium and hits before the ODL Summit just in case
18:05:01 <dfarrell07> I'm counting 6 atm
18:05:04 <LuisGomez> #info LuisGomez
18:05:08 <dfarrell07> 7
18:05:11 <gkaempfer> #info gkaempfer
18:05:13 <dfarrell07> 8
18:05:51 <colindixon> #topic beryllium release
18:06:00 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/RC/Status#Status
18:06:21 * dfarrell07 is so excited for this topic
18:06:49 <colindixon> gkaempfer: I muted you, sorry
18:08:04 <colindixon> #info jamoluhrsen says that there are failures, all projects have signed off on them, they look normal and par for the course
18:09:37 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-February/004663.html some NeXt concerns
18:11:18 <colindixon> #info gzhao says that he feels like NeXt is ready for release based on a release interview with them
18:11:37 <colindixon> #info zxiiro says they shouldn't include them in autorelease in the future, but we already do that for OpFlex, so that's fine
18:13:45 <colindixon> #info abhijitkumbhare asks how we show it on the website
18:14:53 <colindixon> #info colindixon says for VTN it's included in the Karaf distribution, for OpFlex it's documented how to download it, but not on the website
18:15:45 <colindixon> #action colindixon to add better policies around how to release things like NeXt and OpFlex in the futureā€”if only for sanity in terms of the number of downloads
18:15:52 <abhijitkumbhare> +1 LuisGomez
18:16:50 <colindixon> #info LuisGomez says that we may need more time for bug fixing than a single month in a 6 month release
18:17:11 <phrobb_> Should we be including OpFlex and NextUI on the downloads page of the OpenDaylight website, next to the large tar/gz files?... for simplicity of download for the users?
18:17:30 <colindixon> #info rovarga says that his take is that all functionality should be in at M3 and then only bug fixes after M5
18:18:29 <colindixon> #info colindixon says he thinks everyone will agree that we're fixing way too many bugs too late in the release, and we should look at how to fix this
18:18:41 <colindixon> #action colindixon to add the need to fix bugs earlier to the list of lessons learned
18:18:59 <colindixon> #info rovarga says better discipline and making testing happen earlier would likely help
18:21:05 <colindixon> #startvote shall the TSC release Beryllium with the artifacts here https://nexus.opendaylight.org/content/repositories/autorelease-1075/ ? -1, 0, +1
18:21:05 <odl_meetbot> Begin voting on: shall the TSC release Beryllium with the artifacts here https://nexus.opendaylight.org/content/repositories/autorelease-1075/ ? Valid vote options are -1, 0, +1.
18:21:05 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:21:13 <edwarnicke> #vote +1
18:21:14 <dfarrell07> #vote +1
18:21:16 <colindixon> #vote +1
18:21:16 <mohnish_> #vote +1
18:21:17 <abhijitkumbhare> #vote +1
18:21:17 <LuisGomez> #vote +1
18:21:24 <jmedved> #vote +1
18:21:26 <gkaempfer> #vote +1
18:21:34 <colindixon> #endvote
18:21:34 <odl_meetbot> Voted on "shall the TSC release Beryllium with the artifacts here https://nexus.opendaylight.org/content/repositories/autorelease-1075/ ?" Results are
18:21:34 <odl_meetbot> +1 (8): gkaempfer, jmedved, LuisGomez, edwarnicke, dfarrell07, colindixon, mohnish_, abhijitkumbhare
18:22:06 <dfarrell07> Great job all, great job anipbu! :)
18:22:07 <colindixon> #agree beryllium is released
18:22:11 <gzhao> yeah
18:22:16 <jamoluhrsen> w00t!
18:22:21 <gkaempfer> very impressive
18:22:29 <abhijitkumbhare> Great job folks!
18:22:32 <LuisGomez> congrats ODL devs
18:22:33 <Prem_> Great job all!
18:22:36 <anipbu> Thanks to all the folks and projects for a successful Beryllium!!!
18:23:31 <colindixon> #topic TSC elections
18:24:26 <phrobb_> I'm  here on irc if any questions on the email I sent earlier today
18:24:29 <dfarrell07> https://lists.opendaylight.org/pipermail/tsc/2016-February/004656.html
18:24:41 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-February/004656.html we can start an election if we want to
18:25:44 <colindixon> #info phrobb sent out candidate dates for nominations and an elections, are we willing to start an at-large election now
18:25:58 <colindixon> #info colindixon asks if we're ready to vote on this
18:31:03 <colindixon> #info colindixon says his one concern is whether the term will be a full year or shorter
18:31:11 <colindixon> #Info edwarnicke says that this feels rushed to vote 7 hours after the e-mail was sent out
18:33:02 <colindixon> #info mohnish_ says that talking about the terms would be a good point to ask for people to list in the nominations
18:33:27 <colindixon> #undo
18:33:27 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ffb1d0>
18:34:39 <phrobb_> If there is time and interest, it would be good for the TSC to decide the term of the At-Large-Committers; two choices are "until the first full election of the TSC, or "Until the second full election of the TSC"... where the second choice requires that the first election of the TSC accommodate 4 At-Large-Committers as part of that TSC.
18:34:53 <phrobb_> ... and let me know if the TSC is past this topic :-)
18:35:18 <colindixon> phrobb: I just brought this up
18:35:43 <colindixon> #info dfarrell07 says that this sounds like we need a quick writeup and then a next mailing list vote
18:37:29 <colindixon> #action colindixon and phrobb to ensure TSC members are paying attention and can vote if we to quickly
18:37:38 <colindixon> #info the goal would to do this Friday or Monday at the latest
18:38:05 <colindixon> #info mohnish_ asks if we can do a condorcet vote among different options
18:39:11 <colindixon> #info colindixon says that sounds like a really good idea and would speed things up
18:39:27 <colindixon> #action dfarrell07 to start the thread driving toward a vote to begin elections
18:40:24 <colindixon> https://lists.opendaylight.org/pipermail/tsc/2016-February/004648.html
18:40:44 <colindixon> #topic events
18:41:03 <colindixon> #link https://www.opendaylight.org/global-events
18:41:16 <colindixon> #info lots of events, look there
18:41:56 <colindixon> #info dfarrell07 says that the SDN NFV China conference which is linked from OPNFV page, dfarrell07 has the only ODL talk there now
18:42:24 <colindixon> dfarrell07: when you're done I'll change to topic to boron
18:42:50 <dfarrell07> #link https://drive.google.com/file/d/0B_7IPKiQjuIZVFhUa1Y5YkphREE/edit China SDN/NFV CFP
18:42:57 <dfarrell07> #topic boron
18:43:05 <colindixon> #undo
18:43:05 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2044590>
18:43:32 <colindixon> #info dave neary says that there's a LF collaboration summit with a networking track, there is still one more slot if somebody wanted to get it
18:43:56 <colindixon> #info LF collab summit is in Lake Tahoe, 3/29-3/31
18:44:09 <colindixon> #topic boron
18:44:13 <colindixon> #info see the infra update
18:44:18 <colindixon> #topic stable/lithium
18:44:33 <colindixon> #info Lithium-SR4 is coming, the cutoff date is 2/28 with a release on 3/3
18:44:44 <LuisGomez> phrobb_, is there a link for Dev Forum topics?
18:44:45 <dneary> #link http://events.linuxfoundation.org/events/collaboration-summit
18:45:03 <colindixon> #topic infrastructure
18:45:21 <dneary> #link Agenda: http://collabsummit2016.sched.org/overview/type/Networking
18:45:21 <colindixon> phrobb: no, is there?
18:45:54 <colindixon> phrobb: I don't see the agenda listed anywhere for the DDF
18:45:55 <phrobb_> LuisGomez we kicked off the dev forum topics with a standard CFP... only got a handful of submissions.  I'm building a wiki page now and will send an email to Discuss List asking for folks to put them there from now until the event
18:46:33 <colindixon> #info zxiiro says that there was some infrastructure issues that were affecting (mostly) distribution jobs for all projects, it's been fixed
18:46:46 <LuisGomez> that makes sense phrobb_, we discussed on adding integration topics this morning call
18:46:47 <phrobb_> colindixon the Events staff will make a "sched" webpage within the next couple of days...
18:47:07 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-February/005654.html the relevant mail
18:47:23 <colindixon> phrobb_: I'll bring this up as the next topic
18:47:43 <phrobb_> sounds good colindixon
18:47:48 <colindixon> #info rovarga asks if we could automate the creation of images rather than the helpdesk needing to be involved
18:48:13 <colindixon> #info zxiiro says that this is the plan, but by getting nodepool deployed and move into the private cloud, targeted in boron
18:48:15 <abhijitkumbhare> phrobb: do we want to make a google docs for the design forum instead of a standard CFP?
18:48:39 <abhijitkumbhare> I meant google spreadsheet
18:48:47 <colindixon> #topic developer design forum
18:49:00 <colindixon> #info there was a CFP, but they got very few submissions
18:49:16 <colindixon> #action phrobb_ will create a wiki page with those and asking for other topics
18:49:20 <phrobb_> abhijitkumbhare I'm going back to a wiki format... working on it right now actually
18:49:27 <abhijitkumbhare> OK
18:49:37 <colindixon> #action the LF folks are going to send out a sched page to see what's already there
18:50:00 <colindixon> #action please bring your topics to the developer design forum
18:50:07 <colindixon> #link https://www.opendaylight.org/events/2016-02-29-000000-2016-03-01-000000/opendaylight-developer-design-forum more info here
18:50:39 <colindixon> #topic yang tools graduation review
18:51:03 <colindixon> #link https://wiki.opendaylight.org/view/YANG_Tools:Graduation_Proposal
18:51:19 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-February/004621.html requested on 2/2/2016
18:51:39 <colindixon> #info yangtools has been around since the beginning, starting in the controller, then spun out into it's own project
18:51:57 <colindixon> #info have rewritten about 90% of their code base in the last 3 years
18:52:37 <colindixon> #info are now very serious about moving to semantic versioning and other ways to be the most stable project in OpenDaylight
18:53:04 <colindixon> #info mohnish_ asks if YANG tools can be used in other scenarios than OpenDaylight
18:53:32 <colindixon> #info rovarga says they try to be careful to avoid being directly tied to Karaf or OpenDaylight or OSGi or anything like that
18:55:29 <colindixon> #info colindixon notes that the TTP project uses YANG tools to create a standalone CLI jar that uses it to go from Java objects to/from JSON
18:55:55 <colindixon> #info david karr (I think) and edwarnicke confirm that it's used in an Eclipse plugin and in FD.io's honeycomb
18:56:06 <colindixon> #Info LuisGomez asks if there's a standing weekly meeting
18:56:26 <colindixon> #info LuisGomez also asks if there's documentation for developers or contributors
18:56:53 <colindixon> #info rovarga says that mostly the APIs are hidden by the MD-SAL, but it's an area they're trying to fix
18:57:13 <colindixon> #Info rovarga says there is no yangtools-specific weekly meeting, but they attend the weekly MD-SAL meeting and most interaction is via mailing lists and bugzilla
18:57:24 <colindixon> #info rovarga says if there's interest, they can set something up
18:57:48 <colindixon> #info mohnish_ asks what the future of yangtools looks like
18:58:38 <colindixon> #Info colindixon notes (here in IRC, but will also say it next) that YANG tools is very good at adhering to schedules, and especially of late has been good about communicating possibly breaking changes and reverting them if need be
18:59:19 <colindixon> #info rovarga says that there's a binding v2 specification and support for YANG 1.1 are major things, but there's tons of enhancement bugs in bugzilla to look at
18:59:40 <colindixon> what lifecycle?
18:59:41 <colindixon> anyone?
18:59:57 <colindixon> #info rovarga says that in boron they would like to prototype the takari lifecycle to help things
19:00:23 <rovarga> #link http://takari.io/book/40-lifecycle.html
19:00:33 <edwarnicke> +1 for voting
19:00:38 <colindixon> #startvote shall the TSC graduate YANG Tools to being a mature project? -1, 0, +1
19:00:38 <odl_meetbot> Begin voting on: shall the TSC graduate YANG Tools to being a mature project? Valid vote options are -1, 0, +1.
19:00:38 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:00:40 <jmedved> +1 for voting
19:00:46 <jmedved> #vote +1
19:00:48 <dfarrell07> #vote +1
19:00:48 <edwarnicke> #vote +1
19:00:48 <LuisGomez> #vote +1
19:00:49 <colindixon> #vote +1
19:00:50 <gkaempfer> #vote +1
19:00:55 <abhijitkumbhare> #vote +1
19:00:59 <andy_vanko> #vote +1
19:01:01 <mohnish_> #VOTE +1
19:01:09 <colindixon> #endvote
19:01:09 <odl_meetbot> Voted on "shall the TSC graduate YANG Tools to being a mature project?" Results are
19:01:09 <odl_meetbot> +1 (9): gkaempfer, jmedved, LuisGomez, dfarrell07, edwarnicke, colindixon, abhijitkumbhare, andy_vanko, mohnish_
19:01:20 <LuisGomez> congrats yangtools
19:01:21 <anipbu> congrats rovarga and yangtools!
19:01:28 <colindixon> #info colindixon notes that andy_vanko is not a TSC member so it's only 8 +1 votes
19:01:34 <colindixon> #undo
19:01:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x225ff90>
19:01:39 <mohnish_> congrats yangtools
19:01:45 <colindixon> #info colindixon notes that andy_vanko is not a TSC member so it's only 8 +1 votes
19:01:56 <abhijitkumbhare> congrats yangtools
19:02:06 <dfarrell07> congrats yangtools! :)
19:02:12 <colindixon> #agreed YANG Tools is now a mature project
19:02:14 <colindixon> #topic cookies
19:02:17 <colindixon> #endmeeting