18:01:13 <colindixon> #startmeeting tsc
18:01:13 <odl_meetbot> Meeting started Thu Feb 25 18:01:13 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:01:13 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:13 <odl_meetbot> The meeting name has been set to 'tsc'
18:01:18 <colindixon> #topic agenda bashing and roll call
18:01:25 <colindixon> TSC members please #info in
18:01:26 <dfarrell07> #info Daniel Farrell
18:01:26 <colindixon> #info colindixon
18:01:27 <ChrisPriceAB> #info Chris Price
18:01:32 <mohnish_> #info mohnish anumala
18:01:42 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=42965#Agenda the agenda in it's usual place
18:01:47 <dfarrell07> ^^on point, 4 right away ;)
18:02:02 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-02-18-18.00.html last week's minutes
18:02:41 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Lessons_learned_during_the_Beryllium_release updated lessons learned from Beryliium
18:02:46 <LuisGomez> #info LuisGomez
18:02:51 <dfarrell07> 5
18:03:07 <hideyuki> colindixon: Can I add a committer promotion for VTN project? Though I'm ok with the vote in ML instead of the vote in the call.
18:03:08 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan thanks to phrobb we have a draft Boron release plan, which is pretty much just Beryllium with s/Beryllium/Boron/
18:03:14 <colindixon> hideyuki: sure
18:03:37 <colindixon> hideyuki: consider it done
18:03:43 <edwarnicke> #link https://wiki.opendaylight.org/view/Release_Plan/Fast_Phased_Boron <- Fast Phased Release Plan
18:03:52 <hideyuki> colindixon: Thank you very much.
18:04:04 <colindixon> #action colindixon to keep boron planning on our minds
18:04:05 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
18:04:06 <colindixon> #action colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future
18:04:07 <colindixon> #action rovarga to follow up with a counter-proposal with the new workflow ;-)
18:04:58 <colindixon> dfarrell07: are we still at 5
18:05:08 <dfarrell07> colindixon: yes
18:05:13 <edwarnicke> #info edwarnicke
18:05:15 <dfarrell07> 6
18:05:48 <colindixon> #topic TSC mailing list votes and discussions
18:05:59 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-February/004633.html TSC elections
18:06:36 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-February/004648.html what to do with projects that don't meet testing requirements (flag them as experimental)
18:07:31 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-February/005708.html solutions for better/fast docs review, e.g., peer review
18:08:05 <colindixon> #topic events
18:08:15 <colindixon> #link https://www.opendaylight.org/global-events
18:08:27 <colindixon> #info developer design forum is on Mon/Tue
18:08:54 <colindixon> #link http://events.linuxfoundation.org/events/opendaylight-developer-design-forum/program/schedule current schedule is here
18:09:03 <colindixon> #info there will be space for unconference stuff as well
18:09:45 <colindixon> #info registration is still low, we had 209 registered last year, with 200 showing up, we only have 80 registered now
18:10:07 <colindixon> #info phrobb says that if the $200 cost is prohibitive, there may be ways to figure that out
18:10:14 <abhijitkumbhare> On a positive side most registered folks will show up this time :)
18:10:53 <colindixon> #info the Open Networking Summit and ODL mini-summit are on 3/13-3/17, we have 3 submissions to the solutions showcase
18:11:03 <colindixon> #info gzhao will be reaching out to people about demos to show at the ODL booth at ONS
18:11:41 <colindixon> #action phrobb to add the LF collab summit to the events list, it's end of march to beginning of april
18:12:43 <colindixon> #info dneary says that they could use a talk about OpenDaylight, DPDK, and/or SDN controller vendor for the networking track at the LF collab
18:13:10 <colindixon> #Info dneary would like to see something about the broader SDN view and controllers, maybe about cross-controller collaboration, e.g., NetIDE and the like
18:13:57 <colindixon> #topic boron
18:14:17 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Current_Weather_Report there are 3 events
18:14:57 <dfarrell07> dneary: might be interesting to have a panel with projects consumed by OPNFV, like various SDN controllers (and maybe DPDK and such if you want to include that idea)
18:15:19 <colindixon> #info 1.) Move auto-generated config-subsystem files from src folder to target/generated-sources
18:15:35 <colindixon> #info Neutron Security Group Rule with integers for protocols
18:15:46 <colindixon> #info OpenFlowPlugin Li migration
18:16:03 <colindixon> #info the second two will be discussed at the developer design forum
18:16:22 <colindixon> #info zxiiro and others have gotten auto-release back to being happy on all fronts
18:16:36 <dneary> dfarrell07, Nice idea - my thinking at this point is to make a decent proposal out of people who are already attending, rather than requesting someone attend for a specific topic
18:16:53 <colindixon> #topic stable/beryllium
18:17:16 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-February/004721.html Moving Beryllium-SR1 (and later) out 2 weeks
18:18:37 <colindixon> #info colindixon failed to update the SRs to be 2 weeks further out when we delayed beryllium, it's +4,+6,+12,+12 instead of the normal +6,+6,+12,+12
18:19:02 <colindixon> #info ChrisPriceAB says that a release at +4 for Berylium-SR1 would help OPNFV a lot
18:19:24 <mohnish_> then why change it?
18:19:48 <colindixon> mohnish_: that's what I was asking?
18:20:32 <colindixon> #info rovarga says that one downside of having SR2 be two weeks earlier would be less time to do OpenFlow migration activities
18:21:25 <colindixon> #Info colindixon says that we could do +4,+8,+12,+12 which would leave SR2 with the normal amount of space before
18:21:26 <dfarrell07> ChrisPriceAB: I can't find the OPNFV B SR1 date, do you have a pointer?
18:24:22 <colindixon> #info colindixon suggests that we leave SR1 4 weeks out as it is to help with OPNFV and there's not much disadvantage, we might move SR2 and later out when we have more information after the developer design forum
18:25:12 <colindixon> #Info zxiiro said he believes that NeXt has some binary to release with Beryllium and we never got it
18:26:22 <ChrisPriceAB> Hi dfarrell-7:  we don't have a neatly documented date set.  (been a little hectic)  the TSC agreed to set a stable date for    March  - Stable Release 1
18:26:33 <ChrisPriceAB> Hi dfarrell-7:  we don't have a neatly documented date set.  (been a little hectic)  the TSC agreed to set a stable date for    March 24 - Stable Release 1
18:26:38 <ChrisPriceAB> ^^ lol
18:26:47 <dfarrell07> ChrisPriceAB: cool, sounds good, thanks
18:26:51 <dfarrell07> I was digging too lol http://ircbot.wl.linuxfoundation.org/meetings/opnfv-meeting/2016/opnfv-meeting.2016-02-16-14.59.html
18:27:13 <ChrisPriceAB> it get's worse:  https://etherpad.opnfv.org/p/steps_to_brahmaputra
18:27:19 <colindixon> #info zxiiro got a zip file from NeXt which had very few instructions about how to download it and use it
18:27:24 <ChrisPriceAB> scenario 2
18:27:43 <dfarrell07> #info ODL Be SR1 date is currently 3/17, OPNFV B SR1 date is (via ChrisPriceAB) 3/24, so that works
18:27:57 <colindixon> #action anipbu and zxiiro to follow up with NeXt to get a update zip and publish it as part of a release and phrobb to put it on the download page
18:28:08 <colindixon> #topic stable/lithium
18:28:25 <Lisa_> https://wiki.opnfv.org/releases/brahmaputra/release_plan says SR1 is released 25 March 2016
18:28:52 <dfarrell07> Lisa_: thanks!
18:29:26 <colindixon> #info code freeze for Lithium-SR4 is Sunday at 11:59:59 UTC with a release on 3/3, it will auto-trigger because zxiiro will not be traveling
18:29:35 <colindixon> #info this is the last scheduled SR for Lithium, so get your stuff in
18:29:51 <dfarrell07> #link https://wiki.opnfv.org/releases/brahmaputra/release_plan Lisa_ points out that these OPNFV docs have OPNFV B SR1 on 3/25, which still is after ODL Be SR1 at 3/17, so still good
18:30:55 <colindixon> #action zxiiro to sending an e-mail about decommissioning helium jobs (and locking the branches) to release and TSC at least
18:32:03 <colindixon> #info rovarga asks if we could do this at the last SR in the future, colindixon says that we promised to provide security updates until 2 releases later, so not really
18:32:45 <colindixon> #topic system integration and test
18:33:14 <colindixon> #info jamoluhrsen says that he'd like to find ways to make system test more top of mind for people and there's a session at the design forum on that
18:33:39 <colindixon> #info the hope would be that would lead to some changes in boron integration and test requirements
18:33:50 <colindixon> #topic infrastructure
18:34:27 <colindixon> #info tykeal will be leading a developer forum topic on changes in infra, e.g., private cloud, zuul, and nodepool
18:35:00 <colindixon> #info tykeal says those are now possibly near term, given other collaborative projects that have adopted them
18:35:12 <colindixon> #info better slave management, and better triggers are two big advantages
18:35:38 <colindixon> #info zuul only does parallel jobs at the moment, we use pipelined jobs a lot, so we're looking into that
18:36:18 <colindixon> hideyuki: you're up next, so if you have the links ready, that would be great
18:38:59 <colindixon> #info phrobb asks if we plan to go further with signing our releases, e.g., committers signing their release tags
18:39:21 <colindixon> #info phrobb and rovarga both have brought up ideas about migrating to JIRA for Boron
18:39:24 <hideyuki> colindixon: The mail about the request of the commiter promotion in the VTN project: https://lists.opendaylight.org/pipermail/tsc/2016-February/004697.html
18:40:08 <colindixon> #info edwarnicke asks how we're doing with being able to publish artifacts to maven central
18:40:23 <colindixon> #action zxiiro will look more into maven central now that we're at least signing things
18:40:48 <colindixon> #action colindixon to add possible maven central requirements to boron
18:41:44 <colindixon> #Info tykeal says that sonatype has a deployment plugin that pushes to to maven central, but that doesn't work us because we want to sign after build and not as part of it
18:42:23 <colindixon> #topic Venkatrangan as a committer on VTN
18:42:28 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-February/004697.html
18:43:17 <colindixon> #startvote shall the TSC confirm Venkatrangan as a committer on VTN? -1, 0, +1
18:43:17 <odl_meetbot> Begin voting on: shall the TSC confirm Venkatrangan as a committer on VTN? Valid vote options are -1, 0, +1.
18:43:17 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:43:21 <dfarrell07> #vote +1
18:43:38 <colindixon> #Info hideyuki says he'd help the VTN project a lot
18:43:39 <colindixon> #vote +1
18:43:40 <edwarnicke> #vote +1
18:43:42 <mohnish_> #vote +1
18:43:43 <LuisGomez> #vote +1
18:44:23 <colindixon> ChrisPriceAB:
18:45:03 <colindixon> #endvote
18:45:04 <odl_meetbot> Voted on "shall the TSC confirm Venkatrangan as a committer on VTN?" Results are
18:45:04 <odl_meetbot> +1 (5): LuisGomez, colindixon, mohnish_, dfarrell07, edwarnicke
18:45:17 <colindixon> #agree Venkatrangan is now a committer on VTN
18:45:30 <dfarrell07> colindixon: did we need 6?
18:45:33 <colindixon> note that it's a majority of the quorum of TSC members we have present, so the vote carries
18:45:43 <colindixon> dfarrell07: that's my understanding
18:46:21 <colindixon> #info ChrisPriceAB verbally votes +1 and thus it is a majority
18:47:00 * ChrisPriceAB apologiese profusely, got himself tangled in orthogonal activities...
18:47:57 <colindixon> #topic TSC elections
18:48:29 <colindixon> #info dfarrell07 says that there are two families of issues: (i) ironing out the framework, and (ii) what we want to do right now since it's been 18 months since our last "annual" election
18:48:38 * edwarnicke notes its almost like ChrisPriceAB is doing a release or something...
18:49:13 <colindixon> #info dfarrell07 says that everyone seems to want to have committer-at-large election now
18:49:51 <colindixon> #info there has been some discussion about the length of that term, but most people seem to think the boron time frame is the right term (~6 months)
18:50:03 <colindixon> #info edwarnicke and colindixon agrees with that
18:50:51 * ChrisPriceAB loves that the odl community is so relaxed and accepting on such issues as terms of service. (note to self, don't get caught up with dotting i's that can be left alone for the sake of it.)
18:51:00 * ChrisPriceAB also thinks it's time for a vote!
18:52:25 <dlenrow> #info Yeah! edwarnicke said intent
18:52:31 <edwarnicke> dlenrow: LOL
18:52:34 <colindixon> #link https://www.opendaylight.org/tsc-charter "The term for TSC members, including the Chair, is one year.  There are no term limits for TSC members."
18:52:39 <edwarnicke> dlenrow: to change policy ;)
18:53:37 <rovarga> devil's advocate: so if the term is a year, do we even have quorum to vote?
18:53:42 <dlenrow> Colin for TSC chair for life
18:53:52 <ChrisPriceAB> haha dlenrow
18:53:59 <edwarnicke> dlenrow: I thought you liked colindixon ?
18:54:15 <colindixon> #startvote shall the TSC agree to have a 6 month term for the next committer-at-large and chair elections and start them as soon as possible assuming we get board permission as needed? -1, 0, +1
18:54:15 <odl_meetbot> Begin voting on: shall the TSC agree to have a 6 month term for the next committer-at-large and chair elections and start them as soon as possible assuming we get board permission as needed? Valid vote options are -1, 0, +1.
18:54:15 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:54:16 <abhijitkumbhare> edwarnicke: he doesn’t :)
18:54:25 * colindixon doesn't want to be chair for life
18:54:26 <dlenrow> He gets life sentence, er term
18:54:26 <ChrisPriceAB> #vote +1
18:54:29 <dfarrell07> #vote +1
18:54:30 <colindixon> #vote +1
18:54:31 <mohnish_> #vote +1
18:54:34 <edwarnicke> #vote +1
18:54:38 <LuisGomez> #vote +1
18:54:41 <colindixon> #endvote
18:54:41 <odl_meetbot> Voted on "shall the TSC agree to have a 6 month term for the next committer-at-large and chair elections and start them as soon as possible assuming we get board permission as needed?" Results are
18:54:41 <odl_meetbot> +1 (6): dfarrell07, LuisGomez, edwarnicke, ChrisPriceAB, colindixon, mohnish_
18:54:46 <edwarnicke> dlenrow: What did colindixon do to deserve that? ;)
18:55:00 <colindixon> #agreed we will have a committer-at-large election as soon as is possible
18:55:08 <colindixon> #topic boron planning
18:55:12 * ChrisPriceAB thinks the community should elect a chair they may want to revote for in 6 months.
18:55:25 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan draft old-style one
18:55:32 <edwarnicke> #link https://wiki.opendaylight.org/view/Release_Plan/Fast_Phased_Boron
18:55:37 <dlenrow> if nominated I will not run and if elected I will not serve, colin?
18:56:06 * ChrisPriceAB prefers not to think
18:58:26 <colindixon> #info colindixon notes that the consensus seems to be that fast-phased is a good idea in the long run, but there is limited enthusiasm and confidence to move to it now
18:58:56 <colindixon> #info colindixon's thought would be that means we can do a traditional release plan for boron and look at fast-phased for carbon
18:59:17 <colindixon> #info rovarga and edwarnicke asks if we can figure out if we can do some fast-phased stuff with some projects alongside a normal release
19:00:22 <colindixon> #info rovarga says he doesn't know the infrastructure burden though, edwarnicke thinks they are having integration jobs to do testing across branches, and then version bumping scripts to allow for faster releases
19:00:58 <colindixon> #info rovarga says you would also need per-project release jobs (vs. auto-release), edwarnicke says that it's actually a per-phase autorelease job
19:02:28 <colindixon> #info colindixon says it sounds like the consensus is that we will do a traditional-style Boron release, with some parts of fast-phased alongside to try to gain as much experience with it as possible
19:05:12 <colindixon> #topic cookies
19:05:19 <zxiiro> One concern I have is who keeps the integration branches up to date?
19:05:21 <colindixon> #endmeeting