18:00:40 <colindixon> #startmeeting tsc
18:00:40 <odl_meetbot> Meeting started Thu Mar  3 18:00:40 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:40 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:40 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:45 <colindixon> #topic roll call and agenda bashing
18:00:50 <colindixon> TSC members please #info in
18:00:52 <colindixon> #info colindixon
18:01:00 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-02-25-18.01.html last week's meeting minutes
18:01:19 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=43219#Agenda the agenda in it's usual place
18:01:55 <rgoulding> #info Ryan Goulding proxying for Luis Gomez
18:02:11 <ChrisPriceAB> #info Chris Price
18:02:23 <mohnish_> #info mohnish anumala
18:03:20 <colindixon> zxiiro: are you on the line
18:03:35 <colindixon> #action zxiiro will look more into maven central now that we're at least signing things
18:03:58 <colindixon> #action phrobb to post the NeXt zip file to the downloads page
18:04:10 <colindixon> #action zxiiro to sending an e-mail about decommissioning helium jobs (and locking the branches) to release and TSC at least
18:04:22 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
18:04:28 <colindixon> #action colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future
18:04:38 <dfarrell07> #info Daniel Farrell
18:04:43 <colindixon> #action phrobb to add the LF collab summit to the events list, it's end of march to beginning of april
18:05:32 <colindixon> #info colindixon says that the Energy Management Plugin creation review, will happen next week, the presenter has a fire going on at work, I hope the fire is in quotes
18:05:57 <edwarnicke> #info edwarnicke
18:06:42 <colindixon> #topic TSC elections
18:07:10 <colindixon> #info CaseyODL says that phrobb wants to set up a meeting between the TSC, Board, and community about TSC elections
18:07:28 <colindixon> #info the board specifically wants to speak to this
18:08:46 <colindixon> #topic events
18:08:54 <colindixon> #link https://www.opendaylight.org/global-events
18:09:27 <colindixon> #info the Open Networking Summit and co-located ODL  mini-summit are in less than two weeks
18:09:41 <colindixon> #topic stable/lithium
18:10:03 <colindixon> #Info the final build for Lithium-SR4 with no blocking issues
18:10:11 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Lithium/SR4/Status <- Status
18:10:17 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Lithium_SR4_Download <- Download here
18:10:17 <colindixon> #info all the test failures from CSIT have been signed off on by projects
18:10:51 <colindixon> https://docs.google.com/spreadsheets/d/1ktL11ElNdf4D3RUeRNUd8SPnYO0to0DxzSZGst0KdMQ/edit#gid=1117594519
18:11:17 <colindixon> #startvote shall the TSC release the Lithium-SR4 artifacts linked to above? -1, 0, +1
18:11:17 <odl_meetbot> Begin voting on: shall the TSC release the Lithium-SR4 artifacts linked to above? Valid vote options are -1, 0, +1.
18:11:17 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:11:22 <dfarrell07> #vote +1
18:11:23 <ChrisPriceAB> #vote +1
18:11:25 <colindixon> #vote +1
18:11:26 <edwarnicke> #vote +1
18:11:27 <rgoulding> #vote +1
18:11:28 <mohnish_> #vote +1
18:11:48 <colindixon> #endvote
18:11:48 <odl_meetbot> Voted on "shall the TSC release the Lithium-SR4 artifacts linked to above?" Results are
18:11:48 <odl_meetbot> +1 (6): rgoulding, ChrisPriceAB, edwarnicke, dfarrell07, colindixon, mohnish_
18:12:06 <ChrisPriceAB> majority of quorum should be enough right?  But hey, unanimous!
18:12:08 <colindixon> #agree the TSC approves the Lithium-SR4 release, this is the last scheduled release of Lithium
18:12:45 * ChrisPriceAB thinks hitting cadence is the tough part... :D
18:13:02 <colindixon> #topic stable/beryllium
18:13:24 <anipbu> #info Beryllium SR1 Release Date: March 17; Cutoff Date/Time UTC: March 13 at 11:59 pm
18:13:53 <colindixon> #topic boron
18:14:16 <colindixon> #Info no weather issues
18:14:31 <colindixon> #Info anipbu notes that there were some autorelease breakages in AAA, but they've been fixed
18:14:44 <colindixon> #info there are no milestones yet on account of not having a release plan yet
18:15:00 <colindixon> #topic system integration and testing
18:15:21 <rgoulding> autorelease build failure was due to api change in ofj that wasn't advertised to my knowledge.  Fix was merged through https://git.opendaylight.org/gerrit/#/c/35655/
18:15:24 <colindixon> #Info jamoluhrsen says there is going to be a performance-related group with Marcus leading the charge, look out for more information
18:15:28 * edwarnicke recommends calling it the 'high performance group' ;)
18:15:46 <rgoulding> #info autorelease build failure was due to api change in ofj that wasn't advertised to my knowledge.  Fix was merged through https://git.opendaylight.org/gerrit/#/c/35655/
18:16:21 <colindixon> #topic infrastructure
18:16:57 <colindixon> #Info tykeal has no updates, things stayed mostly the same given the time at the DDF
18:17:01 <colindixon> #info  blocking issue for moving to private cload was supposedly fixed whlie we were at the DDF
18:17:47 <colindixon> #info tykeal says that he hopes to have private cloud zuul and nodepool up in a the next couple of weeks, that's getting them aup assuming that we're in teh private cloud, and just getting them up not getting folks migrated
18:18:18 <colindixon> #topic NIC committer actions
18:18:34 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-March/004746.html e-mail about committers on NIC
18:19:10 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-March/004753.html two commiters on NIC stepped down
18:20:00 <colindixon> #action colindixon to ask NIC to reach out to helpdesk to get the two committers removed
18:20:28 * ChrisPriceAB likes the list for unrepresented discussions.
18:20:56 <colindixon> ChrisPriceAB: noted
18:22:04 <colindixon> #info colindixon notes two things here are potentially worth getting dicussions: (i) removing inactive committers, (ii) a new committer with not all +1s and less than a majority of votes (but no -1s)
18:22:23 <jamoluhrsen> I'm confused.  if someone asks to step down as committer, what is the conversation?
18:22:32 <colindixon> jamoluhrsen: there was no conversation there
18:22:57 <ChrisPriceAB> I for one would have a hard time voting +1 if the committers have not...  (Without compelling argumentation)
18:23:55 <phrobb_> #info Hello everyone, sorry I was late.  I have started the recording on the WebEx
18:23:57 <colindixon> #action colindixon will send mail to follow up on the rest of this
18:24:14 <colindixon> #undo
18:24:14 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2c8ef90>
18:24:20 <colindixon> #action colindixon will send mail to follow up on the rest of the NIC committer actions
18:24:39 <colindixon> #topic boron planning
18:25:02 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-March/004748.html recent thread on the mailing list (release and TSC)
18:25:16 <colindixon> #link https://wiki.opendaylight.org/view/Release_Plan/Fast_Phased_Boron proposed fast phase boron
18:25:27 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan proposed traditional boron
18:26:07 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-March/004765.html colin's thought on where we are
18:27:09 <colindixon> https://lists.opendaylight.org/pipermail/tsc/2015-May/003108.html
18:27:45 <colindixon> https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-07-16-17.00.html
18:27:52 <colindixon> 3.z
18:27:56 <colindixon> https://lists.opendaylight.org/pipermail/tsc/2015-May/003108.html
18:31:28 <edwarnicke> #link  https://lists.opendaylight.org/pipermail/tsc/2015-May/003108.html <- Appears to only discuss branch cutting, which was a hot topic
18:32:14 <colindixon> #info it seems like we have three options now (a) pick that we go with a fast phased release plan, (b) pick that we go with a traditional release, (c) decide that we dont' have enough information or need more community involvement
18:32:16 <edwarnicke> #link https://lists.opendaylight.org/pipermail/release/2015-July/003119.html <- first discussion of stable features, 9 days before the vote on the Beryllium Plan
18:32:22 <edwarnicke> (or at least first email I could find)
18:33:38 <colindixon> #info we have the summit on 9/27, to put on the best summit, I think we need at least ~2 weeks weeks to work on their stuff before that, so if we do a boron releas after 9/15 (thursday 12 days before the summit), we'll have push out past the summit, which is 10/6 or 10/13
18:34:07 <colindixon> approx 8 months after Beryllium
18:34:57 <colindixon> #info that would be 8 months after Beryllium
18:35:44 <colindixon> #info edwarnicke notes that having summits near to release seems to cause problems
18:36:23 <colindixon> #info abhijitkumbhare asks if we can have a few weeks where we assume that we're going with a traditional release while have have broader discussions, i.e., provisionally adopt the traditional release plan
18:36:24 <edwarnicke> #info abhijitkumbhare suggests we assume provisionally approve regular release plan, and revisit in a weak or two based on community discussion as to whether to go Fast Phased or Traditional
18:36:36 <colindixon> #undo
18:36:36 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c993d0>
18:37:34 <colindixon> #info edwarnicke asks if there are still issues we need to work through with the traditional plan
18:38:17 <colindixon> #Info colindixon notes that there are two issues people wanted to talk about (a) that we don't start testing earlier enough, and (b) that we might want to have features be experimental without system test
18:39:39 <abhijitkumbhare> Both colindixon or edwarnicke have accurately noted what I had said - either can stand in the meeting minutes
18:39:42 <dfarrell07> #info we could also approve the normal release plan and make amendments to it if/when community finds things it wants to change
18:44:59 <colindixon> #info colindixon notes that dfarrell07 and abhijitkumbhare have suggested that we might provisionally accept the traditional release plan today
18:45:17 <colindixon> mohnish_:
18:45:17 <edwarnicke> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Schedule <- Traditional plans dates for bringing offset-0 projects predate the Developer Design Forum, and offset-0 project deadline is today
18:45:28 <edwarnicke> #info Any new projects with existing dates would require exceptions
18:46:08 <edwarnicke> #undo
18:46:11 <colindixon> #undo
18:46:12 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c99650>
18:46:37 <colindixon> #Info any new projects seeking to join offset 1 woudl have to do do so by the end of the day, offset 2 projects would still have two weeks
18:46:55 <colindixon> #info any new offset 0 projects to join now would require an exeption
18:47:04 <colindixon> #Undo
18:47:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c99750>
18:47:05 <colindixon> #Undo
18:47:05 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c99710>
18:47:15 <colindixon> #Info any new projects seeking to join offset 1 woudl have to do do so by the end of the day, offset 2 projects would still have a week
18:47:21 <colindixon> #info any new offset 0 projects to join now would require an exeption
18:47:22 <edwarnicke> #info Any new offset-0 projects would require an exception, any new offset-1 projects which do not get their project proposals in today would require an exception, any offset-2 projects after next week would require an exception
18:47:27 <dfarrell07> #info dfarrell07 has been talking to Int/*, RelEng/* and others about Fast Phased vs normal. Branch cutting and release tooling aren't ready for FP, but would be ready at Boron end. Everyone seems comfortable with normal release plan, no doubts expressed.
18:47:58 <edwarnicke> #info edwarnicke is concerned that not everyone knows exceptions are available, and thus we may discourage participation
18:49:11 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#note3 the exception
18:49:50 <dfarrell07> #info dfarrell07 notes that edwarnicke seems to have a lot of feedback about things we could do better, which is welcome and encouraged, but would be best delivered via async/archived lists and not now, since we need to vote ASAP.
18:50:26 <colindixon> #action colindixon to send e-mails out making clear that projects coming out of the design forum are what the exceptions are for
18:51:39 <edwarnicke> #info edwarnicke feels that adopting a release plan announced only a week ago is to fast
18:51:53 <edwarnicke> #info edwarnicke is deeply concerned about the lack of community discussion of the plan
18:52:10 <dfarrell07> ^^again, I'm concerned about how true those are
18:52:47 <colindixon> #info dfarrell07 and colindixon note that they don't share the above concern, that there has been broad community discussion about boron for many months
18:52:48 <edwarnicke> dfarrell07: How much discussion can happen in 7 days, in which there was no session at the DDF, and in which many members of the community have been traveling
18:53:16 <delta_days_betwe> Between Hydrogen to Helium: 294 days;  Between Helium to Lithium: 269 days;  Between Lithium to Beryllium: 238 days; Between Beryllium to Boron (Traditional): 204 days.
18:53:47 <colindixon> #Info ChrisPriceAB says that as long as we have a predictable release cadence, this is fine, and having dates in the past is potentially fine
18:54:44 <dfarrell07> I'd really like to vote today, colindixon
18:54:54 <colindixon> #startvote shall the TSC provisionally accept this release plan for Boron while we have discussions that might alter it https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan? -1, 0, +1
18:54:54 <odl_meetbot> Begin voting on: shall the TSC provisionally accept this release plan for Boron while we have discussions that might alter it https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan? Valid vote options are -1, 0, +1.
18:54:54 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:55:00 <dfarrell07> #vote +1
18:55:10 * ChrisPriceAB gets the hint will stay quiet :D
18:55:18 <colindixon> #vote +1
18:55:20 <rgoulding> #vote +1
18:55:54 <edwarnicke> #vote -1
18:55:57 <abhijitkumbhare> Do we want to make sure we address edwarnicke’s concern about some dates in the past & some of the dates before this vote today?
18:56:06 <edwarnicke> #info edwarnicke feels this is inappropriately rushed
18:56:14 <colindixon> abhijitkumbhare: that's the question
18:56:22 <dfarrell07> abhijitkumbhare: I think colindixon socializing exceptions is okay
18:56:25 <edwarnicke> #info and does not feel passing plans with dates in the past is appropriate
18:56:56 * ChrisPriceAB feels we can solve these issues on the fly, having a constrained scope release to set a cadence may be necessary.
18:57:05 <ChrisPriceAB> #vote +1
18:57:11 <colindixon> ChrisPriceAB and mohnish_ pleae vote as you will
18:57:34 <mohnish_> #vote +1
18:57:43 <colindixon> #endvote
18:57:43 <odl_meetbot> Voted on "shall the TSC provisionally accept this release plan for Boron while we have discussions that might alter it https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan?" Results are
18:57:43 <odl_meetbot> +1 (5): colindixon, mohnish_, dfarrell07, rgoulding, ChrisPriceAB
18:57:43 <odl_meetbot> -1 (1): edwarnicke
18:58:20 <colindixon> #agree the TSC provisionally adopts the Boron release plan as while we have discussions that might alter it https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan
18:59:14 <colindixon> #info edwarnicke notes that he (a) thinks that we have only had 7 days to get feedback on this and (b) that that's not enough time to get community feedback
18:59:59 <colindixon> #info colindixon and dfarrell07 note that the they feel like feedback could have come back because the Beryllium release plan was the same and available for feedback, and that those have been discussed
18:59:59 <abhijitkumbhare> Why not the following: allow new projects more time for joining - for others (existing) let them assume this is the plan so they can start executing as per this?
19:00:37 <dfarrell07> #info dfarrell07 notes that he has been very deliberate about talking to the community about this b/c he wasn't sure himself. No one had concerns, people understand it because there have been discussions and they have worked through a copy+paste similar plan before.
19:00:40 <colindixon> #info mohnish_ asks what we could do in the future to make things bettek
19:00:56 <colindixon> #info edwarnicke says make sure the release plan has been out to be commented on for at least a month
19:02:17 * dfarrell07 needs to drop for cperf call
19:04:29 * dfarrell07 hasn't dropped btw, is just late to cperf
19:04:47 <colindixon> #info there is a disagreement between edwarnicke (one one hand) and colindixon and dfarrell07 (on the other hand) about whether we really had community discussion about this release plan, both dfarrell07 and colindixon feel as though we have
19:04:55 <colindixon> dfarrell07: sorry
19:05:06 <dfarrell07> colindixon: not your fault
19:06:26 <colindixon> #info phrobb notes that we have a charter to provide releases approx. twice per year, and that if we have to stop after releases and go through the new release plan for a month, would push us even further from that than we currently are
19:08:19 <colindixon> #info it seems like a concrete action plan moving forward is to make sure that we communicate the new release plan with salient differences and dates on or around M2 of the previous release
19:08:22 <colindixon> #topic cookies
19:08:24 <colindixon> #endmeeting