#opendaylight-meeting: tsc

Meeting started by colindixon at 18:00:06 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 18:00:10)
    1. colindixon (colindixon, 18:00:20)
    2. Daniel Farrell (dfarrell07, 18:00:34)
    3. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=43651#Agenda the agenda in it's usual place (colindixon, 18:00:38)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-03-03-18.00.html last week's meeting minutes (colindixon, 18:00:47)
    5. gkaempfer (gkaempfer, 18:02:13)
    6. Chris Price (ChrisPriceAB, 18:02:18)
    7. ACTION: zxiiro will look more into maven central now that we're at least signing things (colindixon, 18:02:47)
    8. ACTION: phrobb to post the NeXt zip file to the downloads page (colindixon, 18:02:52)
    9. ACTION: phrobb to add the LF collab summit to the events list, it's end of march to beginning of april (colindixon, 18:02:55)
    10. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron? (colindixon, 18:03:05)
    11. ACTION: colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future (colindixon, 18:03:06)
    12. mohnish anumala (mohnish_, 18:03:21)
    13. LuisGomez (LuisGomez, 18:05:16)

  2. TSC elections update  (colindixon, 18:05:18)
    1. there was an informal meeting of several people from the board, from the TSC as well as community members yesterday (colindixon, 18:05:54)
    2. it was mostly information sharing (colindixon, 18:05:59)
    3. edwarnicke (edwarnicke, 18:06:50)
    4. this was to talk about the fact that the board was curious if there was a faster way to remove platinum designates from the TSC, e.g., for *this* election as well as concerns about company caps (colindixon, 18:06:57)
    5. three options seemed surface: (1) have no election until after boron and remove platinum designates, (2) keep the paltinum designates in place and have 4 comitters-at-large elected untl the end of boron, after which use the new election and remove platinum designates (3) remove the platinum designates and have a committer-at-large-only election now, then have a new election after Boron (colindixon, 18:08:45)
    6. in general, people preferred 2 or 3 over 1, but it was a limited number of people attending (colindixon, 18:09:37)
    7. dmm had three principles he voiced: (1) no pay-to-play, (2) meritocracy, (3) simple systems (colindixon, 18:11:19)
    8. dmm's take was that (1) meant no platinum designates, (2) meant no caps, (3) meant that it should be as simple as possible (colindixon, 18:11:48)
    9. dfarrell07 notes that his recollection was that dmm (Dave Meyer) seemed not opposed to the election system we had proposed after the discussion (colindixon, 18:13:45)
    10. colindixon notes that Anshu (board member from HP) expressed pretty strong opinions in favor of company caps (colindixon, 18:15:37)
    11. abhijitkumbhare asked who gets to decide whether we have caps or not have caps, the answer is really the board votes at the end with input from the community and TSC being accepted at their discretion because TSC composition is defined in the bylaws (colindixon, 18:19:33)

  3. events (colindixon, 18:19:43)
    1. https://www.opendaylight.org/global-events (colindixon, 18:19:50)
    2. ONS is next week (colindixon, 18:19:54)

  4. boron (colindixon, 18:20:01)
    1. https://wiki.opendaylight.org/view/Weather#Bug_4527_Security_Groups_:_For_.22Other_Protocol.22_rule.2C_NeutronSecurityRule.getSecurityRuleProtocol.28.29_is_set_to_NULL still waiting on that (colindixon, 18:20:18)
    2. https://wiki.opendaylight.org/view/Weather#Karaf-parent_upgraded_to_use_karaf-plugin still waiting on that (colindixon, 18:20:31)
    3. waiting on USC to fix boron autorelease (colindixon, 18:20:39)
    4. Boron offset 0 M1 is due today assuming the TSC doesn't adjust the dates (colindixon, 18:20:58)

  5. stable beryllium (colindixon, 18:21:14)
    1. cutoff for Beryllium-SR1 is this Sunday at 11:59p UTC, get things in by then for a release on 3/17 (colindixon, 18:21:37)
    2. anipbu says the RC will be around 12 noon on MOnday (colindixon, 18:22:04)

  6. infrastructure (colindixon, 18:22:20)
    1. staring to migrate into the private cloud, static VM for job builder is in the private cloud as of this morning (colindixon, 18:22:45)
    2. staring to move build slaves next (colindixon, 18:22:54)
    3. furhter migration including the jenkins system and others will happen after that (colindixon, 18:23:27)

  7. NIC committer adjustments (colindixon, 18:23:39)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-March/004746.html (colindixon, 18:24:11)
    2. since that e-amil we're at +7 votes which is a majority and unaniumous for 3 of the 4 point (colindixon, 18:25:02)
    3. https://lists.opendaylight.org/pipermail/nic-dev/2016-February/001157.html contributions likted here (colindixon, 18:25:19)
    4. https://lists.opendaylight.org/pipermail/nic-dev/2016-February/001173.html the 4th of the 4 seems to have voluntarily dropped out (colindixon, 18:25:47)
    5. VOTE: Voted on "shall the TSC promote Icaro Camelo, Saket Mahajan, and Yrineu Rodrigues as committers on the NIC project?" Results are, +1: 8 (colindixon, 18:27:44)
    6. note that phrobb_ was voting for ChrisPriceAB (colindixon, 18:27:52)
    7. AGREED: Icaro Camelo, Saket Mahajan, Yrineu Rodrigues are now committers on NIC (colindixon, 18:28:01)
    8. ACTION: colindixon to make sure removing inactive committers for NIC to next week (colindixon, 18:29:00)

  8. eneergy management creation review (colindixon, 18:29:13)
    1. https://wiki.opendaylight.org/view/Project_Proposals:Eman (colindixon, 18:29:22)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2016-February/000397.html proposed on 2/3/2016 (colindixon, 18:29:45)
    3. https://wiki.opendaylight.org/view/File:APSIS_and_OpenDaylight_-_light.pptx slides (colindixon, 18:30:07)
    4. this is the result of of a standards effor (by an ANSI certaified standards body) trying to build software tools do do better energy efficiency (colindixon, 18:32:43)
    5. network usage is very high during the day and pretty much absent at night, they'd like to be able power down some of the network to reduce consumption along with the demand (colindixon, 18:33:19)
    6. there's been a bunch of promising work on how to mechanically do energy attenuation at the devices, so it seems like a good time to start working in ODL to help create complete solutions (colindixon, 18:34:09)
    7. Frank says that they're also working with the IETF to fit this into other frameworks for energy monitoring and control (colindixon, 18:34:45)
    8. uri_ asks if this is targeting compute or underlay or both, Frank says yes, but they're mostly targeting specific network gear in the access networks of the cable industry (colindixon, 18:35:35)
    9. uri_ asks if this project is looking to serve the cable industry or more broadly, Frank says more broadly based on using information models and other tools from the IETF that are more general (colindixon, 18:36:07)
    10. this project would use an abstract information model from APSIS (adaptive power systems something something) that was co-developed with the IETF, and then create software and APIs to be able to control and actuate it (colindixon, 18:38:12)
    11. colindixon has two questions from the project proposal scope: (1) is it just the model and southbound interfaces or is it also the energy management applications, (2) by "stand-alone", I'm assuming you mean that it's just a new set of plugins, not that it runs without the rest of OpenDaylight (colindixon, 18:40:00)
    12. ChrisPriceAB asks if they plan to address multi-service overlay at this time, Frank says that they're focusing on cable use cases them selves, but trying not to let that leak into the tools in ODL (colindixon, 18:41:10)
    13. ChrisPriceAB points out that foucsing a lot on multi-writer stuff would matter a lot then (colindixon, 18:42:01)
    14. dfarrell07 has gotten feedback from RelEng-related folks that having only one committer for a project is something they would like to avoid. It creates more work for them to help the project through the release process, and it adds risk around not being able to get up with ppl in a timely manor (if they go on vacation, for example).Second committer? (dfarrell07, 18:43:07)
    15. Frank says that colindixon's scope reading is correct that this is really just a plugin, but would not provide energy management applications on it's own (colindixon, 18:43:27)
    16. Frank says he meant stand-alone as in it will be a plugin but that it won't likely use other plugins or services beyond the MD-SAL (colindixon, 18:44:35)
    17. colindixon asks if we should add a few other committers per dfarrell07's comments, he suggests Chris Luke and Derek (colindixon, 18:47:19)
    18. Frank says at least Derik (colindixon, 18:47:25)
    19. VOTE: Voted on "shall the TSC approve the energy management project as an incubation project with Derek as an additional committer?" Results are, +1: 6 (colindixon, 18:48:37)
    20. ChrisPriceAB and uri_ also vote +1 (colindixon, 18:48:48)
    21. AGREED: energy monitoring is an incubation project (colindixon, 18:48:59)

  9. OCP plugin creation review (colindixon, 18:49:17)
    1. https://wiki.opendaylight.org/view/Project_Proposals:OCP_Plugin (colindixon, 18:49:48)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2015-December/000389.html proposed on 12/30/2015 (colindixon, 18:50:19)
    3. this is work originally done at FACA (Foxconn Advanced Communication Academy) focusing on Cloud RAN (Radio Area Network) (colindixon, 18:51:15)
    4. https://wiki.opendaylight.org/view/File:OCP_Project_Proposal_for_TSC_Review.pptx slides (colindixon, 18:52:23)
    5. OCP (ORI C&M Protocol) is an ETSI standard protocol for control and management of Remote Radio Head (RRH) equipment (colindixon, 18:52:53)
    6. https://wiki.opendaylight.org/view/Project_Proposals:OCP_Plugin#Scope the scope to review (colindixon, 18:54:48)
    7. for what it's worth it seems like there's *a lot* of information on the project proposal page (colindixon, 18:55:23)
    8. design is inspired by the OpenFlow plugin and OpenFlow java projects, but will be one project (colindixon, 18:55:52)
    9. mohnish_ asks if it has anything to do with openflow, answer is other than the architecture, no (colindixon, 18:57:56)
    10. VOTE: Voted on "shall the TSC move the OCP plugin project to incubation pending IPR?" Results are, +1: 8 (colindixon, 19:02:00)
    11. AGREED: OCP Plugin is now an incubation project (colindixon, 19:02:09)

  10. cookies (colindixon, 19:02:31)


Meeting ended at 19:02:34 UTC (full logs).

Action items

  1. zxiiro will look more into maven central now that we're at least signing things
  2. phrobb to post the NeXt zip file to the downloads page
  3. phrobb to add the LF collab summit to the events list, it's end of march to beginning of april
  4. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
  5. colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future
  6. colindixon to make sure removing inactive committers for NIC to next week


Action items, by person

  1. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
    2. colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future
    3. colindixon to make sure removing inactive committers for NIC to next week
  2. phrobb
    1. phrobb to post the NeXt zip file to the downloads page
    2. phrobb to add the LF collab summit to the events list, it's end of march to beginning of april
  3. zxiiro
    1. zxiiro will look more into maven central now that we're at least signing things


People present (lines said)

  1. colindixon (103)
  2. dfarrell07 (20)
  3. odl_meetbot (18)
  4. edwarnicke (11)
  5. ChrisPriceAB (7)
  6. mohnish_ (7)
  7. LuisGomez (6)
  8. gkaempfer (5)
  9. zxiiro (5)
  10. adetalhouet (3)
  11. phrobb_ (3)
  12. uri_ (3)
  13. tykeal (2)
  14. phrobb (0)
  15. anipbu (0)


Generated by MeetBot 0.1.4.