17:00:32 <colindixon> #startmeeting tsc
17:00:32 <odl_meetbot> Meeting started Thu Apr  7 17:00:32 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:32 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:32 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:36 <colindixon> #topic agenda bashing and roll call
17:00:44 <colindixon> TSC members please #info in
17:00:45 <ChrisPriceAB> #info Chris Price
17:00:46 <rovarga> #info rovarga proxy for jmedved
17:00:49 <colindixon> #info colindixon
17:00:54 <gkaempfer> #info gkaempfer
17:01:08 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=45118#Agenda the agenda
17:01:10 <dfarrell07> #info Daniel Farrell
17:01:17 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-03-31-17.00.html lat week's meeting minutes
17:01:43 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
17:01:44 <colindixon> #action zxiiro will look more into maven central now that we're at least signing things
17:01:53 <colindixon> #undo
17:01:53 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2529190>
17:02:01 <zxiiro> #link https://bugs.opendaylight.org/show_bug.cgi?id=5630 Releasing artifacts to Maven Central
17:03:03 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-April/004994.html thread on a hackfest in June
17:03:22 <LuisGomez> #info LuisGomez
17:03:50 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-April/006203.html mail about build failures in autorelease, but not in projects
17:03:58 <mohnish_> #info mohnish anumala
17:04:19 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2016-April/000477.html colin following up with cardinal after their creation review
17:04:55 <colindixon> #action tykeal or somebody else to write up and send an e-mail about signing commits in gerrit
17:05:25 <rovarga> tykeal: feel free to send that to me, too
17:05:30 <jamoluhrsen> tykeal, colindixon : my key should work too.  I'll play test dummy
17:05:50 <tykeal> ah, yes colindixon you key is setup in a way that should work with it
17:06:38 <colindixon> #action ChrisPriceAB, phrobb, phrobb_, gzhao, CaseyODL and others to help coordinate a bit between ODL and OPNFV at the OpenStack summit to have better presence
17:06:43 <ChrisPriceAB> #info waiting for a chance, after crazy travel schedules, to get everyone on the phone to sort this out.
17:07:02 <tykeal> jamoluhrsen: yours might work, but it's hard to say. You've got a signing key on your master, but you've also got a signing subkey. Depends upon how you use your keys...
17:07:32 <tykeal> rovarga: you're in the same camp as jamoluhrsen
17:07:36 <colindixon> #topic mailing list votes and discussions
17:08:28 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-April/005007.html TSC elections for comitters-at-large for 5-months (throught the end of Boron)
17:08:41 <colindixon> #Info please nominate yourself if you'd like to run for one of the four committer-at-large seats we have
17:08:55 <colindixon> #Info it's worth noting there can only be one winner per unaffilated company
17:09:07 <gzhao> colindixon:  as far as I know, we have 2 panels and 1 demo theater presentation for ODL at Openstack, current, there are 5 projects signed up for demo at ODL booth, but not all will have representative to present.
17:09:23 <colindixon> #info it will not displace platinum designates though
17:10:18 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-March/004956.html MPLS-TP service creation review over e-mail (comments there would be appreciated)
17:10:44 <colindixon> #info there are two MPLS-TP projects under review, so be aware fo that
17:11:10 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-March/004928.html thread on cleaner committer lists
17:12:12 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html continued in April
17:14:06 <phrobb_> We are at 7 TSC members.  We have quorum
17:14:18 <ChrisPriceAB> sounds good
17:14:43 <colindixon> #startvote shall the TSC ask projects to carry out keeping clean committer lists every six months as described here: https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html ? -1,0,+1
17:14:43 <odl_meetbot> Begin voting on: shall the TSC ask projects to carry out keeping clean committer lists every six months as described here: https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html ? Valid vote options are -1, 0, +1.
17:14:43 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:14:50 <dfarrell07> #vote +1
17:14:52 <gkaempfer> #vote +1
17:14:52 <LuisGomez> #vote +1
17:14:52 <colindixon> #chair phrobb phrobb_ anipbu
17:14:52 <odl_meetbot> Current chairs: anipbu colindixon phrobb phrobb_
17:14:55 <colindixon> #vote +1
17:14:56 <rovarga> #vote +1
17:14:58 <mohnish_> #vote +1
17:15:00 <ChrisPriceAB> #vote +1
17:15:08 <colindixon> #endvote
17:15:08 <odl_meetbot> Voted on "shall the TSC ask projects to carry out keeping clean committer lists every six months as described here: https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html ?" Results are
17:15:08 <odl_meetbot> +1 (7): rovarga, LuisGomez, dfarrell07, ChrisPriceAB, gkaempfer, mohnish_, colindixon
17:15:25 <colindixon> #agreed the TSC asks projects to carry out keeping clean committer lists every six months as described here: https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html
17:15:47 <colindixon> #action colindixon to copy this into the TSC main page under processes and procedures: TSC ask projects to carry out keeping clean committer lists every six months as described here: https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html
17:16:09 <colindixon> #action anipbu or colindixon to send an announcement to the release@ list
17:16:15 <colindixon> #Undo
17:16:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2337190>
17:16:23 <colindixon> #action anipbu or colindixon to send an announcement to the release@ list about removing inactive committers
17:16:29 <rovarga> colindixon: thanks
17:16:34 <colindixon> rovarga: thank you
17:16:36 <colindixon> #topic events
17:16:43 <colindixon> #link https://www.opendaylight.org/global-events
17:16:57 <colindixon> #info SDN/NFV conference next week in Beijing, neela will be speaking
17:17:19 <colindixon> #info OpenStack in Austin at the end of the month, gzhao and CaseyODL are seekiing demos for the ODL booth  (contact them)
17:17:36 <colindixon> #Info CFPs for opendaylight mini summit in late june
17:17:47 <colindixon> #info CPFs for opendaylight summit in september is open
17:18:23 <ChrisPriceAB> in favour
17:18:31 <ChrisPriceAB> but as an external stakeholder
17:18:36 <jamoluhrsen> +1 for hackfest
17:18:40 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-April/004994.html planning a hackfest
17:18:53 <abhijitkumbhare> June - folks are on a vacation - I am :)
17:19:01 <colindixon> #Info ChrisPriceAB, jamoluhrsen, LuisGomez, and others are in favor
17:20:07 <colindixon> #info colindixon notes that hackfests have been only OK in his experience, atttendance has been light, maybe we could get by with just DDFs?
17:20:59 <colindixon> #Info maybe just the integration team could set one up, phrobb_ notes that this was really for cross-project stuff originally, but that's been happening less than hoped
17:21:51 <colindixon> #info phrobb_ says that if it's really just the integration team getting value, do a smaller thing for just them might the right approach
17:22:21 <colindixon> #info maybe anipbu to poll projects if they would have people attend
17:23:22 <colindixon> #Info rovarga suggests if there was a way to put it between API freeze of offset 0 and offset 2, colindixon notes we've tried to do that in the past, it hasn't seemed to increase attendance
17:23:53 <colindixon> #info ChrisPriceAB asks if we had more cocrete foci would help, it's a good idea
17:23:58 <rovarga> #info clarification: June is in M4 land offset-0 is 6/2, offset-2 is 6/30
17:25:12 <abhijitkumbhare> If rovarga suggestion of pre M3 is OK with me timing wise (May or May end) is fine with me timing wise
17:25:19 <colindixon> #action phrobb_ to poll projects about whether they would attend and what they would attend for with each project
17:25:45 <jamoluhrsen> hackfest could turn in to bugfest, or docfest or createtutorialsfest
17:26:04 <colindixon> #info phrobb_ asks if we're anticipating doing anyting w.r.t. doing fast-phased or sematic versionion for carbon, so we can get moving on it now, before Carbon
17:26:16 <colindixon> edwarnicke:
17:26:33 <dfarrell07> phrobb_: that would be a good topic for a hackfest?
17:27:19 <colindixon> #action colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest
17:27:25 <colindixon> #topic boron
17:27:44 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Current_Weather_Report
17:27:50 <LuisGomez> +1 jamoluhrsen
17:28:23 <colindixon> #Info jamoluhrsen suggests hackfests turn into mabye bugfixfest or maketutorialsfest
17:28:50 <dfarrell07> +1 jamoluhrsen
17:29:29 <colindixon> #info we are currently tracking OpenFlow Plugin moving to lithium, we want all feedback on isuses by today (still waiting on 8 project )
17:29:37 <colindixon> #info still waiting for M1 for 5 projects
17:29:49 <colindixon> #info today is boron M2 for offset 0 projects
17:30:00 <colindixon> #Info some autorelease breakages with OVSDB SB
17:30:13 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-March/004963.html formally approve the boron release plan
17:30:59 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-March/006121.html making features experimental unless they have fulfilled system test requiments
17:32:02 <colindixon> #info colindixon notes that his feeling is that we could approve the Boron release plan as-is given that it's had lots of opportunity for feedback and only one real discussion has happened (see above)
17:32:45 <colindixon> #Link https://lists.opendaylight.org/pipermail/release/2016-April/006166.html some clarifications around stable features
17:34:05 <colindixon> #action colindixon to make clarifications to the release plan per https://lists.opendaylight.org/pipermail/release/2016-April/006166.html
17:35:15 <colindixon> #info ChrisPriceAB asks who sets the bar for system tests? colindixon answers that it's written by the integration team, and approved by the TSC, Boron is identical to Beryllium at the moment.
17:35:47 <colindixon> #startvote shall the TSC formally adopt the Boron release plan here: https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan ? -1,0,+1
17:35:47 <odl_meetbot> Begin voting on: shall the TSC formally adopt the Boron release plan here: https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan ? Valid vote options are -1, 0, +1.
17:35:47 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:35:57 <dfarrell07> #vote +1
17:35:59 <colindixon> #vote +1
17:35:59 <gkaempfer> #vote +1
17:36:02 <ChrisPriceAB> #vote +1
17:36:02 <LuisGomez> #vote +1
17:36:05 <mohnish_> #vote +1
17:36:07 <rovarga> #vote +1
17:36:10 <colindixon> #endvote
17:36:10 <odl_meetbot> Voted on "shall the TSC formally adopt the Boron release plan here: https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan ?" Results are
17:36:10 <odl_meetbot> +1 (7): gkaempfer, LuisGomez, dfarrell07, ChrisPriceAB, colindixon, mohnish_, rovarga
17:36:35 <colindixon> #agree the TSC formally adopts the Boron release plan here: https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan
17:37:20 <colindixon> #topic EPC OpenFlow Extension creation review
17:37:20 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:EPC_OpenFlow_Extension
17:37:31 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2016-March/000436.html proposed on 3/16/2016
17:38:01 <colindixon> #info the idea is to extend OpenDayligtht to be able to control EPC infrastructure using OpenFlow via vendor-specific OpenFlow OXMs
17:38:28 <colindixon> #info this is mostly controlling GTP tunnels using the GTP-U protocol
17:38:49 <colindixon> #info they explored contributing them directly to the OpenFlow plugin project, the answer seemed to be no
17:40:15 <colindixon> #info in the future, we likely would like to have a simpler way to add openflow extensions than one project per openflow extension
17:40:39 <colindixon> #info colindixon notes that this should probably be called ofextensions/epc not epcofe
17:41:00 <colindixon> #info colindixon notest that the scope is impled, but mostly seems to be in the description
17:43:03 <colindixon> #info mohnish_ asks abhijitkumbhare if there's a mechanism if doing these kind of extensions is there, abhijitkumbhare says yes that mechanism exists, and it should be doable across git repositories as well
17:43:44 <colindixon> #Info rovarga suggests that maybe ofextensions should be openflow/extensions and we should also have openflow/plugin and openflow/java (or openflow/library)
17:44:28 <colindixon> can nobody hear me?
17:44:36 <mohnish_> no
17:45:03 <colindixon> crap
17:45:12 <colindixon> so this is a good discussion, but we need to move on
17:45:56 <abhijitkumbhare> agree colindixon
17:46:34 <abhijitkumbhare> ofextensions/epc makes sense
17:47:00 <colindixon> #action kobyaizer to change the name from epcofe to ofextensions/epc
17:47:49 <colindixon> #actoin abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation
17:47:57 <colindixon> #action abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation
17:48:26 <colindixon> #startvote shall the TSC move the OpenFlow EPC project to incubation? -1,0,+1
17:48:26 <odl_meetbot> Begin voting on: shall the TSC move the OpenFlow EPC project to incubation? Valid vote options are -1, 0, +1.
17:48:26 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:48:34 <rovarga> #vote +1
17:48:36 <mohnish_> #vote +1
17:48:44 <ChrisPriceAB> #vote +1
17:48:52 <LuisGomez> #vote +1
17:48:55 <colindixon> #Info rovarga notes that it woudl be good to have a plan ready for OF projects organization that before we get to Carbon
17:49:01 <colindixon> #vote +1
17:49:05 <dfarrell07> #vote +1
17:49:06 <gkaempfer> #vote +1
17:49:10 <colindixon> #endvote
17:49:10 <odl_meetbot> Voted on "shall the TSC move the OpenFlow EPC project to incubation?" Results are
17:49:10 <odl_meetbot> +1 (7): gkaempfer, rovarga, LuisGomez, dfarrell07, ChrisPriceAB, colindixon, mohnish_
17:49:13 <tykeal> is there IPR needed?
17:49:26 <colindixon> #agreed OF EPC is a now an inbation project
17:50:16 <colindixon> #starvote shall the TSC allow the OF EPC project to join the boron release at offest 2? -1,0,+1
17:50:21 <colindixon> #startvote shall the TSC allow the OF EPC project to join the boron release at offest 2? -1,0,+1
17:50:21 <odl_meetbot> Begin voting on: shall the TSC allow the OF EPC project to join the boron release at offest 2? Valid vote options are -1, 0, +1.
17:50:21 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:50:30 <mohnish_> #vote +1
17:50:31 <gkaempfer> #vote +1
17:50:32 <ChrisPriceAB> #vote +1
17:50:38 <dfarrell07> #vote +1
17:50:38 <rovarga> #vote +1
17:50:40 <colindixon> #Info colindixon notes that in later releases if others want to use it, it should really be offset 1 with the OF plugin
17:50:43 <colindixon> #vote +1
17:50:45 <colindixon> #endvote
17:50:45 <odl_meetbot> Voted on "shall the TSC allow the OF EPC project to join the boron release at offest 2?" Results are
17:50:45 <odl_meetbot> +1 (6): rovarga, dfarrell07, ChrisPriceAB, gkaempfer, colindixon, mohnish_
17:50:55 <colindixon> #agree the OF EPC project can join boron at offest 2
17:51:00 <colindixon> #topic NetVirt creation review
17:51:11 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:NetVirt
17:51:25 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2016-March/000455.html 3/24/2016
17:51:43 <colindixon> congrats kobyaizer and the OF EPC team!
17:52:11 <ChrisPriceAB> phil feeling a little hussled
17:52:29 <colindixon> #action shague to post slides to the wiki so we can link to them later
17:52:46 <rovarga> colindixon: the slides are in the proposal
17:53:05 <rovarga> #link https://docs.google.com/presentation/d/16c-NT19x3dbPrTjPIV5WxKcKrFfURsTLBD4D5n-pOCo/edit#slide=id.g10faa1e6d3_1_16
17:53:07 <colindixon> #info OVSDB has had two halves since nearly the beginning of OpenDaylight, an OVSDB SB plugin and a Neutron OpenStack plugin using that SB plugin (and OpenFlow plugin)
17:53:12 <colindixon> rovarga: thanks
17:53:22 <colindixon> #und
17:53:24 <colindixon> #undo
17:53:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2498450>
17:53:25 <colindixon> #undo
17:53:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x254f710>
17:53:26 <colindixon> #undo
17:53:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2498990>
17:53:34 <colindixon> #link https://docs.google.com/presentation/d/16c-NT19x3dbPrTjPIV5WxKcKrFfURsTLBD4D5n-pOCo/edit#slide=id.g10faa1e6d3_1_16 sldies
17:53:39 <colindixon> #info OVSDB has had two halves since nearly the beginning of OpenDaylight, an OVSDB SB plugin and a Neutron OpenStack plugin using that SB plugin (and OpenFlow plugin)
17:54:53 <colindixon> #info the main reason for the split is to separate the part that lots of other projects use (the SB) from the one that others mostly don't (NetVirt) this will fix offset issues and a dependency cycle with SFC
17:55:16 <colindixon> #info also OSVSDB said they'd do this when their scope was revised during Beryllium
17:56:55 <colindixon> #info rovarga says htanks for following up
17:57:20 <zxiiro> +1 thanks for doing this. It'll make releasing much easier for releng.
17:58:27 <colindixon> #info colindixon asks how we can up with the list of committers, shague says the only difference is adding Andre and removing Flavio voluntarily from the list
17:58:48 <colindixon> #info colindixon notes that in the past there was contention over the project being named netvirt, asks if anyone has issues with that
17:58:54 <colindixon> #info nobody seems to
17:59:42 <gkaempfer> actually the name isn't ideal, but IMO it would be more confusing to change the name at this stage
18:00:20 <colindixon> #startvote shall the TSC create teh NetVirt project as an mature project as a spin out of the OVSDB project which is also mature? -1,0,+1
18:00:20 <odl_meetbot> Begin voting on: shall the TSC create teh NetVirt project as an mature project as a spin out of the OVSDB project which is also mature? Valid vote options are -1, 0, +1.
18:00:20 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:00:26 <rovarga> #vote +1
18:00:27 <LuisGomez> #vote +1
18:00:27 <dfarrell07> #vote +1
18:00:28 <colindixon> #vote +1
18:00:31 <mohnish_> #vote +1
18:00:33 <ChrisPriceAB> #vote +1
18:00:33 <gkaempfer> #vote +1`
18:00:33 <odl_meetbot> gkaempfer: +1` is not a valid option. Valid options are -1, 0, +1.
18:00:38 <gkaempfer> #vote +1
18:00:41 <colindixon> #endvote
18:00:41 <odl_meetbot> Voted on "shall the TSC create teh NetVirt project as an mature project as a spin out of the OVSDB project which is also mature?" Results are
18:00:41 <odl_meetbot> +1 (7): gkaempfer, rovarga, LuisGomez, ChrisPriceAB, dfarrell07, colindixon, mohnish_
18:01:01 <ChrisPriceAB> the only issue I have with making it mature is the committers are not the original committers.  makes me wonder where  the line is
18:01:03 <dfarrell07> congrats OVSDB, and thanks again for doing it
18:01:05 <colindixon> #agreed the NetVirt project is now a mature project
18:01:24 <colindixon> #info ChrisPriceAB notes that the only issue I have with making it mature is the committers are not the original committers.  makes me wonder where  the line is
18:01:27 <shague> Thanks!
18:01:48 <dfarrell07> colindixon: don't forget to endmeeting
18:01:58 <rovarga> colindixon: and cookies!
18:01:59 <rovarga> :)
18:02:06 <colindixon> #action colindixon to start a thread on how split out projects inherit or don't their parent project's lifecycle state, but notes in this case (OVSDB) when ediscussed it before we had agreed it would be done this way
18:02:09 <colindixon> #topic cookies
18:02:12 <colindixon> #endmeeting