17:00:33 <colindixon> #startmeeting tsc
17:00:33 <odl_meetbot> Meeting started Thu Apr 21 17:00:33 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:33 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:33 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:38 <colindixon> #topic agenda bashing and roll call
17:00:41 <gkaempfer> #info gkaempfer
17:00:43 <colindixon> TSC members please #info in
17:00:45 <colindixon> #info colindixon
17:00:59 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=45625#Agenda the agenda
17:01:08 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-04-14-17.01.html last week's minutes for action items
17:01:45 <gkaempfer_> #info gkaempfer
17:01:47 <colindixon> #action colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest and a TWS
17:02:05 <edwarnicke> #info edwarnicke
17:03:01 <LuisGomez> #info LuisGomez
17:03:33 <colindixon> #link https://lists.opendaylight.org/pipermail/discuss/2016-April/006441.html planning the next TWS's including OpenFlow and Carbon planning
17:04:02 * dfarrell07 is having irc problems
17:04:02 <abhijitkumbhare> Hi - is the TSC meeting on?
17:04:15 <tykeal> I see things
17:04:15 <ebrjohn> will the ODL TSC be cancelled next week for OpenStack?
17:04:17 <colindixon> abhijitkumbhare: yes
17:04:33 <colindixon> #action abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation
17:04:54 <abhijitkumbhare> ChrisPriceAB sent me a text to sub for him today
17:04:56 <colindixon> https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-04-21-17.00.log.txt
17:05:29 <dfarrell07> #info Daniel Farrell
17:05:34 <colindixon> #action abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation
17:05:43 <colindixon> #action colindixon to make clarifications to the release plan per https://lists.opendaylight.org/pipermail/release/2016-April/006166.html
17:05:50 <colindixon> #action colindixon to reach out to tykeal else to write up and send an e-mail about signing commits in gerrit
17:05:55 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
17:05:58 * dfarrell07 is still seeing lots of irc lag
17:05:59 <abhijitkumbhare> #info abhijitkumbhare for ChrisPriceAB
17:06:04 <phrobb> #info colindixon gkaempfer_ edwarnicke LuisGomez dfarrell07 abhijitkumbhare  We have quorom
17:07:25 <colindixon> #info edwarnicke says he thinks he's been signing his commits for over a year now, and there's now something new for push signing which is what colindixon and tykeal are talking about
17:07:47 <edwarnicke> phrobb: Thanks :)
17:07:52 <colindixon> #topic TSC mailing list vortes and discussions
17:08:05 <edwarnicke> tykeal: Got a link for push signing?
17:08:27 <colindixon> #info there is a TSC commiitter-at-large election going on right now, if you think you should have a voting invite and don't, reach out to phrobb
17:08:44 <ebrjohn> Sorry guys, but I didnt hear anything about the TSC next week: will the ODL TSC be cancelled next week for OpenStack??
17:09:17 <dfarrell07> ebrjohn: I think so (it will be cancled), there's a thread that seems to have voted that way
17:09:32 <ebrjohn> dfarrell07: ok, thanks!
17:09:55 <edwarnicke> phrobb: What is the subject for the vote invitation emails?  I don't see one...
17:11:00 <tykeal> edwarnicke: https://git-scm.com/docs/git-push but that's just client side. Gerrit requires that you upload your GPG public key to your Gerrit account too ;)
17:11:12 <mohnish> #info mohnish anumala
17:13:19 <zxiiro> what about OpenStack, is OPNFV asking them to release faster too?
17:13:25 * zxiiro is just curious
17:19:28 <colindixon> #agree based on the 0s, and -1s for having a meeting next week, we will skip next week's TSC meeting as many people will be otherwise occupied
17:19:28 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-April/005085.html  more frequent ODL releases
17:19:33 <colindixon> #agree based on the 0s, and -1s for having a meeting next week, we will skip next week's TSC meeting as many people will be otherwise occupied
17:20:23 <colindixon> #info ebrjohn, edwarnicke, dfarrell07, and colindixon talk about ways we could ship fixes faster than every 3 months to downstream, dfarrell07 metions autorelease-based rpms as one way
17:20:37 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-April/005091.html  split-out projects and lifecycle states
17:22:52 <colindixon> #action colindixon and anipbu2 to make sure that we get e-mail votes to release Beryllium-SR2 despite having no TSC meeting and people being at OpenStack
17:23:26 <colindixon> #topic events
17:23:34 <colindixon> #link https://www.opendaylight.org/global-events
17:23:38 <colindixon> #info openstack next week
17:23:50 <CaseyODL> #link https://wiki.opendaylight.org/view/Community/2016-openstack-summit-booth
17:24:45 * ebrjohn finally wont have to deal with the jet lag at OPNFV Berlin :)
17:24:47 <colindixon> edwarnicke, ChrisPriceAB, abhijitkumbhare (if you have the delagation), could you vote on Vasu as a committer on the TSC mailing list
17:25:11 <colindixon> #info info the CFP for the ODL summit in september closes May 6th (which is coming up very quilckly)
17:25:40 <colindixon> #link http://events.linuxfoundation.org/events/opendaylight-summit/program/cfp ODL summit in september's CFP
17:25:44 <abhijitkumbhare> I don’t have ChrisPriceAB mailing list delegation
17:26:10 <zxiiro> I've been having issues too
17:26:25 <colindixon> https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-04-21-17.00.log.txt
17:26:56 <colindixon> #topic boron
17:27:19 <anipbu2> #info we would like projects to 1) review their pom files, 2) remove the <nexusproxy> property, and 3) update the nexus URL from *http://nexus.opendaylight.org* to *https://nexus.opendaylight.org*
17:27:25 <anipbu2> #link https://wiki.opendaylight.org/view/Weather#Nexus_URL_requires_HTTPS   <--- Weather item for Nexus URL
17:27:52 <anipbu2> #info There are currently some breakages while building odlparent as described in Bug 5775.  Thanh has submitted Patch 37980 and hopefully the autorelease build should pass tonight.
17:28:06 <anipbu2> #info Boron M2 Offset 1 is due today.  Please send your status report.
17:28:28 <colindixon> #topic stable/beryllium
17:28:55 <anipbu2> #info Beryllium SR2 cut off is this Sunday on April 24, 2016 at 11:59PM UTC with a release date of April 28, 2016 with a cutoff.  Note that after cutoff, the Beryllium branches will be locked.
17:29:00 <anipbu2> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Schedule   <--- Beryllium SR2 schedule
17:29:22 <anipbu2> #info There are test failures in the Beryllium Autorelease Build for groupbasedpolicy and tsdr.  Those projects should address the issues before the cutoff.
17:29:26 <anipbu2> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-beryllium/133/testReport/   <--- Beryllium Autorelease Build Test Failures
17:29:42 <colindixon> #topic system integration and test
17:29:53 <colindixon> #info jamoluhrsen says everything he was going to say anipbu already covered
17:30:01 <colindixon> #topic infrastructure
17:30:42 <colindixon> #info tykeal says that sonar was migrated in the private cloud yesterday, and now the jenkins plugin which created a short jenkins downtime
17:31:03 <colindixon> #info the only stuff that needs to be moved into the private cloud is releng and sandbox jenkins silos
17:31:20 <colindixon> #info tykeal says there are a few jenkins silos for semi-archived projects
17:31:39 <colindixon> #action tykeal to e-mail the TSC with the list of semi-archived silos to figure out how to procede
17:32:31 <colindixon> #topic JSON RPC 2.0 Plugin
17:32:37 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:JSON-RPC2.0-plugin
17:32:56 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2016-April/000473.html proposed on 4/7/2016
17:33:36 <colindixon> #action anton will post the slides immediately after the call
17:34:35 <colindixon> #info the goal is to have a way to put data, RPCs, and notifications in and out of ODL using JSON-RPC 2.0
17:35:36 <colindixon> #info use IETF draft-netmod-json-yang to provide the conents of the RPCs
17:35:55 <colindixon> #info first transports for the JSON-RPC will be zero MQ, HTTP(s), and maybe more later
17:37:48 <colindixon> #info this will reuese as much as possible from ODL including using the JSON ser/des
17:39:27 <edwarnicke> Looking at JSON RPC 2.0, it looks like you could reuse the existing JSON ser/des of the actual DTOs and RPC/Notification Bodies, with some additional stuff wrapped around for the JSON RPC 2.0 stuff... am I understanding correctly?
17:39:44 <colindixon> #Info one major targetted gap is working with YANG modeled data outside of the JVM and ODL propper
17:40:21 * edwarnicke is amused that the toaster will always be with us ;)
17:40:58 <colindixon> #info things brought on day zero: zero MQ transport, JSON RPC stack, BI extension supporting outbound data/rpcs/notifications, YANMG modeled data for applications outside java, e.g., for now Python
17:43:21 <colindixon> #info ed asks what JSON schema, they're using, anton says for now a simple custom one, edwarnicke notes that there is not a canonical one yet
17:44:18 <edwarnicke> edwarnicke: would also be shocked if a canonical json schema representation ever emerged
17:44:48 <colindixon> #info anton clarifies that this is using YANG schemas to model the json, not something else new
17:47:25 <colindixon> #info phrobb notes that zero MQ might cause problems with licenses
17:49:42 <colindixon> #Info rovarga says that we could package zero MQ outside of ODL to make that OK
17:50:36 <colindixon> #info going forward, they are looking into othe transports, other language bindings, and inbound ODL interfaces to have full-fledged YANG modules outside the JVM
17:56:14 <colindixon> #info somebody asks if they have expectations for the performance of this, anton says that the performance of the message queues is very fast, but the the bottleneck tends to be in JSON ser/des
17:56:30 <gkaempfer_> somebody == gkaempfer
17:56:52 <colindixon> gkaempfer_: I thought so
17:56:54 <colindixon> #undo
17:56:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2924050>
17:57:01 <colindixon> #info gkaempfer_ asks if they have expectations for the performance of this, anton says that the performance of the message queues is very fast, but the the bottleneck tends to be in JSON ser/des
17:58:19 * edwarnicke notes that the toaster will always be with us
17:58:35 <colindixon> #info anton says performance goals are later, focusing on working now
17:58:49 <colindixon> #info anton does a demo where he imports the YANG generated python file starting with the toaster model
17:59:02 <edwarnicke> +1 to starting a vote
17:59:20 <colindixon> #startvote shall the TSC approve the jsonrpc project as an incubation project? -1,0,+1
17:59:20 <odl_meetbot> Begin voting on: shall the TSC approve the jsonrpc project as an incubation project? Valid vote options are -1, 0, +1.
17:59:20 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:59:25 <dfarrell07> #vote +1
17:59:25 <edwarnicke> #vote +1
17:59:26 <LuisGomez> #vote +1
17:59:27 <gkaempfer_> #vote +1
17:59:29 <mohnish> #vote +1
17:59:32 <colindixon> #vote +1
17:59:34 <abhijitkumbhare> #vote +1
17:59:37 <colindixon> #endvote
17:59:37 <odl_meetbot> Voted on "shall the TSC approve the jsonrpc project as an incubation project?" Results are
17:59:37 <odl_meetbot> +1 (7): gkaempfer_, LuisGomez, dfarrell07, edwarnicke, mohnish, colindixon, abhijitkumbhare
17:59:45 <colindixon> #agreed the jsonrpc project is now an incubation project
17:59:46 * dfarrell07 has to run to cperf meeting very soon
18:00:07 <dfarrell07> colindixon: taking part in Boron release?
18:00:09 <colindixon> dfarrell07: yeah
18:00:37 <phrobb> #info Please note this approval is based on successful passing of Inbound Code Review
18:00:50 <edwarnicke> no objection to it joining Boron, agree with colindixon 's tendency to be a stickler for capturing that via vote
18:00:54 <anipbu> which offset?
18:01:21 <colindixon> #startvote shall the TSC allow the jsonrpc project to join boron at offset 2? -1,0,+1
18:01:21 <odl_meetbot> Begin voting on: shall the TSC allow the jsonrpc project to join boron at offset 2? Valid vote options are -1, 0, +1.
18:01:21 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:01:28 <colindixon> #vote +1
18:01:29 <dfarrell07> #vote +1
18:01:32 <gkaempfer_> #vote +1
18:01:33 <mohnish> #vote +1
18:01:34 <abhijitkumbhare> #vote +1
18:01:34 <LuisGomez> #vote +1
18:01:47 <colindixon> #endvote
18:01:47 <odl_meetbot> Voted on "shall the TSC allow the jsonrpc project to join boron at offset 2?" Results are
18:01:47 <odl_meetbot> +1 (6): gkaempfer_, LuisGomez, dfarrell07, mohnish, colindixon, abhijitkumbhare
18:02:08 <colindixon> #agreed the JSON RPC project can join boron at offset 2
18:04:52 <edwarnicke> #info edwarnicke would have voted +1 above but for IRC lag
18:05:14 <colindixon> #info anton continues the demo and show it working of zmq
18:05:32 <colindixon> #topic cookies
18:05:43 <colindixon> #endmeeting