17:00:30 <colindixon> #startmeeting tsc
17:00:30 <odl_meetbot> Meeting started Thu May 19 17:00:30 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:30 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:30 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:35 <dfarrell07> everyone on the int/* call is late fyi
17:00:37 <colindixon> #topic roll call and agenda bashing
17:00:40 <colindixon> dfarrell07: thanks
17:00:47 <colindixon> TSC members please #info in
17:00:49 <colindixon> #info colindixon
17:00:56 <colindixon> I'll be on the WebEx in 2 minutes
17:00:56 <vishnoianil> #info vishnoianil
17:01:01 <mohnish__> #info mohnish anumala
17:01:06 <dfarrell07> #info Daniel Farrell
17:01:11 <rovarga__> #info rovarga__ proxy for edwarnicke
17:01:38 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=46350#Agenda
17:01:48 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-05-12-17.00.html last week's minutes
17:01:52 <ChrisPriceAB> #info Chris Price
17:02:22 <colindixon> #info the MPLS-TP service/solution creation reviews seem to finally be resolving on the maliing list
17:02:31 <gkaempfer> #info gkaempfer
17:02:57 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-May/005271.html end of the MPLS-TP naming controversy thread
17:03:33 <colindixon> #link https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Upcoming_Meeting_Agendas TWS meeting on docs scheduled for 6/14th, if not before
17:03:39 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main#Split-out_Projects_and_Lifecycle_States rough consensus on split-out projects and lifecycle states
17:03:51 <colindixon> #link https://lists.opendaylight.org/pipermail/documentation/2016-May/000706.html boron documentation review committee
17:03:58 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-May/006578.html discussion about stable features in offset 0 projects
17:04:45 <colindixon> #action dfarrell07 to drive forward tooling and planning for the next TSC election
17:05:18 <colindixon> #action jamoluhrsen to send mail about this moving of non-compliant tests out of distribution-test
17:06:04 <abhijitkumbhare> #info abhijitkumbhare
17:06:11 <colindixon> #link https://lists.opendaylight.org/pipermail/integration-dev/2016-May/006777.html gaps between where we are and where we need to be for stable features
17:06:24 <colindixon> #action colindixon to test signing gerrit commits per tykeal's instructions
17:06:24 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
17:06:25 <colindixon> #action colindixon to send e-mail about possibly moving our documentation toolchain to ReStructured Text => Sphinx => Read The Docs, as opposed to using AsciiDoc => Asciidoctor, which has caused us some pain
17:06:51 * ChrisPriceAB is not able to get audio working...
17:06:59 <colindixon> ChrisPriceAB: anything we can do to help?
17:07:19 <ChrisPriceAB> no, just having issues with loud noises and cutting out.  will persist
17:07:56 <dlenrow> ChrisPriceAB: soldier on
17:08:03 <colindixon> #topic creation reviews (lessons learned from the past)
17:08:36 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-May/005259.html vishnoianil has other questions he'd like to hear answered during creation reviews
17:09:23 <colindixon> #action vishnoianil to add short versions of those questions here: https://wiki.opendaylight.org/view/Project_Proposals:Main#Instructions_for_Submitting_Creation_Review and/or the template here: https://wiki.opendaylight.org/view/Project_Proposals:ABC_Plugin
17:11:24 <colindixon> #topic MPLS TP service/solution creation reviews
17:11:35 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-March/004956.html  MPLS-TP Service Creation Review over e-mail
17:11:46 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-April/005033.html MPLS-TP Solution Creation Review over e-mail
17:12:04 <colindixon> #info per above it looks like one with be SPTN and the other will be POTN for names now
17:12:33 <colindixon> #info if TSC members could chime in if there are any other concerns, otherwise, I'll start a vote for one and make sure the other one is ready to go
17:13:03 * dfarrell07 is off checking the email thread
17:13:12 <colindixon> #topic lifecycle state and split-out projects
17:13:27 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main#Split-out_Projects_and_Lifecycle_States
17:14:13 <ChrisPriceAB> looks good
17:14:34 <dfarrell07> +1, looks good
17:14:56 <ChrisPriceAB> Does that mean the splitting project has to prepare review materials for the meeting?
17:15:37 <colindixon> #info abhijitkumbhare asks about adding a note about age of the split-out code, colindixon notes that we already ask that question as part of a graduation review (history of releases using a mature release process)
17:16:14 <colindixon> https://wiki.opendaylight.org/view/Graduation_Reviews/Template
17:17:25 <vishnoianil> +1 looks good to me
17:18:54 <colindixon> #info gkaempfer asks if there is a way for a project to become less mature, e.g., if it significantly rewrites the code, colindixon says no, not really, though it's come up
17:19:47 <colindixon> #info gkaempfer notes that NetVirt is currently undergoing some significant revision, which might be an example
17:20:08 <colindixon> #info colindixon also notes that beign mature is also (as written) as much, if not more so, about the team as it is about the code in the project
17:21:28 <colindixon> #info colindixon notes that we have a label for features being experimental, which can be used to track if code isn't yet ready for prime time
17:22:39 <tykeal> social maturity
17:22:59 <colindixon> #info gkaempfer's point was around VPN code maturity in NetVirt, which is likely less mature
17:23:07 * ChrisPriceAB feels like he will always be incubated...
17:24:17 <colindixon> #Info colindixon notes that for users, we focus on features, not projects and use the labels, experimental, none, and stable to label them
17:25:11 <colindixon> #topics events
17:25:14 <colindixon> #topic events
17:25:21 <colindixon> #link https://www.opendaylight.org/global-events
17:25:54 <colindixon> #link https://www.opendaylight.org/events/2016-06-01-000000-2016-06-02-000000/global-sdnnfv-tech-conference Global SDN/NFV Tech Conference in China (Neela and Colin there)
17:26:00 <ebrjohn> There's an ODL UG in Madrid next week... in case you happen to be in the neighborhood :)
17:26:15 <colindixon> #link https://www.opendaylight.org/events/2016-06-20-000000-2016-06-23-000000/opnfv-summit OPNFV summit with ODL mini-summit in Berlin
17:26:25 <colindixon> #action phrobb to get the hackfest on the events list
17:26:44 <colindixon> #undo
17:26:44 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x293d9d0>
17:26:59 <colindixon> #action colindixon to find the right person to update the events page with the hackfest information
17:27:27 <colindixon> #topic boron
17:27:50 <anipbu> #info The Boron Autorelease job failed to build vxlan-fabric-ovs-adapter.  We are currently working with the FAAS team to fix the blocking bug as soon as possible.
17:28:04 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=5929
17:28:07 <anipbu> #info We have port conflict issues and are currently working with the VPNService team to resolve the use of port 6644.
17:28:11 <anipbu> # We would like to remind projects to remind projects to review and update the Ports page: https://wiki.opendaylight.org/view/Ports
17:28:14 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=5598
17:28:22 <jamoluhrsen> anipbu, colindixon iotdm hit us with a port conflict too
17:28:26 <anipbu> #info Boron M3 Offset 1 Status is due today (5/19).  Projects please send your status email to the release mailing list.
17:28:33 <colindixon> #info We would like to remind projects to remind projects to review and update the Ports page: https://wiki.opendaylight.org/view/Ports
17:28:38 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-May/006577.html
17:28:43 <colindixon> #undo
17:28:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x28e8610>
17:28:55 <anipbu> #info There are plans to upgrade RESTCONF from draft02 to draft11 in ietf-netconf-restconf.  Draft02 will be deprecated by the end of Boron.
17:29:01 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-May/006577.html upgrading from draft 02 to draft 11 of RESTCONF
17:29:09 <anipbu> #link https://wiki.opendaylight.org/view/Weather#Restconf_Draft11_upgrade_and_code_clean-up
17:29:22 <colindixon> #undo
17:29:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2787490>
17:29:23 <colindixon> #undo
17:29:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x28e8450>
17:29:25 <colindixon> sorry
17:29:41 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-May/006577.html offset 1 M3 due today
17:29:41 <anipbu> #link https://wiki.opendaylight.org/view/Weather#Restconf_Draft11_upgrade_and_code_clean-up  <-- Weather item for RESTCONF
17:29:42 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Restconf_Draft11_upgrade_and_code_clean-up
17:29:58 <abhijitkumbhare> About hackfest update on events page: colindixon I think  there was someone called Pankaj Chawla for website updates - Phil had cc’ed her for the TSC profile update email to ttkacik and me for https://www.opendaylight.org/governance/
17:31:02 <colindixon> #info rovarga__ says that the current plan is to deprecate the draft 02 implementation of RESTCONF if the draft 11 one is done in Boron, but that doesn't necessarily mean it will be removed in Carbon
17:32:52 <colindixon> #info colindixon notes that this will likely result in changes to the REST enpoints for most or all of OpenDaylight REST APIs generated from YANG
17:33:48 <colindixon> #info vishnoianil asks why this is happening, colindixon and rovarga__ say that it's because draft 11 is hoped to be only cosmetically changed through when it becomes an RFC, so moving to it would be moving from the draft to the standard
17:34:35 <colindixon> #info abhijitkumbhare asks what will have to change, short version: any project which uses REST APIs anywhere will need to at least update the URLs, this includes nearly all of our testing
17:35:51 <colindixon> #info vishnoianil asks if it's really just URLs that change, or if it's also the content? rovarga__ says he thinks that the payload has not changed, but that the URLs are totally different
17:36:20 <colindixon> #info ttkacik says that draft 11 might be stricter (but should be the same as our draft 02 implementation)
17:37:38 <colindixon> #info colindixon asks what are the plans if there are actual changes that happen after dratt 11?
17:37:55 <colindixon> #info rovarga__ says that the plan is to track changes as much as possible until RC0
17:38:16 <colindixon> #info colindixon asks if we're runnign the risk of asking people to migrate to an implementation that might change again in the future before it's an RFC
17:39:04 <colindixon> #info rovarga__ notes that he thinks this is very unlikely, even if it's possible, also RFCs can have errata so, the risk might be a lot less
17:40:22 <colindixon> #Info vishnoianil asks that projects not be required to migrate until after carbon, rovarga__ says that removing the draft 02 implementation in carbon isn't the plan of record in carbon
17:41:07 <colindixon> #info vishnoianil asks if the plan isn't to remove it until after carbon, why not deprecate it in carbon and leave it alone in boron?
17:42:43 <colindixon> #info rovarga__ says that's to signal that the code is planned to eventually be removed and projects should move toward the new one
17:45:00 <colindixon> #Info colindixon notes that it doesn't seem quite that clear-cut: it's not obvious that a developer would want to pick up a newer implementation and closer to final API over a more mature implementation, but an API (and implementation) that is eventually going to die
17:46:56 <colindixon> #info rovarga__ notes that they've done this a few times, where APIs have stayed deprecated across more than a few releases
17:48:54 <vishnoianil> +1 to have TSC on restconf implementation
17:49:00 <colindixon> #info abhijitkumbhare also ask about deprecating it in carbon instead of boron with a release note in boron, rovarga__ asks what the mechanical difference would be
17:49:08 <vishnoianil> s/TSC/TWS
17:49:16 <colindixon> #action colindixon to try schedule a TWS on RESTCONF draft 11
17:49:41 <colindixon> #topic stable/beryllium
17:49:54 <colindixon> #info nothing this week
17:50:04 <colindixon> #topic infrastructure
17:50:18 <colindixon> #info we are scheduled to do the sandbox cut-over to the private cloud this weekend
17:50:50 <colindixon> #info those people that are using the sandbox presently are going to have to cherry-pick in some patches that are currently drat status to make JJB and maniifests simpler in the long run
17:51:25 <colindixon> #info the production jenkins system migration is planned (tentatively) for the weekend of June 4th
17:51:33 <colindixon> #info that will be a significant outage
17:52:09 <tykeal> system test?
17:52:10 <colindixon> #topic TSC chair elections
17:52:34 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-May/005242.html call for nominations for TSC chair
17:52:50 <ChrisPriceAB> hahahahahahaha  *cry
17:52:54 <abhijitkumbhare> :)
17:53:40 <colindixon> #info it was supposed to close yesterday, my guess is if you still want to nominate yourself, there's still time
17:54:36 <rovarga__> well .. we could vote on that :-D
17:55:05 <colindixon> #info phrobb isn't here, since he's running the process, he will handle the election (or lack thereof) next week
17:55:12 <colindixon> #topic system integration and test
17:56:12 <colindixon> #info the integration group would like to reopen the old repo and remove all files in it, to be replaced by a README pointing to the new code, to minimize confusion
17:56:23 <ChrisPriceAB> sounds like a reasonable request given the confusion caused by keeping it.
17:56:43 <abhijitkumbhare> +1
17:57:01 <colindixon> #startvote shall the TSC allow the integration group to remove the contents of the ingetration repo, but keep the history, despite it being archived? -1, 0, +1
17:57:01 <odl_meetbot> Begin voting on: shall the TSC allow the integration group to remove the contents of the ingetration repo, but keep the history, despite it being archived? Valid vote options are -1, 0, +1.
17:57:01 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:57:12 <dfarrell07> #vote +1
17:57:12 <abhijitkumbhare> #vote +1
17:57:13 <ChrisPriceAB> #vote +1
17:57:13 <colindixon> #vote +1
17:57:16 <mohnish__> #vote +1
17:57:19 <vishnoianil> #vote +1
17:57:22 <gkaempfer> #vote +1
17:57:23 <rovarga__> #vote +1
17:57:27 <ttkacik> #vite +1
17:57:35 <ttkacik> #vote +1
17:57:36 <colindixon> #endvote
17:57:36 <odl_meetbot> Voted on "shall the TSC allow the integration group to remove the contents of the ingetration repo, but keep the history, despite it being archived?" Results are
17:57:36 <odl_meetbot> +1 (9): mohnish__, gkaempfer, ChrisPriceAB, dfarrell07, colindixon, ttkacik, abhijitkumbhare, rovarga__, vishnoianil
17:58:14 <colindixon> #agree the integration project can commit a change change removing all files and replace it with a README
17:58:42 <colindixon> #topic cookies
17:58:48 <colindixon> #endmeeting