17:00:23 <colindixon> #startmeeting tsc
17:00:23 <odl_meetbot> Meeting started Thu Jul  7 17:00:23 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:23 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:23 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:27 <colindixon> #topic agenda bashing and roll call
17:00:33 <gkaempfer> #info gkaempfer
17:00:33 <colindixon> TSC memembers please #info in
17:00:38 <ChrisPriceAB> #info Chris Price
17:00:39 <colindixon> #info colindixon
17:00:48 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=47492#Agenda the agenda in it's usual place
17:00:52 <ttkacik> #info Tony Tkacik
17:01:09 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-06-23-17.00.html last week's meeting minutes
17:01:48 <dfarrell07> #info Daniel Farrell
17:02:15 * dfarrell07 is working on TSC elections TODO, please carry over colindixon
17:02:37 <vishnoianil> #info Anil Vishnoi
17:02:44 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
17:02:54 <colindixon> #action phrobb and dfarrell07 to drive forward tooling and planning for the next TSC election (TWS?)
17:03:20 <colindixon> #action vishnoianil, phrobb and abhijitkumbhare to schedule a meeting to discussion the project categorization, so that it can be helpful for users who wants to propose a project proposal and looking for all the relevant projects in that scope.
17:03:25 <Prem_> #info Prem (for Abhijit K)
17:03:36 <mohnish__> #info mohnish anumala
17:03:54 <colindixon> #action skitt or colindixon to work on removing the ancient org.eclipse dependencies in controller (and elsewhere?)
17:04:44 <colindixon> #action phrobb to work on having a policy for how attendance to design forums works going forward with community involvement
17:04:56 <colindixon> #action phrobb or colindixon to figure out how to communicate the fact that not just people with commits can attend the design forum
17:05:45 <colindixon> #topic  TSC mailing list votes and discussions
17:06:11 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-June/005407.html  Asking the Board to Remove the Singularity Principle
17:06:34 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-June/005428.html Fast and/or Phased Planning for the Carbon Release
17:06:52 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-June/005377.html  Additional questions in the Project Proposal Template
17:07:40 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-June/005475.html OpenDaylight has a new Director of Ecosystem Development: Lisa Caywood (@RealLisaC on twitter)
17:08:16 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005539.html  escalation process we have in OpenDaylight
17:08:38 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005538.html  better understanding the wiki search engine whitelist
17:09:02 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005540.html  removing "draft" from committer promotion process
17:09:32 <ChrisPriceAB> Yep
17:09:35 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Committer_Promotion_Process#Nomination_for_committer_promotion the actual document
17:09:59 <ChrisPriceAB> Consensus == lack of objection
17:10:11 <jamoluhrsen> remove draft is fine.
17:10:19 <mohnish__> I am okay
17:10:20 <ChrisPriceAB> +1 to formalizing
17:10:21 <colindixon> #info colindixon asks if anyone objects to taking draft off of the process
17:10:22 * dfarrell07 does not object
17:10:30 <anipbu> no objections
17:10:50 <colindixon> #agree the committer promotion process here is no long a draft: https://wiki.opendaylight.org/view/TSC:Committer_Promotion_Process#Nomination_for_committer_promotion
17:11:00 <colindixon> #action colindixon to remove draft from the committer promotion process
17:11:17 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005499.html  having one TSC meeting a month at an APAC-friendly time
17:12:28 <colindixon> #link https://www.timeanddate.com/worldclock/meetingdetails.html?year=2016&month=7&day=21&hour=3&min=30&sec=0&p1=771&p2=33&p3=283&p4=263&p5=37 9a India, 11:30a China, 8:30p pacific, 11:30p eastern, and 5:30a central Europe
17:13:02 <colindixon> #link https://www.timeanddate.com/worldclock/meetingdetails.html?year=2016&month=7&day=21&hour=8&min=0&sec=0&p1=771&p2=33&p3=283&p4=263&p5=37 1:30p India, 4p China, 1a pacific, 4a eastern, 10a central Europe
17:13:10 <Prem_> This is a good idea and would increase participation
17:14:01 <colindixon> #link https://www.timeanddate.com/worldclock/meetingdetails.html?year=2016&month=7&day=21&hour=2&min=0&sec=0&p1=771&p2=33&p3=283&p4=263&p5=37 8:30a India, 10a China, 7p pacific, 10p eastern, 4a in CET
17:14:46 * ChrisPriceAB is comfortable in his misery
17:15:05 <colindixon> #undo
17:15:05 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2353a10>
17:15:13 <colindixon> #link https://www.timeanddate.com/worldclock/meetingdetails.html?year=2016&month=7&day=21&hour=2&min=0&sec=0&p1=771&p2=33&p3=283&p4=263&p5=37 7:30a India, 10a China, 7p pacific, 10p eastern, 4a in CET
17:16:10 <colindixon> #info Prem_ points out we need to also look at DST and how it affects things
17:16:43 <colindixon> #info vishnoianil asks if anyone is asking for this, Prem_ says it would help people he knows, colindixon notes that it's come up on his trips Chia
17:17:09 <colindixon> #info davidmichaelkarr points out that we should ask peole in the time zones where this sucks if it helps them or not
17:18:01 <colindixon> #action colindixon to set up a condorcet election with PTLs and TSC members as voters and the 3 options + don't have an alternate meeting as options
17:19:36 <gkaempfer> I would separate the vote of yes/no and the vote on when. Otherwise I think we know the outcome...
17:20:16 <colindixon> #info colindixon also notes that having a home office is not as common in India and China, which means asking them to attend is asking them to be *in the office* at that time
17:20:18 <gkaempfer> if all agree, then leave out the "don't move" option
17:20:44 <colindixon> #info vishnoianil points out we need to make sure we get a quorum of TSC members
17:22:23 <colindixon> #action colindixon to make sure there's a place for feedback with the vote
17:22:55 <colindixon> #info mohnish__ asks aout as-need basis, colindixon and Prem_ point out that as-needed ususally winds up meaning it doesn't happen
17:25:40 <colindixon> #info anipbu asks if we've polled APAC members, colindixon says no, but he doesn't even know who to poll because they mostly don't attend, ttkacik notes that for the TSC we probably do know: it's PTLs, TSC members, and maybe committers, for TWS it might make more sense to be broader
17:26:06 <colindixon> #topic events
17:26:15 <colindixon> #link https://www.opendaylight.org/global-events
17:26:41 <colindixon> #link https://www.opendaylight.org/events/linuxcon-japan linuxcon japan in Tokyo next week
17:26:51 * dfarrell07 has a talk and a keynote panel in LinuxCon Tokyo
17:27:21 <colindixon> #linux https://www.opendaylight.org/events/linuxcon-north-america  August 22, 2016 LinuxCon North America Toronto, Canada
17:27:21 <dfarrell07> #info dfarrell07 has a talk and a keynote panel in LinuxCon Tokyo
17:27:33 <colindixon> #info the OpenDaylight summit in Septemer
17:27:35 <colindixon> #undo
17:27:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2460350>
17:27:38 <colindixon> #info the OpenDaylight summit in September
17:27:41 <colindixon> #chair anipbu
17:27:41 <odl_meetbot> Current chairs: anipbu colindixon
17:28:05 <colindixon> #info the CFP for OpenStack Barcelona closes on 7/13
17:28:12 <colindixon> #undo
17:28:12 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2460210>
17:28:16 <colindixon> #info the CFP for OpenStack Barcelona closes on 7/13 (that's next week)
17:28:33 <colindixon> #link https://www.opendaylight.org/events/opendaylight-forum-india November 16, 2016 OpenDaylight Forum India Bengaluru
17:29:08 <gkaempfer> Is there a CFP for the ODL DDF? (at the ODL Summit)
17:29:09 <colindixon> #info CFP for India ODL forum closes 8/3
17:29:35 <tykeal> DDF is an out of band thing IIRC
17:29:55 <colindixon> #info gkaempfer asks if we have CFPs for developer design forums, colindixon says we haven't in the past, we've done it out-of-band via e-mail/wiki
17:30:12 <colindixon> #action phrobb to create a wiki page with topics for the September DDF
17:30:27 <colindixon> #topic boron
17:31:03 <anipbu> #info The Boron Autorelease job is currently failing to build bgp-rib-impl.
17:31:05 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/41354/   <--- Patch Fixing
17:31:34 <anipbu> #info Reminder to Offset 0 projects that code freeze was last week and to please send in the M5 Status: aaa, controller, infrautils, mdsal, netconf, yangtools
17:32:16 <anipbu> #info We will be upgrading ietf-{inet,yang}-types with the plan to merge independent patches first, obtain +2 for dependant patches, obtain TSC approval for superpowers to merge all together during an IRC working session.
17:32:24 <anipbu> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=778533050
17:33:18 <ttkacik> #info bgpcep patch merged
17:34:01 <anipbu> ttkacik: thanks!
17:34:16 <lori> here's the weather event associated: https://wiki.opendaylight.org/view/Weather#Upgrade_ietf-.7Binet.2Cyang.7D-types_to_2013-07-15
17:34:36 <ttkacik> Anipbu: somehow people forget that I am commiter on bgpcep :D
17:34:39 <colindixon> anipbu: I don't know that you necessarily need superpowers if proejcts have +2ed things, right?
17:34:54 <ChrisPriceAB> No opposition, go with it...
17:35:10 * dfarrell07 is in the "go for it" and we'll fix the breakages camp
17:35:12 <lori> colindixon: I think you do, because I have seen some patches with +2 on them but no submit button
17:36:15 <colindixon> #info colindixon points out that this is a trade-off either way, we leave it there and stay behind the standard for another six months or we try to push forward and fix any unexpected breakages, there has been some testing
17:40:16 <colindixon> #startvote shall the TSC allow the release team to +2 (if needed) and submit patches that have already been +1ed or +2ed by the a committer of that project to help migrate to the new ieft types? -1,0,+1
17:40:16 <odl_meetbot> Begin voting on: shall the TSC allow the release team to +2 (if needed) and submit patches that have already been +1ed or +2ed by the a committer of that project to help migrate to the new ieft types? Valid vote options are -1, 0, +1.
17:40:16 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:40:32 <dfarrell07> #vote +1
17:40:37 <colindixon> #vote +1
17:40:40 <mohnish__> #vote +1
17:40:41 <vishnoianil> #vote +1
17:40:42 <Prem_> #vote +1
17:40:47 <gkaempfer> #vote +1
17:40:50 <ttkacik> #vote +1
17:40:51 <ChrisPriceAB> #vote +1
17:41:02 <colindixon> #endvote
17:41:02 <odl_meetbot> Voted on "shall the TSC allow the release team to +2 (if needed) and submit patches that have already been +1ed or +2ed by the a committer of that project to help migrate to the new ieft types?" Results are
17:41:02 <odl_meetbot> +1 (8): mohnish__, gkaempfer, dfarrell07, ChrisPriceAB, colindixon, ttkacik, Prem_, vishnoianil
17:41:32 <colindixon> #agree the release engineering team can +2 (if needed) and submit patches that have already been +1ed or +2ed by the a committer of that project to help migrate to the new ieft types
17:41:52 <colindixon> #info ttkacik and colindixon say that in the future, we shoudl try to make this +2 and not +1 or +2
17:42:21 <colindixon> #action anipbu to send an e-mail explaining the plan for merging patches concerning the ietf types upgrade to release (and thus all PTLs)
17:43:48 <colindixon> #info anipbu asks if 7a pacific, on wednesday 7/13 would be a good time to do the process on IRC, noboy objects, jamoluhrsen won't be able to join until 8:30a
17:44:12 <colindixon> #topic stable/beryllium
17:44:35 <anipbu> #info there are autorelease build test failures in bgpcep.   Kindly request to fix before the Beryllium SR3 Cutoff
17:44:41 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-beryllium/211/   <--- BGPCEP Autorelease Build Test Failures
17:45:29 <colindixon> #info tpanteli says that it might be the same as master, jamoluhrsen says they look different
17:45:54 <colindixon> #topic system integration and test
17:46:14 <colindixon> #info jamoluhrsen and anipbu would like to remind people to get system tests in order or risk being labeld experimental
17:46:18 <colindixon> #topic infrastructure
17:46:50 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-July/007108.html Ongoing issues with the migration to the private cloud
17:47:17 <colindixon> #info migration to the private cloud finished on 6/25 and 6/26, we've been seeing some pain, but it's been decreasing
17:47:28 <colindixon> #info there is no way to move back sanely at this point, or we would have
17:47:52 <colindixon> #info build minions are all single-use instances to avoid losing hung jobs, this has helped the queue a lot
17:48:21 <colindixon> #info all jobs now how a 6 hour timeout by default, but it's adjustable, times that had different timeouts should still have them
17:48:26 <colindixon> #undo
17:48:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x25974d0>
17:48:31 <colindixon> #info all jobs now have a 6 hour timeout by default, but it's adjustable, times that had different timeouts should still have them
17:48:56 <colindixon> #info we're adjusting our instances and types of instances to keep the queue reasonable
17:49:36 <colindixon> #info tykeal is working with rackspace to redesign how we use the public cloud so that we can burst into the public cloud, we would then to performance, integration, and long-running testing back into the public cloud to alleviate burden
17:51:03 <colindixon> #info we have lots of tests failing because we have less CPU available, people are trying to fix it for some places where it's just timeouts
17:51:34 <colindixon> #info right now, we can't change the CPU per job or per-project, but zxiiro is working on our JJB templates to make that possible
17:51:48 <colindixon> #info we are seeing some timeouts to nexus and that's being investigated now
17:52:39 <colindixon> #info colindixon asks if there's a reason to the private cloud is resource constrained, and is there a way to fix it?
17:53:26 <colindixon> #info tykeal says when we asked rackspace to build a private cloud for us, our budget limited us to 192 CPUs in the private cloud, which was theoretically unlimited
17:54:52 <colindixon> #info solutions: 1.) get board approval to get more h/w in our private cloud, 2.) enable bursting into the public cloud
17:55:17 <colindixon> #info tykeal is hoping to have the public cloud up and working by the end of next week, but it's not certain
18:01:30 <colindixon> #info CaseyODL asks for local meetup leaders to respond to his e-mail
18:01:38 <colindixon> #topic cookies
18:01:48 <colindixon> #endmeeting