17:00:06 <colindixon> #startmeeting tsc
17:00:06 <odl_meetbot> Meeting started Thu Sep 15 17:00:06 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:06 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:06 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:10 <colindixon> #topic agenda bashing and roll call
17:00:16 <colindixon> TSC members please #info in
17:00:25 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=49790#Agenda the agenda
17:00:26 <gkaempfer> #info gkaempfer
17:00:33 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-09-08-17.00.html last week's meeting minutes
17:00:55 <colindixon> #link http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f447623d29817bc7 if we have time, we can go over the APAC time poll results, but we'll see
17:01:03 <ChrisPriceAB> #info chris price
17:01:05 <colindixon> #action colindixon to add APAC time TSC meeting to next week's meeting agenda http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f447623d29817bc7
17:01:10 <vishnoianil> #info Anil Vishnoi
17:01:15 <abhijitkumbhare> #info abhijitkumbhare
17:01:24 <colindixon> #action rovarga will follow up with jira, group management, and user provisioning
17:01:26 <adetalhouet> #info adetalhouet
17:01:34 <colindixon> #action dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
17:02:21 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-September/008306.html thread on better tracking per-project committer activity and liveness
17:02:33 <colindixon> #info colindixon
17:02:46 <edwarnicke> #info edwarnicke
17:02:48 <rovarga> #info rovarga for jmedved
17:03:14 <dfarrell07> #info Daniel Farrell
17:03:27 <colindixon> #topic TSC mailing list votes and discussions
17:03:31 <colindixon> #info see the agend for older ones
17:03:51 <colindixon> #info also see the agenda for issues around Boron, Carbon, Lithium, Beryllium and Elections, which we will get to today
17:04:20 <colindixon> #topic events
17:04:34 <colindixon> #link https://www.opendaylight.org/global-events
17:04:57 <colindixon> #info ODL summit and Carbon Dev Forum is 9/27-30, please register if you haven't already
17:05:15 <colindixon> #link https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum list and look at events here
17:05:47 <abhijitkumbhare> phrobb’s voice sounds distant and soft to me
17:06:13 <colindixon> #info phrobb notes that there are lots of project-specific planning sessions, you should add yours if you want to have one and haven't, we're going to try to do that Thursday morning
17:06:13 <colindixon> phrobb: I missed that, and we need to mute Vina
17:06:18 <adetalhouet> with a little bit of echo
17:06:25 <colindixon> #info the openstack summit is at Barcelona
17:06:41 <colindixon> #undo
17:06:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2ad0410>
17:06:54 <colindixon> #info the openstack summit is at Barcelona in Ocotober, we need a good presence and booth demos, reach out to phrobb  or CaseyODL
17:07:02 <vina_ermagan> colindixon: thanks, Sorry about that
17:07:08 <colindixon> vina_ermagan: no worries
17:07:45 <colindixon> #topic Boron
17:08:09 <anipbu> #info Boron RC3.5 Build 20160912 is ready to be presented to the TSC for approval. All project PTLs or their proxies have voted "GO" to release.  Blocking bugs have been resolved/retargeted and test issues have been signed off as OKAY to release.
17:08:10 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/Status   <--- Status Page
17:08:15 <anipbu> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620   <--- All Projects Vote Go
17:08:20 <colindixon> #chair anipbu phrobb
17:08:20 <odl_meetbot> Current chairs: anipbu colindixon phrobb
17:08:22 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#RC_Download   <--- Boron Artifacts for TSC Approval
17:08:37 <colindixon> anipbu: you can start the vote if you have it ready or I'll prep it
17:09:17 <colindixon> #startvote shall the TSC bless the Boron release as linked to from above? -1,0,+1
17:09:17 <odl_meetbot> Begin voting on: shall the TSC bless the Boron release as linked to from above? Valid vote options are -1, 0, +1.
17:09:17 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:09:19 <abhijitkumbhare> #vote +1
17:09:21 <colindixon> #vote +1
17:09:23 <dfarrell07> #vote +1
17:09:25 <gkaempfer> #vote +1
17:09:25 <ChrisPriceAB> #vote +1
17:09:26 <adetalhouet> #vote +1
17:09:28 <vishnoianil> #vote +1
17:09:36 <rovarga> #vote +1
17:09:43 <adetalhouet> anipbu: great work An! Thank you *very much* for the hard work to everyone involve in getting this out of the door
17:09:53 <colindixon> #endvote
17:09:53 <odl_meetbot> Voted on "shall the TSC bless the Boron release as linked to from above?" Results are
17:09:53 <odl_meetbot> +1 (8): rovarga, gkaempfer, adetalhouet, ChrisPriceAB, dfarrell07, colindixon, abhijitkumbhare, vishnoianil
17:09:53 <gkaempfer> Thank you An!
17:10:01 <colindixon> #agreed Release the Boron!
17:10:02 <jamoluhrsen> super job anipbu !
17:10:06 <dfarrell07> Thanks for all the hard work anipbu! :D
17:10:10 <adetalhouet> Congrats anipbu and al
17:10:12 <vishnoianil> awesome job folks
17:10:12 <ChrisPriceAB> well done all!
17:10:14 <abhijitkumbhare> Great job anipbu
17:10:17 <edwarnicke> #vote +1
17:10:28 <LuisGomez> thanks anipbu
17:10:34 <colindixon> #info note that edwarnicke also voted +1, but late :p
17:10:40 <abhijitkumbhare> and great work many others LuisGomez jamoluhrsen etc.
17:10:48 <anipbu> #info Some project have raised concerns about the timeframe for Boron SR1 on 10/6 with a cutoff on Sunday 10/2 at 23:59 UTC, which gives us only three weeks.  We request TSC to reassess Boron SR1 schedule --->   https://lists.opendaylight.org/pipermail/release/2016-September/008307.html
17:10:52 <anipbu> * Boron-SR1: 10/27/2016
17:10:52 <vishnoianil> and probably that's the first vote that is going out with late vote from edwarnicke :D
17:10:56 <anipbu> * Boron-SR2: 12/15/2016
17:11:00 <anipbu> * Boron-SR3: 3/23/2017
17:11:05 <anipbu> * Boron-SR4: 6/15/2017
17:11:23 <ChrisPriceAB> makes sense
17:11:23 <colindixon> #info thanks to anipbu and everyone else who worked so long and hard to get this out including jamoluhrsen, LuisGomez, etc.
17:11:39 <rovarga> looks good to me
17:12:14 <abhijitkumbhare> I think we should just #agreed
17:12:22 <vishnoianil> looks good to me
17:12:25 <ChrisPriceAB> we seem to have concensus
17:12:28 <colindixon> #agreed the dates here will be the new Boron SR dates: https://lists.opendaylight.org/pipermail/tsc/2016-September/006016.html
17:13:15 <colindixon> #topic stable/beryllium
17:13:18 <ChrisPriceAB> when does the Boron tweet storm officially start?
17:13:18 <anipbu> #info Beryllium SR4 is in one month with a release on October 20, 2016 with a cutoff on Sunday October 16 23:59 UTC.  This will be the last routine SR for Beryllum --->   https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Schedule
17:13:50 <anipbu> #info There is a Beryllium Autorelease Build Test Failure in ClusterAdminRpcServiceTest.testFlipMemberVotingStates.  We kindly request controller to fix the issues --->   https://lists.opendaylight.org/pipermail/controller-dev/2016-September/012648.html
17:14:12 <colindixon> #topic stable/lithium
17:14:19 <anipbu> #info we plan on closing down of the stable/lithium branch and jobs.
17:15:00 <vishnoianil> vote +1
17:15:02 <vishnoianil> :)
17:15:04 <adetalhouet> +1
17:15:08 <abhijitkumbhare> +1
17:15:09 <colindixon> #info this is because we only promise security releases for 2 current releases
17:15:25 <colindixon> #topic carbon
17:15:49 <colindixon> #info M0 is coming on 9/22 (one week from today), M1 is one week from now (10/20)
17:15:52 <anipbu> #info With Carbon M0 on 9/22 and M1 on 10/20, we kindly remind the TSC to update and formally approve the Carbon Simultaneous Release Plan --->   https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan
17:16:05 <anipbu> #info We kindly remind prospective teams of the latest date for project proposal in Carbon is Offset 0: 10/6; Offset 1: 10/13; Offset 2: 10/20 <---   https://lists.opendaylight.org/pipermail/project-proposals/2016-September/000525.html
17:16:27 <anipbu> #info There is a Carbon Autorelease Build Test Failure in UnimgrIT.testCreateAndDeleteEvc.  We kindly request unimgr to fix the issues --->   https://lists.opendaylight.org/pipermail/unimgr-dev/2016-September/000247.html
17:16:33 <colindixon> anipbu: in the future if you #link those instead of #info, you will get clickable links in the notes
17:16:53 <anipbu> colindixon: okay.  thanks.
17:17:04 <anipbu> colindixon: used the keyword
17:17:17 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/006019.html I think the key thing we needed to do beyond what we've done in the past is to consider any modifications to the RC system (tighter restrictions on patches earlier?) and making sure that we have some elements of the plan that will enable us to consider a noticeably different, e.g., fast and/or phased, approach in the future.
17:17:51 <adetalhouet> regarding the project proposal dates, it should be send to a broader audience (not only the project-proposal mailing-list)
17:18:18 <anipbu> adetalhouet: okay will do
17:18:20 <colindixon> #Info colindixon notes that we've already approved the carbon rlease plan schedule dates, just not the "whole enchilada" so to speak
17:18:30 <adetalhouet> anipbu: done already, I added dev + release
17:19:20 <colindixon> #info dfarrell07 notes that we really wanted to try to hammer out fast and/or phased pilot elements durint the dev forum
17:19:35 <adetalhouet> I agree with dfarrell07 that's what I have in mind as well
17:19:48 <colindixon> #action colindixon to add topics to the carbon dev forum around modifying the RC process a bit, and maybe also fast and/or phased
17:21:24 <colindixon> #info colindixon notes that he thinks we've set the most important parts, the dates, so the community probaby has the things it most needs and we can resolve these things over the next bit
17:21:39 <colindixon> #info anipbu basically says, we should formally and fully adopt the release plan sometime soon
17:22:46 <colindixon> #link https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum#Release_Discussion anipbu says this topic will cover revising RCs as soon as possible
17:22:56 <colindixon> #info colindixon says that his take is anipbu can ask projects to delcare intent to participate in carbon now
17:23:29 <vishnoianil> #info https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum#Defining_and_enforcing_our_policies_.28SRs.2C_stable_branches....29
17:23:31 <colindixon> #topic system integration and testing
17:23:37 <colindixon> #info jamoluhrsen says all the fires are out for now
17:23:58 <colindixon> #topic infrastructure
17:24:13 <colindixon> #Info the plague of nexus timeouts should now hopefully be truly behind us
17:24:57 <colindixon> #info after tykeal did tons of testing and back and forth with rackspace have revealed an unknown choke point in our network, we should (as of 90 minutes ago) have no more nexus timeouts
17:25:18 <colindixon> #info the CSIT jobs will still transit that choke point, but should be slow, not timeout
17:26:26 <colindixon> #info we run on a 10G network, boxes have 1G links, all our networks are interconnected by an F5 device
17:26:51 <colindixon> #info it turns out that jenkins to nexus was hairpinning through the F5 device, which had 1G devices, we've fixed that
17:27:27 <colindixon> #info private cloud internal traffic shouldn't touch the F5 device at all
17:27:48 <colindixon> #info we could upgrade the F5 device to 10G, but we need to figure out the cost
17:30:33 <colindixon> #action abhijitkumbhare phrobb tykeal and others to follow up with how to fix the F5 device
17:30:52 <colindixon> #info phrobb asks people to avoid saying Boron is released until 9/21, which is the official big bang
17:31:54 <colindixon> #topic committer promotions
17:32:04 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/006014.html  Successful Mailing List Vote for Michael Vorburger as a committer on infrautils
17:32:16 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/006014.html  Successful Mailing List Vote for Anil Belur as a committer on releng/builder
17:32:27 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/006010.html  Successful Mailing List Vote for Yi Yang as a committer on SFC
17:33:08 <colindixon> #topic upcoming TSC elections
17:33:19 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/005980.html  Successful Mailing List Vote to have the following TSC RGs: Kernel, Protocol/Services, App, Support, Committer at Large (CAL)
17:33:39 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/005971.html  Successful Mailing List Vote to have CAL votes be vote-per-committer, and other RGs be one vote-per-interest
17:34:09 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/006011.html  Ongoing Condorcet vote on allocation of seats to RGs
17:36:12 <colindixon> #info colindixon notes that the official end of the vote is 23:59 UTC
17:36:28 <ChrisPriceAB> that was the 3 way vote with the counting issues right?
17:36:38 <ChrisPriceAB> :)
17:38:03 <ChrisPriceAB> I suggest we do it next week once people understand the result.
17:38:14 <colindixon> #action colindixon to end the poll at 23:59 UTC and send out results
17:39:00 <colindixon> #action phrobb to forward this to the board to get their approval before we kick off the election and nomination process
17:39:22 <colindixon> #action phrobb or anipbu to send out a reminder to make sure projects are categorized they expect
17:39:28 <colindixon> #undo
17:39:28 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2acad90>
17:39:58 <colindixon> #action phrobb or anipbu to send out a reminder to make sure projects are categorized they expect, also to make sure committer lists are accurate and PTLs are accurate because this will affect TSC represtentation in a major way
17:41:01 <colindixon> #info anipbu asks if you need to participate in carbon to be part of the elections, colindixon says (and dfarrell07 confirms) that we have never mentioned anything about SR participation as part of the TSC elections
17:42:05 <colindixon> #info abhijitkumbhare asks about PTL elections, dfarrell07 notes that officially there is no ruling from the TSC about how often PTLs are elected, generally project comitters can call for a new election as they see fit
17:43:32 <colindixon> #info abhijitkumbhare notes that new projects for carbon won't be able to vote, colindixon says that projects which aren't projects at the time of the vote, won't be able to vote
17:43:51 <ChrisPriceAB> agree, freeze tghe list at the start of the process
17:44:32 <colindixon> #info dfarrell07 says his note is that if you are a project, you are able to participate in ongoing events when you become a project, but not before and not retroactively able to participate in ended events
17:46:29 <colindixon> #info rovarga raises the issue that new projects typically come with many committers, who mostly end up being inactive over time, colindixon says his take is that this is orthogonal to the elections and so far hasn't been a real problem
17:47:21 <dfarrell07> #action dfarrell07 to merge vote-per-committer vs vote-per-interest corner case proposal into framework
17:47:48 <abhijitkumbhare> +1 ChrisPriceAB
17:48:34 <colindixon> #info ChrisPriceAB says that they typically freeze the system at the beginning of the process, e.g., if you were not a projecct/committer at the beginning of the election/nomination process, you can't participate
17:49:01 <colindixon> #action colindixon to start a thread on when projects/committers need to be approvied to participate how in elections
17:49:55 <colindixon> #topic incentives for test and bug fixing in releases
17:50:19 <colindixon> #info we had 2-3 really major bugs that seemed like they should have been caught earlier in the boron release cycle
17:51:04 * ChrisPriceAB does like punishing people as well...
17:51:37 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=6440  BUG 6440 in DLUX
17:51:54 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=6591  BUG 6591 in HoneyComb/VBD
17:53:13 <colindixon> #info colindixon notes that we currenty have a frustrating situation where late testing seems to be not particularly disincentivized because the TSC and community will (and have said they will) favor giving better product to users/downstreams over penalizing/punishing late testing
17:53:38 <colindixon> #info vishnoianil also says that blockers will appear to fill all time, so drawing a line in the sand is critical
17:54:01 <colindixon> #info rovarga says he sent a lot of suggestions to anipbu and we can talk about them at the summit/dev forum
17:54:26 <colindixon> #info vishnoianil notes that we're sadly setting a precedent that we will tolerate people testing starting at RC3, and so people do
17:55:04 <colindixon> #info vishnoianil trying to push testing back to RC0 would help everyone
17:55:35 <anipbu> I was talking on mute and wondering why no one was listening =)
17:56:12 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-September/008244.html vishnoianil's original comments with follow-ons
17:57:09 <colindixon> #info vishnoianil note that he feels we need to enforce things, rovarga notes that it's really hard to enforce without understanding the code (which the TSC doesn't currently) thus maybe relying on downstream projects to pay more attention would help
17:57:15 <rovarga> #info furthermore, our M3-M5 are designed to ramp down development in favor of stabilizing codebase, e.g. shift to bugfixes
17:57:44 <colindixon> #info anipbu says he thinks lthe lines in the sand are there, we they just maybe need tougher enforcement and/or to be moved earlier
17:58:05 <colindixon> #info anipbu also notes that there are ideas like hot builds and cold builds and other ites from talking to other release managers and we might consider them
17:58:33 <dfarrell07> #info dfarrell07 notes that "following the mature release process" is the major requirements of becoming a Mature project. We could clarify that late testing/bugfixes may impact TSC's estimation of how well they followed that process in their Graduation Reviews.
18:00:17 <dfarrell07> colindixon: agreed
18:00:27 <rovarga> one thing is that the signs show up way sooner than RCx
18:00:30 <colindixon> #Info colindixon notes that he's seen very little evidence that being mature has any incentives it overs to projects
18:01:14 <colindixon> #Info at the end of the day, the issue is that we really would like to incentivize projects to be seriously testing starting with RC0 or before
18:01:28 * ChrisPriceAB has to drop off... apologies
18:01:31 <rovarga> e.g. if people are working on dropping features past M3, they will most probably be doing M5 work at RC1 (or worse)
18:01:38 * adetalhouet have to drop as well..
18:01:38 <colindixon> rovarga: perhaps, in the above cases, it didnt' surface anywhere we could see
18:02:09 <colindixon> #topic cookies
18:02:17 <colindixon> #endmeeting