17:00:46 <colindixon> #startmeeting tsc
17:00:46 <odl_meetbot> Meeting started Thu Sep 22 17:00:46 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:46 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:46 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:50 <colindixon> #topic agenda bashing and roll call
17:00:54 <colindixon> TSC members please #info in
17:00:56 <colindixon> #info colindixon
17:01:02 <colindixon> #ilnk https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=50166#Agenda today's agenda
17:01:05 <Chrisy> #info Chris Luke for Ed Warnicke
17:01:12 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-09-15-17.00.html last week's meeting minutes
17:01:17 <Prem_> #info Prem_ for Chris Price
17:01:21 <adetalhouet> #info adetalhouet
17:01:44 <gkaempfer> #info gkaempfer
17:01:50 <colindixon> #info colindixon is also adding  APAC time TSC meeting to today's agenda
17:03:23 <colindixon> #action adetalhouet to find the link for the dicussion about committer activity and project liveness and make sure we talk about it today or next week
17:03:37 <adetalhouet> #link https://lists.opendaylight.org/pipermail/release/2016-September/008306.html
17:03:38 <colindixon> #action rovarga will follow up with jira, group management, and user provisioning
17:03:41 <colindixon> #undo
17:03:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2b01850>
17:04:07 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-September/008306.html the discussion of active committers and projects and how to do a better job tracking inactive ones in the future
17:04:21 <colindixon> #chair phrobb anipbu
17:04:21 <odl_meetbot> Current chairs: anipbu colindixon phrobb
17:04:28 <colindixon> #action dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
17:04:39 <colindixon> #action colindixon to add topics to the carbon dev forum around modifying the RC process a bit, and maybe also fast and/or phased
17:05:11 <vishnoianil> #info Anil Vishnoi
17:05:27 <colindixon> #action abhijitkumbhare phrobb tykeal and others to follow up with how to fix the F5 device
17:05:30 <dfarrell07> #info Daniel Farrell
17:06:01 <colindixon> #action phrobb to forward the TSC election planning results the board to get their approval before we kick off the election and nomination process
17:06:26 <dfarrell07> phrobb: you're low-vol to me, colindixon has magic headphones and can hear ;)
17:06:43 <colindixon> dfarrell07: did you get this: dfarrell07 to merge vote-per-committer vs vote-per-interest corner case proposal into framework
17:07:01 <dfarrell07> colindixon: I'll do that now
17:07:05 <dfarrell07> colindixon: so no
17:07:08 <colindixon> #action dfarrell07 to merge vote-per-committer vs vote-per-interest corner case proposal into framework
17:07:09 <tykeal> dfarrell07: I'm on headphones and he's still quiet
17:07:11 <tykeal> oh... better :)
17:07:20 <colindixon> #action colindixon to start a thread on when projects/committers need to be approvied to participate how in elections
17:07:55 <colindixon> #topic TSC discussions
17:08:06 <colindixon> #info see the agenda link above for the current mailing list discussions
17:08:08 <abhijitkumbhare> #info abhijitkumbhare
17:08:10 <colindixon> #topics events
17:08:16 <colindixon> #topic events
17:08:23 <colindixon> #link https://www.opendaylight.org/global-events
17:08:54 <colindixon> I count 8 of 10 TSC members
17:09:09 <colindixon> we're missing Uri (or a sub) and Jan (or a sub)
17:09:20 <rovarga> #info rovarga for jmedved
17:09:22 <colindixon> #link https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum developer forum topics
17:09:26 <rovarga> (sorry for being late)
17:09:28 <anipbu> colindixon: forgot to raise, should we have a topic on whether TSC is meeting next week?
17:09:50 <colindixon> #link https://opendaylightsummit2016.sched.org/ the summit
17:11:07 <colindixon> #info there will be GPG key singing at the summit, tykeal is planning to hold office hours on Thursday moring, cut off will be noon thursday (a week from today) to get Andy key fingerprints (you have to do it again even if you did it before) so that you can particiate in the keysinging stuff
17:11:29 <colindixon> #info it will be in the same room as the board town hall immediately following it
17:11:51 <colindixon> #info phrobb asks if the TSC wants to make this a bigger priority in Carobn
17:11:55 <colindixon> #undo
17:11:55 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b62f90>
17:12:00 <colindixon> #info phrobb asks if the TSC wants to make this a bigger priority in Carbon
17:12:42 <colindixon> #info colindixon punts that tykeal and zxiiro, zxiiro says we current sign our rleases, but we do it as the LF not as the developers
17:13:20 <colindixon> #Info tykeal says that it would be better if each project released it's own stuff and signed them by themselves (e.g., the PTL or a set of the committers)
17:14:39 <colindixon> #info colindixon asks about signing release tags, tykeal and zxiiro say that we can't sign tags except when they're created and only one person can sign the tag then
17:15:32 <colindixon> #info tykeal says his take on this is that what we should really be doing is that we should force that committers on projects to sign their commits as a first step
17:16:07 <colindixon> #action tykeal to create a DDF topic on how we can start to incrementally use our web of trust
17:16:22 <colindixon> #topic boron
17:17:08 <colindixon> #info  Boron-SR1 is on 10/27/2016, cut off will be on Sunday, 10/22 at 23:59 UTC
17:17:29 <colindixon> #topic Beryllum
17:17:50 <colindixon> #info Beryllium-SR4 is on 10/20/2016, cut off on 10/16 at 23:59 UTC
17:17:56 <colindixon> #topic Carbon
17:18:04 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-September/008349.html   <--- Carbon M0: Declare Participation.  Projects should declare their intent to participate in the Carbon Simultaneous Release
17:18:39 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-September/008345.html   <--- For Carbon YANG Tools we will only support maven-3.3.9 or later and have already disabled 3.2.x verify-carbon jobs.
17:19:05 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Carbon/Changes   <--- Tracking Carbon Cross Project Changes: YANG Tools Maven 3.3.9
17:19:48 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-September/008331.html   <--- Releng has migrated to now use freestyle jobs with roughly 30 minutes saving time, but there are still some issues and concerns being investigated with regards to this migration effort.  There may be impact to our autorelease build picking up latest code.
17:19:53 <anipbu> #link https://lists.opendaylight.org/pipermail/dev/2016-September/002766.html   <--- Some issues with autorelease odlparent being up-to-date
17:20:03 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-September/008352.html   <--- Carbon Autorelease Build Failures in sal-rest-docgen
17:22:31 <LuisGomez> jamoluhrsen, the VM does not have host adapter anymore, how do you ssh the VM?
17:22:32 <colindixon> #Info zxiiro says that the autorelease version being up-to-date seems to be a bug in gerrit with the master branch only
17:23:00 <colindixon> #topic system integration and test
17:23:01 <colindixon> #info nothing this week
17:23:05 <colindixon> #topic infrastructure
17:23:32 <colindixon> #info we seem to have finally fixed the Nexus timeout issues
17:23:32 <vrpolak> Before, when autorelease was a maven job, it was able to finish the build even if there were unit test failures.
17:23:55 <colindixon> #info there was an outage issue with nexus earlier this morning, but it's fixed
17:24:10 <colindixon> #info there is a request to see what we can do to get at bigger F5 devices to fix our bottleneck
17:24:36 <colindixon> #info we are plannig to do system upgrades starting the week after the summit
17:24:54 <colindixon> #Info nexus upragdes, gerrit upgrades, jenkins upgrades, and along down the line
17:25:07 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/006052.html some converastion on moving to JIRA
17:26:24 <colindixon> #info tykeal also says that there is a request to the board to think about funding doubling our compute resources with somewhat cheaper hardware, we would then have two availability zones and could use the new one ODL forge and also using it as excess capacity for everything
17:27:25 <colindixon> #Info tykeal says that one of the mandates for ODL forge was to keep it separate and this would make that easier
17:28:09 <colindixon> #Info this would prevent ODL forge from interfering with our other resources
17:29:14 <colindixon> #Info phrobb asks if we could steal all (or most) of ODL forge for non-forge stuff so that we could use it for releasing, tykeal says that we could do that
17:30:06 <colindixon> #info phrobb asks if the current plan is to still run CSIT in the public cloud, tykeal says that his view is that we could maybe put CSIT into the 2nd availability zone as well
17:30:20 <colindixon> #info LuisGomez says the public cloud still has some issues, so this might help
17:30:38 <colindixon> #action LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon
17:32:03 <colindixon> #info LuisGomez says that he's see still seeing a high rate of VM failures in the public cloud, still about 1 in 3 cluster jobs in the public cloud fails in infrastructure issues, LuisGomez remembers those being much more stable in the private cloud
17:35:02 <colindixon> #topic TSC Elections
17:35:04 <lori> tykeal: does the latest Gerrit release add support for submissions signed with offline GPG master key setup? (it was not working on the current installation)
17:36:46 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/005980.html  Successful Mailing List Vote to have the following TSC RGs: Kernel, Protocol/Services, App, Support, Committer at Large (CAL)
17:36:54 <zxiiro> lori: doesn't look like it as far as I can tell
17:36:58 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/005971.html  Successful Mailing List Vote to have CAL votes be vote-per-committer, and other RGs be one vote-per-interest
17:37:04 <zxiiro> lori: there's no movement on our Gerrit issue for that feature
17:37:11 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/006030.html  Results of Condorcet vote on allocation of seats to RGs: 5 Seats to committers-at-large, 2 seats to all others (13 seats total)
17:37:16 <lori> zxiiro: ok, thanks
17:37:47 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-September/006031.html  discussion on options to vote on for company caps
17:38:00 <colindixon> #info  Abhijit proposed to simply say only one person per company in each RG as a simpler alternative (all elections are this independent with no over-max resolution)
17:38:14 <colindixon> #info  Colin feels that this might fail to meet our key requirement to avoid people not running for fear of ousting others in their company, there a key difference in his mind between caps of exactly 1 vs. caps of 2+. In the first case, it's clear who's fault somebody being knocked out is. In the second case, there is more than one person and reason for the cause.
17:39:38 <colindixon> #info abhijitkumbhare came back suggesting instead to resolve over-max by first repeated removing the lowest ranked person in RGs where there are 2 or more representatives from the same capped group (or company) and then using scaled popularity if there is only one person from each capped group in each RG.
17:39:38 * dfarrell07 lost audio?
17:39:44 <colindixon> dfarrell07: I have audio
17:40:17 <dfarrell07> back
17:41:31 <colindixon> #info colindixon asks what the reason is to do that vs. just scaled popularity? abhijitkumbhare says basically the issue is whether you want pick the person who won the most of the vote (as a percent) vs. the person who got the most votes (e.g., a smaller fraction of a larger electorate)
17:43:46 <colindixon> #Info colindixon says the he's not sure if the proposal from abhijitkumbhare actually strikes a balance between the two, it seems like a third alternative that favors an entirely orthogonal thing which is minimizing over-representation by a single group
17:45:28 <colindixon> #info abhijitkumbhare says the advantage of his proposal is that in a somewhat fair way it minimizes the number of times you would have have to resolve issues in a cross-RG manner, which is where the comparison between % vs. votes comes in
17:50:50 <colindixon> #action colindixon to post abhijitkumbhare's alternative to the wiki, and then start a vote
17:53:53 <colindixon> #info rovarga notes that abhijitkumbhare's proposal above would potentially hurt companies that invest most heavily in a small number of RGs vs. spreading out
17:54:24 <colindixon> #info colindixon also notes that we would have to have a way to pick bertween RGs if there were 2+ reps from the same company in more than one RG when you need to resolve it
17:56:57 <colindixon> #info rovarga says that committer-at-large is likely to see more diversity than the RGs, which means that would be less likely to be hit in abhijitkumbhare's scheme
17:57:35 <colindixon> #info instead, rovarga says maybe first dropping CAL's since they might have less concerte value to the TSC than RGs
17:59:06 <colindixon> #topic do we want to have a TSC meeting (during the DDF) next week?
18:00:13 <colindixon> #info colindixon asks if there's anything going on at the same time?
18:00:30 <colindixon> #Info rovarga and dfarrell07 suggests that we could have an open room
18:01:41 <colindixon> #action colindixon to work with phrobb to have TSC meeting during the DDF
18:02:07 <colindixon> #startvote does the TSC want to have a town-hall/open TSC meetnig during the DDF at roughly this time? -1,0,+1
18:02:07 <odl_meetbot> Begin voting on: does the TSC want to have a town-hall/open TSC meetnig during the DDF at roughly this time? Valid vote options are -1, 0, +1.
18:02:07 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:02:09 <dfarrell07> #vote +1
18:02:10 <colindixon> #vote +1
18:02:12 <rovarga> #vote +1
18:02:13 <Chrisy> #vote +1
18:02:14 <vishnoianil> #vote +1
18:02:14 <Prem_> #vote +1
18:02:15 <abhijitkumbhare> #vote +1
18:02:20 <adetalhouet> #vote +1
18:02:23 <colindixon> #endvote
18:02:23 <odl_meetbot> Voted on "does the TSC want to have a town-hall/open TSC meetnig during the DDF at roughly this time?" Results are
18:02:23 <odl_meetbot> +1 (8): rovarga, adetalhouet, Chrisy, dfarrell07, colindixon, abhijitkumbhare, Prem_, vishnoianil
18:02:36 <colindixon> #agreed phrobb and colindixon will work to have an open TSC meeting during the DDF
18:02:56 <tykeal> cookie time
18:03:00 <colindixon> #topic cookies
18:03:41 <colindixon> #agreed (from earlier) colindixon will send a summary of the eletion discussion here to the mailing list and start a vote 24 horus from now to end roughly a week from now so that we can give the results to the board for their meeting a week from tomorrow and get elections going
18:03:44 <colindixon> #endmeeting